IBM-WVE-MIB DEFINITIONS ::= BEGIN IMPORTS MODULE-IDENTITY, OBJECT-TYPE, enterprises, NOTIFICATION-TYPE, TimeTicks FROM SNMPv2-SMI -- RFC2578 DisplayString FROM SNMPv2-TC -- RFC2579 MODULE-COMPLIANCE, OBJECT-GROUP, NOTIFICATION-GROUP FROM SNMPv2-CONF; -- RFC2580 ibmWVEMIB MODULE-IDENTITY LAST-UPDATED "201007010000Z" ORGANIZATION "International Business Machines Corp." CONTACT-INFO "Keith Smith International Business Machines Corporation Application Integration Middleware Division Research Triangle Park, NC, USA E-mail: bksmith@us.ibm.com" DESCRIPTION "This module provides definitions of events generated by WebSphere Intelligent Management and formatting them as SNMP traps. Copyright goes here. " REVISION "201007010000Z" DESCRIPTION "Initial version of the MIB." ::= { ibmProd 231 } ibm OBJECT IDENTIFIER ::= { enterprises 2 } ibmProd OBJECT IDENTIFIER ::= { ibm 6 } -- Top-level structure of the MIB ibmWVENotifications OBJECT IDENTIFIER ::= { ibmWVEMIB 0 } ibmWVEObjects OBJECT IDENTIFIER ::= { ibmWVEMIB 1 } ibmWVEConformance OBJECT IDENTIFIER ::= { ibmWVEMIB 2 } -- Textual Conventions WVEDisplayString ::= TEXTUAL-CONVENTION STATUS current DESCRIPTION "Defines a display string a generated by WebSphere Intelligent Management." SYNTAX DisplayString (SIZE(1..254)) -- Objects ibmHealthPolicyViolationName OBJECT-TYPE SYNTAX WVEDisplayString MAX-ACCESS accessible-for-notify STATUS current DESCRIPTION "The name of the health policy which was violated." ::= { ibmWVEObjects 1 } ibmEntityType OBJECT-TYPE SYNTAX WVEDisplayString MAX-ACCESS accessible-for-notify STATUS current DESCRIPTION "The type of an entity (e.g. 'cell', 'cluster', or 'server'." ::= { ibmWVEObjects 3 } ibmEntityName OBJECT-TYPE SYNTAX WVEDisplayString MAX-ACCESS accessible-for-notify STATUS current DESCRIPTION "The name of an entity whose format depends upon the entity type. For example, an entity of type 'server' has an entity name of the format 'cellName/nodeName/serverName'." ::= { ibmWVEObjects 4 } ibmAutomaticActionName OBJECT-TYPE SYNTAX WVEDisplayString MAX-ACCESS accessible-for-notify STATUS current DESCRIPTION "The name of an automatic action that was executed by the WebSphere Intelligent Management Pack." ::= { ibmWVEObjects 5 } ibmAutomaticActionStatus OBJECT-TYPE SYNTAX WVEDisplayString MAX-ACCESS accessible-for-notify STATUS current DESCRIPTION "The status of an automatic action that was executed by WebSphere Intelligent Management." ::= { ibmWVEObjects 6 } ibmComponentType OBJECT-TYPE SYNTAX WVEDisplayString MAX-ACCESS accessible-for-notify STATUS current DESCRIPTION "The type of a WebSphere Intelligent Management component (e.g. HealthController)." ::= { ibmWVEObjects 7 } -- Notifications ibmHealthPolicyViolation NOTIFICATION-TYPE OBJECTS { ibmHealthPolicyViolationName, ibmEntityType, ibmEntityName } STATUS current DESCRIPTION "This notification is generated when a health policy violation is detected by WebSphere Intelligent Management and a configured action is to generate an SNMP trap. The entity type and entity name denote the entity (typically the server name) which caused the health policy violation." ::= { ibmWVENotifications 1 } ibmAutomaticAction NOTIFICATION-TYPE OBJECTS { ibmAutomaticActionName, ibmEntityType, ibmEntityName, ibmAutomaticActionStatus } STATUS current DESCRIPTION "This notification is generated when WebSphere Intelligent Management takes an automatic action. The entity type and entity name indicate the entity (typically a server) on which the automatic action was taken. The action status indicates the resulting status of attempting to execute the automatic action." ::= { ibmWVENotifications 2 } ibmComponentStatus NOTIFICATION-TYPE OBJECTS { ibmComponentType, ibmEntityType, ibmEntityName, ibmAutomaticActionStatus } STATUS current DESCRIPTION "This notification is generated when WebSphere Intelligent Management takes an automatic action. The entity type and entity name indicate the entity (typically a server) on which the automatic action was taken. The action status indicates the resulting status of attempting to execute the automatic action." ::= { ibmWVENotifications 2 } -- Compliance statements ibmWVECompliances OBJECT IDENTIFIER ::= { ibmWVEConformance 1 } ibmWVEGroups OBJECT IDENTIFIER ::= { ibmWVEConformance 2 } ibmWVECompliance MODULE-COMPLIANCE STATUS current DESCRIPTION "The compliance statement for the IBM-WVE-MIB." MODULE -- this module MANDATORY-GROUPS { ibmWVERequiredObjectsGroup, ibmWVERequiredNotificationsGroup } ::= { ibmWVECompliances 1 } -- MIB groupings ibmWVERequiredObjectsGroup OBJECT-GROUP OBJECTS { ibmHealthPolicyViolationName, ibmEntityType, ibmEntityName, ibmAutomaticAction, ibmAutomaticActionStatus } STATUS current DESCRIPTION "This group defines those MIB objects that MUST be implemented by a compliant implementation." ::= { ibmWVEGroups 1 } ibmWVERequiredNotificationsGroup NOTIFICATION-GROUP NOTIFICATIONS { ibmHealthPolicyViolation, ibmAutomaticAction } STATUS current DESCRIPTION "This group defines those notifications that MUST be implemented by a compliant implementation." ::= { ibmWVEGroups 2 } END