<?xml version="1.0" encoding="UTF-8"?>
<?xml-stylesheet type="text/css" href="../../resources/stylesheets/wasmsgxml.css"?>
<TMSSource name="TivoliMessages" tmsVersion="1.0" xml:lang="en">
<!-- CMVC MSG File Name = ws/code/ras/src/com/ibm/ejs/resources/RasMessages.nlsprops -->
<!-- DO NOT EDIT THIS FILE - This file was generated by the XML/Html & Property emitter -->
<!-- BEGIN MESSAGES -->
<Message ID="TRAS0110E" severity="E" prefix="yes">
  <MsgText pgmKey="EXCEPTION_RESERVED_EXTENSION" varFormat="Java">
    EXCEPTION_RESERVED_EXTENSION=TRAS0110E: The extension name &apos;&apos;{0}&apos;&apos; is reserved
  </MsgText>
  <Explanation>
    The extension name that is specified is the same as an internally used extension name and cannot be used.
  </Explanation>
  <UserResponse>
    Use an extension with a different name.
  </UserResponse>
</Message>
<Message ID="TRAS0014I" severity="I" prefix="yes">
  <MsgText pgmKey="MSG_EXCEPTION_LOGGED" varFormat="Java">
    MSG_EXCEPTION_LOGGED=TRAS0014I: The following exception was logged {0}.
  </MsgText>
  <Explanation>
    An exception message was logged.
  </Explanation>
  <UserResponse>
    Determine the cause of the exception and take appropriate action. Other messages related to the exception might have also been logged.
  </UserResponse>
</Message>
<Message ID="TRAS0018I" severity="I" prefix="yes">
  <MsgText pgmKey="MSG_TRACE_STATE_CHANGED" varFormat="Java">
    MSG_TRACE_STATE_CHANGED=TRAS0018I: The trace state has changed. The new trace state is {0}.
  </MsgText>
  <Explanation>
    A request to change the current trace state was received and processed.
  </Explanation>
  <UserResponse>
    If the new trace state is not the desired trace state, change it to the desired state.
  </UserResponse>
</Message>
<Message ID="TRAS0107E" severity="E" prefix="yes">
  <MsgText pgmKey="EXCEPTION_MISSING_TYPE" varFormat="Java">
    EXCEPTION_MISSING_TYPE=TRAS0107E: Missing type value at &apos;&apos;{0}&apos;&apos;
  </MsgText>
  <Explanation>
    A trace string does not have a type value.
  </Explanation>
  <UserResponse>
    Modify the server.xml file for this server and make the startupTraceSpecification parameter compliant with trace string grammar.
  </UserResponse>
</Message>
<Message ID="TRAS0028I" severity="I" prefix="yes">
  <MsgText pgmKey="MSG_RING_BUFFER_STATUS" varFormat="Java">
    MSG_RING_BUFFER_STATUS=TRAS0028I: The trace output is stored in the circular memory buffer, holding {0} message objects.
  </MsgText>
  <Explanation>
    The trace is configured to go into circular memory buffer. The size of the buffer is printed as well. The buffer holds references to message objects and the amount of memory these message objects use cannot be determined.
  </Explanation>
  <UserResponse>
    Do not use circular memory buffer when enabling full tracing, or configure the buffer to hold less objects, to prevent out of memory condition. Message objects that are used when tracing is enabled will use more memory than non-tracing message objects.
  </UserResponse>
</Message>
<Message ID="TRAS0113I" severity="I" prefix="yes">
  <MsgText pgmKey="RAS_LOG_MBEAN_SHADOW_NOOP" varFormat="Java">
    RAS_LOG_MBEAN_SHADOW_NOOP=TRAS0113I: This MBean Operation should not be used when High Performance Logging is enabled. Function will be forwarded to proper MBean
  </MsgText>
  <Explanation>
    High performance logging has its own MBean.  Use of the MBeans for legacy logging should not be used
  </Explanation>
  <UserResponse>
    Updating user scripts or JMX code is recommended
  </UserResponse>
</Message>
<Message ID="TRAS0104E" severity="E" prefix="yes">
  <MsgText pgmKey="EXCEPTION_MISSING_VALUE_PAIR" varFormat="Java">
    EXCEPTION_MISSING_VALUE_PAIR=TRAS0104E: Missing type=state value pair at &apos;&apos;{0}&apos;&apos;
  </MsgText>
  <Explanation>
    A trace string has an extra comma.
  </Explanation>
  <UserResponse>
    Modify the server.xml file for this server and make the startupTraceSpecification parameter compliant with trace string grammar. An extra comma may need to be removed.
  </UserResponse>
</Message>
<Message ID="TRAS0019I" severity="I" prefix="yes">
  <MsgText pgmKey="MSG_TRACE_TO_RING_BUFFER" varFormat="Java">
    MSG_TRACE_TO_RING_BUFFER=TRAS0019I: Defaulting trace output to the circular memory buffer.
  </MsgText>
  <Explanation>
    An error was detected while attempting to route trace to a file. Trace was routed to the in-memory ring buffer instead.
  </Explanation>
  <UserResponse>
    Search the log file for a message detailing the error encountered when routing trace to the file. That message should contain an exception indicating the root cause of the failure. Fix the root cause of the failure and retry the operation.
  </UserResponse>
</Message>
<Message ID="TRAS0031W" severity="W" prefix="yes">
  <MsgText pgmKey="MSG_ROLLOVER_RENAME_FAILED" varFormat="Java">
    MSG_ROLLOVER_RENAME_FAILED=TRAS0031W: Unable to rename file {0} to {1} during log file rollover. Attempting to copy file contents.
  </MsgText>
  <Explanation>
    Failed to rename the file indicated.  The most likely cause is that another process or thread is accessing the log file. WebSphere will try to complete the rollover operation by copying the contents of the log file - this process is slower, and all threads making attempting to log will be halted during this process.
  </Explanation>
  <UserResponse>
    Determine the cause of the rename failure and resolve it - this may involve shutting down other processes that are accessing the same log file.
  </UserResponse>
</Message>
<Message ID="TRAS0292W" severity="W" prefix="yes">
  <MsgText pgmKey="MSG_HPEL_OWNERFILE_IS_DIRECTORY" varFormat="Java">
    MSG_HPEL_OWNERFILE_IS_DIRECTORY=TRAS0292W: The HPEL repository ownership indicator file {0} is a directory but should be a file.
  </MsgText>
  <Explanation>
    The application server uses the ownership indicator file to track which server is allowed to write to the HPEL repository; the configured HPEL repository location precedes the .owner suffix in the ownership indicator file name.  There is a directory at the location where the ownership indicator file should be.
  </Explanation>
  <UserResponse>
    If a valid directory is already present with the same name as the ownership indicator file, reconfigure the path for the HPEL repository destination. Otherwise, remove the directory with that same name if it is safe to do so.
  </UserResponse>
</Message>
<Message ID="TRAS0111I" severity="I" prefix="yes">
  <MsgText pgmKey="DEPRECATED_MESSAGE_IDS" varFormat="Java">
    DEPRECATED_MESSAGE_IDS=TRAS0111I: The message IDs that are in use are deprecated
  </MsgText>
  <Explanation>
    The message IDs are deprecated.  Use the new message IDs.
  </Explanation>
  <UserResponse>
    Add the com.ibm.websphere.logging.messageId.version=6 system property for your server process to enable new message IDs
  </UserResponse>
</Message>
<Message ID="TRAS0033W" severity="W" prefix="yes">
  <MsgText pgmKey="MSG_TRACE_STATE_OPTIMIZED" varFormat="Java">
    MSG_TRACE_STATE_OPTIMIZED=TRAS0033W: The new trace specification supplied for node {0}, server {1} has been changed from {2} to {3} to eliminate redundancy.
  </MsgText>
  <Explanation>
    A request to change the current trace state was received and processed.
  </Explanation>
  <UserResponse>
    If the new trace state is not the desired trace state, change it to the desired state.
  </UserResponse>
</Message>
<Message ID="TRAS0008E" severity="E" prefix="yes">
  <MsgText pgmKey="MSG_OPEN_TRACE_FILE_FAILED" varFormat="Java">
    MSG_OPEN_TRACE_FILE_FAILED=TRAS0008E: Failed to open trace log file {0} {1}
  </MsgText>
  <Explanation>
    The configuration option to send trace to a stand-alone file was selected. An attempt to open the indicated file failed with the indicated exception. Trace will be routed to an alternate facility.
  </Explanation>
  <UserResponse>
    Examine the exception to determine the root cause of the failure. Ensure that the file name is correct and is a valid name. Ensure that the Application Server run time is allowed write access to the directory for the specified file. Ensure that the file system is not full. If this does not solve the problem, see the problem determination information on the WebSphere Application Server Support Web page: http://www.ibm.com/software/webservers/appserv/was/support.
  </UserResponse>
</Message>
<Message ID="TRAS0250W" severity="W" prefix="yes">
  <MsgText pgmKey="TRAS0250W" varFormat="Java">
    TRAS0250W=TRAS0250W: The {0} on logstream {1} returned a warning - return code {2}, reason code {3}
  </MsgText>
  <Explanation>
    A warning message was returned from this run
  </Explanation>
  <UserResponse>
    Consider reRunning
  </UserResponse>
</Message>
<Message ID="TRAS0029I" severity="I" prefix="yes">
  <MsgText pgmKey="MSG_DUMPED_TO_DEFAULT_LOCATION" varFormat="Java">
    MSG_DUMPED_TO_DEFAULT_LOCATION=TRAS0029I: Could not dump ring buffer to specified directory, {0}.  Dumped to default file, {1}.
  </MsgText>
  <Explanation>
    Failed to write the in-memory trace buffer to the specified file.  This is mostly likely because the file specified is not valid or does not allow write-access.
  </Explanation>
  <UserResponse>
    The trace contents were successfully written to the default dump file.  To prevent this message in the future, specify a valid filename in a directory that allows write access.
  </UserResponse>
</Message>
<Message ID="TRAS0270E" severity="E" prefix="yes">
  <MsgText pgmKey="TRAS0270E" varFormat="Java">
    TRAS0270E=TRAS0270E: Failed to connect to logstream {1} - return code {2}, reason code {3}
  </MsgText>
  <Explanation>
    Could not connect to the logstream
  </Explanation>
  <UserResponse>
    Have a system logger administrator review the configuration and verify the health of the component and the logstream
  </UserResponse>
</Message>
<Message ID="TRAS0013E" severity="E" prefix="yes">
  <MsgText pgmKey="MSG_STREAM_REPLACEMENT_FAILED" varFormat="Java">
    MSG_STREAM_REPLACEMENT_FAILED=TRAS0013E: An attempt to redirect the {0} stream failed. The following exception was encountered. {1}
  </MsgText>
  <Explanation>
    See the message in the base exception. This should indicate the root cause of the failure.
  </Explanation>
  <UserResponse>
    Determine the root cause of the base exception and correct it. If an IOException was encountered, ensure the directory exists, RAS has write access to the directory and that the file system is not full.
  </UserResponse>
</Message>
<Message ID="TRAS0230I" severity="I" prefix="yes">
  <MsgText pgmKey="TRAS0230I" varFormat="Java">
    TRAS0230I=TRAS0230I: The message time stamp exceeded end time.
  </MsgText>
  <Explanation>
    Issue with a message read that had a timeStamp outside of the specified range.
  </Explanation>
  <UserResponse>
    Consider reRunning
  </UserResponse>
</Message>
<Message ID="TRAS0210I" severity="I" prefix="yes">
  <MsgText pgmKey="TRAS0210I" varFormat="Java">
    TRAS0210I=TRAS0210I: The JNI call could not go thru.
  </MsgText>
  <Explanation>
    Could not access error log file via JNI
  </Explanation>
  <UserResponse>
    ReInvoke the reader
  </UserResponse>
</Message>
<Message ID="TRAS0291W" severity="W" prefix="yes">
  <MsgText pgmKey="MSG_OWNERFILE_DIFFERENT_SERVER" varFormat="Java">
    MSG_OWNERFILE_DIFFERENT_SERVER=TRAS0291W: The log/trace file {0} is already configured for use by server {1}, but server {2} is also configured to write log/trace content to that file.
  </MsgText>
  <Explanation>
    Only one server is allowed to write log/trace content to any one location.
  </Explanation>
  <UserResponse>
    Reconfigure the log/trace settings of one or both of the named servers so that they do not use the same location.
  </UserResponse>
</Message>
<Message ID="TRAS0109E" severity="E" prefix="yes">
  <MsgText pgmKey="EXCEPTION_INVALID_STATE" varFormat="Java">
    EXCEPTION_INVALID_STATE=TRAS0109E: Invalid state value - &apos;&apos;{0}&apos;&apos; at &apos;&apos;{1}&apos;&apos;
  </MsgText>
  <Explanation>
    A trace string has a bad state value.
  </Explanation>
  <UserResponse>
    =Modify the server.xml file for this server and make the startupTraceSpecification parameter compliant with trace string grammar.
  </UserResponse>
</Message>
<Message ID="TRAS0290W" severity="W" prefix="yes">
  <MsgText pgmKey="MSG_OWNERFILE_IS_DIRECTORY" varFormat="Java">
    MSG_OWNERFILE_IS_DIRECTORY=TRAS0290W: The log/trace ownership indicator file {0} is a directory but should be a file.
  </MsgText>
  <Explanation>
    The application server uses the ownership indicator file to track which server is allowed to write to the log/trace file; the configured log/trace file name precedes the .owner suffix in the ownership indicator file name. There is a directory at the location where the ownership indicator file should be.
  </Explanation>
  <UserResponse>
    If a valid directory is already present with the same name as the ownership indicator file, reconfigure the file name or path for the log/trace destination. Otherwise, remove the directory with that same name if it is safe to do so.
  </UserResponse>
</Message>
<Message ID="TRAS0012W" severity="W" prefix="yes">
  <MsgText pgmKey="MSG_INVALID_FILENAME" varFormat="Java">
    MSG_INVALID_FILENAME=TRAS0012W: {0} was specified in the configuration information as the name of the file to use for the {1} stream. This is not a legal name. {2} will be used instead
  </MsgText>
  <Explanation>
    The name that is supplied must be a fully-qualified file name. The directory must exist or RAS must be able to create it. RAS must be granted write access to that directory.
  </Explanation>
  <UserResponse>
    Supply a file name that meets the above parameters in the configuration data for the indicated stream. Restart the server in order for this change to take effect.
  </UserResponse>
</Message>
<Message ID="TRAS0021W" severity="W" prefix="yes">
  <MsgText pgmKey="MSG_INVALID_LOGGING_AGENT_HANDLER_LEVEL" varFormat="Java">
    MSG_INVALID_LOGGING_AGENT_HANDLER_LEVEL=TRAS0021W: An invalid level name {0} was used as the filter level for the logging agent handler configuration.
  </MsgText>
  <Explanation>
    The level name specified for the logging agent handler must be one of the following: DETAIL, CONFIG, INFO, AUDIT, WARNING, SEVERE, FATAL
  </Explanation>
  <UserResponse>
    Modify the server configuration to use one of the allowable filter levels.
  </UserResponse>
</Message>
<Message ID="TRAS0102E" severity="E" prefix="yes">
  <MsgText pgmKey="EXCEPTION_NO_VALUE_PAIRS" varFormat="Java">
    EXCEPTION_NO_VALUE_PAIRS=TRAS0102E: No type=state value pair(s) found at &apos;&apos;{0}&apos;&apos;
  </MsgText>
  <Explanation>
    A trace string was found with component and no type=state value pair(s).
  </Explanation>
  <UserResponse>
    Modify the server.xml file for this server and make the startupTraceSpecification parameter compliant with trace string grammar.
  </UserResponse>
</Message>
<Message ID="TRAS0040I" severity="I" prefix="yes">
  <MsgText pgmKey="UNKNOWN_TRACE_SPEC" varFormat="Java">
    UNKNOWN_TRACE_SPEC=TRAS0040I: The configured trace state included the following specifications that do not match any loggers currently registered in the server: {0}
  </MsgText>
  <Explanation>
    Loggers are registered in the server when code that creates them is first used.  The system has detected that certain trace specifications refer to loggers that have not been registered in the server.  The configured trace specifications may be valid for loggers that are not yet registered, or they could have been typed incorrectly. This check is performed each time the trace specification is updated on a running server.
  </Explanation>
  <UserResponse>
    Ensure that the trace specifications has been configured correctly. If there are no mistakes in the trace specification string, no action is required.
  </UserResponse>
</Message>
<Message ID="TRAS0112E" severity="E" prefix="yes">
  <MsgText pgmKey="EXCEPTION_NULL_HOSTNAME" varFormat="Java">
    EXCEPTION_NULL_HOSTNAME=TRAS0112E: Null value returned on call to InetAddress.getLocalHost().getHostName().
  </MsgText>
  <Explanation>
    The TCP/IP subsystem returned a null value when requesting the host name of the local host.
  </Explanation>
  <UserResponse>
    Resolve this issue in the TCP/IP configuration.
  </UserResponse>
</Message>
<Message ID="TRAS0007I" severity="I" prefix="yes">
  <MsgText pgmKey="MSG_SHARED_LOG_DISABLED" varFormat="Java">
    MSG_SHARED_LOG_DISABLED=TRAS0007I: Logging to the service log is disabled
  </MsgText>
  <Explanation>
    The configuration option to disable logging messages to the service log was selected.
  </Explanation>
  <UserResponse>
    Enable logging to the service log file by setting the configuration option to the enabled state.
  </UserResponse>
</Message>
<Message ID="TRAS0293W" severity="W" prefix="yes">
  <MsgText pgmKey="MSG_HPEL_OWNERFILE_DIFFERENT_SERVER" varFormat="Java">
    MSG_HPEL_OWNERFILE_DIFFERENT_SERVER=TRAS0293W: The HPEL repository {0} is already configured for use by server {1}, but server {2} is also configured to write HPEL repository content to that location.
  </MsgText>
  <Explanation>
    Only one server is allowed to write HPEL repository content to any one location.
  </Explanation>
  <UserResponse>
    Reconfigure the HPEL repository settings of one or both of the named servers so that they do not use the same location.
  </UserResponse>
</Message>
<Message ID="TRAS0017I" severity="I" prefix="yes">
  <MsgText pgmKey="MSG_INITIAL_TRACE_STATE" varFormat="Java">
    MSG_INITIAL_TRACE_STATE=TRAS0017I: The startup trace state is {0}.
  </MsgText>
  <Explanation>
    The trace service is started. The startup trace state that is determined from configuration data is displayed here.
  </Explanation>
  <UserResponse>
    If a different trace startup state is desired, change the configuration data appropriately and restart the process.
  </UserResponse>
</Message>
<Message ID="TRAS0108E" severity="E" prefix="yes">
  <MsgText pgmKey="EXCEPTION_INVALID_TYPE" varFormat="Java">
    EXCEPTION_INVALID_TYPE=TRAS0108E: Invalid type value - &apos;&apos;{0}&apos;&apos; at &apos;&apos;{1}&apos;&apos;
  </MsgText>
  <Explanation>
    A trace string has a bad type value.
  </Explanation>
  <UserResponse>
    Modify the server.xml file for this server and make the startupTraceSpecification parameter compliant with trace string grammar.
  </UserResponse>
</Message>
<Message ID="TRAS0022I" severity="I" prefix="yes">
  <MsgText pgmKey="MSG_LOGGING_AGENT_HANDLER_DISABLED" varFormat="Java">
    MSG_LOGGING_AGENT_HANDLER_DISABLED=TRAS0022I: The logging agent handler is disabled.
  </MsgText>
  <Explanation>
    This mesage is for informational purposes only.
  </Explanation>
  <UserResponse>
    No user action is required.
  </UserResponse>
</Message>
<Message ID="TRAS0106E" severity="E" prefix="yes">
  <MsgText pgmKey="EXCEPTION_MISSING_STATE" varFormat="Java">
    EXCEPTION_MISSING_STATE=TRAS0106E: Missing state value at &apos;&apos;{0}&apos;&apos;
  </MsgText>
  <Explanation>
    A trace string does not have a state value.
  </Explanation>
  <UserResponse>
    Modify the server.xml file for this server and make the startupTraceSpecification parameter compliant with trace string grammar.
  </UserResponse>
</Message>
<Message ID="TRAS0025E" severity="E" prefix="yes">
  <MsgText pgmKey="CONVERTLOG_INPUTFILENOTFOUND" varFormat="Java">
    CONVERTLOG_INPUTFILENOTFOUND=TRAS0025E: Unable to load source file {0}.
  </MsgText>
  <Explanation>
    The source file specified might not exist, might be a directory rather than a regular file, or might not be accessible.
  </Explanation>
  <UserResponse>
    Check parameters to make sure that the specified source file exists and is a regular file.  Check also to make sure the user executing the convertLog command has sufficient permissions to read the file.
  </UserResponse>
</Message>
<Message ID="TRAS0103E" severity="E" prefix="yes">
  <MsgText pgmKey="EXCEPTION_NO_COMPONENT_NAME" varFormat="Java">
    EXCEPTION_NO_COMPONENT_NAME=TRAS0103E: No component name found at &apos;&apos;{0}&apos;&apos;
  </MsgText>
  <Explanation>
    A trace string does not have a component name.
  </Explanation>
  <UserResponse>
    Modify the server.xml file for this server and make the startupTraceSpecification parameter compliant with trace string grammar.
  </UserResponse>
</Message>
<Message ID="TRAS0016E" severity="E" prefix="yes">
  <MsgText pgmKey="MSG_ROLLOVER_FAILED_EXCEPTION" varFormat="Java">
    MSG_ROLLOVER_FAILED_EXCEPTION=TRAS0016E: An unexpected exception while trying to archive log file {0} Exception is {1}.
  </MsgText>
  <Explanation>
    The indicated log file was configured to use a rollover algorithm. The rollover threshold was reached. An exception occurred while attempting to roll the log file over.
  </Explanation>
  <UserResponse>
    Determine from the indicated exception whether the event was due to an internal error or an unexpected system state. If the event was due to an internal program error, see the problem determination information on the WebSphere Application Server Support Web page: http://www.ibm.com/software/webservers/appserv/was/support.
  </UserResponse>
</Message>
<Message ID="TRAS0116W" severity="W" prefix="yes">
  <MsgText pgmKey="RAS_LOG_MBEAN_PROXY_JmxInfo" varFormat="Java">
    RAS_LOG_MBEAN_PROXY_JmxInfo=TRAS0116W: JMX Error Info: ObjectName: {0}  Other1: {1} Other2: {2} Other3: {3}
  </MsgText>
  <Explanation>
    This exception is unexpected. The cause is not immediately known.
  </Explanation>
  <UserResponse>
    If the problem persists, additional information might be available if you search for the message ID on the following Web sites: WebSphere Application Server Support page: http://www.ibm.com/software/webservers/appserv/was/support/ WebSphere Application Server for z/OS Support page: http://www.ibm.com/software/webservers/appserv/zos_os390/support/ .
  </UserResponse>
</Message>
<Message ID="TRAS0020W" severity="W" prefix="yes">
  <MsgText pgmKey="MSG_TRACE_SYNTAXERR_WARNING" varFormat="Java">
    MSG_TRACE_SYNTAXERR_WARNING=TRAS0020W: Trace might not be enabled properly due to syntax errors found in the trace string, {0}.
  </MsgText>
  <Explanation>
    Syntax errors were found in the trace string.
  </Explanation>
  <UserResponse>
    Check the parameter startupTraceSpecification parameter in the server.xml file for syntax errors and make it compliant with trace string grammar.
  </UserResponse>
</Message>
<Message ID="TRAS0015E" severity="E" prefix="yes">
  <MsgText pgmKey="MSG_SCHEDULE_TIME_ROLLOVER_FAILED" varFormat="Java">
    MSG_SCHEDULE_TIME_ROLLOVER_FAILED=TRAS0015E: Unable to schedule time-based rollover for log file {0}. Size-based rollover will be used instead {1}.
  </MsgText>
  <Explanation>
    The indicated log file was configured to use a time-based rollover algorithm. An attempt to schedule a rollover event has failed. The log file will use a size-based rollover algorithm.
  </Explanation>
  <UserResponse>
    Determine from the indicated exception whether the event was due to an internal error or an unexpected system state. If the event was due to an internal program error, see the problem determination information on the WebSphere Application Server Support Web page: http://www.ibm.com/software/webservers/appserv/was/support.
  </UserResponse>
</Message>
<Message ID="TRAS0280E" severity="E" prefix="yes">
  <MsgText pgmKey="TRAS0280E" varFormat="Java">
    TRAS0280E=TRAS0280E: Failed to open logstream {1} with return code {2}, reason code {3}
  </MsgText>
  <Explanation>
    Could not open the LogStream
  </Explanation>
  <UserResponse>
    Have a System Logger Administer review the configuration and verify the health of the subSystem and the logger
  </UserResponse>
</Message>
<Message ID="TRAS0027E" severity="E" prefix="yes">
  <MsgText pgmKey="CONVERTLOG_OUTOFMEMORY" varFormat="Java">
    CONVERTLOG_OUTOFMEMORY=TRAS0027E: Insufficient memory to process source file {0}.
  </MsgText>
  <Explanation>
    The source file was too large to process with this tool.
  </Explanation>
  <UserResponse>
    If the source file is large, try breaking it into parts before processing.
  </UserResponse>
</Message>
<Message ID="TRAS0260I" severity="I" prefix="yes">
  <MsgText pgmKey="TRAS0260I" varFormat="Java">
    TRAS0260I=TRAS0260I: The {0} on logstream {1} returned more than 500 messages in the buffer. Excess messages were discarded.
  </MsgText>
  <Explanation>
    Only 500 messages can be returned in the buffer and this would have retrieved &gt; 500 messages
  </Explanation>
  <UserResponse>
    Consider rerunning with more restrictive filtering
  </UserResponse>
</Message>
<Message ID="TRAS0030W" severity="W" prefix="yes">
  <MsgText pgmKey="MSG_UNABLE_TO_DUMP_RING_BUFFER" varFormat="Java">
    MSG_UNABLE_TO_DUMP_RING_BUFFER=TRAS0030W: Failed to dump ring buffer to specified file, {0}, or the default dump file location, {1}.  Exceptions: {2} {3}
  </MsgText>
  <Explanation>
    Failed to write the in-memory trace buffer to the file system.  This is most likely due to a file permission issue - the directories containing the files either do not exist or do not allow write access.
  </Explanation>
  <UserResponse>
    Ensure that the application server process has write permission to the specified directory.
  </UserResponse>
</Message>
<Message ID="TRAS0023I" severity="I" prefix="yes">
  <MsgText pgmKey="MSG_LOGGING_AGENT_HANDLER_ENABLED" varFormat="Java">
    MSG_LOGGING_AGENT_HANDLER_ENABLED=TRAS0023I: The logging agent handler is enabled.  Filter level is set to {0}.
  </MsgText>
  <Explanation>
    This mesage is for informational purposes only.
  </Explanation>
  <UserResponse>
    No user action is required.
  </UserResponse>
</Message>
<Message ID="TRAS0105E" severity="E" prefix="yes">
  <MsgText pgmKey="EXCEPTION_INVALID_VALUE_PAIR" varFormat="Java">
    EXCEPTION_INVALID_VALUE_PAIR=TRAS0105E: Invalid type=state value pair - &apos;&apos;{0}&apos;&apos; at &apos;&apos;{1}&apos;&apos;
  </MsgText>
  <Explanation>
    A trace string has garbage or incomplete type=state pair.
  </Explanation>
  <UserResponse>
    Modify the server.xml file for this server and make the startupTraceSpecification parameter compliant with trace string grammar.
  </UserResponse>
</Message>
<Message ID="TRAS0005E" severity="E" prefix="yes">
  <MsgText pgmKey="MSG_SHARED_LOG_WRITE_FAILED" varFormat="Java">
    MSG_SHARED_LOG_WRITE_FAILED=TRAS0005E: Unable to write to the service log. The following exception was encountered {0}
  </MsgText>
  <Explanation>
    An attempt to write a message to the service log failed.
  </Explanation>
  <UserResponse>
    Examine the exception to determine the root cause of the failure. Ensure that the service log file exists. Ensure that the file system is not full. Ensure that the Application Server run time is allowed write access to the directory for the log file. If this does not solve the problem, see the problem determination information on the WebSphere Application Server Support Web page: http://www.ibm.com/software/webservers/appserv/was/support.
  </UserResponse>
</Message>
<Message ID="TRAS0024I" severity="I" prefix="yes">
  <MsgText pgmKey="MSG_TOO_LARGE_FOR_LOGSTREAM" varFormat="Java">
    MSG_TOO_LARGE_FOR_LOGSTREAM=TRAS0024I: Log entry is of size {0} bytes which is too large to be added to log stream which is configured for {1} byte records.  Log entry will not be logged to the log stream.
  </MsgText>
  <Explanation>
    The log stream record size is too small to accomodate the log entry that is being logged.
  </Explanation>
  <UserResponse>
    If problem occurs frequently, increase the size of records in the log stream.
  </UserResponse>
</Message>
<Message ID="TRAS0240I" severity="I" prefix="yes">
  <MsgText pgmKey="TRAS0240I" varFormat="Java">
    TRAS0240I=TRAS0240I: Logstream {0} does not contain any records beyond start time {1}.
  </MsgText>
  <Explanation>
    The logStream has no records beyond the specified start time
  </Explanation>
  <UserResponse>
    Modify the specified start time
  </UserResponse>
</Message>
<Message ID="TRAS0011I" severity="I" prefix="yes">
  <MsgText pgmKey="MSG_CORRUPT_MESSAGE_COUNT" varFormat="Java">
    MSG_CORRUPT_MESSAGE_COUNT=TRAS0011I: {0} messages could not be read from the service log
  </MsgText>
  <Explanation>
    Corruption was found in the service log file. The indicated number of messages were not readable.
  </Explanation>
  <UserResponse>
    Corruption usually occurs when the service log file is transferred from one machine to another incorrectly. Any such transfer must be made in binary mode.
  </UserResponse>
</Message>
<Message ID="TRAS0220I" severity="I" prefix="yes">
  <MsgText pgmKey="TRAS0220I" varFormat="Java">
    TRAS0220I=TRAS0220I: The number of dropped messages: {0}
  </MsgText>
  <Explanation>
    Some messages were dropped in processing
  </Explanation>
  <UserResponse>
    Consider reRunning
  </UserResponse>
</Message>
<Message ID="TRAS0101E" severity="E" prefix="yes">
  <MsgText pgmKey="EXCEPTION_EMPTY_STRING_SUBTRACESTRING" varFormat="Java">
    EXCEPTION_EMPTY_STRING_SUBTRACESTRING=TRAS0101E: Empty string encountered - remove extra colon
  </MsgText>
  <Explanation>
    Trace string with an extra colon was specified
  </Explanation>
  <UserResponse>
    Modify the server.xml file for this server and make the startupTraceSpecification parameter compliant with trace string grammar.
  </UserResponse>
</Message>
<Message ID="TRAS0009I" severity="I" prefix="yes">
  <MsgText pgmKey="MSG_TRACE_TO_SYSOUT" varFormat="Java">
    MSG_TRACE_TO_SYSOUT=TRAS0009I: Defaulting trace output to SystemOut.log
  </MsgText>
  <Explanation>
    An error was encountered while attempting to route trace to a user-specified file. Trace output will be routed to the SystemOut.log file instead.
  </Explanation>
  <UserResponse>
    Search the log file for other error messages detailing the failure encountered while opening the user-specified file. Correct the error and retry the operation.
  </UserResponse>
</Message>
<Message ID="TRAS0115W" severity="W" prefix="yes">
  <MsgText pgmKey="RAS_LOG_MBEAN_PROXY_ZJmxInvoke" varFormat="Java">
    RAS_LOG_MBEAN_PROXY_ZJmxInvoke=TRAS0115W: Exception resulted from z/OS Servant MBean JMX call
  </MsgText>
  <Explanation>
    This exception is unexpected. The cause is not immediately known.
  </Explanation>
  <UserResponse>
    If the problem persists, additional information might be available if you search for the message ID on the following Web sites: WebSphere Application Server Support page: http://www.ibm.com/software/webservers/appserv/was/support/ WebSphere Application Server for z/OS Support page: http://www.ibm.com/software/webservers/appserv/zos_os390/support/ .
  </UserResponse>
</Message>
<Message ID="TRAS0117W" severity="W" prefix="yes">
  <MsgText pgmKey="RAS_LOG_MBEAN_PROXY_NullParm" varFormat="Java">
    RAS_LOG_MBEAN_PROXY_NullParm=TRAS0117W: Method called with a null parameter.  This is invalid {0}.
  </MsgText>
  <Explanation>
    This exception is unexpected. The cause is not immediately known.
  </Explanation>
  <UserResponse>
    If the problem persists, additional information might be available if you search for the message ID on the following Web sites: WebSphere Application Server Support page: http://www.ibm.com/software/webservers/appserv/was/support/ WebSphere Application Server for z/OS Support page: http://www.ibm.com/software/webservers/appserv/zos_os390/support/ .
  </UserResponse>
</Message>
<Message ID="TRAS0026E" severity="E" prefix="yes">
  <MsgText pgmKey="CONVERTLOG_OUTPUTFILENOTFOUND" varFormat="Java">
    CONVERTLOG_OUTPUTFILENOTFOUND=TRAS0026E: Unable to open destination file {0}.
  </MsgText>
  <Explanation>
    The destination file might not be writable because the file name that is specified is a directory name, or the file name that is specified is not valid.
  </Explanation>
  <UserResponse>
    Check parameters to make sure that the specified destination is a valid file name on a file system that the user has sufficient permissions to write to.
  </UserResponse>
</Message>
<Message ID="TRAS0100E" severity="E" prefix="yes">
  <MsgText pgmKey="EXCEPTION_EMPTY_STRING_TRACESTRING" varFormat="Java">
    EXCEPTION_EMPTY_STRING_TRACESTRING=TRAS0100E: Empty string is not part of trace string grammar
  </MsgText>
  <Explanation>
    The trace string is empty.
  </Explanation>
  <UserResponse>
    Modify the server.xml file for this server and make the startupTraceSpecification parameter compliant with trace string grammar.
  </UserResponse>
</Message>
<Message ID="TRAS0150W" severity="W" prefix="yes">
  <MsgText pgmKey="RAS_REMOTE_BadLoggerRegExp" varFormat="Java">
    RAS_REMOTE_BadLoggerRegExp=TRAS0150W: Invalid Logger Regular Expression {0}, no Logger Checking Enabled
  </MsgText>
  <Explanation>
    The regular expression passed to filter log records by logger is invalid.  Logger filtering disabled
  </Explanation>
  <UserResponse>
    Check the regular expression and reSubmit query
  </UserResponse>
</Message>
<Message ID="TRAS0006E" severity="E" prefix="yes">
  <MsgText pgmKey="MSG_SHARED_LOG_CHANGE_SIZE_FAILED" varFormat="Java">
    MSG_SHARED_LOG_CHANGE_SIZE_FAILED=TRAS0006E: Unable to change the size of the service log. The following exception was encountered {0}
  </MsgText>
  <Explanation>
    An attempt to change the size of the service log failed.
  </Explanation>
  <UserResponse>
    Examine the exception to determine the root cause of the failure. Ensure that the service log file exists. Ensure that the file system is not full. Ensure that the Application Server run time is allowed write access to the directory for the log file. If this does not solve the problem, see the problem determination information on the WebSphere Application Server Support Web page: http://www.ibm.com/software/webservers/appserv/was/support.
  </UserResponse>
</Message>
<Message ID="TRAS0004E" severity="E" prefix="yes">
  <MsgText pgmKey="MSG_SHARED_LOG_CTOR_FAILED" varFormat="Java">
    MSG_SHARED_LOG_CTOR_FAILED=TRAS0004E: Unable to create or open the service log file {0}. The following exception was encountered {1}
  </MsgText>
  <Explanation>
    An attempt to open the specified service log file failed. The exception indicates the root cause of the failure.
  </Explanation>
  <UserResponse>
    Examine the exception to determine the root cause. Ensure that the specified file name is a valid file name. Ensure that the Application Server runtime is allowed write access to the directory for the service log file. If this does not solve the problem, see the problem determination information on the WebSphere Application Server Support Web page: http://www.ibm.com/software/webservers/appserv/was/support.
  </UserResponse>
</Message>
<Message ID="TRAS0010I" severity="I" prefix="yes">
  <MsgText pgmKey="MSG_ACTIVITY_LOG_CORRUPTED" varFormat="Java">
    MSG_ACTIVITY_LOG_CORRUPTED=TRAS0010I: The size of the service log indicates that some corruption has occurred. This could be due to not transferring the file in binary mode
  </MsgText>
  <Explanation>
    The service log is maintained in a binary format. When transferred from one machine to another, it must be transferred in binary format.
  </Explanation>
  <UserResponse>
    Transfer the log file in binary format. In some cases it is possible to undo the damage by transferring the log file back to the original machine using the original transfer format, then retransferring the log file back to the target machine in binary format.
  </UserResponse>
</Message>
<Message ID="TRAS0118W" severity="W" prefix="yes">
  <MsgText pgmKey="RAS_LOG_MBEAN_PROXY_RegFail" varFormat="Java">
    RAS_LOG_MBEAN_PROXY_RegFail=TRAS0118W: Diagnostic Provider Registry Propagation failed because {0}
  </MsgText>
  <Explanation>
    This exception is unexpected. The cause is not immediately known.
  </Explanation>
  <UserResponse>
    If the problem persists, additional information might be available if you search for the message ID on the following Web sites: WebSphere Application Server Support page: http://www.ibm.com/software/webservers/appserv/was/support/ WebSphere Application Server for z/OS Support page: http://www.ibm.com/software/webservers/appserv/zos_os390/support/ .
  </UserResponse>
</Message>
<!-- END MESSAGES -->
</TMSSource>
