<?xml version="1.0" encoding="UTF-8"?>
<?xml-stylesheet type="text/css" href="../../resources/stylesheets/wasmsgxml.css"?>
<TMSSource name="TivoliMessages" tmsVersion="1.0" xml:lang="en">
<!-- CMVC MSG File Name = ws/code/plugincfg/src/com/ibm/websphere/plugincfg/generator/PluginConfigGeneratorNLS.nlsprops -->
<!-- DO NOT EDIT THIS FILE - This file was generated by the XML/Html & Property emitter -->
<!-- BEGIN MESSAGES -->
<Message ID="PLGC0020E" severity="E" prefix="yes">
  <MsgText pgmKey="no.valid.servers.for.cluster" varFormat="Java">
    no.valid.servers.for.cluster=PLGC0020E: No valid server definitions are found for the server cluster
  </MsgText>
  <Explanation>
    No servers are found in the specified cluster.
  </Explanation>
  <UserResponse>
    Use either the administrative console or the wsadmin tool to configure the servers within the cluster.
  </UserResponse>
</Message>
<Message ID="PLGC0008I" severity="I" prefix="yes">
  <MsgText pgmKey="single.server.gen" varFormat="Java">
    single.server.gen=PLGC0008I: The plug-in is generating a single-server plug-in configuration file for the cell.
  </MsgText>
  <Explanation>
    This informational message indicates that the configuration file for the cell is generating.
  </Explanation>
  <UserResponse>
    No user action is required.
  </UserResponse>
</Message>
<Message ID="PLGC0049E" severity="E" prefix="yes">
  <MsgText pgmKey="propagate.failed" varFormat="Java">
    propagate.failed=PLGC0049E: The propagation of the plug-in configuration file failed for the Web server.
  </MsgText>
  <Explanation>
    The Application Server cannot transfer the plug-in configuration file.
  </Explanation>
  <UserResponse>
    Verify that the IBM HTTP Server administration server is configured correctly.
  </UserResponse>
</Message>
<Message ID="PLGC0054E" severity="E" prefix="yes">
  <MsgText pgmKey="servertype.unknown" varFormat="Java">
    servertype.unknown=PLGC0054E: The plug-in is unable to get the server type for the server.
  </MsgText>
  <Explanation>
    The Application Server cannot determine the type of the server
  </Explanation>
  <UserResponse>
    Enable trace for the com.ibm.websphere.plugincfg.generator.* classes.  If the problem persists, see the problem determination information on the WebSphere Application Server Support Web page on http://www.ibm.com/software/webservers/appserv/was/support/.
  </UserResponse>
</Message>
<Message ID="PLGC0024E" severity="E" prefix="yes">
  <MsgText pgmKey="exception.reading.web.con" varFormat="Java">
    exception.reading.web.con=PLGC0024E: An exception occurred while getting the Web container configuration for the specified server.
  </MsgText>
  <Explanation>
    No configuration data is available for the Web container component of one or more of the specified servers.
  </Explanation>
  <UserResponse>
    Use either the administrative console or the wsadmin.sh tool to configure the Web containers again.
  </UserResponse>
</Message>
<Message ID="PLGC0040I" severity="I" prefix="yes">
  <MsgText pgmKey="morethan.one.node" varFormat="Java">
    morethan.one.node=PLGC0040I: More than one node is specified in the list; only the first node is selected.
  </MsgText>
  <Explanation>
    You can specify only one node when multiple servers are passed as parameters.
  </Explanation>
  <UserResponse>
    Specify only one node using either the administrative console or the wsadmin.sh tool.
  </UserResponse>
</Message>
<Message ID="PLGC0082I" severity="I" prefix="yes">
  <MsgText pgmKey="hostname.filter.does.not.exists.risk" varFormat="Java">
    hostname.filter.does.not.exists.risk=PLGC0082I: There are no filters based on host names in virtualhosts.xml. The requests are not being filtered according to specific host names in virtualhosts.xml. This protects against the security exposure in which JSP source code shown by the Web server.
  </MsgText>
  <Explanation>
    Requests are not being filtered. The Web server Plug-in will process all requests and forward each to an application server running the requested application.
  </Explanation>
  <UserResponse>
    For more protection, make sure the Web server document root does not point to Application Server source files.
  </UserResponse>
</Message>
<Message ID="PLGC0064I" severity="I" prefix="yes">
  <MsgText pgmKey="propagate.keyring.location" varFormat="Java">
    propagate.keyring.location=PLGC0064I: The plug-in keyring file is propagated from {0} to {1} on the Web server computer.
  </MsgText>
  <Explanation>
    This message is for informational purposes only.
  </Explanation>
  <UserResponse>
    No user action is required.
  </UserResponse>
</Message>
<Message ID="PLGC0058E" severity="E" prefix="yes">
  <MsgText pgmKey="pluginconfigservice.starterror" varFormat="Java">
    pluginconfigservice.starterror=PLGC0058E: The plug-in cannot initialize the plug-in configuration service.
  </MsgText>
  <Explanation>
    The Application Server cannot start the plug-in configuration service.
  </Explanation>
  <UserResponse>
    Enable trace for the com.ibm.websphere.plugincfg.generator.* classes.  If the problem persists, see the problem determination information on the WebSphere Application Server Support Web page on http://www.ibm.com/software/webservers/appserv/was/support/.
  </UserResponse>
</Message>
<Message ID="PLGC0079I" severity="I" prefix="yes">
  <MsgText pgmKey="https.transport.exists.risk" varFormat="Java">
    https.transport.exists.risk=PLGC0079I: HTTPS transport is defined between the web server {0} and the application server {1}. Communication between the web server and application server is over HTTPS which is encrypted and secure.
  </MsgText>
  <Explanation>
    HTTPS transport is configured. Secure communication can take place between web server and application server.
  </Explanation>
  <UserResponse>
    No user action is required.
  </UserResponse>
</Message>
<Message ID="PLGC0088E" severity="E" prefix="yes">
  <MsgText pgmKey="clusteraddressendpoint.duplicates.https" varFormat="Java">
    clusteraddressendpoint.duplicates.https=PLGC0088E: The clusterAddress has more than one HTTPS transport defined.
  </MsgText>
  <Explanation>
    Only one HTTPS transport can be defined for the clusterAddress.
  </Explanation>
  <UserResponse>
    Use the administrative console or the wsadmin.sh tool to fix this problem.
  </UserResponse>
</Message>
<Message ID="PLGC0063E" severity="E" prefix="yes">
  <MsgText pgmKey="propagate.location.failed" varFormat="Java">
    propagate.location.failed=PLGC0063E: The propagation of the plug-in configuration file from {0} to {1} on the Web server computer failed.
  </MsgText>
  <Explanation>
    The Application Server cannot transfer the plug-in configuration file.
  </Explanation>
  <UserResponse>
    Verify that the administration server for IBM HTTP Server is configured correctly.
  </UserResponse>
</Message>
<Message ID="PLGC0050W" severity="W" prefix="yes">
  <MsgText pgmKey="propagate.notsupported" varFormat="Java">
    propagate.notsupported=PLGC0050W: The propagation of the plug-in configuration file is not supported for the remote Web server.
  </MsgText>
  <Explanation>
    The propagation of the plug-in configuration file to the remote Web server is supported for the IBM HTTP Server Web server only.
  </Explanation>
  <UserResponse>
    No user action is required.
  </UserResponse>
</Message>
<Message ID="PLGC0044W" severity="W" prefix="yes">
  <MsgText pgmKey="error.reading.lotusuris" varFormat="Java">
    error.reading.lotusuris=PLGC0044W: An exception occurred while getting the URI lists for Lotus workplace clusters.
  </MsgText>
  <Explanation>
    This message is for informational purposes only.
  </Explanation>
  <UserResponse>
    No user action is required.
  </UserResponse>
</Message>
<Message ID="PLGC0030E" severity="E" prefix="yes">
  <MsgText pgmKey="no.nodes.in.cell" varFormat="Java">
    no.nodes.in.cell=PLGC0030E: No nodes are defined in the cell.
  </MsgText>
  <Explanation>
    Nodes are not defined in the present configuration. This problem can result from a corrupted configuration.
  </Explanation>
  <UserResponse>
    Verify that the configuration data is saved in the repository. If the problem persists, see the problem determination information on the WebSphere Application Server Support Web page on http://www.ibm.com/software/webservers/appserv/was/support/.
  </UserResponse>
</Message>
<Message ID="PLGC0004E" severity="E" prefix="yes">
  <MsgText pgmKey="rerun.with.debug" varFormat="Java">
    rerun.with.debug=PLGC0004E: An exception occurred while running the GenPluginCfg utility.
  </MsgText>
  <Explanation>
    An error occurred while the utility was running.
  </Explanation>
  <UserResponse>
    Rerun the GenPluginCfg script with the -debug option set to yes to see trace details. For example, run GenPluginCfg -debug yes. If the problem persists, see the problem determination on the WebSphere Application Server Support Web page on http://www.ibm.com/software/webservers/appserv/was/support/.
  </UserResponse>
</Message>
<Message ID="PLGC0073W" severity="W" prefix="yes">
  <MsgText pgmKey="no.def.for.pmirm" varFormat="Java">
    no.def.for.pmirm=PLGC0073W: No definition is found for request metrics.
  </MsgText>
  <Explanation>
    This informational message indicates the program status.
  </Explanation>
  <UserResponse>
    No user action is required.
  </UserResponse>
</Message>
<Message ID="PLGC0018E" severity="E" prefix="yes">
  <MsgText pgmKey="exception.parsing.cluster" varFormat="Java">
    exception.parsing.cluster=PLGC0018E: An exception occurred while reading the server cluster configuration for a cluster.
  </MsgText>
  <Explanation>
    This error occured because of a corrupted cluster configuration file.
  </Explanation>
  <UserResponse>
    Use the administrative console or the wsadmin.sh tool to cluster your servers again. If that action fails, delete any cluster configuration that is present and try again.
  </UserResponse>
</Message>
<Message ID="PLGC0086W" severity="W" prefix="yes">
  <MsgText pgmKey="no.alias.tag.exists.risk" varFormat="Java">
    no.alias.tag.exists.risk=PLGC0086W: There are no aliases tags in the file {0}. Aliases are not defined for the virual host groups.
  </MsgText>
  <Explanation>
    No host aliases are defined for virtual host groups.
  </Explanation>
  <UserResponse>
    Make sure that virtual host group definitions has some host aliases.
  </UserResponse>
</Message>
<Message ID="PLGC0067E" severity="E" prefix="yes">
  <MsgText pgmKey="propagate.stashfile.location.failed" varFormat="Java">
    propagate.stashfile.location.failed=PLGC0067E: The propagation of plug-in stash file from {0} to {1} on the Web server computer failed.
  </MsgText>
  <Explanation>
    The Application Server cannot transfer the plug-in stash file.
  </Explanation>
  <UserResponse>
    Verify that the administration server for IBM HTTP Server is configured correctly.
  </UserResponse>
</Message>
<Message ID="PLGC0010E" severity="E" prefix="yes">
  <MsgText pgmKey="no.cell.name" varFormat="Java">
    no.cell.name=PLGC0010E: No cell name is specified...stopping generation.
  </MsgText>
  <Explanation>
    A cell name is required.
  </Explanation>
  <UserResponse>
    Specify a cell name. Verify that the configuration data is saved in the repository. If the problem persists, see the problem determination information on the WebSphere Application Server Support Web page on http://www.ibm.com/software/webservers/appserv/was/support/.
  </UserResponse>
</Message>
<Message ID="PLGC0055E" severity="E" prefix="yes">
  <MsgText pgmKey="webserverlist.unknown" varFormat="Java">
    webserverlist.unknown=PLGC0055E: The plug-in is unable to get the list of Web servers that is defined on the node.
  </MsgText>
  <Explanation>
    The Application Server cannot retrieve the list of Web servers.
  </Explanation>
  <UserResponse>
    Enable trace for the com.ibm.websphere.plugincfg.generator.* classes.  If the problem persists, see the problem determination information on the WebSphere Application Server Support Web page on http://www.ibm.com/software/webservers/appserv/was/support/.
  </UserResponse>
</Message>
<Message ID="PLGC0014E" severity="E" prefix="yes">
  <MsgText pgmKey="no.clusters.or.nodes" varFormat="Java">
    no.clusters.or.nodes=PLGC0014E: No clusters or nodes are defined...exiting.
  </MsgText>
  <Explanation>
    Nodes or clusters are not defined in the present configuration. Servers are not available for which to generate a plug-in configuration.
  </Explanation>
  <UserResponse>
    Create nodes and clusters that have servers in them using either the administrative console, or the wsadmin.sh tool.
  </UserResponse>
</Message>
<Message ID="PLGC0046W" severity="W" prefix="yes">
  <MsgText pgmKey="error.reading.tunneluris" varFormat="Java">
    error.reading.tunneluris=PLGC0046W: An exception occurred while getting the URI lists for tunnel clusters.
  </MsgText>
  <Explanation>
    This message is for informational purposes only.
  </Explanation>
  <UserResponse>
    No user action is required.
  </UserResponse>
</Message>
<Message ID="PLGC0056E" severity="E" prefix="yes">
  <MsgText pgmKey="nopluginproperties.found" varFormat="Java">
    nopluginproperties.found=PLGC0056E: The plug-in is unable to get the plug-in properties for the Web server.
  </MsgText>
  <Explanation>
    The Application Server cannot retrieve the plug-in properties.
  </Explanation>
  <UserResponse>
    Enable trace for the com.ibm.websphere.plugincfg.generator.* classes.  If the problem persists, see the problem determination information on the WebSphere Application Server Support Web page on http://www.ibm.com/software/webservers/appserv/was/support/.
  </UserResponse>
</Message>
<Message ID="PLGC0015E" severity="E" prefix="yes">
  <MsgText pgmKey="no.server.defs.for.cell" varFormat="Java">
    no.server.defs.for.cell=PLGC0015E: No server definitions are found for the cell.
  </MsgText>
  <Explanation>
    Servers are not defined in the given cell. Servers are not available for which to generate a plug-in configuration.
  </Explanation>
  <UserResponse>
    Create servers within the nodes and clusters before running the tool, by using either the administrative console or the wsadmin.sh tool.
  </UserResponse>
</Message>
<Message ID="PLGC0016E" severity="E" prefix="yes">
  <MsgText pgmKey="server.name.not.set" varFormat="Java">
    server.name.not.set=PLGC0016E: A server name is not set for a member server in the cluster.
  </MsgText>
  <Explanation>
    One or more of the cluster members do not have server names.
  </Explanation>
  <UserResponse>
    Use the administrative console or the wsadmin.sh tool to fix this problem.
  </UserResponse>
</Message>
<Message ID="PLGC0090E" severity="E" prefix="yes">
  <MsgText pgmKey="clusteraddressendpoint.port.zero" varFormat="Java">
    clusteraddressendpoint.port.zero=PLGC0090E: The clusterAddress endpoint port is zero.
  </MsgText>
  <Explanation>
    The clusterADdress endpoint needs a valid port defined.
  </Explanation>
  <UserResponse>
    Use the administrative console or the wsadmin.sh tool to fix this problem.
  </UserResponse>
</Message>
<Message ID="PLGC0051I" severity="I" prefix="yes">
  <MsgText pgmKey="generate.started" varFormat="Java">
    generate.started=PLGC0051I: Plug-in configuration file generation started for the Web server.
  </MsgText>
  <Explanation>
    This message is for informational purposes only.
  </Explanation>
  <UserResponse>
    No user action is required.
  </UserResponse>
</Message>
<Message ID="PLGC0035E" severity="E" prefix="yes">
  <MsgText pgmKey="error.reading.routermodule" varFormat="Java">
    error.reading.routermodule=PLGC0035E: An exception occurred while getting the associated router module name.
  </MsgText>
  <Explanation>
    This exception is unexpected. The cause is not immediately known.
  </Explanation>
  <UserResponse>
    Rerun the GenPluginCfg script with the -debug option set to yes to see trace details. For example, run the following command: GenPluginCfg -debug yes. If the problem persists, see the problem determination information on the WebSphere Application Server Support Web page on http://www.ibm.com/software/webservers/appserv/was/support/.
  </UserResponse>
</Message>
<Message ID="PLGC0068I" severity="I" prefix="yes">
  <MsgText pgmKey="nodesync.keyring.started" varFormat="Java">
    nodesync.keyring.started=PLGC0068I: Node synchronization is started to propagate the plug-in keyring and stash file that is defined in the managed node.
  </MsgText>
  <Explanation>
    Node synchronization is used to move the plug-in keyring and stash file to the managed node.
  </Explanation>
  <UserResponse>
    No user action is required.
  </UserResponse>
</Message>
<Message ID="PLGC0083E" severity="E" prefix="yes">
  <MsgText pgmKey="unable.to.parse.file.risk" varFormat="Java">
    unable.to.parse.file.risk=PLGC0083E: Unable to parse the file {0}. The config file does not exist or the content is corrupted.
  </MsgText>
  <Explanation>
    The Application Server cannot parse the specified configuration file.
  </Explanation>
  <UserResponse>
    Check the location of the file and make sure that it has valid contents.
  </UserResponse>
</Message>
<Message ID="PLGC0045W" severity="W" prefix="yes">
  <MsgText pgmKey="error.loading.tunnelcfghelper" varFormat="Java">
    error.loading.tunnelcfghelper=PLGC0045W: The plug-in is unable to load the com.ibm.ws.httptunnel.channel.WSHttpTunnelPluginConfigHelper helper class.
  </MsgText>
  <Explanation>
    The HTTP tunnel configuration helper class did not load.
  </Explanation>
  <UserResponse>
    No user action is required if the servers that use the HTTP tunnel are not defined. If the servers are defined using the HTTP tunnel, verify that the class path includes the cfplugin.jar file.
  </UserResponse>
</Message>
<Message ID="PLGC0038E" severity="E" prefix="yes">
  <MsgText pgmKey="app.server.root.missing" varFormat="Java">
    app.server.root.missing=PLGC0038E: The application server root must be specified in the generate method.
  </MsgText>
  <Explanation>
    This exception is unexpected. The cause is not immediately known.
  </Explanation>
  <UserResponse>
    If the problem persists, see the problem determination information on the WebSphere Application Server Support Web page on http://www.ibm.com/software/webservers/appserv/was/support/.
  </UserResponse>
</Message>
<Message ID="PLGC0036E" severity="E" prefix="yes">
  <MsgText pgmKey="error.getting.urlpatterns" varFormat="Java">
    error.getting.urlpatterns=PLGC0036E: An exception occurred while getting dynamically generated servlet URL patterns for a Web services-enabled Web archive (WAR) module.
  </MsgText>
  <Explanation>
    This exception is unexpected. The cause is not immediately known.
  </Explanation>
  <UserResponse>
    Rerun the GenPluginCfg script with the -debug option set to yes to see trace details. For example, run the following command: GenPluginCfg -debug yes. If the problem persists, see the problem determination information on the WebSphere Application Server Support Web page on http://www.ibm.com/software/webservers/appserv/was/support/.
  </UserResponse>
</Message>
<Message ID="PLGC0075I" severity="I" prefix="yes">
  <MsgText pgmKey="node.in.sync.stashfile" varFormat="Java">
    node.in.sync.stashfile=PLGC0075I: The node is already synchronized and the stash file is already propagated.
  </MsgText>
  <Explanation>
    Node synchronization has already propagated the stash file to the managed node.
  </Explanation>
  <UserResponse>
    No user action is required.
  </UserResponse>
</Message>
<Message ID="PLGC0066I" severity="I" prefix="yes">
  <MsgText pgmKey="propagate.stashfile.location" varFormat="Java">
    propagate.stashfile.location=PLGC0066I: The plug-in stash file is propagated from {0} to {1} on the Web server computer.
  </MsgText>
  <Explanation>
    This message is for informational purposes only.
  </Explanation>
  <UserResponse>
    No user action is required.
  </UserResponse>
</Message>
<Message ID="PLGC0087E" severity="E" prefix="yes">
  <MsgText pgmKey="clusteraddressendpoint.duplicate.http" varFormat="Java">
    clusteraddressendpoint.duplicate.http=PLGC0087E: The clusterAddress has more than one HTTP transport defined.
  </MsgText>
  <Explanation>
    Only one HTTP transport can be defined for the clusterAddress.
  </Explanation>
  <UserResponse>
    Use the administrative console or the wsadmin.sh tool to fix this problem.
  </UserResponse>
</Message>
<Message ID="PLGC0039I" severity="I" prefix="yes">
  <MsgText pgmKey="gen.for.cluster" varFormat="Java">
    gen.for.cluster=PLGC0039I: The plug-in is generating a server plug-in configuration file using the cluster definition.
  </MsgText>
  <Explanation>
    This message is for informational purposes only.
  </Explanation>
  <UserResponse>
    No user action is required.
  </UserResponse>
</Message>
<Message ID="PLGC0009I" severity="I" prefix="yes">
  <MsgText pgmKey="single.node.gen" varFormat="Java">
    single.node.gen=PLGC0009I: The plug-in is generating for all the servers in the cell.
  </MsgText>
  <Explanation>
    This message is for informational purposes only.
  </Explanation>
  <UserResponse>
    No user action is required.
  </UserResponse>
</Message>
<Message ID="PLGC0062I" severity="I" prefix="yes">
  <MsgText pgmKey="propagate.location" varFormat="Java">
    propagate.location=PLGC0062I: The plug-in configuration file is propagated from {0} to {1} on the Web server computer.
  </MsgText>
  <Explanation>
    This message is for informational purposes only.
  </Explanation>
  <UserResponse>
    No user action is required.
  </UserResponse>
</Message>
<Message ID="PLGC0065E" severity="E" prefix="yes">
  <MsgText pgmKey="propagate.keyring.location.failed" varFormat="Java">
    propagate.keyring.location.failed=PLGC0065E: The propagation of plug-in keyring file from {0} to {1} on the Web server computer failed.
  </MsgText>
  <Explanation>
    The Application Server cannot transfer the plug-in keyring file.
  </Explanation>
  <UserResponse>
    Verify that administration server IBM HTTP Server is configured correctly.
  </UserResponse>
</Message>
<Message ID="PLGC0002E" severity="E" prefix="yes">
  <MsgText pgmKey="node.required" varFormat="Java">
    node.required=PLGC0002E: A server name is specified without a node name.
  </MsgText>
  <Explanation>
    Both the server name and the node name are required for single-server plug-in generation.
  </Explanation>
  <UserResponse>
    If you specify a server name, you must specify a node name.
  </UserResponse>
</Message>
<Message ID="PLGC0070E" severity="E" prefix="yes">
  <MsgText pgmKey="propagate.keyring.failed" varFormat="Java">
    propagate.keyring.failed=PLGC0070E: The propagation of the plug-in keyring has failed for the Web server.
  </MsgText>
  <Explanation>
    The Application Server cannot transfer the plug-in keyring file.
  </Explanation>
  <UserResponse>
    Verify that the administration server for IBM HTTP Server is configured correctly.
  </UserResponse>
</Message>
<Message ID="PLGC0089E" severity="E" prefix="yes">
  <MsgText pgmKey="clusteraddressendpoint.host.null" varFormat="Java">
    clusteraddressendpoint.host.null=PLGC0089E: The clusterAddress endpoint host is null.
  </MsgText>
  <Explanation>
    The clusterADdress endpoint needs a valid host defined.
  </Explanation>
  <UserResponse>
    Use the administrative console or the wsadmin.sh tool to fix this problem.
  </UserResponse>
</Message>
<Message ID="PLGC0069I" severity="I" prefix="yes">
  <MsgText pgmKey="propagate.keyring.complete" varFormat="Java">
    propagate.keyring.complete=PLGC0069I: The propagation of the plug-in keyring is complete for the Web server.
  </MsgText>
  <Explanation>
    This message is for informational purposes only.
  </Explanation>
  <UserResponse>
    No user action is required.
  </UserResponse>
</Message>
<Message ID="PLGC0074I" severity="I" prefix="yes">
  <MsgText pgmKey="node.in.sync.plugincfg" varFormat="Java">
    node.in.sync.plugincfg=PLGC0074I: The node is already synchronized and the plug-in configuration file is already propagated.
  </MsgText>
  <Explanation>
    Node synchronization has already propagated the plug-in configuration file to the managed node.
  </Explanation>
  <UserResponse>
    No user action is required.
  </UserResponse>
</Message>
<Message ID="PLGC0029E" severity="E" prefix="yes">
  <MsgText pgmKey="exception.reading.ear" varFormat="Java">
    exception.reading.ear=PLGC0029E: An exception occurred while reading the enterprise archive (EAR) file
  </MsgText>
  <Explanation>
    One or more of the applications that are deployed on the specified servers cannot be read.
  </Explanation>
  <UserResponse>
    Examine the exception. Rerun the GenPluginCfg script with the -debug option set to yes to see trace details. For example: run GenPluginCfg -debug yes. Make sure that the configuration data is saved in the repository. If the problem persists, redeploy the application. Verify that the enterprise archive (EAR) file and the Web archive (WAR) file are valid. If the problem persists, see the problem determination information on the WebSphere Application Server Support Web page on http://www.ibm.com/software/webservers/appserv/was/support/.
  </UserResponse>
</Message>
<Message ID="PLGC0091E" severity="E" prefix="yes">
  <MsgText pgmKey="clusteraddressendpoint.unknown.name" varFormat="Java">
    clusteraddressendpoint.unknown.name=PLGC0091E: The clusterAddress endpoint name is unknown,
  </MsgText>
  <Explanation>
    The clusterAddress endpoint name has to be HTTP_ENDPOINT or HTTPS_ENDPOINT.
  </Explanation>
  <UserResponse>
    Use the administrative console or the wsadmin.sh tool to fix this problem.
  </UserResponse>
</Message>
<Message ID="PLGC0001E" severity="E" prefix="yes">
  <MsgText pgmKey="cell.required" varFormat="Java">
    cell.required=PLGC0001E: A cell name is not specified.
  </MsgText>
  <Explanation>
    The cell name is a required value.
  </Explanation>
  <UserResponse>
    You must specify a cell name.
  </UserResponse>
</Message>
<Message ID="PLGC0084W" severity="W" prefix="yes">
  <MsgText pgmKey="no.server.tag.exists.risk" varFormat="Java">
    no.server.tag.exists.risk=PLGC0084W: There are no Server tags in the file {0}. The configuration file has no application server definition.
  </MsgText>
  <Explanation>
    The configuration has no application servers defined.
  </Explanation>
  <UserResponse>
    Make sure that some application servers are defined and used by the web server.
  </UserResponse>
</Message>
<Message ID="PLGC0025E" severity="E" prefix="yes">
  <MsgText pgmKey="error.reading.web.con" varFormat="Java">
    error.reading.web.con=PLGC0025E: The plug-in cannot get the Web container configuration for the specified server
  </MsgText>
  <Explanation>
    No configuration data for the Web container component is available for one or more of the specified servers.
  </Explanation>
  <UserResponse>
    Use either the administrative console or the wsadmin.sh tool to configure the Web containers again.
  </UserResponse>
</Message>
<Message ID="PLGC0080W" severity="W" prefix="yes">
  <MsgText pgmKey="no.transport.exists.risk" varFormat="Java">
    no.transport.exists.risk=PLGC0080W: No transports are defined between the webserver {0} and the application server {1}. Communication between the web server and application server is currently not possible.
  </MsgText>
  <Explanation>
    There are no HTTP nor HTTPS transports defined Web server and Application Server.
  </Explanation>
  <UserResponse>
    Set up HTTPS (SSL) transports between the web server and application server, in order to have the communication between web server and the application server be encrypted.
  </UserResponse>
</Message>
<Message ID="PLGC0003E" severity="E" prefix="yes">
  <MsgText pgmKey="unknown.parameter" varFormat="Java">
    unknown.parameter=PLGC0003E: Unknown parameter:
  </MsgText>
  <Explanation>
    An unknown parameter is encountered.
  </Explanation>
  <UserResponse>
    Review the usage information of the GenPluginCfg utility for valid parameters.
  </UserResponse>
</Message>
<Message ID="PLGC0085W" severity="W" prefix="yes">
  <MsgText pgmKey="no.transport.tag.exists.risk" varFormat="Java">
    no.transport.tag.exists.risk=PLGC0085W: There are no Transport tags for the application server {0} in the file {1}.
  </MsgText>
  <Explanation>
    The Application Server has no Transports defined in plug-in configuration.
  </Explanation>
  <UserResponse>
    Set up HTTPS  (SSL) transports between the webserver and application server, in order to have the communication between webserver and application server be encrypted.
  </UserResponse>
</Message>
<Message ID="PLGC0006E" severity="E" prefix="yes">
  <MsgText pgmKey="doc.output.exception" varFormat="Java">
    doc.output.exception=PLGC0006E: An exception occurred while outputting the document.
  </MsgText>
  <Explanation>
    An error occured while generating the plug-in configuration file.
  </Explanation>
  <UserResponse>
    Rerun the GenPluginCfg script with the -debug option set to yes to see trace details. For example run GenPluginCfg -debug yes. If the problem persists, see the problem determination on the WebSphere Application Server Support Web page on http://www.ibm.com/software/webservers/appserv/was/support/.
  </UserResponse>
</Message>
<Message ID="PLGC0076E" severity="E" prefix="yes">
  <MsgText pgmKey="config.service.notAvailable" varFormat="Java">
    config.service.notAvailable=PLGC0076E: The configuration service is not available.
  </MsgText>
  <Explanation>
    The configuration root specified is incorrect. The plug-in configuration generator is not able to access the repository.
  </Explanation>
  <UserResponse>
    Verify that configuration root is correctly passed to the plug-in configuration generator.
  </UserResponse>
</Message>
<Message ID="PLGC0034E" severity="E" prefix="yes">
  <MsgText pgmKey="root.exception" varFormat="Java">
    root.exception=PLGC0034E: Root exception:
  </MsgText>
  <Explanation>
    This informational message indicates a root exception.
  </Explanation>
  <UserResponse>
    Rerun the GenPluginCfg script with the -debug option set to yes to see trace details. For example, run the following command: GenPluginCfg -debug yes. If the problem persists, see the problem determination information on the WebSphere Application Server Support Web page on http://www.ibm.com/software/webservers/appserv/was/support/.
  </UserResponse>
</Message>
<Message ID="PLGC0042W" severity="W" prefix="yes">
  <MsgText pgmKey="error.reading.lotusclusters" varFormat="Java">
    error.reading.lotusclusters=PLGC0042W: An exception occurred while getting the Lotus workplace clusters.
  </MsgText>
  <Explanation>
    This message is for informational purposes only.
  </Explanation>
  <UserResponse>
    No user action is required.
  </UserResponse>
</Message>
<Message ID="PLGC0026E" severity="E" prefix="yes">
  <MsgText pgmKey="no.server.index" varFormat="Java">
    no.server.index=PLGC0026E: An exception occurred while reading the server index for the server.
  </MsgText>
  <Explanation>
    The present configuration did not contain a server index file. This missing file can result from a corrupted configuration.
  </Explanation>
  <UserResponse>
    Verify that the serverindex.xml file exists. If it does not exist, create the file.
  </UserResponse>
</Message>
<Message ID="PLGC0023E" severity="E" prefix="yes">
  <MsgText pgmKey="exception.reading.server" varFormat="Java">
    exception.reading.server=PLGC0023E: An exception occurred while reading the server configuration
  </MsgText>
  <Explanation>
    No configuration data is found for one or more of the servers that you specified.
  </Explanation>
  <UserResponse>
    Use either the administrative console or the wsadmin.sh tool to configure your servers.
  </UserResponse>
</Message>
<Message ID="PLGC0053E" severity="E" prefix="yes">
  <MsgText pgmKey="generate.notcomplete" varFormat="Java">
    generate.notcomplete=PLGC0053E: The plug-in configuration file is not created for the Web server.
  </MsgText>
  <Explanation>
    The Application Server cannot generate the plug-in configuration file.
  </Explanation>
  <UserResponse>
    Enable trace for the com.ibm.websphere.plugincfg.generator.* classes.  If the problem persists, see the problem determination information on the WebSphere Application Server Support Web page on http://www.ibm.com/software/webservers/appserv/was/support/.
  </UserResponse>
</Message>
<Message ID="PLGC0072E" severity="E" prefix="yes">
  <MsgText pgmKey="propagate.stashfile.failed" varFormat="Java">
    propagate.stashfile.failed=PLGC0072E: The propagation of the plug-in stash file has failed for the Web server.
  </MsgText>
  <Explanation>
    The Appplication Server cannot transfer the plug-in stash file.
  </Explanation>
  <UserResponse>
    Verify that the administration server for IBM HTTP Server is configured correctly.
  </UserResponse>
</Message>
<Message ID="PLGC0043W" severity="W" prefix="yes">
  <MsgText pgmKey="error.reading.lotustransports" varFormat="Java">
    error.reading.lotustransports=PLGC0043W: An exception occurred while getting the transports for Lotus workplace servers.
  </MsgText>
  <Explanation>
    This message is for informational purposes only.
  </Explanation>
  <UserResponse>
    No user action is required.
  </UserResponse>
</Message>
<Message ID="PLGC0021E" severity="E" prefix="yes">
  <MsgText pgmKey="no.server.for.any.cluster" varFormat="Java">
    no.server.for.any.cluster=PLGC0021E: No valid server definitions are found for any cluster.  No plugin-cfg.xml document is generated.
  </MsgText>
  <Explanation>
    No servers are found. No servers are available for which to generate the plug-in configuration.
  </Explanation>
  <UserResponse>
    Use either the administrative console or the wsadmin.sh tool to configure the servers within the cluster.
  </UserResponse>
</Message>
<Message ID="PLGC0031E" severity="E" prefix="yes">
  <MsgText pgmKey="error.reading.nodes.in.cell" varFormat="Java">
    error.reading.nodes.in.cell=PLGC0031E: An error occurred while reading nodes in a cell.
  </MsgText>
  <Explanation>
    This exception is unexpected. The cause is not immediately known.
  </Explanation>
  <UserResponse>
    Make sure that the configuration data is saved in the repository. If the problem persists, see the problem determination information on the WebSphere Application Server Support Web page on http://www.ibm.com/software/webservers/appserv/was/support/.
  </UserResponse>
</Message>
<Message ID="PLGC0019E" severity="E" prefix="yes">
  <MsgText pgmKey="no.cells.defined" varFormat="Java">
    no.cells.defined=PLGC0019E: No cell definitions are found.
  </MsgText>
  <Explanation>
    No cells are found in your existing configuration.
  </Explanation>
  <UserResponse>
    Use the administrative console or the wsadmin.sh tool to create the cells.
  </UserResponse>
</Message>
<Message ID="PLGC0017E" severity="E" prefix="yes">
  <MsgText pgmKey="error.parsing.cluster" varFormat="Java">
    error.parsing.cluster=PLGC0017E: The plug-in cannot parse the server cluster configuration for the cluster.
  </MsgText>
  <Explanation>
    This error occurred because of a corrupted cluster configuration file.
  </Explanation>
  <UserResponse>
    Use the administrative console to cluster your servers again. If that action fails, delete any cluster configuration that is present and try again. Make sure that the configuration data is saved in the repository. If the problem persists, see the problem determination information on the WebSphere Application Server Support Web page on http://www.ibm.com/software/webservers/appserv/was/support/.
  </UserResponse>
</Message>
<Message ID="PLGC0012I" severity="I" prefix="yes">
  <MsgText pgmKey="gen.for.clusters" varFormat="Java">
    gen.for.clusters=PLGC0012I: The plug-in is generating a server plug-in configuration file using the cluster definition.
  </MsgText>
  <Explanation>
    This message is for informational purposes only.
  </Explanation>
  <UserResponse>
    No user action is required.
  </UserResponse>
</Message>
<Message ID="PLGC0037E" severity="E" prefix="yes">
  <MsgText pgmKey="error.loading.plugincfghelper" varFormat="Java">
    error.loading.plugincfghelper=PLGC0037E: The plug-in cannot load the com.ibm.ws.webservices.deploy.PluginCfgHelper helper class.
  </MsgText>
  <Explanation>
    The webservices.jar file might not be in the class path.
  </Explanation>
  <UserResponse>
    Check the class path and include the java archive (JAR) file, if necessary.
  </UserResponse>
</Message>
<Message ID="PLGC0047I" severity="I" prefix="yes">
  <MsgText pgmKey="nodesync.started" varFormat="Java">
    nodesync.started=PLGC0047I: Node synchronization is started to propagate the plug-in configuration file that is defined in the managed node.
  </MsgText>
  <Explanation>
    Node synchronization is used to move the plug-in configuration file to the managed node.
  </Explanation>
  <UserResponse>
    No user action is required.
  </UserResponse>
</Message>
<Message ID="PLGC0061I" severity="I" prefix="yes">
  <MsgText pgmKey="debug.file.name" varFormat="Java">
    debug.file.name=PLGC0061I: Debug log file =
  </MsgText>
  <Explanation>
    This informational message indicates the name of the debug log file.
  </Explanation>
  <UserResponse>
    No user action is required.
  </UserResponse>
</Message>
<Message ID="PLGC0022W" severity="W" prefix="yes">
  <MsgText pgmKey="no.def.for.server" varFormat="Java">
    no.def.for.server=PLGC0022W: No definition is found for the specified server
  </MsgText>
  <Explanation>
    No configuration data is found for one or more of the servers that you specified.
  </Explanation>
  <UserResponse>
    Use either the administrative console or the wsadmin.sh tool to configure your servers.
  </UserResponse>
</Message>
<Message ID="PLGC0071I" severity="I" prefix="yes">
  <MsgText pgmKey="propagate.stashfile.complete" varFormat="Java">
    propagate.stashfile.complete=PLGC0071I: The propagation of the plug-in stash file is complete for the Web server.
  </MsgText>
  <Explanation>
    This message is for informational purposes only.
  </Explanation>
  <UserResponse>
    No user action is required.
  </UserResponse>
</Message>
<Message ID="PLGC0057I" severity="I" prefix="yes">
  <MsgText pgmKey="pluginconfigservice.started" varFormat="Java">
    pluginconfigservice.started=PLGC0057I: The plug-in configuration service started successfully.
  </MsgText>
  <Explanation>
    This message is for informational purposes only.
  </Explanation>
  <UserResponse>
    No user action is required.
  </UserResponse>
</Message>
<Message ID="PLGC0060E" severity="E" prefix="yes">
  <MsgText pgmKey="webserver.noapplications" varFormat="Java">
    webserver.noapplications=PLGC0060E: No applications are mapped to the Web server.
  </MsgText>
  <Explanation>
    The plug-in configuration file for the Web server is generated based on the applications that are mapped to it. Applications are not mapped to the Web server.
  </Explanation>
  <UserResponse>
    Use the Application Installation wizard  to map modules to the Web server.
  </UserResponse>
</Message>
<Message ID="PLGC0081W" severity="W" prefix="yes">
  <MsgText pgmKey="hostname.filter.exists.risk" varFormat="Java">
    hostname.filter.exists.risk=PLGC0081W: There are filters based on host names in virtualhosts.xml. The requests are filtered according to specific host names in virtualhosts.xml, when the value specified in the host header doesn&apos;t match the filter, the web server plug-in would pass the control to webserver indicating that the Application Server will not handle the request. The web server could potentially serve the JSP source from the IHS document root.
  </MsgText>
  <Explanation>
    The Web server will prevent an HTTP request from being sent to the Application Server if the value specified in host header does not exist in the filter. The request is then served by the Web server.
  </Explanation>
  <UserResponse>
    Make sure that the web server document root does not point to Application Server source files and change the Virtual Host Name in virtualhosts.xml to filter generic requests, for example, *:9080.
  </UserResponse>
</Message>
<Message ID="PLGC0041W" severity="W" prefix="yes">
  <MsgText pgmKey="error.loading.lotuscfghelper" varFormat="Java">
    error.loading.lotuscfghelper=PLGC0041W: The plug-in is unable to load the com.ibm.wkplc.generator.LotusCfgHelper helper class.
  </MsgText>
  <Explanation>
    The Lotus Workplace server helper class did not load.
  </Explanation>
  <UserResponse>
    No user action is required, if Lotus Workplace servers are not defined. If you define Lotus Workplace servers, verify that the class path includes the cfplugin.jar file.
  </UserResponse>
</Message>
<Message ID="PLGC0005I" severity="I" prefix="yes">
  <MsgText pgmKey="config.file.name" varFormat="Java">
    config.file.name=PLGC0005I: Plug-in configuration file =
  </MsgText>
  <Explanation>
    This informational message indicates the name of the plug-in configuration file.
  </Explanation>
  <UserResponse>
    No user action is required.
  </UserResponse>
</Message>
<Message ID="PLGC0013I" severity="I" prefix="yes">
  <MsgText pgmKey="gen.for.all.cell.servers" varFormat="Java">
    gen.for.all.cell.servers=PLGC0013I: The plug-in is generating a server plug-in configuration file for all of the servers in the cell.
  </MsgText>
  <Explanation>
    This message is for informational purposes only.
  </Explanation>
  <UserResponse>
    No user action is required.
  </UserResponse>
</Message>
<Message ID="PLGC0059I" severity="I" prefix="yes">
  <MsgText pgmKey="pluginconfigservice.notstarted" varFormat="Java">
    pluginconfigservice.notstarted=PLGC0059I: The plug-in configuration service is not started.
  </MsgText>
  <Explanation>
    The plug-in configuration service is started when it is enabled only, and is run on the deployment manager server or the stand-alone Application Server.
  </Explanation>
  <UserResponse>
    No user action is required.
  </UserResponse>
</Message>
<Message ID="PLGC0048I" severity="I" prefix="yes">
  <MsgText pgmKey="propagate.complete" varFormat="Java">
    propagate.complete=PLGC0048I: The propagation of the plug-in configuration file is complete for the Web server.
  </MsgText>
  <Explanation>
    This message is for informational purposes only.
  </Explanation>
  <UserResponse>
    No user action is required.
  </UserResponse>
</Message>
<Message ID="PLGC0052I" severity="I" prefix="yes">
  <MsgText pgmKey="generate.complete" varFormat="Java">
    generate.complete=PLGC0052I: Plug-in configuration file generation is complete for the Web server.
  </MsgText>
  <Explanation>
    This message is for informational purposes only.
  </Explanation>
  <UserResponse>
    No user action is required.
  </UserResponse>
</Message>
<Message ID="PLGC0077I" severity="I" prefix="yes">
  <MsgText pgmKey="no.webservers.in.cell.risk" varFormat="Java">
    no.webservers.in.cell.risk=PLGC0077I: There are no web servers defined in the cell {0}.
  </MsgText>
  <Explanation>
    No web servers are defined in the specified cell.
  </Explanation>
  <UserResponse>
    No user action is required.
  </UserResponse>
</Message>
<Message ID="PLGC0028E" severity="E" prefix="yes">
  <MsgText pgmKey="exception.reading.app" varFormat="Java">
    exception.reading.app=PLGC0028E: An exception occurred while reading the deployed applications for the specified server.
  </MsgText>
  <Explanation>
    One or more of the applications that are deployed on the specified servers cannot be read.
  </Explanation>
  <UserResponse>
    Examine the exception information. Rerun the GenPluginCfg script with the -debug option set to yes to see trace details. For example: run GenPluginCfg -debug yes. If the problem persists, redeploy the application. Verify that the enterprise archive (EAR) file and the Web archive (WAR) file are valid. If the problem persists, see the problem determination information on the WebSphere Application Server Support Web page on http://www.ibm.com/software/webservers/appserv/was/support/.
  </UserResponse>
</Message>
<Message ID="PLGC0078I" severity="I" prefix="yes">
  <MsgText pgmKey="only.http.transport.exists.risk" varFormat="Java">
    only.http.transport.exists.risk=PLGC0078I: Only HTTP transport is defined between the web server {0} and the application server {1}. Communication between the web server and application server is over HTTP which is unencrypted and in clear text.
  </MsgText>
  <Explanation>
    Only HTTP transport is configured. All communication between web server and application server will be in clear text.
  </Explanation>
  <UserResponse>
    Evaluate if HTTP transport is required for your environment. If sensitive information is being transmitted between the web server and the application server, it is recommended to use HTTPS (SSL) transports between the web server and the application server.
  </UserResponse>
</Message>
<Message ID="PLGC0007E" severity="E" prefix="yes">
  <MsgText pgmKey="doc.gen.exception" varFormat="Java">
    doc.gen.exception=PLGC0007E: An exception occurred while generating a plug-in configuration document.
  </MsgText>
  <Explanation>
    An error occurred while generating the plug-in configuration file.
  </Explanation>
  <UserResponse>
    Rerun the GenPluginCfg script with the -debug option set to yes to see trace details. For example run GenPluginCfg -debug yes. If the problem persists, see the problem determination on the WebSphere Application Server Support Web page on http://www.ibm.com/software/webservers/appserv/was/support/.
  </UserResponse>
</Message>
<Message ID="PLGC0033E" severity="E" prefix="yes">
  <MsgText pgmKey="runtime.exception.while.generating" varFormat="Java">
    runtime.exception.while.generating=PLGC0033E: A runtime exception occurred while generating the plug-in configuration:
  </MsgText>
  <Explanation>
    A problem resulted from generating the configuration file.
  </Explanation>
  <UserResponse>
    Examine the exception for nested exceptions and error codes. Rerun the GenPluginCfg script with the -debug option set to yes to see trace details. For example, run the following command: GenPluginCfg -debug yes. If the problem persists, see the problem determination information on the WebSphere Application Server Support Web page on http://www.ibm.com/software/webservers/appserv/was/support/.
  </UserResponse>
</Message>
<Message ID="PLGC0032E" severity="E" prefix="yes">
  <MsgText pgmKey="exception.while.generating" varFormat="Java">
    exception.while.generating=PLGC0032E: An exception occurred while generating plug-in configuration:
  </MsgText>
  <Explanation>
    A problem resulted from generating the plug-in configuration file.
  </Explanation>
  <UserResponse>
    Examine the exception for nested exceptions and error codes. Rerun the GenPluginCfg script with the -debug option set to yes to see trace details. For example, run the following command: GenPluginCfg -debug yes. If the problem persists, see the problem determination information on the WebSphere Application Server Support Web page on http://www.ibm.com/software/webservers/appserv/was/support/.
  </UserResponse>
</Message>
<!-- END MESSAGES -->
</TMSSource>
