<?xml version="1.0" encoding="UTF-8"?>
<?xml-stylesheet type="text/css" href="../../resources/stylesheets/wasmsgxml.css"?>
<TMSSource name="TivoliMessages" tmsVersion="1.0" xml:lang="en">
<!-- CMVC MSG File Name = ws/code/activity.session.impl/src/com/ibm/ws/ActivitySession/resources/ActivitySessionMessages.nlsprops -->
<!-- DO NOT EDIT THIS FILE - This file was generated by the XML/Html & Property emitter -->
<!-- BEGIN MESSAGES -->
<Message ID="WACS0017E" severity="E" prefix="yes">
  <MsgText pgmKey="ERR_ACTIVE_COMPLETING" varFormat="Java">
    ERR_ACTIVE_COMPLETING=WACS0017E: Unable to get final outcome of SignalSet as status is Active or Completing.
  </MsgText>
  <Explanation>
    An internal error occurred because there was an attempt to determine the outcome of a SignalSet before it was completed.
  </Explanation>
  <UserResponse>
    If the problem persists, additional information might be available if you search for the message ID on the following Web sites: WebSphere Application Server Support page: http://www.ibm.com/software/webservers/appserv/was/support/ WebSphere Application Server for z/OS Support page: http://www.ibm.com/software/webservers/appserv/zos_os390/support/ .
  </UserResponse>
</Message>
<Message ID="WACS0045I" severity="I" prefix="yes">
  <MsgText pgmKey="INF_NOT_ENABLED" varFormat="Java">
    INF_NOT_ENABLED=WACS0045I: ActivitySession service is disabled.
  </MsgText>
  <Explanation>
    The ActivitySession service has been disabled in the configuration, and it will be inaccessible on the server.
  </Explanation>
  <UserResponse>
    No action is required.
  </UserResponse>
</Message>
<Message ID="WACS0026E" severity="E" prefix="yes">
  <MsgText pgmKey="ERR_TIMEOUT_OUT_OF_RANGE" varFormat="Java">
    ERR_TIMEOUT_OUT_OF_RANGE=WACS0026E: Timeout value is not within defined range.
  </MsgText>
  <Explanation>
    setSessionTimeout() has been called on an ActivitySession with a value that is outside the acceptable range.
  </Explanation>
  <UserResponse>
    Try a different value for the timeout.
  </UserResponse>
</Message>
<Message ID="WACS0024E" severity="E" prefix="yes">
  <MsgText pgmKey="ERR_RESETONLY" varFormat="Java">
    ERR_RESETONLY=WACS0024E: Unexpected error occurred whilst setting ResetOnly flag.
  </MsgText>
  <Explanation>
    An internal error occurred while setting the ResetOnly flag, so the ResetOnly flag is not set and an exception is created.
  </Explanation>
  <UserResponse>
    If the problem persists, additional information might be available if you search for the message ID on the following Web sites: WebSphere Application Server Support page: http://www.ibm.com/software/webservers/appserv/was/support/ WebSphere Application Server for z/OS Support page: http://www.ibm.com/software/webservers/appserv/zos_os390/support/ .
  </UserResponse>
</Message>
<Message ID="WACS0001E" severity="E" prefix="yes">
  <MsgText pgmKey="ERR_INT_ERROR" varFormat="Java">
    ERR_INT_ERROR=WACS0001E: An internal error occurred in method {0} in class {1}; the exception stack trace follows: {2}.
  </MsgText>
  <Explanation>
    An internal error was detected in the ActivitySession service.
  </Explanation>
  <UserResponse>
    If the problem persists, additional information might be available if you search for the message ID on the following Web sites: WebSphere Application Server Support page: http://www.ibm.com/software/webservers/appserv/was/support/ WebSphere Application Server for z/OS Support page: http://www.ibm.com/software/webservers/appserv/zos_os390/support/ .
  </UserResponse>
</Message>
<Message ID="WACS0027E" severity="E" prefix="yes">
  <MsgText pgmKey="ERR_CHECKPOINT_UNEXPECTED" varFormat="Java">
    ERR_CHECKPOINT_UNEXPECTED=WACS0027E: Unexpected error occurred whilst checkpointing ActivitySession.
  </MsgText>
  <Explanation>
    An internal error occurred while attempting to checkpoint the ActivitySession.
  </Explanation>
  <UserResponse>
    If the problem persists, additional information might be available if you search for the message ID on the following Web sites: WebSphere Application Server Support page: http://www.ibm.com/software/webservers/appserv/was/support/ WebSphere Application Server for z/OS Support page: http://www.ibm.com/software/webservers/appserv/zos_os390/support/ .
  </UserResponse>
</Message>
<Message ID="WACS0019E" severity="E" prefix="yes">
  <MsgText pgmKey="ERR_GLOBAL_TRAN_BEGIN" varFormat="Java">
    ERR_GLOBAL_TRAN_BEGIN=WACS0019E: Cannot begin an ActivitySession whilst a Global Transaction is active.
  </MsgText>
  <Explanation>
    The container, or your application, attempted to begin a new ActivitySession without completing the current active global transaction.
  </Explanation>
  <UserResponse>
    Ensure that your application completes any outstanding global transactions before attempting to begin an ActivitySession.
  </UserResponse>
</Message>
<Message ID="WACS0011E" severity="E" prefix="yes">
  <MsgText pgmKey="ERR_SYNC_REGISTER" varFormat="Java">
    ERR_SYNC_REGISTER=WACS0011E: Unexpected error occurred whilst registering Synchronization with Activity service. The exception was {0}
  </MsgText>
  <Explanation>
    An internal error occurred when the container attempted to enlist a synchronization object with the ActivitySession service.
  </Explanation>
  <UserResponse>
    If the problem persists, additional information might be available if you search for the message ID on the following Web sites: WebSphere Application Server Support page: http://www.ibm.com/software/webservers/appserv/was/support/ WebSphere Application Server for z/OS Support page: http://www.ibm.com/software/webservers/appserv/zos_os390/support/ .
  </UserResponse>
</Message>
<Message ID="WACS0035E" severity="E" prefix="yes">
  <MsgText pgmKey="ERR_NO_HTTP_REQUEST" varFormat="Java">
    ERR_NO_HTTP_REQUEST=WACS0035E: No HTTP request available.
  </MsgText>
  <Explanation>
    The Web container has not assigned an HTTP request to the ActivitySession.
  </Explanation>
  <UserResponse>
    If the problem persists, additional information might be available if you search for the message ID on the following Web sites: WebSphere Application Server Support page: http://www.ibm.com/software/webservers/appserv/was/support/ WebSphere Application Server for z/OS Support page: http://www.ibm.com/software/webservers/appserv/zos_os390/support/ .
  </UserResponse>
</Message>
<Message ID="WACS0050E" severity="E" prefix="yes">
  <MsgText pgmKey="ERR_WEBAPP_DEPLOYMENT" varFormat="Java">
    ERR_WEBAPP_DEPLOYMENT=WACS0050E: Error found starting an application.  {0} specified an unsupported combination of ActivitySession attributes.
  </MsgText>
  <Explanation>
    The application component that is identified in the message has been assembled with ActivitySession extensions that are not supported. All Web components in a Web application must be configured with the same value for the ActivitySession control kind attribute.
  </Explanation>
  <UserResponse>
    Reassemble the failed application with different ActivitySession attributes, then redeploy the application on the server.
  </UserResponse>
</Message>
<Message ID="WACS0034I" severity="I" prefix="yes">
  <MsgText pgmKey="INF_RESET_ONLY" varFormat="Java">
    INF_RESET_ONLY=WACS0034I: ActivitySession was reset due to setResetOnly() being called.
  </MsgText>
  <Explanation>
    The ActivitySession and its resources were reset at completion time because setResetOnly() was called.
  </Explanation>
  <UserResponse>
    No action is required. This message is for informational purposes only.
  </UserResponse>
</Message>
<Message ID="WACS0039E" severity="E" prefix="yes">
  <MsgText pgmKey="ERR_ACTIVITY_EXISTS" varFormat="Java">
    ERR_ACTIVITY_EXISTS=WACS0039E: Unexpected error occurred whilst accessing status of underlying Activity.
  </MsgText>
  <Explanation>
    An internal error occurred while accessing the status of the Activity that is associated with the current ActivitySession.
  </Explanation>
  <UserResponse>
    If the problem persists, additional information might be available if you search for the message ID on the following Web sites: WebSphere Application Server Support page: http://www.ibm.com/software/webservers/appserv/was/support/ WebSphere Application Server for z/OS Support page: http://www.ibm.com/software/webservers/appserv/zos_os390/support/ .
  </UserResponse>
</Message>
<Message ID="WACS0005E" severity="E" prefix="yes">
  <MsgText pgmKey="ERR_RESUME_AS" varFormat="Java">
    ERR_RESUME_AS=WACS0005E: Unexpected error occurred whilst resuming ActivitySession. The exception was {0}
  </MsgText>
  <Explanation>
    An internal error occurred when there was an attempt to resume a previously suspended ActivitySession.
  </Explanation>
  <UserResponse>
    If the problem persists, additional information might be available if you search for the message ID on the following Web sites: WebSphere Application Server Support page: http://www.ibm.com/software/webservers/appserv/was/support/ WebSphere Application Server for z/OS Support page: http://www.ibm.com/software/webservers/appserv/zos_os390/support/ .
  </UserResponse>
</Message>
<Message ID="WACS0042E" severity="E" prefix="yes">
  <MsgText pgmKey="ERR_POSTINVOKE_ACTIVE_SESS" varFormat="Java">
    ERR_POSTINVOKE_ACTIVE_SESS=WACS0042E: The container is resetting an active application managed ActivitySession, {0}, in postInvoke.
  </MsgText>
  <Explanation>
    An application-managed ActivitySession was active on the thread at method end.
  </Explanation>
  <UserResponse>
    This condition indicates an error in the application.
  </UserResponse>
</Message>
<Message ID="WACS0047W" severity="W" prefix="yes">
  <MsgText pgmKey="WRN_DISABLED" varFormat="Java">
    WRN_DISABLED=WACS0047W: ActivitySession service disabled due to previous errors.
  </MsgText>
  <Explanation>
    There was an error during initialization of the ActivitySession service. The service is inaccessible on the given server. The root error should be logged already.
  </Explanation>
  <UserResponse>
    Try to resolve the errors that are already logged.
  </UserResponse>
</Message>
<Message ID="WACS0043E" severity="E" prefix="yes">
  <MsgText pgmKey="ERR_ASSERVICE_REQUIRED" varFormat="Java">
    ERR_ASSERVICE_REQUIRED=WACS0043E: Error found starting an application.  {0} specified an ActivitySession attribute that is not allowed when the ActivitySession service is not enabled.
  </MsgText>
  <Explanation>
    The application component that is identified in the message has been assembled with ActivitySession extensions that are not supported when the ActivitySession service is disabled.
  </Explanation>
  <UserResponse>
    Either reassemble the failed application with different ActivitySession attributes, or enable the ActivitySession service for this server.
  </UserResponse>
</Message>
<Message ID="WACS0044E" severity="E" prefix="yes">
  <MsgText pgmKey="ERR_NO_SERVICE" varFormat="Java">
    ERR_NO_SERVICE=WACS0044E: ActivitySession service could not resolve the {0} service.
  </MsgText>
  <Explanation>
    The ActivitySession service could not resolve the specified service, which is required for the ActivitySession service. Look through the log to see whether the specified service started successfully.
  </Explanation>
  <UserResponse>
    If you want to use the ActivitySession service, correct the problem with the specified service.
  </UserResponse>
</Message>
<Message ID="WACS0046I" severity="I" prefix="yes">
  <MsgText pgmKey="INF_CANNOT_BE_DISABLED" varFormat="Java">
    INF_CANNOT_BE_DISABLED=WACS0046I: ActivitySession service cannot be disabled.
  </MsgText>
  <Explanation>
    You attempted to disable the ActivitySession service in the configuration, but disabling this service would cause other services on the server to fail.
  </Explanation>
  <UserResponse>
    No action is required.
  </UserResponse>
</Message>
<Message ID="WACS0055E" severity="E" prefix="yes">
  <MsgText pgmKey="ERR_GET_RESET_ONLY" varFormat="Java">
    ERR_GET_RESET_ONLY=WACS0055E: Unexpected error occurred whilst getting the ResetOnly flag on current ActivitySession.
  </MsgText>
  <Explanation>
    An internal error occurred while retrieving the completionStatus of the Activity that is associated with the current ActivitySession.
  </Explanation>
  <UserResponse>
    If the problem persists, additional information might be available if you search for the message ID on the following Web sites: WebSphere Application Server Support page: http://www.ibm.com/software/webservers/appserv/was/support/ WebSphere Application Server for z/OS Support page: http://www.ibm.com/software/webservers/appserv/zos_os390/support/ .
  </UserResponse>
</Message>
<Message ID="WACS0054I" severity="I" prefix="yes">
  <MsgText pgmKey="INF_TX_SET_ROLLBACK_ONLY" varFormat="Java">
    INF_TX_SET_ROLLBACK_ONLY=WACS0054I: Transaction has been marked rollbackOnly.
  </MsgText>
  <Explanation>
    This might happen if the transaction began during the Activity Session but did not complete before the Activity Session was reset.
  </Explanation>
  <UserResponse>
    No action is required. This message is for informational purposes only.
  </UserResponse>
</Message>
<Message ID="WACS0004E" severity="E" prefix="yes">
  <MsgText pgmKey="ERR_SUSPEND_AS" varFormat="Java">
    ERR_SUSPEND_AS=WACS0004E: Unexpected error occurred whilst suspending ActivitySession. The exception was {0}
  </MsgText>
  <Explanation>
    An internal error occurred when there was an attempt to suspend the current ActivitySession.
  </Explanation>
  <UserResponse>
    If the problem persists, additional information might be available if you search for the message ID on the following Web sites: WebSphere Application Server Support page: http://www.ibm.com/software/webservers/appserv/was/support/ WebSphere Application Server for z/OS Support page: http://www.ibm.com/software/webservers/appserv/zos_os390/support/ .
  </UserResponse>
</Message>
<Message ID="WACS0029E" severity="E" prefix="yes">
  <MsgText pgmKey="ERR_INIT_UNEXPECTED" varFormat="Java">
    ERR_INIT_UNEXPECTED=WACS0029E: Unexpected error occurred whilst initialising ActivitySession service.
  </MsgText>
  <Explanation>
    The ActivitySession service cannot initialise because of an internal error.
  </Explanation>
  <UserResponse>
    If the problem persists, additional information might be available if you search for the message ID on the following Web sites: WebSphere Application Server Support page: http://www.ibm.com/software/webservers/appserv/was/support/ WebSphere Application Server for z/OS Support page: http://www.ibm.com/software/webservers/appserv/zos_os390/support/ .
  </UserResponse>
</Message>
<Message ID="WACS0037E" severity="E" prefix="yes">
  <MsgText pgmKey="ERR_ACTIVITY_NAME" varFormat="Java">
    ERR_ACTIVITY_NAME=WACS0037E: Unexpected error occurred whilst retrieving name of underlying Activity.
  </MsgText>
  <Explanation>
    An internal error occurred while accessing the name of the Activity that is associated with the current ActivitySession.
  </Explanation>
  <UserResponse>
    If the problem persists, additional information might be available if you search for the message ID on the following Web sites: WebSphere Application Server Support page: http://www.ibm.com/software/webservers/appserv/was/support/ WebSphere Application Server for z/OS Support page: http://www.ibm.com/software/webservers/appserv/zos_os390/support/ .
  </UserResponse>
</Message>
<Message ID="WACS0015E" severity="E" prefix="yes">
  <MsgText pgmKey="ERR_ENVIRONMENT_NOT_VALID" varFormat="Java">
    ERR_ENVIRONMENT_NOT_VALID=WACS0015E: Cannot access ActivitySessionServiceManager in current environment.
  </MsgText>
  <Explanation>
    An internal error occurred because there was an attempt to access the ActivitySessionServiceManager in an unsupported environment, such as the client container.
  </Explanation>
  <UserResponse>
    If the problem persists, additional information might be available if you search for the message ID on the following Web sites: WebSphere Application Server Support page: http://www.ibm.com/software/webservers/appserv/was/support/ WebSphere Application Server for z/OS Support page: http://www.ibm.com/software/webservers/appserv/zos_os390/support/ .
  </UserResponse>
</Message>
<Message ID="WACS0051E" severity="E" prefix="yes">
  <MsgText pgmKey="ERR_HTTPSESS_ASSOC" varFormat="Java">
    ERR_HTTPSESS_ASSOC=WACS0051E: Error occurred during association of an ActivitySession with an HttpSession.  The exception was {0}.
  </MsgText>
  <Explanation>
    Association of a new ActivitySession with an HttpSession failed because of the exception reported in the message.
  </Explanation>
  <UserResponse>
    Try to resolve the errors that are already logged.
  </UserResponse>
</Message>
<Message ID="WACS0025E" severity="E" prefix="yes">
  <MsgText pgmKey="ERR_NO_SESSION" varFormat="Java">
    ERR_NO_SESSION=WACS0025E: No ActivitySession currently active on current thread.
  </MsgText>
  <Explanation>
    There was an attempt to access an ActivitySession when an ActivitySession does not exist on the current thread.
  </Explanation>
  <UserResponse>
    Check that your application has started an ActivitySession before you attempt to access it further.
  </UserResponse>
</Message>
<Message ID="WACS0021E" severity="E" prefix="yes">
  <MsgText pgmKey="ERR_SESSION_ALREADY_ACTIVE" varFormat="Java">
    ERR_SESSION_ALREADY_ACTIVE=WACS0021E: Cannot begin new ActivitySession when one already exists on current thread.
  </MsgText>
  <Explanation>
    There was an attempt to start a new ActivitySession while another incomplete ActivitySession exists.
  </Explanation>
  <UserResponse>
    Ensure that your application ends any active ActivitySession before beginning a new one.
  </UserResponse>
</Message>
<Message ID="WACS0016E" severity="E" prefix="yes">
  <MsgText pgmKey="ERR_RESPONSE_OUTCOME" varFormat="Java">
    ERR_RESPONSE_OUTCOME=WACS0016E: Unexpected error occurred whilst retrieving extended outcome from response.
  </MsgText>
  <Explanation>
    An internal error occurred while determining why a resource failed to complete.
  </Explanation>
  <UserResponse>
    If the problem persists, additional information might be available if you search for the message ID on the following Web sites: WebSphere Application Server Support page: http://www.ibm.com/software/webservers/appserv/was/support/ WebSphere Application Server for z/OS Support page: http://www.ibm.com/software/webservers/appserv/zos_os390/support/ .
  </UserResponse>
</Message>
<Message ID="WACS0006E" severity="E" prefix="yes">
  <MsgText pgmKey="ERR_RES_NOT_PROCESS_SIGNAL" varFormat="Java">
    ERR_RES_NOT_PROCESS_SIGNAL=WACS0006E: Resource unable to process signal. The exception was {0}
  </MsgText>
  <Explanation>
    An internal error occurred when a resource enlisted with the ActivitySession failed to process a supplied signal.
  </Explanation>
  <UserResponse>
    If the problem persists, additional information might be available if you search for the message ID on the following Web sites: WebSphere Application Server Support page: http://www.ibm.com/software/webservers/appserv/was/support/ WebSphere Application Server for z/OS Support page: http://www.ibm.com/software/webservers/appserv/zos_os390/support/ .
  </UserResponse>
</Message>
<Message ID="WACS0002E" severity="E" prefix="yes">
  <MsgText pgmKey="ERR_NO_ACTIVITY_MANAGER" varFormat="Java">
    ERR_NO_ACTIVITY_MANAGER=WACS0002E: Unable to retrieve ActivityManager from Namespace.
  </MsgText>
  <Explanation>
    The ActivitySession service cannot find an ActivityManager instance in the JNDI namespace.
  </Explanation>
  <UserResponse>
    If the problem persists, additional information might be available if you search for the message ID on the following Web sites: WebSphere Application Server Support page: http://www.ibm.com/software/webservers/appserv/was/support/ WebSphere Application Server for z/OS Support page: http://www.ibm.com/software/webservers/appserv/zos_os390/support/ .
  </UserResponse>
</Message>
<Message ID="WACS0012E" severity="E" prefix="yes">
  <MsgText pgmKey="ERR_AS_NOT_VALID_STATE" varFormat="Java">
    ERR_AS_NOT_VALID_STATE=WACS0012E: Unable to enlist synchronization. ActivitySession is not in a valid state.
  </MsgText>
  <Explanation>
    The container is attempting to enlist a synchronization object with the current ActivitySession after the ActivitySession has completed.
  </Explanation>
  <UserResponse>
    If the problem persists, additional information might be available if you search for the message ID on the following Web sites: WebSphere Application Server Support page: http://www.ibm.com/software/webservers/appserv/was/support/ WebSphere Application Server for z/OS Support page: http://www.ibm.com/software/webservers/appserv/zos_os390/support/ .
  </UserResponse>
</Message>
<Message ID="WACS0052E" severity="E" prefix="yes">
  <MsgText pgmKey="ERR_TX_RESUME_FAILED" varFormat="Java">
    ERR_TX_RESUME_FAILED=WACS0052E: During the resume of an ActivitySession the attempt to resume a contained global transaction failed. The exception was {0}.
  </MsgText>
  <Explanation>
    The resume of a global transaction failed because of the exception reported in the message.
  </Explanation>
  <UserResponse>
    Try to resolve the errors that are already logged.
  </UserResponse>
</Message>
<Message ID="WACS0031E" severity="E" prefix="yes">
  <MsgText pgmKey="ERR_CANNOT_ACCESS_AM" varFormat="Java">
    ERR_CANNOT_ACCESS_AM=WACS0031E: Cannot access ActivityManager in current environment.
  </MsgText>
  <Explanation>
    An internal error has occurred because access to the ActivityManager object is not allowed from within the client container.
  </Explanation>
  <UserResponse>
    If the problem persists, additional information might be available if you search for the message ID on the following Web sites: WebSphere Application Server Support page: http://www.ibm.com/software/webservers/appserv/was/support/ WebSphere Application Server for z/OS Support page: http://www.ibm.com/software/webservers/appserv/zos_os390/support/ .
  </UserResponse>
</Message>
<Message ID="WACS0022E" severity="E" prefix="yes">
  <MsgText pgmKey="ERR_SESSION_STATUS" varFormat="Java">
    ERR_SESSION_STATUS=WACS0022E: Unexpected error occurred whilst accessing status of current ActivitySession.
  </MsgText>
  <Explanation>
    An internal error occurred when trying to retrieve the status of the current ActivitySession.
  </Explanation>
  <UserResponse>
    If the problem persists, additional information might be available if you search for the message ID on the following Web sites: WebSphere Application Server Support page: http://www.ibm.com/software/webservers/appserv/was/support/ WebSphere Application Server for z/OS Support page: http://www.ibm.com/software/webservers/appserv/zos_os390/support/ .
  </UserResponse>
</Message>
<Message ID="WACS0038E" severity="E" prefix="yes">
  <MsgText pgmKey="ERR_SET_RESET_ONLY" varFormat="Java">
    ERR_SET_RESET_ONLY=WACS0038E: Unexpected error occurred whilst setting ResetOnly flag on current ActivitySession.
  </MsgText>
  <Explanation>
    An internal error occurred while updating the completionStatus of the Activity that is associated with the current ActivitySession.
  </Explanation>
  <UserResponse>
    If the problem persists, additional information might be available if you search for the message ID on the following Web sites: WebSphere Application Server Support page: http://www.ibm.com/software/webservers/appserv/was/support/ WebSphere Application Server for z/OS Support page: http://www.ibm.com/software/webservers/appserv/zos_os390/support/ .
  </UserResponse>
</Message>
<Message ID="WACS0048I" severity="I" prefix="yes">
  <MsgText pgmKey="INF_STARTED" varFormat="Java">
    INF_STARTED=WACS0048I: The ActivitySession service started successfully.
  </MsgText>
  <Explanation>
    The ActivitySession service started successfully.
  </Explanation>
  <UserResponse>
    No action is required. This message is for informational purposes only.
  </UserResponse>
</Message>
<Message ID="WACS0049I" severity="I" prefix="yes">
  <MsgText pgmKey="INF_STOPPING" varFormat="Java">
    INF_STOPPING=WACS0049I: The ActivitySession service is stopping.
  </MsgText>
  <Explanation>
    The ActivitySession service is stopping.
  </Explanation>
  <UserResponse>
    No action is required. This message is for informational purposes only.
  </UserResponse>
</Message>
<Message ID="WACS0028E" severity="E" prefix="yes">
  <MsgText pgmKey="ERR_RESET_UNEXPECTED" varFormat="Java">
    ERR_RESET_UNEXPECTED=WACS0028E: Unexpected error occurred whilst reseting ActivitySession.
  </MsgText>
  <Explanation>
    An internal error occurred while attempting to reset the ActivitySession.
  </Explanation>
  <UserResponse>
    If the problem persists, additional information might be available if you search for the message ID on the following Web sites: WebSphere Application Server Support page: http://www.ibm.com/software/webservers/appserv/was/support/ WebSphere Application Server for z/OS Support page: http://www.ibm.com/software/webservers/appserv/zos_os390/support/ .
  </UserResponse>
</Message>
<Message ID="WACS0020E" severity="E" prefix="yes">
  <MsgText pgmKey="ERR_GLOBAL_TRAN_RESUME" varFormat="Java">
    ERR_GLOBAL_TRAN_RESUME=WACS0020E: Cannot resume an ActivitySession whilst a Global Transaction is active.
  </MsgText>
  <Explanation>
    The container attempted to resume an ActivitySession while a global transaction is still active on the thread.
  </Explanation>
  <UserResponse>
    If the problem persists, additional information might be available if you search for the message ID on the following Web sites: WebSphere Application Server Support page: http://www.ibm.com/software/webservers/appserv/was/support/ WebSphere Application Server for z/OS Support page: http://www.ibm.com/software/webservers/appserv/zos_os390/support/ .
  </UserResponse>
</Message>
<Message ID="WACS0010E" severity="E" prefix="yes">
  <MsgText pgmKey="ERR_AS_NOT_STARTED" varFormat="Java">
    ERR_AS_NOT_STARTED=WACS0010E: Unable to enlist resource. ActivitySession has not been started.
  </MsgText>
  <Explanation>
    An internal error occurred because there was an attempt to enlist a resource with an ActivitySession when there is no ActivitySession active.
  </Explanation>
  <UserResponse>
    If the problem persists, additional information might be available if you search for the message ID on the following Web sites: WebSphere Application Server Support page: http://www.ibm.com/software/webservers/appserv/was/support/ WebSphere Application Server for z/OS Support page: http://www.ibm.com/software/webservers/appserv/zos_os390/support/ .
  </UserResponse>
</Message>
<Message ID="WACS0040E" severity="E" prefix="yes">
  <MsgText pgmKey="ERR_SESSION_TYPE" varFormat="Java">
    ERR_SESSION_TYPE=WACS0040E: Caller type of getFromHttpSession, is container {0}, does not match management type of ActivitySession, container managed {1}.
  </MsgText>
  <Explanation>
    Containers and applications cannot resume ActivitySessions that are managed by the other type.
  </Explanation>
  <UserResponse>
    This condition indicates an error in the application.
  </UserResponse>
</Message>
<Message ID="WACS0013E" severity="E" prefix="yes">
  <MsgText pgmKey="ERR_ACTIVITY_STATUS" varFormat="Java">
    ERR_ACTIVITY_STATUS=WACS0013E: Unexpected error occurred whilst retrieving status of underlying Activity.
  </MsgText>
  <Explanation>
    An internal error occurred when there was an attempt to determine the status of the current ActivitySession.
  </Explanation>
  <UserResponse>
    If the problem persists, additional information might be available if you search for the message ID on the following Web sites: WebSphere Application Server Support page: http://www.ibm.com/software/webservers/appserv/was/support/ WebSphere Application Server for z/OS Support page: http://www.ibm.com/software/webservers/appserv/zos_os390/support/ .
  </UserResponse>
</Message>
<Message ID="WACS0014E" severity="E" prefix="yes">
  <MsgText pgmKey="ERR_SIGNAL_SET_NAME" varFormat="Java">
    ERR_SIGNAL_SET_NAME=WACS0014E: SignalSet name not valid for ActivitySession service.
  </MsgText>
  <Explanation>
    An internal error occurred because the Activity service requested a SignalSet that is not valid.
  </Explanation>
  <UserResponse>
    If the problem persists, additional information might be available if you search for the message ID on the following Web sites: WebSphere Application Server Support page: http://www.ibm.com/software/webservers/appserv/was/support/ WebSphere Application Server for z/OS Support page: http://www.ibm.com/software/webservers/appserv/zos_os390/support/ .
  </UserResponse>
</Message>
<Message ID="WACS0030E" severity="E" prefix="yes">
  <MsgText pgmKey="ERR_NO_USER_ACTIVITY" varFormat="Java">
    ERR_NO_USER_ACTIVITY=WACS0030E: Unable to retrieve UserActivity from Namespace.
  </MsgText>
  <Explanation>
    The ActivitySession service cannot find a UserActivity instance in the JNDI namespace.
  </Explanation>
  <UserResponse>
    If the problem persists, additional information might be available if you search for the message ID on the following Web sites: WebSphere Application Server Support page: http://www.ibm.com/software/webservers/appserv/was/support/ WebSphere Application Server for z/OS Support page: http://www.ibm.com/software/webservers/appserv/zos_os390/support/ .
  </UserResponse>
</Message>
<Message ID="WACS0033E" severity="E" prefix="yes">
  <MsgText pgmKey="ERR_END_UNEXPECTED" varFormat="Java">
    ERR_END_UNEXPECTED=WACS0033E: Unexpected error occurred whilst ending ActivitySession.
  </MsgText>
  <Explanation>
    An internal error occurred while attempting to end the ActivitySession.
  </Explanation>
  <UserResponse>
    If the problem persists, additional information might be available if you search for the message ID on the following Web sites: WebSphere Application Server Support page: http://www.ibm.com/software/webservers/appserv/was/support/ WebSphere Application Server for z/OS Support page: http://www.ibm.com/software/webservers/appserv/zos_os390/support/ .
  </UserResponse>
</Message>
<Message ID="WACS0007E" severity="E" prefix="yes">
  <MsgText pgmKey="ERR_PROCESS_SIGNAL" varFormat="Java">
    ERR_PROCESS_SIGNAL=WACS0007E: Unexpected error occurred whilst processing Signal. The exception was {0}
  </MsgText>
  <Explanation>
    An internal error occurred during the processing of a signal.
  </Explanation>
  <UserResponse>
    If the problem persists, additional information might be available if you search for the message ID on the following Web sites: WebSphere Application Server Support page: http://www.ibm.com/software/webservers/appserv/was/support/ WebSphere Application Server for z/OS Support page: http://www.ibm.com/software/webservers/appserv/zos_os390/support/ .
  </UserResponse>
</Message>
<Message ID="WACS0036E" severity="E" prefix="yes">
  <MsgText pgmKey="ERR_MIXED_OUTCOME" varFormat="Java">
    ERR_MIXED_OUTCOME=WACS0036E: Mixed outcomes were achieved by Resources during ActivitySession completion.
  </MsgText>
  <Explanation>
    Resources that were completed as part of an ActivitySession had a mixture of outcomes including success, failure, and error.
  </Explanation>
  <UserResponse>
    Examine the exceptions that are returned from the getFailedResourceExceptions() method of the MixedOutcomeException class for messages that show which resources failed.
  </UserResponse>
</Message>
<Message ID="WACS0023E" severity="E" prefix="yes">
  <MsgText pgmKey="ERR_SESSION_NAME" varFormat="Java">
    ERR_SESSION_NAME=WACS0023E: Unexpected error occurred whilst accessing the name of current ActivitySession.
  </MsgText>
  <Explanation>
    An internal error occurred when trying to retrieve the name of the current ActivitySession.
  </Explanation>
  <UserResponse>
    If the problem persists, additional information might be available if you search for the message ID on the following Web sites: WebSphere Application Server Support page: http://www.ibm.com/software/webservers/appserv/was/support/ WebSphere Application Server for z/OS Support page: http://www.ibm.com/software/webservers/appserv/zos_os390/support/ .
  </UserResponse>
</Message>
<Message ID="WACS0041E" severity="E" prefix="yes">
  <MsgText pgmKey="ERR_SESSION_NO_TYPE" varFormat="Java">
    ERR_SESSION_NO_TYPE=WACS0041E: Management type indicator of ActivitySession missing from HTTPSesion.
  </MsgText>
  <Explanation>
    The getFromHttpSession cannot be performed because a management type is missing, which prevents proper policing.
  </Explanation>
  <UserResponse>
    If the problem persists, additional information might be available if you search for the message ID on the following Web sites: WebSphere Application Server Support page: http://www.ibm.com/software/webservers/appserv/was/support/ WebSphere Application Server for z/OS Support page: http://www.ibm.com/software/webservers/appserv/zos_os390/support/ .
  </UserResponse>
</Message>
<Message ID="WACS0053E" severity="E" prefix="yes">
  <MsgText pgmKey="ERR_GET_PG_FAILED" varFormat="Java">
    ERR_GET_PG_FAILED=WACS0053E: Unexpected error occured trying to access the ActivitySession property group
  </MsgText>
  <Explanation>
    An internal error occured when trying to get the ActivitySession property group.
  </Explanation>
  <UserResponse>
    Try to resolve the errors that are already logged.
  </UserResponse>
</Message>
<Message ID="WACS0003E" severity="E" prefix="yes">
  <MsgText pgmKey="ERR_BEGIN_AS" varFormat="Java">
    ERR_BEGIN_AS=WACS0003E: Unexpected error occurred whilst beginning a new ActivitySession. The exception was {0}
  </MsgText>
  <Explanation>
    An internal error occurred when there was an attempt to begin a new ActivitySession.
  </Explanation>
  <UserResponse>
    If the problem persists, additional information might be available if you search for the message ID on the following Web sites: WebSphere Application Server Support page: http://www.ibm.com/software/webservers/appserv/was/support/ WebSphere Application Server for z/OS Support page: http://www.ibm.com/software/webservers/appserv/zos_os390/support/ .
  </UserResponse>
</Message>
<Message ID="WACS0032E" severity="E" prefix="yes">
  <MsgText pgmKey="ERR_GET_USERACTIVITY" varFormat="Java">
    ERR_GET_USERACTIVITY=WACS0032E: Unexpected error occurred whilst getting UserActivity instance.
  </MsgText>
  <Explanation>
    An internal error occurred while accessing the UserActivity instance of the ActivitySession service.
  </Explanation>
  <UserResponse>
    If the problem persists, additional information might be available if you search for the message ID on the following Web sites: WebSphere Application Server Support page: http://www.ibm.com/software/webservers/appserv/was/support/ WebSphere Application Server for z/OS Support page: http://www.ibm.com/software/webservers/appserv/zos_os390/support/ .
  </UserResponse>
</Message>
<Message ID="WACS0009E" severity="E" prefix="yes">
  <MsgText pgmKey="ERR_RESOURCE_REGISTER" varFormat="Java">
    ERR_RESOURCE_REGISTER=WACS0009E: Unexpected error occurred whilst registering Resource with ActivitySession service. The exception was {0}
  </MsgText>
  <Explanation>
    An internal error occurred when attempting to enlist a new resource with the ActivitySession service.
  </Explanation>
  <UserResponse>
    If the problem persists, additional information might be available if you search for the message ID on the following Web sites: WebSphere Application Server Support page: http://www.ibm.com/software/webservers/appserv/was/support/ WebSphere Application Server for z/OS Support page: http://www.ibm.com/software/webservers/appserv/zos_os390/support/ .
  </UserResponse>
</Message>
<Message ID="WACS0008E" severity="E" prefix="yes">
  <MsgText pgmKey="ERR_GET_ACTIVITYMANAGER" varFormat="Java">
    ERR_GET_ACTIVITYMANAGER=WACS0008E: Unexpected error occurred whilst getting ActivityManager instance.
  </MsgText>
  <Explanation>
    An internal error occurred when accessing the ActivityManager instance of the ActivitySession service.
  </Explanation>
  <UserResponse>
    If the problem persists, additional information might be available if you search for the message ID on the following Web sites: WebSphere Application Server Support page: http://www.ibm.com/software/webservers/appserv/was/support/ WebSphere Application Server for z/OS Support page: http://www.ibm.com/software/webservers/appserv/zos_os390/support/ .
  </UserResponse>
</Message>
<Message ID="WACS0018E" severity="E" prefix="yes">
  <MsgText pgmKey="ERR_NO_SIGNALS" varFormat="Java">
    ERR_NO_SIGNALS=WACS0018E: No Signals have yet been produced by this SignalSet.
  </MsgText>
  <Explanation>
    An internal error occurred because there was an attempt to determine the completion status of a SignalSet before any signals were produced.
  </Explanation>
  <UserResponse>
    If the problem persists, additional information might be available if you search for the message ID on the following Web sites: WebSphere Application Server Support page: http://www.ibm.com/software/webservers/appserv/was/support/ WebSphere Application Server for z/OS Support page: http://www.ibm.com/software/webservers/appserv/zos_os390/support/ .
  </UserResponse>
</Message>
<!-- END MESSAGES -->
</TMSSource>
