<?xml version="1.0" encoding="UTF-8"?>
<?xml-stylesheet type="text/css" href="../../resources/stylesheets/wasmsgxml.css"?>
<TMSSource name="TivoliMessages" tmsVersion="1.0" xml:lang="en">
<!-- CMVC MSG File Name = ws/code/asynchbeans/src/com/ibm/ws/asynchbeans/AsynchBeansMessages.nlsprops -->
<!-- DO NOT EDIT THIS FILE - This file was generated by the XML/Html & Property emitter -->
<!-- BEGIN MESSAGES -->
<Message ID="ASYN0058I" severity="I" prefix="yes">
  <MsgText pgmKey="PMI_INIT_ERROR" varFormat="Java">
    PMI_INIT_ERROR=ASYN0058I: There was an error initializing Asynchronous Beans PMI .
  </MsgText>
  <Explanation>
    The Asynchronous Beans PMI module could not be registered with the PMI service
  </Explanation>
  <UserResponse>
    Verify that the product is installed correctly, and check the logs for further details.  This error affects only performance data gathering.
  </UserResponse>
</Message>
<Message ID="ASYN0063E" severity="E" prefix="yes">
  <MsgText pgmKey="INVALID_TIMERMANAGER_STATE" varFormat="Java">
    INVALID_TIMERMANAGER_STATE=ASYN0063E: The {0} is in {1} state.
  </MsgText>
  <Explanation>
    An TimerManager or AlarmManager is not in a working state.
  </Explanation>
  <UserResponse>
    If the TimerManager or AlarmManager is in Stop or Stopping state, get a new AlarmManager or TimerManager. If the TimerManager is in Suspended or Suspending state, resume the TimerManager before scheduling a Timer.
  </UserResponse>
</Message>
<Message ID="ASYN0093E" severity="E" prefix="yes">
  <MsgText pgmKey="ASYN0093.operation.not.supported" varFormat="Java">
    ASYN0093.operation.not.supported=ASYN0093E: The operation {0} is not supported.
  </MsgText>
  <Explanation>
    The specified operation is not supported.
  </Explanation>
  <UserResponse>
    Update the application such that it no longer attempts to perform the unsupported operation.
  </UserResponse>
</Message>
<Message ID="ASYN0067I" severity="I" prefix="yes">
  <MsgText pgmKey="NO_RESREF_INFO" varFormat="Java">
    NO_RESREF_INFO=ASYN0067I: Resource {0} is being looked up without using resource reference.
  </MsgText>
  <Explanation>
    The resource is being looked up without using resource reference. This is not a recommended way to lookup a resource.
  </Explanation>
  <UserResponse>
    Configure a resource reference for this resource, and use &quot;java:comp/env/RESOURCE_JNDI_NAME&quot; to lookup the resource.
  </UserResponse>
</Message>
<Message ID="ASYN0064E" severity="E" prefix="yes">
  <MsgText pgmKey="RESREF_ERROR" varFormat="Java">
    RESREF_ERROR=ASYN0064E: The value {0} of the {1} resource reference element {2} is not right. Only the following values are allowed: {3}.
  </MsgText>
  <Explanation>
    The resource reference is not configured properly. Refer to the message for the permitted values.
  </Explanation>
  <UserResponse>
    Use the permitted values described in the message.
  </UserResponse>
</Message>
<Message ID="ASYN0020E" severity="E" prefix="yes">
  <MsgText pgmKey="MSG_KEY_46" varFormat="Java">
    MSG_KEY_46=ASYN0020E: Cannot create WorkManager object pools.
  </MsgText>
  <Explanation>
    Various object pools needed by the WorkManager could not be created.
  </Explanation>
  <UserResponse>
    Verify that the installation is not damaged.
  </UserResponse>
</Message>
<Message ID="ASYN0019E" severity="E" prefix="yes">
  <MsgText pgmKey="MSG_KEY_45" varFormat="Java">
    MSG_KEY_45=ASYN0019E: Attempt to push invalid service context named {0}, exception is {1}.
  </MsgText>
  <Explanation>
    An attempt to push a captured service context has failed.
  </Explanation>
  <UserResponse>
    Examine the service name and exception. This should only happen with WorkWithExecutionContexts which were serialized.
  </UserResponse>
</Message>
<Message ID="ASYN0017E" severity="E" prefix="yes">
  <MsgText pgmKey="MSG_KEY_43" varFormat="Java">
    MSG_KEY_43=ASYN0017E: Create threw exception {0}.
  </MsgText>
  <Explanation>
    An unexpected exception occurred when creating an alarm.
  </Explanation>
  <UserResponse>
    Review the exception to determine and correct the problem.
  </UserResponse>
</Message>
<Message ID="ASYN0014E" severity="E" prefix="yes">
  <MsgText pgmKey="MSG_KEY_40" varFormat="Java">
    MSG_KEY_40=ASYN0014E: Cancel method threw exception {0}.
  </MsgText>
  <Explanation>
    The alarm could not be canceled.
  </Explanation>
  <UserResponse>
    Report the problem with a test case, if possible, to IBM product support for examination.
  </UserResponse>
</Message>
<Message ID="ASYN9999E" severity="E" prefix="yes">
  <MsgText pgmKey="MSG_KEY_UNEX_EXCEPT" varFormat="Java">
    MSG_KEY_UNEX_EXCEPT=ASYN9999E: Unexpected Exception Occurred: {0}.
  </MsgText>
  <Explanation>
    This exception is unexpected. The cause is not immediately known.
  </Explanation>
  <UserResponse>
    If the problem persists, additional information might be available if you search for the message ID on the following Web sites: WebSphere Application Server Support page: http://www.ibm.com/software/webservers/appserv/was/support/ WebSphere Application Server for z/OS Support page: http://www.ibm.com/software/webservers/appserv/zos_os390/support/ .
  </UserResponse>
</Message>
<Message ID="ASYN0090I" severity="I" prefix="yes">
  <MsgText pgmKey="ASYN0090_LATE_WORK" varFormat="Java">
    ASYN0090_LATE_WORK=ASYN0090I: Work manager {0} is running work item {1} later than expected. The work item was submitted at {2} and is starting to run at {3}.
  </MsgText>
  <Explanation>
    The interval between submitting and starting the work item exceeded the lateWorkTime threshold.
  </Explanation>
  <UserResponse>
    Consider allocating more work threads to the work manager, reducing the load on the system, or increasing the lateWorkTime threshold.
  </UserResponse>
</Message>
<Message ID="ASYN0070E" severity="E" prefix="yes">
  <MsgText pgmKey="MIN_MAX_ERROR" varFormat="Java">
    MIN_MAX_ERROR=ASYN0070E: The minimum number of work threads, {0}, cannot be configured higher than the maximum number of work threads, {1}.
  </MsgText>
  <Explanation>
    The minimum number of work threads must be configured to a value less than or equal to the maximum number of work threads.
  </Explanation>
  <UserResponse>
    Reconfigure the minimum number of work threads, the maximum number of work threads, or both, such that the minimum number of work threads is less than or equal to the maximum number of work threads.
  </UserResponse>
</Message>
<Message ID="ASYN0050E" severity="E" prefix="yes">
  <MsgText pgmKey="ERR_MISSING_KEY" varFormat="Java">
    ERR_MISSING_KEY=ASYN0050E: Message key {0} was not found in any searched resource bundles.
  </MsgText>
  <Explanation>
    A key was passed into the Messages class to resolve to a string, but a properties file for the locale could not be found, and the appropriate message could not be retrieved.
  </Explanation>
  <UserResponse>
    Determine why the message catalog could not be found.
  </UserResponse>
</Message>
<Message ID="ASYN0091I" severity="I" prefix="yes">
  <MsgText pgmKey="ASYN0091_LATE_ALARM" varFormat="Java">
    ASYN0091_LATE_ALARM=ASYN0091I: Work manager {0} is running alarm {1} later than expected. The scheduled time at which the alarm was expected to run is {2}, but instead the alarm is running at {3}.
  </MsgText>
  <Explanation>
    The interval between the expected and actual start time exceeded the lateAlarmTime threshold.
  </Explanation>
  <UserResponse>
    Consider allocating more alarm threads to the work manager, reducing the load on the system, or increasing the lateAlarmTime threshold.
  </UserResponse>
</Message>
<Message ID="ASYN0061E" severity="E" prefix="yes">
  <MsgText pgmKey="INVALID_VALUE_2" varFormat="Java">
    INVALID_VALUE_2=ASYN0061E: The value {0} is not valid for {1}.
  </MsgText>
  <Explanation>
    The value is not valid.
  </Explanation>
  <UserResponse>
    Provide a value in the valid range.
  </UserResponse>
</Message>
<Message ID="ASYN0013E" severity="E" prefix="yes">
  <MsgText pgmKey="MSG_KEY_39" varFormat="Java">
    MSG_KEY_39=ASYN0013E: Reset method threw exception {0}.
  </MsgText>
  <Explanation>
    The alarm could not be reset.
  </Explanation>
  <UserResponse>
    Report the problem with a test case, if possible, to IBM product support for examination.
  </UserResponse>
</Message>
<Message ID="ASYN0069E" severity="E" prefix="yes">
  <MsgText pgmKey="NO_RESREF_ERROR" varFormat="Java">
    NO_RESREF_ERROR=ASYN0069E: TimerManager {0} is being looked up without using resource reference.
  </MsgText>
  <Explanation>
    A TimerManager is being looked up without using resource reference. This is not a permitted way to look up a TimerManager.
  </Explanation>
  <UserResponse>
    Configure a resource reference for the TimerManager, and use &quot;java:comp/env/TIMER_MANAGER_JNDI_NAME&quot; to lookup the TimerManager.
  </UserResponse>
</Message>
<Message ID="ASYN0012E" severity="E" prefix="yes">
  <MsgText pgmKey="MSG_KEY_38" varFormat="Java">
    MSG_KEY_38=ASYN0012E: Alarm/Timer threw exception {0}.
  </MsgText>
  <Explanation>
    If this is a WorkException then an AlarmListener/TimerListener threw an exception. AlarmListeners or TimerListeners should not throw exceptions. Any other kind of exception indicates a possible bug.
  </Explanation>
  <UserResponse>
    If it is a WorkException then a NOTIFICATION_EXCEPTION is fired on the associated AlarmManager or TimerManager. Correct the AlarmListener or TimerListener throwing the exception and restart the application.
  </UserResponse>
</Message>
<Message ID="ASYN0010E" severity="E" prefix="yes">
  <MsgText pgmKey="MSG_KEY_36" varFormat="Java">
    MSG_KEY_36=ASYN0010E: Cannot retreive alarm pool.
  </MsgText>
  <Explanation>
    This primary alarm manager could not be created. This should not happen during normal operation.
  </Explanation>
  <UserResponse>
    This should only happen if the installation was corrupted or the installation has been damaged. Reinstall the application server.
  </UserResponse>
</Message>
<Message ID="ASYN0055I" severity="I" prefix="yes">
  <MsgText pgmKey="WORKMANAGER_STARTED" varFormat="Java">
    WORKMANAGER_STARTED=ASYN0055I: The Work Manager service started successfully.
  </MsgText>
  <Explanation>
    The Work Manager service was started and is available to receive requests.
  </Explanation>
  <UserResponse>
    No user action required.
  </UserResponse>
</Message>
<Message ID="ASYN0054W" severity="W" prefix="yes">
  <MsgText pgmKey="WORKMANAGER_DISABLED" varFormat="Java">
    WORKMANAGER_DISABLED=ASYN0054W: Work Manager service is disabled due to previous errors.
  </MsgText>
  <Explanation>
    The Work Manager service experienced an error during initialization. The service will be inaccessible on the given server. The root error should have been logged previously.
  </Explanation>
  <UserResponse>
    Try to resolve the previously logged errors. If unable to do so, contact IBM product support.
  </UserResponse>
</Message>
<Message ID="ASYN0007E" severity="E" prefix="yes">
  <MsgText pgmKey="MSG_KEY_28" varFormat="Java">
    MSG_KEY_28=ASYN0007E: Cannot recover original context because unable to pop {0}.
  </MsgText>
  <Explanation>
    There was a problem establishing a new context on the thread. We attempted to restore the original context and this has failed.
  </Explanation>
  <UserResponse>
    This is an unrecoverable error. Examine the logs and verify the installation. If the problem persists, contact IBM product support.
  </UserResponse>
</Message>
<Message ID="ASYN0006I" severity="I" prefix="yes">
  <MsgText pgmKey="MSG_KEY_26" varFormat="Java">
    MSG_KEY_26=ASYN0006I: Context invalid exception, {1} was thrown while popping the service named {0}.
  </MsgText>
  <Explanation>
    This exception is unexpected. The cause is not immediately known.
  </Explanation>
  <UserResponse>
    If the problem persists, additional information might be available if you search for the message ID on the following Web sites: WebSphere Application Server Support page: http://www.ibm.com/software/webservers/appserv/was/support/ WebSphere Application Server for z/OS Support page: http://www.ibm.com/software/webservers/appserv/zos_os390/support/ .
  </UserResponse>
</Message>
<Message ID="ASYN0059I" severity="I" prefix="yes">
  <MsgText pgmKey="ASYN0059I" varFormat="Java">
    ASYN0059I=ASYN0059I: Work Manager service initialized successfully.
  </MsgText>
  <Explanation>
    The Work Manager service was successfully initialized.
  </Explanation>
  <UserResponse>
    No user action required.
  </UserResponse>
</Message>
<Message ID="ASYN0053I" severity="I" prefix="yes">
  <MsgText pgmKey="WORKMANAGER_CANNOT_BE_DISABLED" varFormat="Java">
    WORKMANAGER_CANNOT_BE_DISABLED=ASYN0053I: Work Manager service cannot be disabled.
  </MsgText>
  <Explanation>
    The Work Manager service has been disabled in the configuration but will continue to run because of service dependencies.
  </Explanation>
  <UserResponse>
    Enable the Work Manager service in the configuration to avoid receiving this message in the future.
  </UserResponse>
</Message>
<Message ID="ASYN0060E" severity="E" prefix="yes">
  <MsgText pgmKey="INVALID_VALUE" varFormat="Java">
    INVALID_VALUE=ASYN0060E: The value {0} is not valid for {1}. The valid values are: {2}.
  </MsgText>
  <Explanation>
    The value is not valid.
  </Explanation>
  <UserResponse>
    Provide a value in the valid range.
  </UserResponse>
</Message>
<Message ID="ASYN0068E" severity="E" prefix="yes">
  <MsgText pgmKey="INVALID_ITEM_IN_COLLECTION" varFormat="Java">
    INVALID_ITEM_IN_COLLECTION=ASYN0068E: The object {0} in the work item collection is not a {1} object.
  </MsgText>
  <Explanation>
    All the objects in the work item collection should implement the appropriate WorkItem interface.
  </Explanation>
  <UserResponse>
    Make sure all the objects in the work item collection implement the appropriate WorkItem interface.
  </UserResponse>
</Message>
<Message ID="ASYN0092I" severity="I" prefix="yes">
  <MsgText pgmKey="ASYN0092_LATE_TIMER" varFormat="Java">
    ASYN0092_LATE_TIMER=ASYN0092I: Timer manager {0} is running timer {1} later than expected. The scheduled time at which the timer was expected to run is {2}, but instead the timer is running at {3}.
  </MsgText>
  <Explanation>
    The interval between the expected and actual start time exceeded the lateTimerTime threshold.
  </Explanation>
  <UserResponse>
    Consider allocating more timer threads to the timer manager, reducing the load on the system, or increasing the lateTimerTime threshold.
  </UserResponse>
</Message>
<Message ID="ASYN0005I" severity="I" prefix="yes">
  <MsgText pgmKey="MSG_KEY_19" varFormat="Java">
    MSG_KEY_19=ASYN0005I: No such JCE Algorithm (SHA1withDSA) exists.
  </MsgText>
  <Explanation>
    The needed JCE algorithm SHA1withDSA is not available.
  </Explanation>
  <UserResponse>
    If the problem persists, additional information might be available if you search for the message ID on the following Web sites: WebSphere Application Server Support page: http://www.ibm.com/software/webservers/appserv/was/support/ WebSphere Application Server for z/OS Support page: http://www.ibm.com/software/webservers/appserv/zos_os390/support/ .
  </UserResponse>
</Message>
<Message ID="ASYN0004I" severity="I" prefix="yes">
  <MsgText pgmKey="MSG_KEY_18" varFormat="Java">
    MSG_KEY_18=ASYN0004I: No such JCE provider exists.
  </MsgText>
  <Explanation>
    The JCE provider (Sun) needed is not installed.
  </Explanation>
  <UserResponse>
    If the problem persists, additional information might be available if you search for the message ID on the following Web sites: WebSphere Application Server Support page: http://www.ibm.com/software/webservers/appserv/was/support/ WebSphere Application Server for z/OS Support page: http://www.ibm.com/software/webservers/appserv/zos_os390/support/ .
  </UserResponse>
</Message>
<Message ID="ASYN0003I" severity="I" prefix="yes">
  <MsgText pgmKey="MSG_KEY_17" varFormat="Java">
    MSG_KEY_17=ASYN0003I: Invalid Key
  </MsgText>
  <Explanation>
    This key which is used to make a digital signature is not valid.
  </Explanation>
  <UserResponse>
    CSMG0002
  </UserResponse>
</Message>
<Message ID="ASYN0002I" severity="I" prefix="yes">
  <MsgText pgmKey="MSG_KEY_16" varFormat="Java">
    MSG_KEY_16=ASYN0002I: Signature Exception
  </MsgText>
  <Explanation>
    This is a problem generating a digital signature.
  </Explanation>
  <UserResponse>
    If the problem persists, additional information might be available if you search for the message ID on the following Web sites: WebSphere Application Server Support page: http://www.ibm.com/software/webservers/appserv/was/support/ WebSphere Application Server for z/OS Support page: http://www.ibm.com/software/webservers/appserv/zos_os390/support/ .
  </UserResponse>
</Message>
<Message ID="ASYN0051I" severity="I" prefix="yes">
  <MsgText pgmKey="MSG_INFO_LISTENER_NOT_FOUND" varFormat="Java">
    MSG_INFO_LISTENER_NOT_FOUND=ASYN0051I: Listener {0} was not found for broadcaster {1}.
  </MsgText>
  <Explanation>
    The listener has already been removed or was never added.
  </Explanation>
  <UserResponse>
    Verify that the specified listener has been added and has not already been removed.
  </UserResponse>
</Message>
<Message ID="ASYN0057E" severity="E" prefix="yes">
  <MsgText pgmKey="ERR_NO_SERVICE" varFormat="Java">
    ERR_NO_SERVICE=ASYN0057E: Work Manager service could not resolve the {0} service.
  </MsgText>
  <Explanation>
    The Work Manager service could not resolve the specified service, which is required for the Work Manager service. Look through the log to determine the specified service started successfully.
  </Explanation>
  <UserResponse>
    If you wish to use the Work Manager service, correct the problem with the specified service. If you are unable to correct the problem, contact IBM product support.
  </UserResponse>
</Message>
<Message ID="ASYN0001E" severity="E" prefix="yes">
  <MsgText pgmKey="MSG_KEY_08" varFormat="Java">
    MSG_KEY_08=ASYN0001E: Waiter not found in list.
  </MsgText>
  <Explanation>
    This exception is unexpected. The cause is not immediately known.
  </Explanation>
  <UserResponse>
    If the problem persists, additional information might be available if you search for the message ID on the following Web sites: WebSphere Application Server Support page: http://www.ibm.com/software/webservers/appserv/was/support/ WebSphere Application Server for z/OS Support page: http://www.ibm.com/software/webservers/appserv/zos_os390/support/ .
  </UserResponse>
</Message>
<Message ID="ASYN0080W" severity="W" prefix="yes">
  <MsgText pgmKey="SERVICE_REGISTERED_TOO_LATE" varFormat="Java">
    SERVICE_REGISTERED_TOO_LATE=ASYN0080W: Registration of the {0} service might not be honored because the service was registered after asynchronous beans was used.
  </MsgText>
  <Explanation>
    When asynchronous beans is used, it processes the list of registered services. If a service is registered after this point, the registration might not be honored.
  </Explanation>
  <UserResponse>
    The service needs to be registered before asynchronous beans is used. Contact IBM product support.
  </UserResponse>
</Message>
<Message ID="ASYN0043E" severity="E" prefix="yes">
  <MsgText pgmKey="MSG_KEY_60" varFormat="Java">
    MSG_KEY_60=ASYN0043E: IOException during JNDI operation.
  </MsgText>
  <Explanation>
    An unexpected exception occurred binding an WorkManager/ObjectPoolManager in to JNDI.
  </Explanation>
  <UserResponse>
    Indicates a damaged installation. Reinstall and try again.
  </UserResponse>
</Message>
<Message ID="ASYN0065W" severity="W" prefix="yes">
  <MsgText pgmKey="CUSTOM_PROPERTY_WARNING" varFormat="Java">
    CUSTOM_PROPERTY_WARNING=ASYN0065W: The custom property {0} has been deprecated.  Please use a cooresponding configuration attribute.
  </MsgText>
  <Explanation>
    A configuration attribute is available for this setting and is preferred over the custom property.
  </Explanation>
  <UserResponse>
    Migrate all configuration utilities to use the configuration attribute and avoid using this custom property.
  </UserResponse>
</Message>
<Message ID="ASYN0066E" severity="E" prefix="yes">
  <MsgText pgmKey="METHOD_THROW_THROWABLE" varFormat="Java">
    METHOD_THROW_THROWABLE=ASYN0066E: The method {0} threw an Throwable: {1}.
  </MsgText>
  <Explanation>
    A method threw an Throwable and is caught by AsynchBeans component.
  </Explanation>
  <UserResponse>
    Make sure the method does not throw an Throwable.
  </UserResponse>
</Message>
<Message ID="ASYN0042E" severity="E" prefix="yes">
  <MsgText pgmKey="MSG_KEY_59" varFormat="Java">
    MSG_KEY_59=ASYN0042E: Cannot find the security service.
  </MsgText>
  <Explanation>
    Indicates the security service could not be located.
  </Explanation>
  <UserResponse>
    Indicates the server installation has been damaged. Reinstall.
  </UserResponse>
</Message>
<Message ID="ASYN0031E" severity="E" prefix="yes">
  <MsgText pgmKey="MSG_KEY_57" varFormat="Java">
    MSG_KEY_57=ASYN0031E: The locateComponentMetaData method failed {0}.
  </MsgText>
  <Explanation>
    An unexpected exception occurred locating the meta data for a Java Platform, Enterprise Edition component when inflating a WorkWithExecutionContext.
  </Explanation>
  <UserResponse>
    This is an unrecoverable error. Verify the installation is not damaged and try again.
  </UserResponse>
</Message>
<Message ID="ASYN0030E" severity="E" prefix="yes">
  <MsgText pgmKey="MSG_KEY_56" varFormat="Java">
    MSG_KEY_56=ASYN0030E: Cannot find meta data for j2eename {0}.
  </MsgText>
  <Explanation>
    A WorkWithExecutionContext was created using the named Java Platform, Enterprise Edition component. An attempt was made to serialize and then inflate this in an EAR which the component does not exist.
  </Explanation>
  <UserResponse>
    Inflate the object in a server that has the EAR containing the component.
  </UserResponse>
</Message>
<Message ID="ASYN0062E" severity="E" prefix="yes">
  <MsgText pgmKey="ASYNCHBEAN_CANNOT_BE_ENTERPRISEBEAN" varFormat="Java">
    ASYNCHBEAN_CANNOT_BE_ENTERPRISEBEAN=ASYN0062E: {0} cannot be an Enterprise Bean. It must be either a remote or local interface to an EJB.
  </MsgText>
  <Explanation>
    An AsynchBean, Work, WorkListener, or TimerListener cannot implement javax.ejb.EnterpriseBean. It must be either a remote or local interface to an EJB.
  </Explanation>
  <UserResponse>
    Do not make the AsynchBean, Work, WorkListener, or TimerListener implement javax.ejb.EnterpriseBean. Make it a remote or local interface to an EJB.
  </UserResponse>
</Message>
<!-- END MESSAGES -->
</TMSSource>
