<?xml version="1.0" encoding="UTF-8"?>
<?xml-stylesheet type="text/css" href="../../resources/stylesheets/wasmsgxml.css"?>
<TMSSource name="TivoliMessages" tmsVersion="1.0" xml:lang="en">
<!-- CMVC MSG File Name = ws/code/cscope.impl/src/com/ibm/ws/cscope/resources/CScopeMessages.nlsprops -->
<!-- DO NOT EDIT THIS FILE - This file was generated by the XML/Html & Property emitter -->
<!-- BEGIN MESSAGES -->
<Message ID="CSCP0013E" severity="E" prefix="yes">
  <MsgText pgmKey="ERR_RECOVERY_FAILURE" varFormat="Java">
    ERR_RECOVERY_FAILURE=CSCP0013E: During Compensation Scope recovery an error occurred. The error was {0}.
  </MsgText>
  <Explanation>
    An internal error occurred when attempting to perform compensation recovery.
  </Explanation>
  <UserResponse>
    If the problem persists, additional information might be available if you search for the message ID on the following Web sites: WebSphere Application Server Support page: http://www.ibm.com/software/webservers/appserv/was/support/ WebSphere Application Server for z/OS Support page: http://www.ibm.com/software/webservers/appserv/zos_os390/support/ .
  </UserResponse>
</Message>
<Message ID="CSCP0003I" severity="I" prefix="yes">
  <MsgText pgmKey="INF_CANNOT_BE_DISABLED" varFormat="Java">
    INF_CANNOT_BE_DISABLED=CSCP0003I: Compensation service cannot be disabled.
  </MsgText>
  <Explanation>
    You attempted to disable the compensation service in the configuration, but disabling this service would cause other services on the server to fail.
  </Explanation>
  <UserResponse>
    No action is required.
  </UserResponse>
</Message>
<Message ID="CSCP0007E" severity="E" prefix="yes">
  <MsgText pgmKey="ERR_UNEXPECTED_ERROR" varFormat="Java">
    ERR_UNEXPECTED_ERROR=CSCP0007E: An unexpected error occurred in method {0} in class {1}; the exception stack trace follows: {2}.
  </MsgText>
  <Explanation>
    An unexpected error was detected in the Compensation Scope service.
  </Explanation>
  <UserResponse>
    If the problem persists, additional information might be available if you search for the message ID on the following Web sites: WebSphere Application Server Support page: http://www.ibm.com/software/webservers/appserv/was/support/ WebSphere Application Server for z/OS Support page: http://www.ibm.com/software/webservers/appserv/zos_os390/support/ .
  </UserResponse>
</Message>
<Message ID="CSCP0004W" severity="W" prefix="yes">
  <MsgText pgmKey="WRN_DISABLED" varFormat="Java">
    WRN_DISABLED=CSCP0004W: Compensation service disabled due to previous errors.
  </MsgText>
  <Explanation>
    There was error during initialization of the compensation service. The service is inaccessible on the given server. The root error should be logged already.
  </Explanation>
  <UserResponse>
    Try to resolve the errors that are already logged.
  </UserResponse>
</Message>
<Message ID="CSCP0018E" severity="E" prefix="yes">
  <MsgText pgmKey="ERR_LTC_RESOLVER" varFormat="Java">
    ERR_LTC_RESOLVER=CSCP0018E: Error found invoking an EJB method. The method {0} on EJB {1} specified a CompensationKind attribute that is not allowed with local transactions with a resolution control other than container at boundary.
  </MsgText>
  <Explanation>
    The application component identified in the message has been assembled to use Compensation extensions that are supported with local transactions only if the resolution control is ContainerAtBoundary.
  </Explanation>
  <UserResponse>
    Reassemble the failed application to use different Compensation attributes, or local transactions with  the resolution control deployment setting set to ContainerAtBoundary.
  </UserResponse>
</Message>
<Message ID="CSCP0005I" severity="I" prefix="yes">
  <MsgText pgmKey="INF_STARTED" varFormat="Java">
    INF_STARTED=CSCP0005I: The Compensation service started successfully.
  </MsgText>
  <Explanation>
    This message is for informational purposes only.
  </Explanation>
  <UserResponse>
    No action is required.
  </UserResponse>
</Message>
<Message ID="CSCP0024W" severity="W" prefix="yes">
  <MsgText pgmKey="INF_LOG_WARNING" varFormat="Java">
    INF_LOG_WARNING=CSCP0024W: Compensation service log {0} has used {1} bytes of a total of {2}. The maximum size of the log file might need to be greater.
  </MsgText>
  <Explanation>
    The recovery log file is nearly full because of the workload flowing through the compensation service. If the log file becomes full, the server must be restarted.
  </Explanation>
  <UserResponse>
    Consider increasing the maximum log file size for the compensation service log.
  </UserResponse>
</Message>
<Message ID="CSCP0009E" severity="E" prefix="yes">
  <MsgText pgmKey="ERR_COMPENSATOR_UNEXPECTED" varFormat="Java">
    ERR_COMPENSATOR_UNEXPECTED=CSCP0009E: Unexpected error occurred when registering compensation logic with Compensation scope. The exception was {0}
  </MsgText>
  <Explanation>
    An internal error occurred when attempting to enlist a new compensator with the compensation scope.
  </Explanation>
  <UserResponse>
    If the problem persists, additional information might be available if you search for the message ID on the following Web sites: WebSphere Application Server Support page: http://www.ibm.com/software/webservers/appserv/was/support/ WebSphere Application Server for z/OS Support page: http://www.ibm.com/software/webservers/appserv/zos_os390/support/ .
  </UserResponse>
</Message>
<Message ID="CSCP0012E" severity="E" prefix="yes">
  <MsgText pgmKey="ERR_PERSIST_FAILURE" varFormat="Java">
    ERR_PERSIST_FAILURE=CSCP0012E: An error occurred when persisting a Compensation Scope. The exception was {0}.
  </MsgText>
  <Explanation>
    An internal error occurred when attempting to maintain persistence for information about a compensation scope.
  </Explanation>
  <UserResponse>
    If the problem persists, additional information might be available if you search for the message ID on the following Web sites: WebSphere Application Server Support page: http://www.ibm.com/software/webservers/appserv/was/support/ WebSphere Application Server for z/OS Support page: http://www.ibm.com/software/webservers/appserv/zos_os390/support/ .
  </UserResponse>
</Message>
<Message ID="CSCP0011E" severity="E" prefix="yes">
  <MsgText pgmKey="ERR_CKIND_REQUIRED_BMT" varFormat="Java">
    ERR_CKIND_REQUIRED_BMT=CSCP0011E: Error found starting an application. {0} specified a CompensationKind attribute that is not allowed with Bean Managed Transactions.
  </MsgText>
  <Explanation>
    The application component identified in the message has been assembled to use Compensation extensions that are not supported with bean-managed transactions.
  </Explanation>
  <UserResponse>
    Reassemble the failing application to use different compensation attributes or container-managed transactions.
  </UserResponse>
</Message>
<Message ID="CSCP0010E" severity="E" prefix="yes">
  <MsgText pgmKey="ERR_END_UNEXPECTED" varFormat="Java">
    ERR_END_UNEXPECTED=CSCP0010E: Unexpected error occurred when ending Compensation scope. The exception was {0}.
  </MsgText>
  <Explanation>
    An internal error occurred when attempting to end the compensation scope.
  </Explanation>
  <UserResponse>
    If the problem persists, additional information might be available if you search for the message ID on the following Web sites: WebSphere Application Server Support page: http://www.ibm.com/software/webservers/appserv/was/support/ WebSphere Application Server for z/OS Support page: http://www.ibm.com/software/webservers/appserv/zos_os390/support/ .
  </UserResponse>
</Message>
<Message ID="CSCP0014E" severity="E" prefix="yes">
  <MsgText pgmKey="ERR_ACTIVITY_RECREATE" varFormat="Java">
    ERR_ACTIVITY_RECREATE=CSCP0014E: During Compensation Scope recovery a recreation attempt failed. The cause of the failure was {0}.
  </MsgText>
  <Explanation>
    An internal error occurred when attempting to recreate a recovered compensation scope.
  </Explanation>
  <UserResponse>
    If the problem persists, additional information might be available if you search for the message ID on the following Web sites: WebSphere Application Server Support page: http://www.ibm.com/software/webservers/appserv/was/support/ WebSphere Application Server for z/OS Support page: http://www.ibm.com/software/webservers/appserv/zos_os390/support/ .
  </UserResponse>
</Message>
<Message ID="CSCP0020I" severity="I" prefix="yes">
  <MsgText pgmKey="INF_COMPENSATOR_RETRY" varFormat="Java">
    INF_COMPENSATOR_RETRY=CSCP0020I: The call to {0} on {1} failed. It will be retried in {2} seconds.
  </MsgText>
  <Explanation>
    The compensation service that triggered the retry process detected a retry exception.
  </Explanation>
  <UserResponse>
    No action is required. This message is for informational purposes only.
  </UserResponse>
</Message>
<Message ID="CSCP0019E" severity="E" prefix="yes">
  <MsgText pgmKey="ERR_COMPENSATOR_SORT_FAILURE" varFormat="Java">
    ERR_COMPENSATOR_SORT_FAILURE=CSCP0019E: When ordering the compensators for Compensation Scope {0} an unexpected error occurred. The error was {1}.
  </MsgText>
  <Explanation>
    An internal error occurred when attempting to order the compensators of a compensation scope. The compensators might be out of order.
  </Explanation>
  <UserResponse>
    If the problem persists, additional information might be available if you search for the message ID on the following Web sites: WebSphere Application Server Support page: http://www.ibm.com/software/webservers/appserv/was/support/ WebSphere Application Server for z/OS Support page: http://www.ibm.com/software/webservers/appserv/zos_os390/support/ .
  </UserResponse>
</Message>
<Message ID="CSCP0022E" severity="E" prefix="yes">
  <MsgText pgmKey="ERR_INVALID_STATE_FAULT_DETAIL" varFormat="Java">
    ERR_INVALID_STATE_FAULT_DETAIL=CSCP0022E: The BusinessActivity with ID {0} has received a SOAP fault from {1} with fault code {2}, and fault string {3}. The full SOAP fault was {4}.
  </MsgText>
  <Explanation>
    An internal state error has occurred. The BusinessActivity could not process the protocol message it was sent, because it was not in the appropriate state to receive it.
  </Explanation>
  <UserResponse>
    If the problem persists, additional information might be available if you search for the message ID on the following Web sites: WebSphere Application Server Support page: http://www.ibm.com/software/webservers/appserv/was/support/ WebSphere Application Server for z/OS Support page: http://www.ibm.com/software/webservers/appserv/zos_os390/support/ .
  </UserResponse>
</Message>
<Message ID="CSCP0021I" severity="I" prefix="yes">
  <MsgText pgmKey="INF_COMPENSATOR_RETRY_LIMIT" varFormat="Java">
    INF_COMPENSATOR_RETRY_LIMIT=CSCP0021I: The method {0} on {1} has been retried {2} times and has reached the retry limit. It will not be retried again.
  </MsgText>
  <Explanation>
    The compensation service will not retry the compensation handler again because it has reached the retry limit.
  </Explanation>
  <UserResponse>
    No action is required. This message is for informational purposes only.
  </UserResponse>
</Message>
<Message ID="CSCP0006I" severity="I" prefix="yes">
  <MsgText pgmKey="INF_STOPPING" varFormat="Java">
    INF_STOPPING=CSCP0006I: The Compensation service is stopping.
  </MsgText>
  <Explanation>
    This message is for informational purposes only.
  </Explanation>
  <UserResponse>
    No action is required.
  </UserResponse>
</Message>
<Message ID="CSCP0001E" severity="E" prefix="yes">
  <MsgText pgmKey="ERR_NO_SERVICE" varFormat="Java">
    ERR_NO_SERVICE=CSCP0001E: Compensation service could not resolve the {0} service.
  </MsgText>
  <Explanation>
    The compensation service could not resolve the specified service, which is required for the compensation scope service. Look through the log to see if the specified service started successfully.
  </Explanation>
  <UserResponse>
    If you want to use the compensation service, correct the problem with the specified service.
  </UserResponse>
</Message>
<Message ID="CSCP0017E" severity="E" prefix="yes">
  <MsgText pgmKey="ERR_LOG_FULL" varFormat="Java">
    ERR_LOG_FULL=CSCP0017E: The recovery log does not have sufficient space available to persist the current Compensation Scope.
  </MsgText>
  <Explanation>
    There is not enough space in the recovery log to maintain persistence for the data that is passed to it. Persistence of the current compensation scope has failed.
  </Explanation>
  <UserResponse>
    Use compensators with a smaller serialized size, or increase the Recovery Log File Size for the compensation service.
  </UserResponse>
</Message>
<Message ID="CSCP0016E" severity="E" prefix="yes">
  <MsgText pgmKey="ERR_SUBORD_ERROR" varFormat="Java">
    ERR_SUBORD_ERROR=CSCP0016E: An error occurred when attempting to communicate with a subordinate Compensation Scope. The error was {0}.
  </MsgText>
  <Explanation>
    An internal error occurred when attempting to direct a subordinate compensation scope.
  </Explanation>
  <UserResponse>
    If the problem persists, additional information might be available if you search for the message ID on the following Web sites: WebSphere Application Server Support page: http://www.ibm.com/software/webservers/appserv/was/support/ WebSphere Application Server for z/OS Support page: http://www.ibm.com/software/webservers/appserv/zos_os390/support/ .
  </UserResponse>
</Message>
<Message ID="CSCP0023E" severity="E" prefix="yes">
  <MsgText pgmKey="ERR_INVALID_STATE_FAULT" varFormat="Java">
    ERR_INVALID_STATE_FAULT=CSCP0023E: The BusinessActivity with ID {0} has received a SOAP fault from {1}. The full SOAP fault was {2}.
  </MsgText>
  <Explanation>
    An internal state error has occured. The BusinessActivity could not process the protocol message it was sent, because it was not in the appropriate state to receive it.
  </Explanation>
  <UserResponse>
    If the problem persists, additional information might be available if you search for the message ID on the following Web sites: WebSphere Application Server Support page: http://www.ibm.com/software/webservers/appserv/was/support/ WebSphere Application Server for z/OS Support page: http://www.ibm.com/software/webservers/appserv/zos_os390/support/ .
  </UserResponse>
</Message>
<Message ID="CSCP0015E" severity="E" prefix="yes">
  <MsgText pgmKey="ERR_LOG_CORRUPT" varFormat="Java">
    ERR_LOG_CORRUPT=CSCP0015E: When recovering the log entries for Compensation Scope {0} an unexpected entry was found.
  </MsgText>
  <Explanation>
    There is an unexpected or malformed log entry, and you cannot rely on the integrity of the data.
  </Explanation>
  <UserResponse>
    If the problem persists, additional information might be available if you search for the message ID on the following Web sites: WebSphere Application Server Support page: http://www.ibm.com/software/webservers/appserv/was/support/ WebSphere Application Server for z/OS Support page: http://www.ibm.com/software/webservers/appserv/zos_os390/support/ .
  </UserResponse>
</Message>
<Message ID="CSCP0002I" severity="I" prefix="yes">
  <MsgText pgmKey="INF_NOT_ENABLED" varFormat="Java">
    INF_NOT_ENABLED=CSCP0002I: Compensation service is disabled.
  </MsgText>
  <Explanation>
    The compensation service is disabled in the configuration, and it will be inaccessible on the server.
  </Explanation>
  <UserResponse>
    No action is required.
  </UserResponse>
</Message>
<Message ID="CSCP0008E" severity="E" prefix="yes">
  <MsgText pgmKey="ERR_BEGIN_UNEXPECTED" varFormat="Java">
    ERR_BEGIN_UNEXPECTED=CSCP0008E: Unexpected error occurred when beginning a new Compensation Scope. The exception was {0}
  </MsgText>
  <Explanation>
    An internal error occurred when an attempt to begin a new compensation scope was made.
  </Explanation>
  <UserResponse>
    If the problem persists, additional information might be available if you search for the message ID on the following Web sites: WebSphere Application Server Support page: http://www.ibm.com/software/webservers/appserv/was/support/ WebSphere Application Server for z/OS Support page: http://www.ibm.com/software/webservers/appserv/zos_os390/support/ .
  </UserResponse>
</Message>
<!-- END MESSAGES -->
</TMSSource>
