<?xml version="1.0" encoding="UTF-8"?>
<?xml-stylesheet type="text/css" href="../../resources/stylesheets/wasmsgxml.css"?>
<TMSSource name="TivoliMessages" tmsVersion="1.0" xml:lang="en">
<!-- CMVC MSG File Name = ws/code/DCS/src/com/ibm/ws/dcs/common/event/nls/dcs.nlsprops -->
<!-- DO NOT EDIT THIS FILE - This file was generated by the XML/Html & Property emitter -->
<!-- BEGIN MESSAGES -->
<Message ID="DCSV0001E" severity="E" prefix="yes">
  <MsgText pgmKey="DCSV0001" varFormat="Java">
    DCSV0001=DCSV0001E: DCS Stack {0} at Member {1}: An internal error occurred in DCS. The exception is {2}. Method is {3}.
  </MsgText>
  <Explanation>
    An internal error occurred in the distribution and consistency services (DCS). See the exception stack trace for more detail.
  </Explanation>
  <UserResponse>
    See the problem determination information on the WebSphere Application Server Support Web page: http://www.ibm.com/software/webservers/appserv/was/support for additional information.
  </UserResponse>
</Message>
<Message ID="DCSV0000W" severity="W" prefix="yes">
  <MsgText pgmKey="DCSV0000" varFormat="Java">
    DCSV0000=DCSV0000W: DCS Stack {0} at Member {1}: DCS encountered an internal problem while logging. Log message details are: {2}.
  </MsgText>
  <Explanation>
    Distribution and consistency services (DCS) could not log a message properly.
  </Explanation>
  <UserResponse>
    See the problem determination information on the WebSphere Application Server Support Web page: http://www.ibm.com/software/webservers/appserv/was/support for possible causes of this problem.
  </UserResponse>
</Message>
<Message ID="DCSV1013W" severity="W" prefix="yes">
  <MsgText pgmKey="DCSV1013" varFormat="Java">
    DCSV1013=DCSV1013W: DCS Stack {0} at Member {1}: The transport infastructure failed to send a UDP datagram to address {2}. DCS Logical Channel is {3}. Exception is {4}.
  </MsgText>
  <Explanation>
    The distribution and consistency services (DCS) transport infrastructure for this member failed to send a UDP datagram.
  </Explanation>
  <UserResponse>
    Check the network connectivity of this machine.
  </UserResponse>
</Message>
<Message ID="DCSV1012E" severity="E" prefix="yes">
  <MsgText pgmKey="DCSV1012" varFormat="Java">
    DCSV1012=DCSV1012E: DCS Stack {0} at Member {1}: Unable to communicate with other members, due to failure to join the connected multicast group {2}.
  </MsgText>
  <Explanation>
    The distribution and consistency services (DCS) failed to join a multicast group address. A possible cause for this problem is a configured system limit for the maximum number of multicast groups.
  </Explanation>
  <UserResponse>
    Check the network and firewall configuration settings for your operating system.
  </UserResponse>
</Message>
<Message ID="DCSV1011W" severity="W" prefix="yes">
  <MsgText pgmKey="DCSV1011" varFormat="Java">
    DCSV1011=DCSV1011W: DCS Stack {0} at Member {1}: Failed to join a view due to a problem with  multicast group {2}. Will not be able to receive messages from member(s) {3}.
  </MsgText>
  <Explanation>
    The distribution and consistency services (DCS) failed to join a multicast group address. A possible cause for this problem is a configured system limit for the maximum number of multicast groups.
  </Explanation>
  <UserResponse>
    Check the network and firewall configuration settings for your operating system.
  </UserResponse>
</Message>
<Message ID="DCSV8072W" severity="W" prefix="yes">
  <MsgText pgmKey="DCSV8072" varFormat="Java">
    DCSV8072=DCSV8072W: DCS Stack {0} at Member {1}: Failed to serialize HA Manager state. Version is {2}
  </MsgText>
  <Explanation>
    The distribution and consistency services (DCS) failed to serialize the high availability manager state.
  </Explanation>
  <UserResponse>
    See the problem determination information on the WebSphere Application Server Support Web page: http://www.ibm.com/software/webservers/appserv/was/support for additional information.
  </UserResponse>
</Message>
<Message ID="DCSV8071W" severity="W" prefix="yes">
  <MsgText pgmKey="DCSV8071" varFormat="Java">
    DCSV8071=DCSV8071W: DCS Stack {0} at Member {1}: Failed to deserialize HA Manager state. Internal details: {2}
  </MsgText>
  <Explanation>
    The distribution and consistency services (DCS) failed to deserialize the high availability manager state.
  </Explanation>
  <UserResponse>
    See the problem determination information on the WebSphere Application Server Support Web page: http://www.ibm.com/software/webservers/appserv/was/support for additional information.
  </UserResponse>
</Message>
<Message ID="DCSV8070I" severity="I" prefix="yes">
  <MsgText pgmKey="DCSV8070" varFormat="Java">
    DCSV8070=DCSV8070I: DCS Stack {0} at Member {1}: Updated HA Manager state. New state version is {2}
  </MsgText>
  <Explanation>
    The high availability manager state was updated.
  </Explanation>
  <UserResponse>
    No action required.
  </UserResponse>
</Message>
<Message ID="DCSV8108W" severity="W" prefix="yes">
  <MsgText pgmKey="DCSV8108" varFormat="Java">
    DCSV8108=DCSV8108W: DCS Stack {0} at Member {1}: Removing all other members due to an internal inconsistency. The internal details are {2}
  </MsgText>
  <Explanation>
    All other members will be removed from the view because of an internal inconsistency.
  </Explanation>
  <UserResponse>
    No action required. If this warning reoccurs frequently, see the problem determination information on the WebSphere Application Server Support Web page: http://www.ibm.com/software/webservers/appserv/was/support for additional information.
  </UserResponse>
</Message>
<Message ID="DCSV8106I" severity="I" prefix="yes">
  <MsgText pgmKey="DCSV8106" varFormat="Java">
    DCSV8106=DCSV8106I: DCS Stack {0} at Member {1}: Denied member {2} because of administrative denial request. Internal details: {3}.
  </MsgText>
  <Explanation>
    The distribution and consistency services (DCS) received an administrative request to remove the indicated member from the view.
  </Explanation>
  <UserResponse>
    No action required.
  </UserResponse>
</Message>
<Message ID="DCSV1003E" severity="E" prefix="yes">
  <MsgText pgmKey="DCSV1003" varFormat="Java">
    DCSV1003=DCSV1003E: DCS Stack {0} at Member {1}: Failed to create transport infrastructure. Transport type is {2}.
  </MsgText>
  <Explanation>
    The distribution and consistency services (DCS) failed to create its transport infrastructure instance. For example it failed to create the infrastructure for the channel framework DCS transports.
  </Explanation>
  <UserResponse>
    Check the log for other errors specific to the DCS transport type. If the problem cannot be resolved, see the problem determination information on the WebSphere Application Server Support Web page: http://www.ibm.com/software/webservers/appserv/was/support for additional information.
  </UserResponse>
</Message>
<Message ID="DCSV1002I" severity="I" prefix="yes">
  <MsgText pgmKey="DCSV1002" varFormat="Java">
    DCSV1002=DCSV1002I: DCS Stack {0} at Member {1}: Linked to an existing transport infrastructure instance. Transport type is {2}.  Version information is {3}.
  </MsgText>
  <Explanation>
    The distribution and consistency services (DCS) linked to an existing transport infrastructure instance.
  </Explanation>
  <UserResponse>
    No action required.
  </UserResponse>
</Message>
<Message ID="DCSV8104W" severity="W" prefix="yes">
  <MsgText pgmKey="DCSV8104" varFormat="Java">
    DCSV8104=DCSV8104W: DCS Stack {0} at Member {1}: Removing member {2} because the member was requested to be removed  by member {3}. Internal details {4}
  </MsgText>
  <Explanation>
    The removed member was marked as failed by another view member. It will be removed from the view.
  </Explanation>
  <UserResponse>
    Check the logs for removed member and the requesting member and the network communication between them.
  </UserResponse>
</Message>
<Message ID="DCSV1001I" severity="I" prefix="yes">
  <MsgText pgmKey="DCSV1001" varFormat="Java">
    DCSV1001=DCSV1001I: DCS Stack {0} at Member {1}: Created a new transport infrastructure instance successfully. Transport type is {2}. Version information is {3}.
  </MsgText>
  <Explanation>
    The distribution and consistency services (DCS) started a new transport infrastructure instance.
  </Explanation>
  <UserResponse>
    No action required.
  </UserResponse>
</Message>
<Message ID="DCSV8103W" severity="W" prefix="yes">
  <MsgText pgmKey="DCSV8103" varFormat="Java">
    DCSV8103=DCSV8103W: DCS Stack {0} at Member {1}: Removing member {2} from view because the member did not respond within the timeout period of {3} seconds. Internal details: {4}.
  </MsgText>
  <Explanation>
    Another member did not respond within the expected time period. The other member will be removed from the view and processing will continue.
  </Explanation>
  <UserResponse>
    Check the logs for the other member and the communication between the two members.
  </UserResponse>
</Message>
<Message ID="DCSV8102W" severity="W" prefix="yes">
  <MsgText pgmKey="DCSV8102" varFormat="Java">
    DCSV8102=DCSV8102W: DCS Stack {0} at Member {1}: Removing member {2} from view  because it broke protocol. Internal details: {3}
  </MsgText>
  <Explanation>
    The member that is being removed sent a message that was out of protocol sequence.
  </Explanation>
  <UserResponse>
    No action required. If the problem persists, see the problem determination information on the WebSphere Application Server Support Web page: http://www.ibm.com/software/webservers/appserv/was/support for additional information.
  </UserResponse>
</Message>
<Message ID="DCSV8100W" severity="W" prefix="yes">
  <MsgText pgmKey="DCSV8100" varFormat="Java">
    DCSV8100=DCSV8100W: DCS Stack {0} at Member {1}: Removing member {2} from view as a response to removal by other member  of local member.
  </MsgText>
  <Explanation>
    This member was marked as failed by another member. This member will mark the other member as failed and will remove it from the view.
  </Explanation>
  <UserResponse>
    Check the logs for the other member to determine why it marked this member as failed.
  </UserResponse>
</Message>
<Message ID="DCSV8063I" severity="I" prefix="yes">
  <MsgText pgmKey="DCSV8063" varFormat="Java">
    DCSV8063=DCSV8063I: DCS Stack {0} at Member {1}: Received request to change the Core group membership set. Internal details: {2}
  </MsgText>
  <Explanation>
    The distribution and consistency services (DCS) received a request to change the core group membership set.
  </Explanation>
  <UserResponse>
    No action required.
  </UserResponse>
</Message>
<Message ID="DCSV8060I" severity="I" prefix="yes">
  <MsgText pgmKey="DCSV8060" varFormat="Java">
    DCSV8060=DCSV8060I: DCS Data Stack {0} at Member {1}: Received request for a new view. Current view identifier: {2}. Request to add: {3}. Request to remove: {4}. Internal details: {5}
  </MsgText>
  <Explanation>
    Received request to install a new view in a data stack.
  </Explanation>
  <UserResponse>
    No action required.
  </UserResponse>
</Message>
<Message ID="DCSV1152W" severity="W" prefix="yes">
  <MsgText pgmKey="DCSV1152" varFormat="Java">
    DCSV1152=DCSV1152W: DCS Stack {0} at Member {1}: Removing member {2} because it failed to acknowledge messages at a sufficient rate. The internal details are {3}.
  </MsgText>
  <Explanation>
    The transport infrastructure suspected a member that failed to acknowledge messages at a sufficient rate. That member caused the memory, dedicated for saving outgoing unacknowledged messages, to be exhausted. The member might either be down or cannot handle its current workload.
  </Explanation>
  <UserResponse>
    Make sure that the indicated member is running. If it is running, consider lowering the workload on the local machine or make sure that the indicated member can handle its assigned workload.
  </UserResponse>
</Message>
<Message ID="DCSV1151W" severity="W" prefix="yes">
  <MsgText pgmKey="DCSV1151" varFormat="Java">
    DCSV1151=DCSV1151W: DCS Stack {0} at Member {1}: Removing member {2} because its outgoing messaging rate is too high.  The internal details are {3}.
  </MsgText>
  <Explanation>
    The receiver side memory of the transport infrastructure is exhausted. To free memory the indicated member was removed.
  </Explanation>
  <UserResponse>
    Consider increasing the dynamic memory size in the transport infrastructure configuration or lowering the workload of the member that was removed.
  </UserResponse>
</Message>
<Message ID="DCSV8057I" severity="I" prefix="yes">
  <MsgText pgmKey="DCSV8057" varFormat="Java">
    DCSV8057=DCSV8057I: DCS Stack {0} at Member {1}: View change in process. Number of members excluded is {2}. For more information see the logs above.
  </MsgText>
  <Explanation>
    An internal view change protocol in process. Failed members will be excluded from the new view. Because the number of failed members is large, they are not listed. Information about failures can be found in the message logs.
  </Explanation>
  <UserResponse>
    No action required.
  </UserResponse>
</Message>
<Message ID="DCSV8056I" severity="I" prefix="yes">
  <MsgText pgmKey="DCSV8056" varFormat="Java">
    DCSV8056=DCSV8056I: DCS Stack {0} at Member {1}: Failed to do a core group membership set change request. Internal details are: {2}.
  </MsgText>
  <Explanation>
    An attempt to update the core group membership for the stack failed. The problem might be caused by the timing of the request
  </Explanation>
  <UserResponse>
    No action required.
  </UserResponse>
</Message>
<Message ID="DCSV8055W" severity="W" prefix="yes">
  <MsgText pgmKey="DCSV8055" varFormat="Java">
    DCSV8055=DCSV8055W: DCS Stack {0} at Member {1}: Core group membership set changed. Added: {2} Failed to add {3}.
  </MsgText>
  <Explanation>
    New members were added to the core group membership for the stack. However, some failures occurred.
  </Explanation>
  <UserResponse>
    No action required.
  </UserResponse>
</Message>
<Message ID="DCSV8054I" severity="I" prefix="yes">
  <MsgText pgmKey="DCSV8054" varFormat="Java">
    DCSV8054=DCSV8054I: DCS Stack {0} at Member {1}: View change in process.
  </MsgText>
  <Explanation>
    An internal view change protocol in process
  </Explanation>
  <UserResponse>
    No action required.
  </UserResponse>
</Message>
<Message ID="DCSV8053I" severity="I" prefix="yes">
  <MsgText pgmKey="DCSV8053" varFormat="Java">
    DCSV8053=DCSV8053I: DCS Stack {0} at Member {1}: View change in process. Excluded members are {2}.
  </MsgText>
  <Explanation>
    An internal view change protocol in process. Failed members will be excluded from the new view.
  </Explanation>
  <UserResponse>
    No action required.
  </UserResponse>
</Message>
<Message ID="DCSV8052I" severity="I" prefix="yes">
  <MsgText pgmKey="DCSV8052" varFormat="Java">
    DCSV8052=DCSV8052I: DCS Stack {0} at Member {1}: Core group membership set changed. Removed: {2}.
  </MsgText>
  <Explanation>
    Existing members were removed from the core group membership for the stack.
  </Explanation>
  <UserResponse>
    No action required.
  </UserResponse>
</Message>
<Message ID="DCSV8051I" severity="I" prefix="yes">
  <MsgText pgmKey="DCSV8051" varFormat="Java">
    DCSV8051=DCSV8051I: DCS Stack {0} at Member {1}: Core group membership set changed. Added: {2}.
  </MsgText>
  <Explanation>
    New members were added to the core group membership for the stack.
  </Explanation>
  <UserResponse>
    No action required.
  </UserResponse>
</Message>
<Message ID="DCSV8050I" severity="I" prefix="yes">
  <MsgText pgmKey="DCSV8050" varFormat="Java">
    DCSV8050=DCSV8050I: DCS Stack {0} at Member {1}: New view installed, identifier {2}, view size is {3}
  </MsgText>
  <Explanation>
    A view change has completed
  </Explanation>
  <UserResponse>
    No action required. If this message is logged continuously, examine the logs of other members for potential problems.
  </UserResponse>
</Message>
<Message ID="DCSV2006I" severity="I" prefix="yes">
  <MsgText pgmKey="DCSV2006" varFormat="Java">
    DCSV2006=DCSV2006I: DCS Stack {0} at Member {1}: The amount of memory available for view synchronization is back to normal.
  </MsgText>
  <Explanation>
    The amount of memory available for view synchronization is back to normal.
  </Explanation>
  <UserResponse>
    No action required.
  </UserResponse>
</Message>
<Message ID="DCSV2005W" severity="W" prefix="yes">
  <MsgText pgmKey="DCSV2005" varFormat="Java">
    DCSV2005=DCSV2005W: DCS Stack {0} at Member {1}: The amount of memory available for view synchronization is low. The configured memory size is {2} bytes. Currently used memory size is {3} bytes.
  </MsgText>
  <Explanation>
    The amount of memory available for view synchronization is low.
  </Explanation>
  <UserResponse>
    If this message is logged frequently, consider decreasing the load on this process or increasing the total memory that is available to DCS. For more information see the product Information Center topic that describes how to configure a core group for replication.
  </UserResponse>
</Message>
<Message ID="DCSV2004I" severity="I" prefix="yes">
  <MsgText pgmKey="DCSV2004" varFormat="Java">
    DCSV2004=DCSV2004I: DCS Stack {0} at Member {1}: View synchronization completed successfully. The View Identifier is {2}. The internal details are {3}.
  </MsgText>
  <Explanation>
    View synchronization completed successfully.
  </Explanation>
  <UserResponse>
    No action required.
  </UserResponse>
</Message>
<Message ID="DCSV2002W" severity="W" prefix="yes">
  <MsgText pgmKey="DCSV2002" varFormat="Java">
    DCSV2002=DCSV2002W: DCS Stack {0} at Member {1}: Received message from invalid member {2}. The message was ignored. The message is considered invalid due to {3}.
  </MsgText>
  <Explanation>
    The distribution and consistency services (DCS) received a message from an sender that was not in the proper state and ignored it.
  </Explanation>
  <UserResponse>
    Verify the configuration of the member whose message was ignored.
  </UserResponse>
</Message>
<Message ID="DCSV2001W" severity="W" prefix="yes">
  <MsgText pgmKey="DCSV2001" varFormat="Java">
    DCSV2001=DCSV2001W: DCS Stack {0} at Member {1}: The view synchronization procedure timed out. The configured timeout is {2}. The internal details are {3}.
  </MsgText>
  <Explanation>
    The view synchronization timed out, failing to guarantee that all members will continue to be in the next view. Some members will be removed
  </Explanation>
  <UserResponse>
    If this warning repeats, see the problem determination information on the WebSphere Application Server Support Web page: http://www.ibm.com/software/webservers/appserv/was/support for additional information.
  </UserResponse>
</Message>
<Message ID="DCSV7011E" severity="E" prefix="yes">
  <MsgText pgmKey="DCSV7011" varFormat="Java">
    DCSV7011=DCSV7011E: DCS Stack {0} at Member {1}: An exception occurred during a callback to High Availability Manager. The method is {2}. The exception is {3}.
  </MsgText>
  <Explanation>
    An unexpected error occurred. See the exception stack trace for more detail.
  </Explanation>
  <UserResponse>
    If the root cause cannot be determined and corrected, see the problem determination information on the WebSphere Application Server Support Web page: http://www.ibm.com/software/webservers/appserv/was/support for additional information.
  </UserResponse>
</Message>
<Message ID="DCSV1136W" severity="W" prefix="yes">
  <MsgText pgmKey="DCSV1136" varFormat="Java">
    DCSV1136=DCSV1136W: DCS Stack {0} at Member {1}: Member {2} failed to establish a connection to this member. The member will not be included in the new view.  The new view identifier is {3}.
  </MsgText>
  <Explanation>
    A new view has been established. This member was unable to send the proper notification to the other member. This indicates a communication problem between the two members.
  </Explanation>
  <UserResponse>
    Check both members for errors and check the network connectivity between the members.
  </UserResponse>
</Message>
<Message ID="DCSV1135W" severity="W" prefix="yes">
  <MsgText pgmKey="DCSV1135" varFormat="Java">
    DCSV1135=DCSV1135W: DCS Stack {0} at Member {1}: Removing member {2} because it is included in the new view, yet it is denied. The new view identifier is {3}.
  </MsgText>
  <Explanation>
    A new view has been established. The removed member is in a state that prevents it from participating in the new view.
  </Explanation>
  <UserResponse>
    If this message repeats, see the problem determination information on the WebSphere Application Server Support Web page: http://www.ibm.com/software/webservers/appserv/was/support for additional information.
  </UserResponse>
</Message>
<Message ID="DCSV1134W" severity="W" prefix="yes">
  <MsgText pgmKey="DCSV1134" varFormat="Java">
    DCSV1134=DCSV1134W: DCS Stack {0} at Member {1}: Member {2} established an additional connection. The member will be removed from the view. DCS logical channel is {3}.
  </MsgText>
  <Explanation>
    Another member opened multiple network connections to this member. This may be an indication of network configuration problems. Two members may have the same IP Address and port configuration.
  </Explanation>
  <UserResponse>
    Check the host and port values in the DCS_UNICAST_ADDRESS end points for the two members. Check the IP address assignments for the hosts involved.
  </UserResponse>
</Message>
<Message ID="DCSV1133W" severity="W" prefix="yes">
  <MsgText pgmKey="DCSV1133" varFormat="Java">
    DCSV1133=DCSV1133W: DCS Stack {0} at Member {1}: Member {2} did not include the local member in the new view. The other member will be removed. New view identifier is {3}. DCS logical channel is {4}.
  </MsgText>
  <Explanation>
    A new view has been established on another member. This member is not included in the new view.
  </Explanation>
  <UserResponse>
    Check the member that excluded this member from the new view.
  </UserResponse>
</Message>
<Message ID="DCSV1132W" severity="W" prefix="yes">
  <MsgText pgmKey="DCSV1132" varFormat="Java">
    DCSV1132=DCSV1132W: DCS Stack {0} at Member {1}: Member {2} is not connected despite the fact that the member is in the new view. The member will be removed from the next view. The new view identifier is {3}.
  </MsgText>
  <Explanation>
    A new view has been established. A network connection to the other member does not exist.
  </Explanation>
  <UserResponse>
    No action required. If this message repeats, see the problem determination information on the WebSphere Application Server Support Web page: http://www.ibm.com/software/webservers/appserv/was/support for additional information.
  </UserResponse>
</Message>
<Message ID="DCSV1131W" severity="W" prefix="yes">
  <MsgText pgmKey="DCSV1131" varFormat="Java">
    DCSV1131=DCSV1131W: DCS Stack {0} at Member {1}: Member {2} failed to confirm the establishment of a new view. The member will be removed from next view.  New view identifier is {3}. Configured timeout is {4} milliseconds. DCS logical channel is {5}.
  </MsgText>
  <Explanation>
    A new view has been established. This member failed to receive the proper notification from the other member. This indicates a problem with the other member.
  </Explanation>
  <UserResponse>
    Check the other member for errors and check the network connectivity to the other member.
  </UserResponse>
</Message>
<Message ID="DCSV8032I" severity="I" prefix="yes">
  <MsgText pgmKey="DCSV8032" varFormat="Java">
    DCSV8032=DCSV8032I: DCS Stack {0} at Member {1}: Ignored attept to join a view by member {2} because the local member is not in a proper state to do a join.
  </MsgText>
  <Explanation>
    A view change request from the indicated member was ignored. This member is already involved in a view change. After the current view change completes, the new view change will be attempted again.
  </Explanation>
  <UserResponse>
    No action required. The view change will automatically be attempted again. If the problem persists, see the problem determination information on the WebSphere Application Server Support Web page: http://www.ibm.com/software/webservers/appserv/was/support for additional information.
  </UserResponse>
</Message>
<Message ID="DCSV8031I" severity="I" prefix="yes">
  <MsgText pgmKey="DCSV8031" varFormat="Java">
    DCSV8031=DCSV8031I: DCS Stack {0} at Member {1}: Failed to join or establish a view due to timeout,{2} seconds, waiting for member {3}
  </MsgText>
  <Explanation>
    An attempt to establish a new view with the indicated member failed. The member failed to respond within a reasonable amount of time. This might be caused by high workloads on the involved nodes.
  </Explanation>
  <UserResponse>
    Check the workload on the involved nodes. If this problem reoccurs frequently, see the problem determination information on the WebSphere Application Server Support Web page: http://www.ibm.com/software/webservers/appserv/was/support for additional information.
  </UserResponse>
</Message>
<Message ID="DCSV8030I" severity="I" prefix="yes">
  <MsgText pgmKey="DCSV8030" varFormat="Java">
    DCSV8030=DCSV8030I: DCS Stack {0} at Member {1}: Failed  to join or establish a view with member {2}. The reason is {3}.
  </MsgText>
  <Explanation>
    An attempt to establish a new view with the indicated member failed. The reason will give additional information about the root cause of the failure.
  </Explanation>
  <UserResponse>
    If this problem reoccurs frequently, see the problem determination information on the WebSphere Application Server Support Web page: http://www.ibm.com/software/webservers/appserv/was/support for additional information.
  </UserResponse>
</Message>
<Message ID="DCSV8022I" severity="I" prefix="yes">
  <MsgText pgmKey="DCSV8022" varFormat="Java">
    DCSV8022=DCSV8022I: DCS Stack {0} at Member {1}: Inconsistency of configured core group membership with that of another member. Inconsistent member is {2}. The list of members only in the local coregroup membership is {3}, whereas the list of members only in the coregroup membership at the inconsistent member is {4}.
  </MsgText>
  <Explanation>
    The two members have different core group memberships. The inconsistency may be fixed automatically.
  </Explanation>
  <UserResponse>
    Verify that the configuration has been synchronized across all of the nodes in the cell. If the configuration has not been synchronized across all of the nodes in the cell, manually synchronize the configuration. After the configuration stabilizes, this problem should resolve itself automatically.
  </UserResponse>
</Message>
<Message ID="DCSV8021W" severity="W" prefix="yes">
  <MsgText pgmKey="DCSV8021" varFormat="Java">
    DCSV8021=DCSV8021W: DCS Stack {0} at Member {1}:  The configuration is inconsistent with that of member {2}. Local configuration parameter {3} has a value of {4}, whereas the value at the inconsistent member is {5}.
  </MsgText>
  <Explanation>
    The distribution and consistency services (DCS) stack is configured differently on the two members.
  </Explanation>
  <UserResponse>
    Check the configuration of the two members. If the problem cannot be resolved, see the problem determination information on the WebSphere Application Server Support Web page: http://www.ibm.com/software/webservers/appserv/was/support for additional information.
  </UserResponse>
</Message>
<Message ID="DCSV8020W" severity="W" prefix="yes">
  <MsgText pgmKey="DCSV8020" varFormat="Java">
    DCSV8020=DCSV8020W: DCS Stack {0} at Member {1}: Inconsistency of configuration with that of member {2}.
  </MsgText>
  <Explanation>
    The distribution and consistency services (DCS) stack is configured differently on the two members. More information may follow in message DCSV8021W.
  </Explanation>
  <UserResponse>
    Check the configuration of the two members. If the problem cannot be resolved, see the problem determination information on the WebSphere Application Server Support Web page: http://www.ibm.com/software/webservers/appserv/was/support for additional information.
  </UserResponse>
</Message>
<Message ID="DCSV1117W" severity="W" prefix="yes">
  <MsgText pgmKey="DCSV1117" varFormat="Java">
    DCSV1117=DCSV1117W: DCS Stack {0} at Member {1}: The stream from Member {2} has closed. The channnel is {3}.
  </MsgText>
  <Explanation>
    A network stream has closed unexpectedly. The underlying connection may have closed.
  </Explanation>
  <UserResponse>
    See the problem determination information on the WebSphere Application Server Support Web page: http://www.ibm.com/software/webservers/appserv/was/support for additional information.
  </UserResponse>
</Message>
<Message ID="DCSV1116W" severity="W" prefix="yes">
  <MsgText pgmKey="DCSV1116" varFormat="Java">
    DCSV1116=DCSV1116W: DCS Stack {0} at Member {1}: Member {2} has suspected this member and will remove it from the view.
  </MsgText>
  <Explanation>
    Another member encountered a problem with this member and removed it from the view. See the logs of the other member for more information.
  </Explanation>
  <UserResponse>
    See the problem determination information on the WebSphere Application Server Support Web page: http://www.ibm.com/software/webservers/appserv/was/support for additional information.
  </UserResponse>
</Message>
<Message ID="DCSV1115W" severity="W" prefix="yes">
  <MsgText pgmKey="DCSV1115" varFormat="Java">
    DCSV1115=DCSV1115W: DCS Stack {0} at Member {1}: Member {2} connection  was closed. Member will  be removed from view. DCS connection status is {3}.
  </MsgText>
  <Explanation>
    The network connection between this member and another member has been closed. The other member may have been stopped, there may be a problem with either member or there may be a problem with network connectivity.
  </Explanation>
  <UserResponse>
    If the other member has not been stopped, check the other member for errors and check the network connectivity to the other member.
  </UserResponse>
</Message>
<Message ID="DCSV1114W" severity="W" prefix="yes">
  <MsgText pgmKey="DCSV1114" varFormat="Java">
    DCSV1114=DCSV1114W: DCS Stack {0} at Member {1}: Packet sent by {2} was lost. DCS logical channel is {3}.
  </MsgText>
  <Explanation>
    A packet sent by another member was lost.
  </Explanation>
  <UserResponse>
    See the problem determination information on the WebSphere Application Server Support Web page: http://www.ibm.com/software/webservers/appserv/was/support for additional information.
  </UserResponse>
</Message>
<Message ID="DCSV1113W" severity="W" prefix="yes">
  <MsgText pgmKey="DCSV1113" varFormat="Java">
    DCSV1113=DCSV1113W: DCS Stack {0} at Member {1}: Outgoing connection to the other member was closed. Member to be removed from view is {2}. DCS logical channel is {3}.
  </MsgText>
  <Explanation>
    The outgoing connection to another member was closed. The other member might have been stopped, or there might be a network connectivy problem between the members.
  </Explanation>
  <UserResponse>
    If the other member has not been stopped, check the other member for errors and check the network connectivity to the other member.
  </UserResponse>
</Message>
<Message ID="DCSV1112W" severity="W" prefix="yes">
  <MsgText pgmKey="DCSV1112" varFormat="Java">
    DCSV1112=DCSV1112W: DCS Stack {0} at Member {1}: Member {2} failed to respond to periodic heartbeats. Member will be removed from view. Configured Timeout is {3} milliseconds. DCS logical channel is {4}.
  </MsgText>
  <Explanation>
    The distribution and consistency services (DCS) failed to receive a heartbeat from another member within the configured time interval. This message might indicate that there is a problem with the other member, or with network connectivity.
  </Explanation>
  <UserResponse>
    Check the other member for errors and check the network connectivity to the other member.
  </UserResponse>
</Message>
<Message ID="DCSV1111W" severity="W" prefix="yes">
  <MsgText pgmKey="DCSV1111" varFormat="Java">
    DCSV1111=DCSV1111W: DCS Stack {0} at Member {1}: Outgoing connection from the other member was closed. Member to be removed from view is: {2} . DCS logical channel is {3}.
  </MsgText>
  <Explanation>
    Another member closed its outgoing connection to the local member. The other member might have been stopped, or there might be a problem with the member or with network connectivity.
  </Explanation>
  <UserResponse>
    If the other member has not been stopped, check the other member for errors, and check network connectivity to the other member.
  </UserResponse>
</Message>
<Message ID="DCSV1072E" severity="E" prefix="yes">
  <MsgText pgmKey="DCSV1072" varFormat="Java">
    DCSV1072=DCSV1072E: DCS Stack {0} at Member {1}: Received token from HA Manager that exceeds the configured maximum token length. Received token length is {2}. Configured maximum length is {3}.
  </MsgText>
  <Explanation>
    The distribution and consistency services (DCS) received a security token with a length that exceeds the configured maximum token length.
  </Explanation>
  <UserResponse>
    Increase the value specified for the maximum security token length configuration parameter.
  </UserResponse>
</Message>
<Message ID="DCSV1071E" severity="E" prefix="yes">
  <MsgText pgmKey="DCSV1071" varFormat="Java">
    DCSV1071=DCSV1071E: DCS Stack {0} at Member {1}: Transport infrastructure internal error. Exception is {2}.
  </MsgText>
  <Explanation>
    An inconsistent internal state was detected in the transport infrastructure. The exception should give more information about the root cause of the problem.
  </Explanation>
  <UserResponse>
    Correct the cause of the problem. See the problem determination information on the WebSphere Application Server Support Web page: http://www.ibm.com/software/webservers/appserv/was/support for additional information.
  </UserResponse>
</Message>
<Message ID="DCSV8011I" severity="I" prefix="yes">
  <MsgText pgmKey="DCSV8011" varFormat="Java">
    DCSV8011=DCSV8011I: DCS Stack {0} at Member {1}: Member received a request for shutdown.
  </MsgText>
  <Explanation>
    The indicated DCS stack has been stopped normally.
  </Explanation>
  <UserResponse>
    No action required.
  </UserResponse>
</Message>
<Message ID="DCSV8010E" severity="E" prefix="yes">
  <MsgText pgmKey="DCSV8010" varFormat="Java">
    DCSV8010=DCSV8010E: DCS Stack {0} at Member {1}: An internal error was encountered while processing a view change. Internal details are {2}.
  </MsgText>
  <Explanation>
    An internal inconsistency was detected. No recovery is possible.
  </Explanation>
  <UserResponse>
    See the problem determination information on the WebSphere Application Server Support Web page: http://www.ibm.com/software/webservers/appserv/was/support for additional information.
  </UserResponse>
</Message>
<Message ID="DCSV9421W" severity="W" prefix="yes">
  <MsgText pgmKey="DCSV9421" varFormat="Java">
    DCSV9421=DCSV9421W: General networking problem occurred on socket address {0}. Exception is {1}.
  </MsgText>
  <Explanation>
    A general networking problem occurred on the indicated socket address.
  </Explanation>
  <UserResponse>
    Check the network configuration.
  </UserResponse>
</Message>
<Message ID="DCSV9420W" severity="W" prefix="yes">
  <MsgText pgmKey="DCSV9420" varFormat="Java">
    DCSV9420=DCSV9420W: Received an incoming connection with a tag that exceeds the configured maximum length. Source address is {0}. Length of the received tag is {1}. Configured maximum tag length is {2}. Exception is {3}.
  </MsgText>
  <Explanation>
    The transport layer (RMM) received an incoming connection with a tag (queue name) that exceeds the configured maximum length. This problem probably indicates either a maximum topic size configuration problem or that a malicious tampering with wire format has occurred.
  </Explanation>
  <UserResponse>
    Check the identity and the configured maximum token size of the specified sending machine.
  </UserResponse>
</Message>
<Message ID="DCSV1055I" severity="I" prefix="yes">
  <MsgText pgmKey="DCSV1055" varFormat="Java">
    DCSV1055=DCSV1055I: DCS Stack {0} at Member {1}: Incoming message congestion has returned to normal.
  </MsgText>
  <Explanation>
    The incoming message queue is back to its normal limit.
  </Explanation>
  <UserResponse>
    No action required.
  </UserResponse>
</Message>
<Message ID="DCSV1054W" severity="W" prefix="yes">
  <MsgText pgmKey="DCSV1054" varFormat="Java">
    DCSV1054=DCSV1054W: DCS Stack {0} at Member {1}: Raised a medium severity congestion event for incoming messages. The sender that requires most memory is {2}. Configured and actual memory thresholds are {3}.
  </MsgText>
  <Explanation>
    The distribution and consistency services (DCS) transport infrastructure incoming messages queue is close to exceeding its configured memory limit.
  </Explanation>
  <UserResponse>
    Consider increasing the configured memory limit for the transport buffer or lowering the workload of the specified sender. For more information see the product Information Center topic that describes how to configure a core group for replication.
  </UserResponse>
</Message>
<Message ID="DCSV1053I" severity="I" prefix="yes">
  <MsgText pgmKey="DCSV1053" varFormat="Java">
    DCSV1053=DCSV1053I: DCS Stack {0} at Member {1}: Outgoing message congestion has returned to normal.
  </MsgText>
  <Explanation>
    The distribution and consistency services (DCS) outgoing messages queue is back to its normal limit.
  </Explanation>
  <UserResponse>
    No action required.
  </UserResponse>
</Message>
<Message ID="DCSV1052W" severity="W" prefix="yes">
  <MsgText pgmKey="DCSV1052" varFormat="Java">
    DCSV1052=DCSV1052W: DCS Stack {0} at Member {1}: Raised a medium severity congestion event for outgoing messages. Configured and actual memory thresholds are {2}.
  </MsgText>
  <Explanation>
    The distribution and consistency services (DCS) outgoing messages queue is close to exceeding its configured memory limit.
  </Explanation>
  <UserResponse>
    If this message is logged frequently, consider decreasing the workload on this process or increasing the total memory that is available to DCS.  For more information see the product Information Center topic that describes how to configure a core group for replication.
  </UserResponse>
</Message>
<Message ID="DCSV9419W" severity="W" prefix="yes">
  <MsgText pgmKey="DCSV9419" varFormat="Java">
    DCSV9419=DCSV9419W: Failed to set socket parameter {0} to {1}. Exception is {2}.
  </MsgText>
  <Explanation>
    The transport layer (RMM) failed to set a socket parameter.
  </Explanation>
  <UserResponse>
    Check the network configuration for the operating system.
  </UserResponse>
</Message>
<Message ID="DCSV1051W" severity="W" prefix="yes">
  <MsgText pgmKey="DCSV1051" varFormat="Java">
    DCSV1051=DCSV1051W: DCS Stack {0} at Member {1}: Raised a high severity congestion event for outgoing messages. Configured and actual memory thresholds are {2}.
  </MsgText>
  <Explanation>
    The distribution and consistency services (DCS) outgoing messages queue exceeded its configured memory limit. Further outgoing messages will be blocked.
  </Explanation>
  <UserResponse>
    If this message is logged frequently, consider decreasing the load on this process or increasing the total memory that is available to DCS. For more information see the product Information Center topic that describes how to configure a core group for replication.
  </UserResponse>
</Message>
<Message ID="DCSV9417W" severity="W" prefix="yes">
  <MsgText pgmKey="DCSV9417" varFormat="Java">
    DCSV9417=DCSV9417W: Failed to send a UDP packet to address:port {0}. The exception is {1}.
  </MsgText>
  <Explanation>
    The transport layer (RMM) failed to send a UDP packet because of a connectivity problem.
  </Explanation>
  <UserResponse>
    Check the network connectivity.
  </UserResponse>
</Message>
<Message ID="DCSV9416E" severity="E" prefix="yes">
  <MsgText pgmKey="DCSV9416" varFormat="Java">
    DCSV9416=DCSV9416E: An internal error occurred. Exception is {0}.
  </MsgText>
  <Explanation>
    An unexpected error occurred. See the exception stack trace for more detail.
  </Explanation>
  <UserResponse>
    See the problem determination information on the WebSphere Application Server Support Web page: http://www.ibm.com/software/webservers/appserv/was/support for additional information.
  </UserResponse>
</Message>
<Message ID="DCSV9415W" severity="W" prefix="yes">
  <MsgText pgmKey="DCSV9415" varFormat="Java">
    DCSV9415=DCSV9415W: Received packet larger than configured buffer length {0} from RMM address {1}. Exception is {2}. A possible port conflict exists.
  </MsgText>
  <Explanation>
    Another machine sent a packet that was longer than the configured buffer length for incoming packets. The problem has various causes. The most common cause is a port conflict because an unexpected server is using the port and sending unrelated data. Other causes include that a port might have been defined in the ephemeral port range, that another application is using RMM with a larger configured packet size, or that a malicious sender attempted to send large packets to the local machine.
  </Explanation>
  <UserResponse>
    Check the identity and configuration of the specified sending machine and verify that there are no port conflicts within the cell.
  </UserResponse>
</Message>
<Message ID="DCSV9414E" severity="E" prefix="yes">
  <MsgText pgmKey="DCSV9414" varFormat="Java">
    DCSV9414=DCSV9414E: Failed to bind a socket to address {0}. Exception is {1}.
  </MsgText>
  <Explanation>
    The transport layer (RMM) failed to bind a socket to the specified address. This problem probably indicates that the specified port is already in use.
  </Explanation>
  <UserResponse>
    Check configuration of the server socket port.
  </UserResponse>
</Message>
<Message ID="DCSV9413W" severity="W" prefix="yes">
  <MsgText pgmKey="DCSV9413" varFormat="Java">
    DCSV9413=DCSV9413W: Failed to set buffer size on the socket to {0}. Internal details are {1}. Exception is {2}.
  </MsgText>
  <Explanation>
    The transport layer (RMM) failed to set the buffer size on the socket. This probably indicates a configured limitation in the operating system. This limitation may lead to poor transport performance.
  </Explanation>
  <UserResponse>
    Check the network configuration for the operating system.
  </UserResponse>
</Message>
<Message ID="DCSV9412W" severity="W" prefix="yes">
  <MsgText pgmKey="DCSV9412" varFormat="Java">
    DCSV9412=DCSV9412W: Failed to resolve internet address {0}. Exception is {1}.
  </MsgText>
  <Explanation>
    The transport layer (RMM) failed to resolve an internet address. This problem might indicate that there is a DNS problem.
  </Explanation>
  <UserResponse>
    Check the DNS environment.
  </UserResponse>
</Message>
<Message ID="DCSV9411E" severity="E" prefix="yes">
  <MsgText pgmKey="DCSV9411" varFormat="Java">
    DCSV9411=DCSV9411E: Encoding {0} not supported on this host. Exception is {1}.
  </MsgText>
  <Explanation>
    The transport layer (RMM) failed to encode or decode a string because the local operating system does not support the specified encoding.
  </Explanation>
  <UserResponse>
    Configure the local operating system to support the specified encoding.
  </UserResponse>
</Message>
<Message ID="DCSV9410W" severity="W" prefix="yes">
  <MsgText pgmKey="DCSV9410" varFormat="Java">
    DCSV9410=DCSV9410W: Failed to allocate memory: {0} bytes. Exception is {1}.
  </MsgText>
  <Explanation>
    The transport layer (RMM) failed to allocate enough memory to receive an incoming message.
  </Explanation>
  <UserResponse>
    Consider increasing the JVM memory heap size or decreasing the workload of other members.
  </UserResponse>
</Message>
<Message ID="DCSV9409W" severity="W" prefix="yes">
  <MsgText pgmKey="DCSV9409" varFormat="Java">
    DCSV9409=DCSV9409W: Failed to leave multicast group {0}. Exception is {1}.
  </MsgText>
  <Explanation>
    The transport layer (RMM) failed to leave a multicast group address. This problem might indicate that there is a multicast network configuration problem.
  </Explanation>
  <UserResponse>
    Check the network and firewall configuration of the operating system.
  </UserResponse>
</Message>
<Message ID="DCSV9408W" severity="W" prefix="yes">
  <MsgText pgmKey="DCSV9408" varFormat="Java">
    DCSV9408=DCSV9408W: Failed to join multicast group {0}. Exception is {1}.
  </MsgText>
  <Explanation>
    The transport layer (RMM) failed to join a multicast group address. This problem might indicate that there is a multicast network configuration problem. A possible cause for this problem is a configured system limit on the maximum number of multicast groups.
  </Explanation>
  <UserResponse>
    Check the network and firewall configuration of the operating system.
  </UserResponse>
</Message>
<Message ID="DCSV9407E" severity="E" prefix="yes">
  <MsgText pgmKey="DCSV9407" varFormat="Java">
    DCSV9407=DCSV9407E: Failed to set multicast Time-To-Live to {0}. Exception is {1}.
  </MsgText>
  <Explanation>
    The transport layer (RMM) failed to set the Time-To-Live parameter on the multicast socket.
  </Explanation>
  <UserResponse>
    See the problem determination information on the WebSphere Application Server Support Web page: http://www.ibm.com/software/webservers/appserv/was/support for additional information.
  </UserResponse>
</Message>
<Message ID="DCSV9405E" severity="E" prefix="yes">
  <MsgText pgmKey="DCSV9405" varFormat="Java">
    DCSV9405=DCSV9405E: Failed to set Multicast interface {0}. Exception is {1}.
  </MsgText>
  <Explanation>
    The transport layer (RMM) failed to set the interface on the multicast socket. This problem might indicate an incorrectly configured interface address.
  </Explanation>
  <UserResponse>
    Check the configured local interface address.
  </UserResponse>
</Message>
<Message ID="DCSV9404E" severity="E" prefix="yes">
  <MsgText pgmKey="DCSV9404" varFormat="Java">
    DCSV9404=DCSV9404E: Failed to create socket. Port is {0}. Exception is {1}.
  </MsgText>
  <Explanation>
    The transport layer (RMM) failed to create a socket. This problem might indicate a host network configuration problem. For example, RMM might be trying to create a multicast socket when multicast is disabled on the host.
  </Explanation>
  <UserResponse>
    Check the exception message.
  </UserResponse>
</Message>
<Message ID="DCSV9403E" severity="E" prefix="yes">
  <MsgText pgmKey="DCSV9403" varFormat="Java">
    DCSV9403=DCSV9403E: Received an illegal configuration argument. Parameter {0}, value: {1}. Exception is {2}.
  </MsgText>
  <Explanation>
    The transport layer (RMM) failed to start because of an illegal configuration value.
  </Explanation>
  <UserResponse>
    Change the values of the transport configuration parameters.
  </UserResponse>
</Message>
<Message ID="DCSV2103W" severity="W" prefix="yes">
  <MsgText pgmKey="DCSV2103" varFormat="Java">
    DCSV2103=DCSV2103W: DCS Stack {0} at Member {1}: Member {2} broke the view synchronization protocol, and will not be allowed into the next view. Internal details are {3}.
  </MsgText>
  <Explanation>
    The distribution and consistency services (DCS) detected that the indicated member broke the view synchronization protocol.
  </Explanation>
  <UserResponse>
    See the problem determination information on the WebSphere Application Server Support Web page: http://www.ibm.com/software/webservers/appserv/was/support for additional information.
  </UserResponse>
</Message>
<Message ID="DCSV2102W" severity="W" prefix="yes">
  <MsgText pgmKey="DCSV2102" varFormat="Java">
    DCSV2102=DCSV2102W: DCS Stack {0} at Member {1}: Member {2} failed to complete the synchronization procedure, and will not be allowed into the next view.
  </MsgText>
  <Explanation>
    Another member failed to complete the view synchronization procedure within the expected time.
  </Explanation>
  <UserResponse>
    If this warning repeats, see the problem determination information on the WebSphere Application Server Support Web page: http://www.ibm.com/software/webservers/appserv/was/support for additional information.
  </UserResponse>
</Message>
<Message ID="DCSV2101W" severity="W" prefix="yes">
  <MsgText pgmKey="DCSV2101" varFormat="Java">
    DCSV2101=DCSV2101W: DCS Stack {0} at Member {1}: Member {2} sent messages in the wrong order. The current incoming message number is {3},  the previous message number is {4}. The other member will not be allowed in the next view.
  </MsgText>
  <Explanation>
    The distribution and consistency services (DCS) received an out of order message from another member.
  </Explanation>
  <UserResponse>
    See the problem determination information on the WebSphere Application Server Support Web page: http://www.ibm.com/software/webservers/appserv/was/support for additional information.
  </UserResponse>
</Message>
<Message ID="DCSV1036W" severity="W" prefix="yes">
  <MsgText pgmKey="DCSV1036" varFormat="Java">
    DCSV1036=DCSV1036W: DCS Stack {0} at Member {1}: An unusual connectivity state occured with member {2}, details: {3}.
  </MsgText>
  <Explanation>
    An unexpected network connectivity state has occurred. The situation may be recovered automatically.
  </Explanation>
  <UserResponse>
    If this situation reoccurs frequently, see the problem determination information on the WebSphere Application Server Support Web page: http://www.ibm.com/software/webservers/appserv/was/support for additional information.
  </UserResponse>
</Message>
<Message ID="DCSV1035I" severity="I" prefix="yes">
  <MsgText pgmKey="DCSV1035" varFormat="Java">
    DCSV1035=DCSV1035I: DCS Stack {0} at Member {1}: Connectivity information regarding member {2}, details: {3}
  </MsgText>
  <Explanation>
    An unusual network connectivity state has been detected. This may lead to an error condition in the future. The information logged in this message may be useful in analyzing other DCS error messages.
  </Explanation>
  <UserResponse>
    No action required.
  </UserResponse>
</Message>
<Message ID="DCSV1033I" severity="I" prefix="yes">
  <MsgText pgmKey="DCSV1033" varFormat="Java">
    DCSV1033=DCSV1033I: DCS Stack {0} at Member {1}: Confirmed all new view members in view identifier {2}. View channel type is {3}.
  </MsgText>
  <Explanation>
    A new view has been established. This member has received a notification from all members of the new view.
  </Explanation>
  <UserResponse>
    No action required.
  </UserResponse>
</Message>
<Message ID="DCSV1032I" severity="I" prefix="yes">
  <MsgText pgmKey="DCSV1032" varFormat="Java">
    DCSV1032=DCSV1032I: DCS Stack {0} at Member {1}: Connected a defined member {2}.
  </MsgText>
  <Explanation>
    The distribution and consistency services (DCS) established a connection to another process which is a member of the same core group.
  </Explanation>
  <UserResponse>
    No action required.
  </UserResponse>
</Message>
<Message ID="DCSV1031I" severity="I" prefix="yes">
  <MsgText pgmKey="DCSV1031" varFormat="Java">
    DCSV1031=DCSV1031I: DCS Stack {0} at Member {1}: Received a connection from an undefined member {2}. Source address is {3}.
  </MsgText>
  <Explanation>
    The distribution and consistency services (DCS) received a connection request from a process that is currently not a member of the core group.
  </Explanation>
  <UserResponse>
    If this condition persists, synchronize the configuration for all nodes in the cell. It may be necessary to restart this process.
  </UserResponse>
</Message>
<Message ID="DCSV0009W" severity="W" prefix="yes">
  <MsgText pgmKey="DCSV0009" varFormat="Java">
    DCSV0009=DCSV0009W: DCS Stack {0} at Member {1}:  Received an unreadable message from member {2}. Member will be removed from view. Version details are {3}.
  </MsgText>
  <Explanation>
    An unreadable message was received from another member. This problem might indicate incompatible software versions.
  </Explanation>
  <UserResponse>
    Check the versions of your software.
  </UserResponse>
</Message>
<Message ID="DCSV0008I" severity="I" prefix="yes">
  <MsgText pgmKey="DCSV0008" varFormat="Java">
    DCSV0008=DCSV0008I: DCS Stack {0} at Member {1}: General information message. Internal details: {2}
  </MsgText>
  <Explanation>
    This message is issued to help track important view change events
  </Explanation>
  <UserResponse>
    No action required.
  </UserResponse>
</Message>
<Message ID="DCSV0006W" severity="W" prefix="yes">
  <MsgText pgmKey="DCSV0006" varFormat="Java">
    DCSV0006=DCSV0006W: DCS Stack {0} at Member {1}: Failed to establish connection. Stack version information: {2}. Stack protocol information: {3}.
  </MsgText>
  <Explanation>
    The distribution and consistency services (DCS) stack failed to start
  </Explanation>
  <UserResponse>
    Check the connectivity between this member and other members.
  </UserResponse>
</Message>
<Message ID="DCSV0005I" severity="I" prefix="yes">
  <MsgText pgmKey="DCSV0005" varFormat="Java">
    DCSV0005=DCSV0005I: DCS Stack {0} at Member {1}: Started. Stack version information: {2}. Stack protocol information: {3}.
  </MsgText>
  <Explanation>
    DCS stack started
  </Explanation>
  <UserResponse>
    No action required.
  </UserResponse>
</Message>
<Message ID="DCSV0004W" severity="W" prefix="yes">
  <MsgText pgmKey="DCSV0004" varFormat="Java">
    DCSV0004=DCSV0004W: DCS Stack {0} at Member {1}: Did not receive adequate CPU time slice. Last known CPU usage time at {2}. Inactivity duration was {3} seconds.
  </MsgText>
  <Explanation>
    A DCS check discovered that a runnable thread was required to wait for an excessively long time before it was dispatched to the CPU.
  </Explanation>
  <UserResponse>
    Check the load on the machine. Try to reduce the workload by freeing resources, such as memory and CPU utilization. If the root cause cannot be determined, see the problem determination information on the WebSphere Application Server Support Web page: http://www.ibm.com/software/webservers/appserv/was/support for additional information.
  </UserResponse>
</Message>
<Message ID="DCSV0003I" severity="I" prefix="yes">
  <MsgText pgmKey="DCSV0003" varFormat="Java">
    DCSV0003=DCSV0003I: DCS Stack {0} at Member {1}: Internal programming state information. Internal details: {2}
  </MsgText>
  <Explanation>
    An unusual programming state has occurred. This information might be useful for interpreting other DCS error messages.
  </Explanation>
  <UserResponse>
    No action required.
  </UserResponse>
</Message>
<Message ID="DCSV0002W" severity="W" prefix="yes">
  <MsgText pgmKey="DCSV0002" varFormat="Java">
    DCSV0002=DCSV0002W: DCS Stack {0} at Member {1}: An unexpected internal programming state has occurred. Internal details: {2}. The exception is {3}.
  </MsgText>
  <Explanation>
    An unexpected internal programming state has occurred. The situation may have been automatically corrected.
  </Explanation>
  <UserResponse>
    If the situation reoccurs frequently, see the problem determination information on the WebSphere Application Server Support Web page: http://www.ibm.com/software/webservers/appserv/was/support for additional information.
  </UserResponse>
</Message>
<!-- END MESSAGES -->
</TMSSource>
