<?xml version="1.0" encoding="UTF-8"?>
<?xml-stylesheet type="text/css" href="../../resources/stylesheets/wasmsgxml.css"?>
<TMSSource name="TivoliMessages" tmsVersion="1.0" xml:lang="en">
<!-- CMVC MSG File Name = ws/code/admin.jmx/src/com/ibm/ws/management/resources/discovery.nlsprops -->
<!-- DO NOT EDIT THIS FILE - This file was generated by the XML/Html & Property emitter -->
<!-- BEGIN MESSAGES -->
<Message ID="ADMD0023I" severity="I" prefix="yes">
  <MsgText pgmKey="ADMD0023I" varFormat="Java">
    ADMD0023I=ADMD0023I: The system discovered process (name: {0}, type: {1}, pid: {2})
  </MsgText>
  <Explanation>
    This informational message indicates the system status.  The pid indicates the Process ID for Distributed platforms while on z/OS it represents the Server token(stoken).
  </Explanation>
  <UserResponse>
    No user action is required.
  </UserResponse>
</Message>
<Message ID="ADMD0009W" severity="W" prefix="yes">
  <MsgText pgmKey="ADMD0009W" varFormat="Java">
    ADMD0009W=ADMD0009W: Unable to send out the discovery response message with exception: {0}
  </MsgText>
  <Explanation>
    The discovery query message could not be send out because of the specified exception.
  </Explanation>
  <UserResponse>
    Examine the exception in this message for problem determination. Check the logs, trace, and the First Failure Data Capture (FFDC) to find the most relevant root cause for this error.
  </UserResponse>
</Message>
<Message ID="ADMD0019E" severity="E" prefix="yes">
  <MsgText pgmKey="ADMD0019E" varFormat="Java">
    ADMD0019E=ADMD0019E: The UDP Transport cannot be initialized; exception: {0}
  </MsgText>
  <Explanation>
    The discovery fails to initialize the User Datagram Protocol (UDP) transport to receive the incoming discovery message.
  </Explanation>
  <UserResponse>
    Resolve any port conflicts that might exist.  Examine the exception in this message for problem determination. Check the logs, trace, and the First Failure Data Capture (FFDC) to find the most relevant root cause for this error.
  </UserResponse>
</Message>
<Message ID="ADMD0003E" severity="E" prefix="yes">
  <MsgText pgmKey="ADMD0003E" varFormat="Java">
    ADMD0003E=ADMD0003E: The multicast socket cannot be opened to join multicast group: {0}
  </MsgText>
  <Explanation>
    The multicast socket cannot be opened to join the specified multicast group because the router does not have multicasting capability.
  </Explanation>
  <UserResponse>
    Consult the network administrator to make sure that the router supports multicasting.
  </UserResponse>
</Message>
<Message ID="ADMD0022W" severity="W" prefix="yes">
  <MsgText pgmKey="ADMD0022W" varFormat="Java">
    ADMD0022W=ADMD0022W: Host &quot;{0}&quot; cannot be resolved while sending discovery messages.
  </MsgText>
  <Explanation>
    The host in question cannot be resolved from the domain name server (DNS). Several causes are possible: the host to resolve might not exist, or runs on a Dynamic Host Configuration Protocol (DHCP) machine, or has a short host name that cannot be resolved without appending an appropriate DNS suffix.
  </Explanation>
  <UserResponse>
    Check whether the host to resolve does exist in the network or runs on a DHCP machine. If it has a short host name, check the default DNS suffix in the local machine where discovery occurs.
  </UserResponse>
</Message>
<Message ID="ADMD0008W" severity="W" prefix="yes">
  <MsgText pgmKey="ADMD0008W" varFormat="Java">
    ADMD0008W=ADMD0008W: Unable to construct the discovery response message with exception: {0}
  </MsgText>
  <Explanation>
    The discovery response message could not be constructed because of the specified exception.
  </Explanation>
  <UserResponse>
    Examine the exception in this message for problem determination. Check the logs, trace, and the First Failure Data Capture (FFDC) to find the most relevant root cause for this error.
  </UserResponse>
</Message>
<Message ID="ADMD0012E" severity="E" prefix="yes">
  <MsgText pgmKey="ADMD0012E" varFormat="Java">
    ADMD0012E=ADMD0012E: The transport of type: {0} cannot be initialized.
  </MsgText>
  <Explanation>
    The specified transport cannot be initialized.  The discovery service is built on top of a specific transport, such as User Datagram Protocol (UDP), Transmission Control Protocol (TCP) or Multicasting.
  </Explanation>
  <UserResponse>
    Check the serverindex.xml file to make sure there is no port conflict with the discovery port in your local system. For multicasting discovery, make sure your LAN router supports the multicasting.
  </UserResponse>
</Message>
<Message ID="ADMD0018E" severity="E" prefix="yes">
  <MsgText pgmKey="ADMD0018E" varFormat="Java">
    ADMD0018E=ADMD0018E: The TCP transport cannot be initialized; exception: {0}
  </MsgText>
  <Explanation>
    The discovery fails to initialize the Transmission Control Protocol (TCP) transport to receive the incoming discovery message.
  </Explanation>
  <UserResponse>
    Resolve any port conflicts that might exist.  Examine the exception in this message for problem determination. Check the logs, trace, and the First Failure Data Capture (FFDC) to find the most relevant root cause for this error.
  </UserResponse>
</Message>
<Message ID="ADMD0002E" severity="E" prefix="yes">
  <MsgText pgmKey="ADMD0002E" varFormat="Java">
    ADMD0002E=ADMD0002E: Only a multicast address is allowed to open the multicast socket
  </MsgText>
  <Explanation>
    The multicast socket could not be opened because the IP address supplied was not a multicast address.  Multicast group addresses are in the range of 224.0.0.0 through 239.255.255.255
  </Explanation>
  <UserResponse>
    Check the multicast IP address in the serverindex.xml file to verify that the IP address provided is in the valid range. Some multicast IP conflicts might exist in your network. Consult your network administrator.
  </UserResponse>
</Message>
<Message ID="ADMD0021W" severity="W" prefix="yes">
  <MsgText pgmKey="ADMD0021W" varFormat="Java">
    ADMD0021W=ADMD0021W: Unable to handle discovery connection with exception: {0}
  </MsgText>
  <Explanation>
    The connection failed to get initialized.
  </Explanation>
  <UserResponse>
    Examine the exception in this message for problem determination. Check the logs, trace, and the First Failure Data Capture (FFDC) to find the most relevant root cause for this error.
  </UserResponse>
</Message>
<Message ID="ADMD0017W" severity="W" prefix="yes">
  <MsgText pgmKey="ADMD0017W" varFormat="Java">
    ADMD0017W=ADMD0017W: Datagram socket failure in receiving package: {0}
  </MsgText>
  <Explanation>
    Socket may have been timeout.  Two possibilities to consider are multicast server may not working or nodeagent process is down.
  </Explanation>
  <UserResponse>
    Examine the exception in this message for problem determination. Check the logs, trace, and the First Failure Data Capture (FFDC) to find the most relevant root cause for this error.
  </UserResponse>
</Message>
<Message ID="ADMD0007W" severity="W" prefix="yes">
  <MsgText pgmKey="ADMD0007W" varFormat="Java">
    ADMD0007W=ADMD0007W: Unable to construct the discovery query message with exception: {0}
  </MsgText>
  <Explanation>
    The discovery query message could not be constructed because of the specified exception.
  </Explanation>
  <UserResponse>
    Examine the exception in this message for problem determination. Check the logs, trace, and the First Failure Data Capture (FFDC) to find the most relevant root cause for this error.
  </UserResponse>
</Message>
<Message ID="ADMD0027I" severity="I" prefix="yes">
  <MsgText pgmKey="ADMD0027I" varFormat="Java">
    ADMD0027I=ADMD0027I: The z/OS process {1} (name: {0}) has the UNIX PID: {2}
  </MsgText>
  <Explanation>
    This message indicates the system status.
  </Explanation>
  <UserResponse>
    No user action is required.
  </UserResponse>
</Message>
<Message ID="ADMD0011E" severity="E" prefix="yes">
  <MsgText pgmKey="ADMD0011E" varFormat="Java">
    ADMD0011E=ADMD0011E: Unsupported transport protocol
  </MsgText>
  <Explanation>
    Unsupported transport protocol was used.
  </Explanation>
  <UserResponse>
    Make sure the transport protocol such as User Datagram Protocol (UDP), Transmission Control Protocol (TCP) or Multicast specified is valid. Check the logs, trace, and the First Failure Data Capture (FFDC) to find the most relevant root cause for this error.
  </UserResponse>
</Message>
<Message ID="ADMD0001E" severity="E" prefix="yes">
  <MsgText pgmKey="ADMD0001E" varFormat="Java">
    ADMD0001E=ADMD0001E: The discovery MBean cannot be activated.
  </MsgText>
  <Explanation>
    Every Network Deployment process requires one discovery MBean.  The discovery MBean could not be activated.
  </Explanation>
  <UserResponse>
    Check that the remote process is running with the correct discovery port and, if necessary, start the remote process.
  </UserResponse>
</Message>
<Message ID="ADMD0020W" severity="W" prefix="yes">
  <MsgText pgmKey="ADMD0020W" varFormat="Java">
    ADMD0020W=ADMD0020W: Tcp socket failure in receiving package: {0}
  </MsgText>
  <Explanation>
    An I/O error occurs when waiting for a connection.
  </Explanation>
  <UserResponse>
    Examine the exception in this message for problem determination. Check the logs, trace, and the First Failure Data Capture (FFDC) to find the most relevant root cause for this error.
  </UserResponse>
</Message>
<Message ID="ADMD0026W" severity="W" prefix="yes">
  <MsgText pgmKey="ADMD0026W" varFormat="Java">
    ADMD0026W=ADMD0026W: The version of the deployment manager ({0}) is earlier than that of this node ({1}).
  </MsgText>
  <Explanation>
    A deployment manager version that is earlier than that of a node is an unsupported configuration.
  </Explanation>
  <UserResponse>
    Upgrade the deployment manager to the same or later version as that of the node.
  </UserResponse>
</Message>
<Message ID="ADMD0016W" severity="W" prefix="yes">
  <MsgText pgmKey="ADMD0016W" varFormat="Java">
    ADMD0016W=ADMD0016W: Unable to close the server socket with exception: {0}
  </MsgText>
  <Explanation>
    Unable to shutdown the multicast server.
  </Explanation>
  <UserResponse>
    Examine the exception in this message for problem determination. Check the logs, trace, and the First Failure Data Capture (FFDC) to find the most relevant root cause for this error.
  </UserResponse>
</Message>
<Message ID="ADMD0010E" severity="E" prefix="yes">
  <MsgText pgmKey="ADMD0010E" varFormat="Java">
    ADMD0010E=ADMD0010E: Incorrect discovery endpoint address
  </MsgText>
  <Explanation>
    Incorrect discovery endpoint address was used.
  </Explanation>
  <UserResponse>
    Make sure the discovery endpoint address specified is valid. Check the logs, trace, and the First Failure Data Capture (FFDC) to find the most relevant root cause for this error.
  </UserResponse>
</Message>
<Message ID="ADMD0006E" severity="E" prefix="yes">
  <MsgText pgmKey="ADMD0006E" varFormat="Java">
    ADMD0006E=ADMD0006E: The destination endpoint is not specified
  </MsgText>
  <Explanation>
    The destination endpoint is not specified.  The discovery needs to know the destination endpoint before sending out the discovery message.
  </Explanation>
  <UserResponse>
    Examine the exception in this message for problem determination. Check the logs, trace, and the First Failure Data Capture (FFDC) to find the most relevant root cause for this error.
  </UserResponse>
</Message>
<Message ID="ADMD0025W" severity="W" prefix="yes">
  <MsgText pgmKey="ADMD0025W" varFormat="Java">
    ADMD0025W=ADMD0025W: In process discovery, the 127.0.0.1 IP address is used to advertise an endpoint. This usage might cause problems in a network environment.
  </MsgText>
  <Explanation>
    The 127.0.0.1 IP address, or local host, is known as the loopback IP address, which is only valid in a stand-alone environment. Hosts cannot be recognized by others through this IP address over the network.
  </Explanation>
  <UserResponse>
    Verify that the host address and the domain name server configurations are set correctly. For Linux configurations, configure the /etc/nsswitch.conf file to search the Domain Name Server (DNS) before the /etc/hosts file.
  </UserResponse>
</Message>
<Message ID="ADMD0015W" severity="W" prefix="yes">
  <MsgText pgmKey="ADMD0015W" varFormat="Java">
    ADMD0015W=ADMD0015W: The multicast group: {0} cannot be joined.
  </MsgText>
  <Explanation>
    A certain type of discovery requires multicasting support. Either multicasting is not supported within the local area network, or the target multicast group rejects join requests.
  </Explanation>
  <UserResponse>
    Make sure that multicasting is supported in your local area network and that the right multicast group is specified for discovery.
  </UserResponse>
</Message>
<Message ID="ADMD0005E" severity="E" prefix="yes">
  <MsgText pgmKey="ADMD0005E" varFormat="Java">
    ADMD0005E=ADMD0005E: The User Datagram Protocol (UDP) socket: {0} cannot be opened.
  </MsgText>
  <Explanation>
    The specified User Datagram Protocol (UDP) socket cannot be opened. The UDP-based discovery needs to open a UDP socket before sending out discovery message.  The socket is not listening, the remote socket is not listening, or a network failure has occured.
  </Explanation>
  <UserResponse>
    Check that the remote process is running with the correct discovery port and, if necessary, start the remote process.
  </UserResponse>
</Message>
<Message ID="ADMD0024W" severity="W" prefix="yes">
  <MsgText pgmKey="ADMD0024W" varFormat="Java">
    ADMD0024W=ADMD0024W: Failed to send out the discovery message to the process: {0}
  </MsgText>
  <Explanation>
    Failed to send out discovery message.  Nodeagent process may be down.
  </Explanation>
  <UserResponse>
    Examine the exception in this message for problem determination. Check the logs, trace, and the First Failure Data Capture (FFDC) to find the most relevant root cause for this error.
  </UserResponse>
</Message>
<Message ID="ADMD0014W" severity="W" prefix="yes">
  <MsgText pgmKey="ADMD0014W" varFormat="Java">
    ADMD0014W=ADMD0014W: The multicast server cannot be initialized at port: {0}
  </MsgText>
  <Explanation>
    A failure occurred while initializing the transport that receives the multicast requests.
  </Explanation>
  <UserResponse>
    Verify that multicasting is supported in your local area network and that no port conflict exists.
  </UserResponse>
</Message>
<Message ID="ADMD0004E" severity="E" prefix="yes">
  <MsgText pgmKey="ADMD0004E" varFormat="Java">
    ADMD0004E=ADMD0004E: The TCP socket: {0} cannot be opened.  Check if port is opened by remote process.
  </MsgText>
  <Explanation>
    The specified Transmission Control Protocol (TCP) socket cannot be opened.  The socket is not listening, the remote socket is not listening, or a network failure has occured.  The TCP-based discovery needs to open a TCP socket before sending a discovery message. The socket might be the CELL_DISCOVERY_ADDRESS port for your deployment manager or the NODE_DISCOVERY_ADDRESS port for a node agent. If this message is from your deployment manger, then verify that node agents are open for e-business. If the message is from a node agent, then verify that the deployment manager is open for e-business.
  </Explanation>
  <UserResponse>
    Check that the remote process is running with the correct discovery port and, if necessary, start the remote process.
  </UserResponse>
</Message>
<Message ID="ADMD0013W" severity="W" prefix="yes">
  <MsgText pgmKey="ADMD0013W" varFormat="Java">
    ADMD0013W=ADMD0013W: Invalid discovery message: No Source End Tag
  </MsgText>
  <Explanation>
    The discovery message used inside the Java code is not valid.
  </Explanation>
  <UserResponse>
    Check the logs, trace, and the First Failure Data Capture (FFDC) to find the most relevant root cause for this error.
  </UserResponse>
</Message>
<!-- END MESSAGES -->
</TMSSource>
