<?xml version="1.0" encoding="UTF-8"?>
<?xml-stylesheet type="text/css" href="../../resources/stylesheets/wasmsgxml.css"?>
<TMSSource name="TivoliMessages" tmsVersion="1.0" xml:lang="en">
<!-- CMVC MSG File Name = ws/code/admin.jmx/src/com/ibm/ws/management/resources/launcher.nlsprops -->
<!-- DO NOT EDIT THIS FILE - This file was generated by the XML/Html & Property emitter -->
<!-- BEGIN MESSAGES -->
<Message ID="ADML0064I" severity="I" prefix="yes">
  <MsgText pgmKey="ADML0064I" varFormat="Java">
    ADML0064I=ADML0064I: Restarting an unreachable server &quot;{0}&quot;.
  </MsgText>
  <Explanation>
    This information message indicates the program status.
  </Explanation>
  <UserResponse>
    No user action is required.
  </UserResponse>
</Message>
<Message ID="ADML0115I" severity="I" prefix="yes">
  <MsgText pgmKey="ADML0115I" varFormat="Java">
    ADML0115I=ADML0115I: The trace mode is on. The trace output is directed to: {0}
  </MsgText>
  <Explanation>
    The trace data is stored in a file.
  </Explanation>
  <UserResponse>
    No user action is required.
  </UserResponse>
</Message>
<Message ID="ADML0005I" severity="I" prefix="yes">
  <MsgText pgmKey="ADML0005I" varFormat="Java">
    ADML0005I=ADML0005I: The ${USER_INSTALL_ROOT} variable is missing; the tool is using ${WAS_INSTALL_ROOT} as a default.
  </MsgText>
  <Explanation>
    The ${USER_INSTALL_ROOT} variable is not set in the configuration files.
  </Explanation>
  <UserResponse>
    Edit the configuration and provide a ${USER_INSTALL_ROOT} variable.
  </UserResponse>
</Message>
<Message ID="ADML3001W" severity="W" prefix="yes">
  <MsgText pgmKey="ADML3001W" varFormat="Java">
    ADML3001W=ADML3001W: The {0} property is missing from the systemlaunch.properties file.
  </MsgText>
  <Explanation>
    A required property cannot be located in the system.properties file.
  </Explanation>
  <UserResponse>
    Edit the file and add the required property, along with a value for that property.
  </UserResponse>
</Message>
<Message ID="ADML0063W" severity="W" prefix="yes">
  <MsgText pgmKey="ADML0063W" varFormat="Java">
    ADML0063W=ADML0063W: The tool cannot contact server &quot;{0}&quot;. Force stop this server if it is still running.
  </MsgText>
  <Explanation>
    The nodeagent failed to contact the given server. The server might be malfunctioning. The specified server can be restarted if the&quot;autoRestart&quot; attribute is set to &quot;true&quot; in the server monitoring policy, which is defined in the server.xml file. For restarting the server, the nodeagent must try to stop the server by calling the stop method on the process.  If the stop does not complete, the nodeagent may also call the terminate method on the process.
  </Explanation>
  <UserResponse>
    Check the logs and trace for this server. Normally, the logs show why the server cannot respond to the nodeagent. If the &quot;autoRestart&quot; attribute is set to true, check to see whether the nodeagent restarted the server.
  </UserResponse>
</Message>
<Message ID="ADML0004E" severity="E" prefix="yes">
  <MsgText pgmKey="ADML0004E" varFormat="Java">
    ADML0004E=ADML0004E: An exception occurred when attempting to expand variable {0} {1}.
  </MsgText>
  <Explanation>
    The variable in the configuration data cannot be resolved. The variable may not exist or it may have the wrong value.
  </Explanation>
  <UserResponse>
    Check variable.xml file in your WebSphere configuration to see make sure the variable exist and has the correct value.  Edit the configuration and change the value of the property to use a variable that can be resolved.
  </UserResponse>
</Message>
<Message ID="ADML0059E" severity="E" prefix="yes">
  <MsgText pgmKey="ADML0059E" varFormat="Java">
    ADML0059E=ADML0059E: An error occurred restarting the nodeagent: {0}
  </MsgText>
  <Explanation>
    The nodeagent failed to restart itself.
  </Explanation>
  <UserResponse>
    Stop and start the nodeagent by using the startNode or stopNode command-line utilities scripts.
  </UserResponse>
</Message>
<Message ID="ADML0062W" severity="W" prefix="yes">
  <MsgText pgmKey="ADML0062W" varFormat="Java">
    ADML0062W=ADML0062W: The tool cannot load the server.xml file for server {0}.
  </MsgText>
  <Explanation>
    The nodeagent failed to load the server.xml file to read the monitoring policy for a given server.
  </Explanation>
  <UserResponse>
    Open the problem server.xml file to check for XML syntax errors.
  </UserResponse>
</Message>
<Message ID="ADML3000E" severity="E" prefix="yes">
  <MsgText pgmKey="ADML3000E" varFormat="Java">
    ADML3000E=ADML3000E: The tool is unable to locate the systemlaunch.properties file: {0}
  </MsgText>
  <Explanation>
    The systemlaunch.properties file contains default settings for important system properties. This file is required for server launching.
  </Explanation>
  <UserResponse>
    Verify that the file is available and can be read.
  </UserResponse>
</Message>
<Message ID="ADML0029E" severity="E" prefix="yes">
  <MsgText pgmKey="ADML0029E" varFormat="Java">
    ADML0029E=ADML0029E: No configuration is defined for server: {0}
  </MsgText>
  <Explanation>
    An attempt was made to start a server that has no configuration.
  </Explanation>
  <UserResponse>
    Verify that the server name is correct.
  </UserResponse>
</Message>
<Message ID="ADML0068I" severity="I" prefix="yes">
  <MsgText pgmKey="ADML0068I" varFormat="Java">
    ADML0068I=ADML0068I: Attempt {0} to restart an unreachable server &quot;{1}&quot; returned with the following status indicating whether the server was restarted successfully: {2}
  </MsgText>
  <Explanation>
    Multiple attempts are made to restart an unreachable server. This message indicates the resulting status for one of these attempts.
  </Explanation>
  <UserResponse>
    No user action is required.
  </UserResponse>
</Message>
<Message ID="ADML0019E" severity="E" prefix="yes">
  <MsgText pgmKey="ADML0019E" varFormat="Java">
    ADML0019E=ADML0019E: An exception occurred waiting for the server stop {0}.
  </MsgText>
  <Explanation>
    The server could not be stopped.
  </Explanation>
  <UserResponse>
    Examine the exception in this message for problem determination.  Check the logs, trace, and the First Failure Data Capture (FFDC) to find the most relevant root cause for this error.
  </UserResponse>
</Message>
<Message ID="ADML0003E" severity="E" prefix="yes">
  <MsgText pgmKey="ADML0003E" varFormat="Java">
    ADML0003E=ADML0003E: A configuration error occurred in the ProcessDef Umask property {0}.
  </MsgText>
  <Explanation>
    The value of the Umask property is not in a valid integer format. The valid format is string containing the integer representation.
  </Explanation>
  <UserResponse>
    Edit the configuration and change the value of the process Umask property.
  </UserResponse>
</Message>
<Message ID="ADML0009E" severity="E" prefix="yes">
  <MsgText pgmKey="ADML0009E" varFormat="Java">
    ADML0009E=ADML0009E: An exception occurred waiting for server initialization {0}.
  </MsgText>
  <Explanation>
    An error occurred while waiting for the server to get initialized.  The server socket may have been timeout.
  </Explanation>
  <UserResponse>
    Examine the exception in this message for problem determination. Check the logs, trace, and the First Failure Data Capture (FFDC) to find the most relevant root cause for this error.
  </UserResponse>
</Message>
<Message ID="ADML0058E" severity="E" prefix="yes">
  <MsgText pgmKey="ADML0058E" varFormat="Java">
    ADML0058E=ADML0058E: An error occurred while stopping the node.
  </MsgText>
  <Explanation>
    The nodeagent failed to stop the local application servers or itself.
  </Explanation>
  <UserResponse>
    Examine the exception in this message for problem determination. Check the logs, trace, and the First Failure Data Capture (FFDC) to find the most relevant root cause for this error.
  </UserResponse>
</Message>
<Message ID="ADML0523E" severity="E" prefix="yes">
  <MsgText pgmKey="ADML0523E" varFormat="Java">
    ADML0523E=ADML0523E: An error occurred trying to get the object name of server {0}.:  {1}
  </MsgText>
  <Explanation>
    The Server MBean could not be queried.  The server name might be misspelled or the Server MBean might not run.
  </Explanation>
  <UserResponse>
    Check the spelling of the server name. Examine the exception in this message for problem determination. Check the logs, trace, and the First Failure Data Capture (FFDC) to find the most relevant root cause for this error.
  </UserResponse>
</Message>
<Message ID="ADML0008W" severity="W" prefix="yes">
  <MsgText pgmKey="ADML0008W" varFormat="Java">
    ADML0008W=ADML0008W: An unsupported platform type is encountered: {0} {1}
  </MsgText>
  <Explanation>
    The program is starting on an operating system platform that is not supported.
  </Explanation>
  <UserResponse>
    Do not attempt to run the program on this platform.
  </UserResponse>
</Message>
<Message ID="ADML0012E" severity="E" prefix="yes">
  <MsgText pgmKey="ADML0012E" varFormat="Java">
    ADML0012E=ADML0012E: An exception occurred when attempting to get a free port for status socket {0}.
  </MsgText>
  <Explanation>
    The server status could not be obtained because the attempt to bind to a socket failed.  The socket might be in use.
  </Explanation>
  <UserResponse>
    Examine the exception in this message for problem determination. Check the logs, trace, and the First Failure Data Capture (FFDC) to find the most relevant root cause for this error. If the problem caused by socket in use, check with your network administrator how to solve this problem.
  </UserResponse>
</Message>
<Message ID="ADML0061E" severity="E" prefix="yes">
  <MsgText pgmKey="ADML0061E" varFormat="Java">
    ADML0061E=ADML0061E: An error occurred during synchronization. Set the synchOnServerStartup value to false, if you want to proceed without synchronization.
  </MsgText>
  <Explanation>
    The nodeagent tried to do file synchronization before launching the process, but the synchronization failed.
  </Explanation>
  <UserResponse>
    Check to see the nodeagent is started without error by looking at nodeagent logs.  Or set the synchOnServerStartup value to false if you want to proceed without synchronization.
  </UserResponse>
</Message>
<Message ID="ADML0018I" severity="I" prefix="yes">
  <MsgText pgmKey="ADML0018I" varFormat="Java">
    ADML0018I=ADML0018I: The log is generated.
  </MsgText>
  <Explanation>
    The program log was generated.
  </Explanation>
  <UserResponse>
    No user action is required.
  </UserResponse>
</Message>
<Message ID="ADML0067I" severity="I" prefix="yes">
  <MsgText pgmKey="ADML0067I" varFormat="Java">
    ADML0067I=ADML0067I: The initial heap size of  {0} MB is larger than the maximum heap size of {1} MB.  The server will use a maximum heap size that is the same value as the initial heap size.
  </MsgText>
  <Explanation>
    The server will fail to start with an initial heap size that is greater than the maximum heap size.
  </Explanation>
  <UserResponse>
    No action is necessary.
  </UserResponse>
</Message>
<Message ID="ADML0057E" severity="E" prefix="yes">
  <MsgText pgmKey="ADML0057E" varFormat="Java">
    ADML0057E=ADML0057E: An error occurred while running file synchronization.
  </MsgText>
  <Explanation>
    The nodeagent failed to run the file synchronization.
  </Explanation>
  <UserResponse>
    Check the logs and trace to see the detailed error.
  </UserResponse>
</Message>
<Message ID="ADML0060W" severity="W" prefix="yes">
  <MsgText pgmKey="ADML0060W" varFormat="Java">
    ADML0060W=ADML0060W: The tool cannot contact server &quot;{0}&quot;.   The server will not be restarted since Automatic Restart is false.
  </MsgText>
  <Explanation>
    The node agent failed to contact the server. The server might be malfunctioning. The specified server restarts if the &quot;autoRestart&quot; attribute is set to &quot;true&quot; in the server monitoring policy, which is defined in the server.xml file.   For this server, the &quot;autoRestart&quot; attribute is set to false.
  </Explanation>
  <UserResponse>
    Check the logs and trace for this server. Usually, the logs show why the given server cannot respond to the node agent.
  </UserResponse>
</Message>
<Message ID="ADML0031E" severity="E" prefix="yes">
  <MsgText pgmKey="ADML0031E" varFormat="Java">
    ADML0031E=ADML0031E: The value specified in the ExecutableTargetKind property {0} is not valid.
  </MsgText>
  <Explanation>
    The value of the ExecutableTargetKind property is not valid.
  </Explanation>
  <UserResponse>
    Select a valid ExecutableTargetKind such as Java class or jar.  You may want to examine the exception in this message for problem determination. You could also check the logs, trace, and the First Failure Data Capture (FFDC) to find the most relevant root cause for this error.
  </UserResponse>
</Message>
<Message ID="ADML0011E" severity="E" prefix="yes">
  <MsgText pgmKey="ADML0011E" varFormat="Java">
    ADML0011E=ADML0011E: The server launched, but failed initialization. See the server log files for failure information.
  </MsgText>
  <Explanation>
    The server failed to run.
  </Explanation>
  <UserResponse>
    Check the logs, trace, and the First Failure Data Capture (FFDC) to find the most relevant root cause for this error.
  </UserResponse>
</Message>
<Message ID="ADML0066I" severity="I" prefix="yes">
  <MsgText pgmKey="ADML0066I" varFormat="Java">
    ADML0066I=ADML0066I: The stop did not complete. The node agent is trying to end processing of server &quot;{0}&quot;.
  </MsgText>
  <Explanation>
    The node agent tried unsuccessfully to stop an application server. The node agent is trying the terminate method to force the server to end processing.
  </Explanation>
  <UserResponse>
    Check the logs and trace for this server. Usually, the logs show why the server cannot respond to the node agent. See whether the node agent was able to terminate the process and restart the server.
  </UserResponse>
</Message>
<Message ID="ADML0111E" severity="E" prefix="yes">
  <MsgText pgmKey="ADML0111E" varFormat="Java">
    ADML0111E=ADML0111E: A request to stop the server stop failed to complete.
  </MsgText>
  <Explanation>
    The server did not return a status indicating that it completed shutdown in response to a stop request.
  </Explanation>
  <UserResponse>
    Examine the server logs and trace to see if an exception occurred during the stop logic that might have prevented a successful shutdown.
  </UserResponse>
</Message>
<Message ID="ADML0056E" severity="E" prefix="yes">
  <MsgText pgmKey="ADML0056E" varFormat="Java">
    ADML0056E=ADML0056E: The tool is unable to initiate monitoring for process {0} with PID {1} because of exception: {2}
  </MsgText>
  <Explanation>
    The nodeagent failed to establish a connection to the launched process.
  </Explanation>
  <UserResponse>
    Check to make sure nodeagent is running, look at nodeagent logs, trace, and the First Failure Data Capture (FFDC) to find the most relevant root cause for this error.
  </UserResponse>
</Message>
<Message ID="ADML0040E" severity="E" prefix="yes">
  <MsgText pgmKey="ADML0040E" varFormat="Java">
    ADML0040E=ADML0040E: The process timed out waiting for server &quot;{0}&quot; initialization: {1} seconds
  </MsgText>
  <Explanation>
    The server initialization process exceeded the timeout limit.
  </Explanation>
  <UserResponse>
    Examine the exception in this message for problem determination.  Check the logs, trace, and the First Failure Data Capture (FFDC) to find the most relevant root cause for this error.
  </UserResponse>
</Message>
<Message ID="ADML0065W" severity="W" prefix="yes">
  <MsgText pgmKey="ADML0065W" varFormat="Java">
    ADML0065W=ADML0065W: A sync operation prior to starting an application server failed.
  </MsgText>
  <Explanation>
    The node agent started the application server, but could not first synchronize the configuration data of the node with the master copy of configuration data at the deployment manager. The deployment manager might not be running or might be unavailable.
  </Explanation>
  <UserResponse>
    If you require synchronization for the server configuration, ensure that the deployment manager is running before another synchronization occurs.
  </UserResponse>
</Message>
<Message ID="ADML0220I" severity="I" prefix="yes">
  <MsgText pgmKey="ADML0220I" varFormat="Java">
    ADML0220I=ADML0220I: The base server run time initialized; the tool is waiting for application initialization.
  </MsgText>
  <Explanation>
    This informational message indicates the progress of the program.
  </Explanation>
  <UserResponse>
    No user action is required.
  </UserResponse>
</Message>
<Message ID="ADML0000I" severity="I" prefix="yes">
  <MsgText pgmKey="ADML0000I" varFormat="Java">
    ADML0000I=ADML0000I: The server initialization is complete. The process ID is: {0}, server name is: {1}
  </MsgText>
  <Explanation>
    The server process started successfully.
  </Explanation>
  <UserResponse>
    No user action is required.
  </UserResponse>
</Message>
<Message ID="ADML0006E" severity="E" prefix="yes">
  <MsgText pgmKey="ADML0006E" varFormat="Java">
    ADML0006E=ADML0006E: The ${WAS_INSTALL_ROOT} variable is missing.
  </MsgText>
  <Explanation>
    The variable setting for ${WAS_INSTALL_ROOT} value is missing. This variable is required.
  </Explanation>
  <UserResponse>
    Edit the configuration and provide a ${WAS_INSTALL_ROOT} variable.
  </UserResponse>
</Message>
<!-- END MESSAGES -->
</TMSSource>
