<?xml version="1.0" encoding="UTF-8"?>
<?xml-stylesheet type="text/css" href="../../resources/stylesheets/wasmsgxml.css"?>
<TMSSource name="TivoliMessages" tmsVersion="1.0" xml:lang="en">
<!-- CMVC MSG File Name = ws/code/asynchbeans/src/com/ibm/ws/asynchbeans/pool/ObjectPoolMessages.nlsprops -->
<!-- DO NOT EDIT THIS FILE - This file was generated by the XML/Html & Property emitter -->
<!-- BEGIN MESSAGES -->
<Message ID="OBPL0013I" severity="I" prefix="yes">
  <MsgText pgmKey="PMI_INIT_ERROR" varFormat="Java">
    PMI_INIT_ERROR=OBPL0013I: An error occurred while initializing performance monitoring for the Object Pool.
  </MsgText>
  <Explanation>
    The Object Pool PMI module could not be registered with the PMI service.
  </Explanation>
  <UserResponse>
    Verify that the product is installed correctly and check the logs for further details.  This error affects only performance data gathering.
  </UserResponse>
</Message>
<Message ID="OBPL0004E" severity="E" prefix="yes">
  <MsgText pgmKey="ERR_MISSING_KEY" varFormat="Java">
    ERR_MISSING_KEY=OBPL0004E: Message key {0} was not found in any searched resource bundles.
  </MsgText>
  <Explanation>
    The message key supplied to retrieve a message is not valid.
  </Explanation>
  <UserResponse>
    Determine why the message catalog could not be found.
  </UserResponse>
</Message>
<Message ID="OBPL0007I" severity="I" prefix="yes">
  <MsgText pgmKey="OBJPOOLMGR_NOT_ENABLED" varFormat="Java">
    OBJPOOLMGR_NOT_ENABLED=OBPL0007I: Object Pool Manager service is disabled.
  </MsgText>
  <Explanation>
    The Object Pool service has been disabled in the configuration and is inaccessible on the server.
  </Explanation>
  <UserResponse>
    Action is not required.
  </UserResponse>
</Message>
<Message ID="OBPL0003E" severity="E" prefix="yes">
  <MsgText pgmKey="FATAL_JNDI_IOEXCEPTION" varFormat="Java">
    FATAL_JNDI_IOEXCEPTION=OBPL0003E: IOException was raised during a JNDI operation.
  </MsgText>
  <Explanation>
    An unexpected exception occurred binding a WorkManager/ObjectPoolManager into JNDI.
  </Explanation>
  <UserResponse>
    This indicates a damaged installation. Reinstall the application server product and try again.
  </UserResponse>
</Message>
<Message ID="OBPL0012E" severity="E" prefix="yes">
  <MsgText pgmKey="ERR_NO_SERVICE" varFormat="Java">
    ERR_NO_SERVICE=OBPL0012E: Object Pool service could not resolve the {0} service.
  </MsgText>
  <Explanation>
    The Object Pool service could not resolve the specified service, which is required for the Object Pool service. Review the log to determine whether the specified service started successfully.
  </Explanation>
  <UserResponse>
    To use the Object Pool service, correct the problem with the specified service. If you are unable to correct the problem, contact IBM support.
  </UserResponse>
</Message>
<Message ID="OBPL0009W" severity="W" prefix="yes">
  <MsgText pgmKey="OBJPOOLMGR_DISABLED" varFormat="Java">
    OBJPOOLMGR_DISABLED=OBPL0009W: Object Pool service is disabled due to previous errors.
  </MsgText>
  <Explanation>
    The Object Pool service experienced an error during initialization. The service is inaccessible on the given server. The root error should have been logged previously.
  </Explanation>
  <UserResponse>
    Resolve the previously logged errors. If unable to do so, contact IBM product support.
  </UserResponse>
</Message>
<Message ID="OBPL0006E" severity="E" prefix="yes">
  <MsgText pgmKey="WARN_OBJPOOLMGR_MBEAN_ACTIVATION_EXCEPT" varFormat="Java">
    WARN_OBJPOOLMGR_MBEAN_ACTIVATION_EXCEPT=OBPL0006E: ObjectPoolManagerMBeanActivateException {0} for MBeanID {1}
  </MsgText>
  <Explanation>
    Unable to activate the specified MBean when creating an ObjectPoolManager.
  </Explanation>
  <UserResponse>
    Verify that the parameters used to create the ObjectPoolManager are valid.
  </UserResponse>
</Message>
<Message ID="OBPL0011I" severity="I" prefix="yes">
  <MsgText pgmKey="OBJPOOLMGR_STOPPING" varFormat="Java">
    OBJPOOLMGR_STOPPING=OBPL0011I: The Object Pool service is stopping.
  </MsgText>
  <Explanation>
    The Object Pool service is stopping and is unable to receive requests.
  </Explanation>
  <UserResponse>
    Action is not required.
  </UserResponse>
</Message>
<Message ID="OBPL0005E" severity="E" prefix="yes">
  <MsgText pgmKey="WARN_OBJPOOL_MBEAN_ACTIVATION_EXCEPT" varFormat="Java">
    WARN_OBJPOOL_MBEAN_ACTIVATION_EXCEPT=OBPL0005E: ObjectPoolMBeanActivateException {0} for MBeanID {1}
  </MsgText>
  <Explanation>
    Unable to activate the specified MBean when creating an ObjectPool.
  </Explanation>
  <UserResponse>
    Verify that the parameters used to create the ObjectPool are valid.
  </UserResponse>
</Message>
<Message ID="OBPL9999E" severity="E" prefix="yes">
  <MsgText pgmKey="MSG_KEY_UNEX_EXCEPT" varFormat="Java">
    MSG_KEY_UNEX_EXCEPT=OBPL9999E: Unexpected exception occurred: {0}.
  </MsgText>
  <Explanation>
    This exception is unexpected. The cause is not immediately known.
  </Explanation>
  <UserResponse>
    If the problem persists, additional information might be available if you search for the message ID on the following Web sites: WebSphere Application Server Support page: http://www.ibm.com/software/webservers/appserv/was/support/ WebSphere Application Server for z/OS Support page: http://www.ibm.com/software/webservers/appserv/zos_os390/support/ .
  </UserResponse>
</Message>
<Message ID="OBPL0001E" severity="E" prefix="yes">
  <MsgText pgmKey="ERR_OBJPOOLINIT_ILLEGALACCESS" varFormat="Java">
    ERR_OBJPOOLINIT_ILLEGALACCESS=OBPL0001E: IllegalAccessException occurred when initializing the object pool. The type of object being pooled might not be public or might not have a default constructor: {0}.
  </MsgText>
  <Explanation>
    An IllegalAccessException occurred when instantiating the requested object for an object pool.
  </Explanation>
  <UserResponse>
    Verify that the class of object being pooled has a public default constructor. If your class does not meet these requirements then create a CustomObjectPool for your class and register the CustomObjectPool with the ObjectPoolManager.
  </UserResponse>
</Message>
<Message ID="OBPL0002E" severity="E" prefix="yes">
  <MsgText pgmKey="ERR_OBJPOOL_RETOBJ_INCORRTYPE" varFormat="Java">
    ERR_OBJPOOL_RETOBJ_INCORRTYPE=OBPL0002E: The specified object cannot be returned to the object pool because is not the correct type. The class of object specified is {0}. The expected class is {1}.
  </MsgText>
  <Explanation>
    An attempt was made to return an object of the wrong type to an object pool.
  </Explanation>
  <UserResponse>
    There is an error in the application. The wrong object pool was used for a return operation. Correct the application.
  </UserResponse>
</Message>
<Message ID="OBPL0010I" severity="I" prefix="yes">
  <MsgText pgmKey="OBJPOOLMGR_STARTED" varFormat="Java">
    OBJPOOLMGR_STARTED=OBPL0010I: The Object Pool service started successfully.
  </MsgText>
  <Explanation>
    The Object Pool service was started and is available to receive requests.
  </Explanation>
  <UserResponse>
    Action is not required.
  </UserResponse>
</Message>
<!-- END MESSAGES -->
</TMSSource>
