<?xml version="1.0" encoding="UTF-8"?>
<?xml-stylesheet type="text/css" href="../../resources/stylesheets/wasmsgxml.css"?>
<TMSSource name="TivoliMessages" tmsVersion="1.0" xml:lang="en">
<!-- CMVC MSG File Name = ws/code/proxy.impl/src/com/ibm/ws/proxy/filter/resources/filter.nlsprops -->
<!-- DO NOT EDIT THIS FILE - This file was generated by the XML/Html & Property emitter -->
<!-- BEGIN MESSAGES -->
<Message ID="PROX0054W" severity="W" prefix="yes">
  <MsgText pgmKey="PROX0054W" varFormat="Java">
    PROX0054W=PROX0054W: Routing Rule {0} will be ignored.
  </MsgText>
  <Explanation>
    All of the required elements of the specified routing rule are not completely defined and cannot be routed to.
  </Explanation>
  <UserResponse>
    Make sure a URI Group, virtual host, and routing action are specified in this routing rule.
  </UserResponse>
</Message>
<Message ID="PROX0064I" severity="I" prefix="yes">
  <MsgText pgmKey="PROX0064I" varFormat="Java">
    PROX0064I=PROX0064I: Filters deployed by the proxy are listed below in execution order by protocol and filter point: {0}
  </MsgText>
  <Explanation>
    All of the installed filters are displayed.
  </Explanation>
  <UserResponse>
    None
  </UserResponse>
</Message>
<Message ID="PROX0063W" severity="W" prefix="yes">
  <MsgText pgmKey="PROX0063W" varFormat="Java">
    PROX0063W=PROX0063W: A filter named {0} does not exist.
  </MsgText>
  <Explanation>
    Indicates an attempt was made to modify a filter that does not exist.
  </Explanation>
  <UserResponse>
    Ensure the filter name was typed correctly.  Also, filter names are case sensitive.
  </UserResponse>
</Message>
<Message ID="PROX0069W" severity="W" prefix="yes">
  <MsgText pgmKey="PROX0069W" varFormat="Java">
    PROX0069W=PROX0069W: The static routing file directory is not set and static routing is enabled.
  </MsgText>
  <Explanation>
    When static routing is enabled, the static routing file directory must be set to a valid directory that contains the exported static routing XML file.
  </Explanation>
  <UserResponse>
    Review the configuration and set the static file routing directory to a valid directory that contains the exported static routing XML file.
  </UserResponse>
</Message>
<Message ID="PROX0053W" severity="W" prefix="yes">
  <MsgText pgmKey="PROX0053W" varFormat="Java">
    PROX0053W=PROX0053W: Problems occurred while creating error logs.
  </MsgText>
  <Explanation>
    No logging will occur due to the unhandled event.
  </Explanation>
  <UserResponse>
    Make sure the specified log file name(s) are valid and accessible.
  </UserResponse>
</Message>
<Message ID="PROX0073I" severity="I" prefix="yes">
  <MsgText pgmKey="PROX0073I" varFormat="Java">
    PROX0073I=PROX0073I: HTTP Proxy quiesce completed.
  </MsgText>
  <Explanation>
    The HTTP Proxy quiesce is completed.
  </Explanation>
  <UserResponse>
    None
  </UserResponse>
</Message>
<Message ID="PROX0059E" severity="E" prefix="yes">
  <MsgText pgmKey="PROX0059E" varFormat="Java">
    PROX0059E=PROX0059E: Object cache instance {0} is not properly configured for proxy-cache use.
  </MsgText>
  <Explanation>
    The proxy server requires a specific configuration for its object cache.  The proxy server cannot start with this condition.
  </Explanation>
  <UserResponse>
    Either disable proxy server caching, or ensure the proxy server object cache is configured to enable NIO support.
  </UserResponse>
</Message>
<Message ID="PROX0068W" severity="W" prefix="yes">
  <MsgText pgmKey="PROX0068W" varFormat="Java">
    PROX0068W=PROX0068W: The specified time mapping could not be converted to a valid time object.
  </MsgText>
  <Explanation>
    A value that was not valid was provided that prevented the time mapping from being converted into a valid time.
  </Explanation>
  <UserResponse>
    Review the time mapping configuration and specify a valid time. Hours are represented between 0-23 inclusive and minutes between 0-59 inclusive.  For example, 10:30.
  </UserResponse>
</Message>
<Message ID="PROX0052W" severity="W" prefix="yes">
  <MsgText pgmKey="PROX0052W" varFormat="Java">
    PROX0052W=PROX0052W: Problems occurred while handling error page application URI.  Error Page URI={0}
  </MsgText>
  <Explanation>
    A host for the error page application could not be found.
  </Explanation>
  <UserResponse>
    Make sure that the error page application URI is located in an available Web module or routing rule.
  </UserResponse>
</Message>
<Message ID="PROX0072I" severity="I" prefix="yes">
  <MsgText pgmKey="PROX0072I" varFormat="Java">
    PROX0072I=PROX0072I: HTTP Proxy quiesce started.
  </MsgText>
  <Explanation>
    The HTTP Proxy received a start quiesce request.
  </Explanation>
  <UserResponse>
    None
  </UserResponse>
</Message>
<Message ID="PROX0058W" severity="W" prefix="yes">
  <MsgText pgmKey="PROX0058W" varFormat="Java">
    PROX0058W=PROX0058W: The following rewrite rule is improperly formatted and will not be active - FROM URL PATTERN: {0} TO URL PATTERN: {1}
  </MsgText>
  <Explanation>
    Indicates one or both of the supplied URL patterns cannot be parsed
  </Explanation>
  <UserResponse>
    Make sure that the patterns do not contain any typos and are formatted according to RFC 2396
  </UserResponse>
</Message>
<Message ID="PROX0062I" severity="I" prefix="yes">
  <MsgText pgmKey="PROX0062I" varFormat="Java">
    PROX0062I=PROX0062I: The ordinal of filter: {0} was set to: {1}
  </MsgText>
  <Explanation>
    A filter&apos;s ordinal was modified.
  </Explanation>
  <UserResponse>
    None.
  </UserResponse>
</Message>
<Message ID="PROX0061W" severity="W" prefix="yes">
  <MsgText pgmKey="PROX0061W" varFormat="Java">
    PROX0061W=PROX0061W: Filter: {0} is internal and cannot be modified.
  </MsgText>
  <Explanation>
    Indicates a user incorrectly attempted to modify an internal filter.  Only custom filters can be modified.
  </Explanation>
  <UserResponse>
    None.
  </UserResponse>
</Message>
<Message ID="PROX0067W" severity="W" prefix="yes">
  <MsgText pgmKey="PROX0067W" varFormat="Java">
    PROX0067W=PROX0067W: The method {0} was unable to complete successfully due to an argument that is not valid: {1}
  </MsgText>
  <Explanation>
    A value that was not valid was provided that caused the method to fail.
  </Explanation>
  <UserResponse>
    Review mbean command and use correct argument(s).
  </UserResponse>
</Message>
<Message ID="PROX0071I" severity="I" prefix="yes">
  <MsgText pgmKey="PROX0071I" varFormat="Java">
    PROX0071I=PROX0071I: HTTP Proxy has informed the load balancer of readiness.
  </MsgText>
  <Explanation>
    The HTTP Proxy is successfully responding to load balancer inquiries.
  </Explanation>
  <UserResponse>
    None
  </UserResponse>
</Message>
<Message ID="PROX0057W" severity="W" prefix="yes">
  <MsgText pgmKey="PROX0057W" varFormat="Java">
    PROX0057W=PROX0057W: The URL {0} from is improperly formatted and cannot be parsed.
  </MsgText>
  <Explanation>
    A URL received from a server is not formatted according to RFC 2396.
  </Explanation>
  <UserResponse>
    Correct the format of the specified URL.
  </UserResponse>
</Message>
<Message ID="PROX0051E" severity="E" prefix="yes">
  <MsgText pgmKey="PROX0051E" varFormat="Java">
    PROX0051E=PROX0051E: Caught unhandled exception from doFilter in filter={0}; exception={1}.
  </MsgText>
  <Explanation>
    The identified filter failed to handle an event. No error response will be built because the response is already committed.
  </Explanation>
  <UserResponse>
    Review the log file for related reasons as to why the filter failed.  If the problem persists, contact the vendor for the filter.
  </UserResponse>
</Message>
<Message ID="PROX0070W" severity="W" prefix="yes">
  <MsgText pgmKey="PROX0070W" varFormat="Java">
    PROX0070W=PROX0070W: The static routing file directory does not contain any files and static routing is enabled.
  </MsgText>
  <Explanation>
    When static routing is enabled, the static routing file directory must contain the exported XML routing files or the proxy will fail to route requests.
  </Explanation>
  <UserResponse>
    Review the configuration and ensure the static routing file directory contains one or more XML files generated from the TargetTreeMbean on the Deployment Manager of the target cells.
  </UserResponse>
</Message>
<Message ID="PROX0060I" severity="I" prefix="yes">
  <MsgText pgmKey="PROX0060I" varFormat="Java">
    PROX0060I=PROX0060I: The filter {0} has the following filter initialization custom property set: {1} {2}
  </MsgText>
  <Explanation>
    Indicates a filter initialization custom property recognized by the proxy was set.
  </Explanation>
  <UserResponse>
    None.
  </UserResponse>
</Message>
<Message ID="PROX0066I" severity="I" prefix="yes">
  <MsgText pgmKey="PROX0066I" varFormat="Java">
    PROX0066I=PROX0066I: No filters are available to be displayed.
  </MsgText>
  <Explanation>
    Indicates no filters are available to be displayed for the specified filter protocol(s) and filter point(s).
  </Explanation>
  <UserResponse>
    None
  </UserResponse>
</Message>
<Message ID="PROX0050E" severity="E" prefix="yes">
  <MsgText pgmKey="PROX0050E" varFormat="Java">
    PROX0050E=PROX0050E: Caught unhandled exception from doFilter in filter={0}; exception={1}.
  </MsgText>
  <Explanation>
    The identified filter failed to handle an event. A proxy server internal error response will be built.
  </Explanation>
  <UserResponse>
    Review the log file for related reasons as to why the filter failed.  If the problem persists, contact the vendor for the filter.
  </UserResponse>
</Message>
<Message ID="PROX0056I" severity="I" prefix="yes">
  <MsgText pgmKey="PROX0056I" varFormat="Java">
    PROX0056I=PROX0056I: The custom property {0} with the value {1} is recognized but not active on the proxy.
  </MsgText>
  <Explanation>
    Indicates that the specified custom property is recognized by the proxy server, but you must restart the proxy server for this value to become active.
  </Explanation>
  <UserResponse>
    Restart the proxy server if you require the custom property value to be operational at this time.
  </UserResponse>
</Message>
<Message ID="PROX0065I" severity="I" prefix="yes">
  <MsgText pgmKey="PROX0065I" varFormat="Java">
    PROX0065I=PROX0065I: A subset of the filters deployed by the proxy are listed below in execution order by protocol and filter point: {0}
  </MsgText>
  <Explanation>
    Filters are being displayed based on the protocol and filter point specified.
  </Explanation>
  <UserResponse>
    None
  </UserResponse>
</Message>
<Message ID="PROX0055I" severity="I" prefix="yes">
  <MsgText pgmKey="PROX0055I" varFormat="Java">
    PROX0055I=PROX0055I: The custom property {0} with the value {1} is recognized and active on the proxy.
  </MsgText>
  <Explanation>
    Indicates that the specified custom property has been successfully processed by the proxy server.
  </Explanation>
  <UserResponse>
    None.
  </UserResponse>
</Message>
<!-- END MESSAGES -->
</TMSSource>
