<?xml version="1.0" encoding="UTF-8"?>
<?xml-stylesheet type="text/css" href="../../resources/stylesheets/wasmsgxml.css"?>
<TMSSource name="TivoliMessages" tmsVersion="1.0" xml:lang="en">
<!-- CMVC MSG File Name = ws/code/recovery.log.impl/src/com/ibm/ws/recoverylog/resources/RecoveryLogMsgs.nlsprops -->
<!-- DO NOT EDIT THIS FILE - This file was generated by the XML/Html & Property emitter -->
<!-- BEGIN MESSAGES -->
<Message ID="CWRLS0019I" severity="I" prefix="yes">
  <MsgText pgmKey="CWRLS0019_SNAPSHOT_SAFE" varFormat="Java">
    CWRLS0019_SNAPSHOT_SAFE=CWRLS0019I: The Recovery Log Service has been configured as snapshot safe in the transaction service custom properties.
  </MsgText>
  <Explanation>
    When a snapshot of the log files is requested, all transaction logging activity is suspended while the snapshot is taken, to ensure that the log files are in a known state that is consistent with other systems involved in the snapshot.
  </Explanation>
  <UserResponse>
    No action is required.
  </UserResponse>
</Message>
<Message ID="CWRLS0014I" severity="I" prefix="yes">
  <MsgText pgmKey="CWRLS0014_HALT_PEER_RECOVERY" varFormat="Java">
    CWRLS0014_HALT_PEER_RECOVERY=CWRLS0014I: Halting any current recovery processing for a peer WebSphere server ({0}).
  </MsgText>
  <Explanation>
    Recovery processing is being transferred to an alternative application server. Typically, this occurs when a server is restarted and retakes ownership of its recovery logs.
  </Explanation>
  <UserResponse>
    No action is required.
  </UserResponse>
</Message>
<Message ID="CWRLS0008E" severity="E" prefix="yes">
  <MsgText pgmKey="CWRLS0008_RECOVERY_LOG_FAILED" varFormat="Java">
    CWRLS0008_RECOVERY_LOG_FAILED=CWRLS0008E: Recovery log is being marked as failed. [ {0} {1} ]
  </MsgText>
  <Explanation>
    The recovery log has failed, and there is no further access to the recovery log. The message shows the component and the relevant exception.
  </Explanation>
  <UserResponse>
    Restart the server so that the log can be repaired. Try to fix any conditions indicated by the exception in the message.
  </UserResponse>
</Message>
<Message ID="CWRLS0001I" severity="I" prefix="yes">
  <MsgText pgmKey="CWRLS0001_SUSPEND_RLS" varFormat="Java">
    CWRLS0001_SUSPEND_RLS=CWRLS0001I: The Recovery Log Service has been suspended ({0}).
  </MsgText>
  <Explanation>
    The Recovery Log Service is in pending state to allow the system to backup the recovery log files.
  </Explanation>
  <UserResponse>
    No action is required.
  </UserResponse>
</Message>
<Message ID="CWRLS0028W" severity="W" prefix="yes">
  <MsgText pgmKey="CWRLS0028_COMMON_COMPLOG_DIRS" varFormat="Java">
    CWRLS0028_COMMON_COMPLOG_DIRS=CWRLS0028W: Common compensation log directory {0} has been defined for servers {1} and {2}
  </MsgText>
  <Explanation>
    Compensation logs from two servers are using a common directory configuration. This might cause to recovery lock contention or a failure of data integrity.
  </Explanation>
  <UserResponse>
    Configure separate log directory paths for each server.
  </UserResponse>
</Message>
<Message ID="CWRLS0010I" severity="I" prefix="yes">
  <MsgText pgmKey="CWRLS0010_PERFORM_LOCAL_RECOVERY" varFormat="Java">
    CWRLS0010_PERFORM_LOCAL_RECOVERY=CWRLS0010I: Performing recovery processing for local WebSphere server ({0}).
  </MsgText>
  <Explanation>
    The recovery log service is directing recovery processing of associated client services.
  </Explanation>
  <UserResponse>
    No action is required.
  </UserResponse>
</Message>
<Message ID="CWRLS0009E" severity="E" prefix="yes">
  <MsgText pgmKey="CWRLS0009_RECOVERY_LOG_FAILED_DETAIL" varFormat="Java">
    CWRLS0009_RECOVERY_LOG_FAILED_DETAIL=CWRLS0009E: Details of recovery log failure: {0}
  </MsgText>
  <Explanation>
    This message is issued with message CWRLS0008E to indicate the details of the recovery log failure.
  </Explanation>
  <UserResponse>
    Use the information in this message and message CWRLS0008E to correct that condition that caused the recovery log to fail.
  </UserResponse>
</Message>
<Message ID="CWRLS0025E" severity="E" prefix="yes">
  <MsgText pgmKey="CWRLS0025_RECOVER_MODE_NOT_COMPATIBLE" varFormat="Java">
    CWRLS0025_RECOVER_MODE_NOT_COMPATIBLE=CWRLS0025E: Server recovery mode startup is not compatible with HA enablement.
  </MsgText>
  <Explanation>
    In a high availability configuration, server recovery might be automatically initiated on a peer server.
  </Explanation>
  <UserResponse>
    Do not attempt to start a server in recovery mode if it is enabled for high availability .
  </UserResponse>
</Message>
<Message ID="CWRLS0026W" severity="W" prefix="yes">
  <MsgText pgmKey="CWRLS0026_RECOVERY_LOG_LOCK_RETRY" varFormat="Java">
    CWRLS0026_RECOVERY_LOG_LOCK_RETRY=CWRLS0026W: Unable to obtain an exclusive file lock on {0} - retrying.
  </MsgText>
  <Explanation>
    The recovery log service cannot exclusively lock the file indicated in the message during recovery, because the file appears to be in use. The recovery service will attempt periodically to gain the exclusive lock so that recovery can proceed. If the recovery log file is one of the main server recovery logs, startup is suspended until access to the logs is possible.  If the recovery log file belongs to another peer server, another server might gain the locks and perform peer recovery; in this situation, this server will stop trying to recover.
  </Explanation>
  <UserResponse>
    Examine any related messages to determine the cause of the problem. If there are no related messages, check the location of the recovery logs and ensure they are not being accessed by another server. For example, this situation could occur if more than one server is configured to use the recovery logs of another server.
  </UserResponse>
</Message>
<Message ID="CWRLS0017I" severity="I" prefix="yes">
  <MsgText pgmKey="CWRLS0017_RECOVERY_PROCESSING_INTERRUPTED" varFormat="Java">
    CWRLS0017_RECOVERY_PROCESSING_INTERRUPTED=CWRLS0017I: An attempt to obtain an exclusive file lock needed to perform recovery processing for server {0} was interrupted.   Another server is being activated to perform this recovery processing.
  </MsgText>
  <Explanation>
    Control of a recovery log has been passed between two application servers.
  </Explanation>
  <UserResponse>
    No action is required.
  </UserResponse>
</Message>
<Message ID="CWRLS0018E" severity="E" prefix="yes">
  <MsgText pgmKey="CWRLS0018_RECOVERY_PROCESSING_FAILED" varFormat="Java">
    CWRLS0018_RECOVERY_PROCESSING_FAILED=CWRLS0018E: An attempt to halt transactional recovery and forward processing for the local server ({0}) has been aborted.
  </MsgText>
  <Explanation>
    The recovery log service has stopped the local server from relinquishing control of its own recovery logs. This might be caused by the core group policy configuration.
  </Explanation>
  <UserResponse>
    Ensure that the policy configuration does not assign ownership of the recovery log of an active server to an alternative server.
  </UserResponse>
</Message>
<Message ID="CWRLS0020W" severity="W" prefix="yes">
  <MsgText pgmKey="CWRLS0020_SNAPSHOT_SAFE" varFormat="Java">
    CWRLS0020_SNAPSHOT_SAFE=CWRLS0020W: The Recovery Log Service has NOT been configured as snapshot safe in the transaction service custom properties.
  </MsgText>
  <Explanation>
    If a snapshot of the log files is taken, the log files might not be in a state that is consistent with other systems involved in the snapshot.
  </Explanation>
  <UserResponse>
    No action is required.
  </UserResponse>
</Message>
<Message ID="CWRLS0004E" severity="E" prefix="yes">
  <MsgText pgmKey="CWRLS0004_RECOVERY_LOG_CREATE_FAILED" varFormat="Java">
    CWRLS0004_RECOVERY_LOG_CREATE_FAILED=CWRLS0004E: Unable to create recovery log file {0}.
  </MsgText>
  <Explanation>
    The recovery log service could not create the file indicated in the message. Either the target directory is inaccessible, or the system does not have sufficient permissions to create the required file.
  </Explanation>
  <UserResponse>
    Ensure that the required directory hierarchy is valid and accessible to the recovery log service.
  </UserResponse>
</Message>
<Message ID="CWRLS0027W" severity="W" prefix="yes">
  <MsgText pgmKey="CWRLS0027_COMMON_TRANLOG_DIRS" varFormat="Java">
    CWRLS0027_COMMON_TRANLOG_DIRS=CWRLS0027W: Common transaction log directory {0} has been defined for servers {1} and {2}
  </MsgText>
  <Explanation>
    Transaction logs from two servers are using a common directory configuration. This might cause recovery lock contention or a failure of data integrity.
  </Explanation>
  <UserResponse>
    Configure separate log directory paths for each server.
  </UserResponse>
</Message>
<Message ID="CWRLS0013I" severity="I" prefix="yes">
  <MsgText pgmKey="CWRLS0013_DIRECT_PEER_RECOVERY" varFormat="Java">
    CWRLS0013_DIRECT_PEER_RECOVERY=CWRLS0013I: All persistent services have been directed to perform recovery processing for a peer WebSphere server ({0}).
  </MsgText>
  <Explanation>
    The recovery log service has prompted all associated client services to begin recovery for the peer server.
  </Explanation>
  <UserResponse>
    No action is required.
  </UserResponse>
</Message>
<Message ID="CWRLS0002I" severity="I" prefix="yes">
  <MsgText pgmKey="CWRLS0002_RESUME_RLS" varFormat="Java">
    CWRLS0002_RESUME_RLS=CWRLS0002I: The Recovery Log Service has been resumed ({0}).
  </MsgText>
  <Explanation>
    The Recovery Log Service that was suspended earlier is restored to running state.
  </Explanation>
  <UserResponse>
    No action is required.
  </UserResponse>
</Message>
<Message ID="CWRLS0022I" severity="I" prefix="yes">
  <MsgText pgmKey="CWRLS0022_RLS_SUSPEND_TIMEOUT" varFormat="Java">
    CWRLS0022_RLS_SUSPEND_TIMEOUT=CWRLS0022I: A Recovery Log Service suspend operation has timed out ({0}).
  </MsgText>
  <Explanation>
    If there are no outstanding suspend operations the recovery log service will resume.
  </Explanation>
  <UserResponse>
    No action is required.
  </UserResponse>
</Message>
<Message ID="CWRLS0023I" severity="I" prefix="yes">
  <MsgText pgmKey="CWRLS0023_RESUME_RLS" varFormat="Java">
    CWRLS0023_RESUME_RLS=CWRLS0023I: The Recovery Log Service has been resumed following the timeout of a suspend operation.
  </MsgText>
  <Explanation>
    This message is for informational purposes only.
  </Explanation>
  <UserResponse>
    No action is required.
  </UserResponse>
</Message>
<Message ID="CWRLS0015I" severity="I" prefix="yes">
  <MsgText pgmKey="CWRLS0015_DISABLE_FILE_LOCKING" varFormat="Java">
    CWRLS0015_DISABLE_FILE_LOCKING=CWRLS0015I: Recovery log file locking has been disabled in the transaction service custom properties.
  </MsgText>
  <Explanation>
    The file locking mechanism that the recovery log service uses to ensure exclusive access to recovery log files has been explicitly disabled.
  </Explanation>
  <UserResponse>
    Ensure that the appropriate constraints are in place to support this configuration setting.
  </UserResponse>
</Message>
<Message ID="CWRLS0030W" severity="W" prefix="yes">
  <MsgText pgmKey="CWRLS0030_WAITING_FOR_HAM_ACTIVATE" varFormat="Java">
    CWRLS0030_WAITING_FOR_HAM_ACTIVATE=CWRLS0030W: Waiting for HAManager to activate recovery processing for local WebSphere server
  </MsgText>
  <Explanation>
    The recovery log service cannot initiate recovery processing for the local server, because it is waiting for the HAManager to activate group membership for the recovery logs of this local server.
  </Explanation>
  <UserResponse>
    Examine any related messages to determine the cause of the problem. If there are no related messages, check the configuration of the DefaultCoreGroup settings and associated policy definitions for the recovery log service for the server. For example, if the Clustered TM policy is set to not support fail back, another server might have a hold on the logs and will stop this server from being activated.
  </UserResponse>
</Message>
<Message ID="CWRLS0029W" severity="W" prefix="yes">
  <MsgText pgmKey="CWRLS0029_LOCAL_RECOVERY_FAILED" varFormat="Java">
    CWRLS0029_LOCAL_RECOVERY_FAILED=CWRLS0029W: Unable to perform recovery processing for local WebSphere server - server being terminated
  </MsgText>
  <Explanation>
    The recovery log service cannot perform or complete recovery for the local server and no further work can proceed, so the server will be stopped.
  </Explanation>
  <UserResponse>
    If the problem persists, additional information might be available if you search for the message ID on the following Web sites: WebSphere Application Server Support page: http://www.ibm.com/software/webservers/appserv/was/support/ WebSphere Application Server for z/OS Support page: http://www.ibm.com/software/webservers/appserv/zos_os390/support/ .
  </UserResponse>
</Message>
<Message ID="CWRLS0005E" severity="E" prefix="yes">
  <MsgText pgmKey="CWRLS0005_RECOVERY_LOG_LOCK_FAILED" varFormat="Java">
    CWRLS0005_RECOVERY_LOG_LOCK_FAILED=CWRLS0005E: Unable to obtain an exclusive file lock on {0}.
  </MsgText>
  <Explanation>
    The recovery log service could not exclusively lock the file indicated in the message.
  </Explanation>
  <UserResponse>
    If the problem persists, additional information might be available if you search for the message ID on the following Web sites: WebSphere Application Server Support page: http://www.ibm.com/software/webservers/appserv/was/support/ WebSphere Application Server for z/OS Support page: http://www.ibm.com/software/webservers/appserv/zos_os390/support/ .
  </UserResponse>
</Message>
<Message ID="CWRLS0021I" severity="I" prefix="yes">
  <MsgText pgmKey="CWRLS0021_RESUME_ATTEMPT_RLS" varFormat="Java">
    CWRLS0021_RESUME_ATTEMPT_RLS=CWRLS0021I: The Recovery Log Service has been called to resume ({0}) but there are other outstanding suspends.
  </MsgText>
  <Explanation>
    The recovery log service will be resumed only when there are no outstanding suspend operations.
  </Explanation>
  <UserResponse>
    No action is required.
  </UserResponse>
</Message>
<Message ID="CWRLS0006I" severity="I" prefix="yes">
  <MsgText pgmKey="CWRLS0006_RECOVERY_LOG_CREATE" varFormat="Java">
    CWRLS0006_RECOVERY_LOG_CREATE=CWRLS0006I: Creating new recovery log file {0}.
  </MsgText>
  <Explanation>
    A new recovery log file has been established to store persistent data.
  </Explanation>
  <UserResponse>
    No action is required.
  </UserResponse>
</Message>
<Message ID="CWRLS0011I" severity="I" prefix="yes">
  <MsgText pgmKey="CWRLS0011_PERFORM_PEER_RECOVERY" varFormat="Java">
    CWRLS0011_PERFORM_PEER_RECOVERY=CWRLS0011I: Performing recovery processing for a peer WebSphere server ({0}).
  </MsgText>
  <Explanation>
    The recovery log service is directing recovery processing of associated client services for the peer server.
  </Explanation>
  <UserResponse>
    No action is required.
  </UserResponse>
</Message>
<Message ID="CWRLS0016E" severity="E" prefix="yes">
  <MsgText pgmKey="CWRLS0016_RECOVERY_PROCESSING_FAILED" varFormat="Java">
    CWRLS0016_RECOVERY_PROCESSING_FAILED=CWRLS0016E: Unable to obtain an exclusive file lock needed to perform recovery processing for server {0}.
  </MsgText>
  <Explanation>
    Either the target server is active, or the recovery log configuration is incorrect.
  </Explanation>
  <UserResponse>
    Ensure that the recovery log configuration is valid.
  </UserResponse>
</Message>
<Message ID="CWRLS0012I" severity="I" prefix="yes">
  <MsgText pgmKey="CWRLS0012_DIRECT_LOCAL_RECOVERY" varFormat="Java">
    CWRLS0012_DIRECT_LOCAL_RECOVERY=CWRLS0012I: All persistent services have been directed to perform recovery processing for this WebSphere server ({0}).
  </MsgText>
  <Explanation>
    The recovery log service has prompted all associated client services to begin recovery.
  </Explanation>
  <UserResponse>
    No action is required.
  </UserResponse>
</Message>
<Message ID="CWRLS0007I" severity="I" prefix="yes">
  <MsgText pgmKey="CWRLS0007_RECOVERY_LOG_NOT_EXIST" varFormat="Java">
    CWRLS0007_RECOVERY_LOG_NOT_EXIST=CWRLS0007I: No existing recovery log files found in {0}. Cold starting the recovery log.
  </MsgText>
  <Explanation>
    Either previously recovery log files have been deleted, or this is the first time recovery log files have been stored in this location. In either case, the associated service will start and will not perform any recovery processing.
  </Explanation>
  <UserResponse>
    No action is required.
  </UserResponse>
</Message>
<Message ID="CWRLS0024E" severity="E" prefix="yes">
  <MsgText pgmKey="CWRLS0024_EXC_DURING_RECOVERY" varFormat="Java">
    CWRLS0024_EXC_DURING_RECOVERY=CWRLS0024E: Exception caught during recovery! {0}
  </MsgText>
  <Explanation>
    An exception was detected while attempting to recover from a previous server failure.
  </Explanation>
  <UserResponse>
    If the problem persists, additional information might be available if you search for the message ID on the following Web sites: WebSphere Application Server Support page: http://www.ibm.com/software/webservers/appserv/was/support/ WebSphere Application Server for z/OS Support page: http://www.ibm.com/software/webservers/appserv/zos_os390/support/ .
  </UserResponse>
</Message>
<Message ID="CWRLS0003E" severity="E" prefix="yes">
  <MsgText pgmKey="CWRLS0003_GENERIC_ERROR" varFormat="Java">
    CWRLS0003_GENERIC_ERROR=CWRLS0003E: {0}
  </MsgText>
  <Explanation>
    This message code is used to support messages that have not yet been allocated their own message code.
  </Explanation>
  <UserResponse>
    Refer to the message text for more information.
  </UserResponse>
</Message>
<!-- END MESSAGES -->
</TMSSource>
