<?xml version="1.0" encoding="UTF-8"?>
<?xml-stylesheet type="text/css" href="../../resources/stylesheets/wasmsgxml.css"?>
<TMSSource name="TivoliMessages" tmsVersion="1.0" xml:lang="en">
<!-- CMVC MSG File Name = SERV1/ws/code/security/src/com/ibm/ws/security/spnego/resources/TAIMsgs.nlsprops -->
<!-- DO NOT EDIT THIS FILE - This file was generated by the XML/Html & Property emitter -->
<!-- BEGIN MESSAGES -->
<Message ID="CWSPN0035I" severity="I" prefix="yes">
  <MsgText pgmKey="security.spnego.deleteprops" varFormat="Java">
    security.spnego.deleteprops=CWSPN0035I: SPNEGO TAI property {0} has been removed from the SPNEGO TAI configuration.
  </MsgText>
  <Explanation>
    The SPNEGO TAI property removed from the security configuration is shown.
  </Explanation>
  <UserResponse>
    None, informational only.
  </UserResponse>
</Message>
<Message ID="CWSPN0041W" severity="W" prefix="yes">
  <MsgText pgmKey="security.spnego.invalid.filter" varFormat="Java">
    security.spnego.invalid.filter=CWSPN0041W: Filter {0} is malformed, verify syntax of the specified filter rules.
  </MsgText>
  <Explanation>
    The specified filter rules are not valid.
  </Explanation>
  <UserResponse>
    Verify the filter rules conform to the syntax supported by the default HTTPHeaderFilter class.
  </UserResponse>
</Message>
<Message ID="CWSPN0029E" severity="E" prefix="yes">
  <MsgText pgmKey="security.spnego.kerberos.init.error" varFormat="Java">
    security.spnego.kerberos.init.error=CWSPN0029E: Unexpected error during Kerberos initialization: {0}.
  </MsgText>
  <Explanation>
    The error occurred during initialization of the ServerCredential object.
  </Explanation>
  <UserResponse>
    If the problem persists, additional information might be available if you search for the message ID on the following Web sites: WebSphere Application Server Support page: http://www.ibm.com/software/webservers/appserv/was/support/ WebSphere Application Server for z/OS Support page: http://www.ibm.com/software/webservers/appserv/zos_os390/support/ .
  </UserResponse>
</Message>
<Message ID="CWSPN0002E" severity="E" prefix="yes">
  <MsgText pgmKey="security.spnego.authentication.failed" varFormat="Java">
    security.spnego.authentication.failed=CWSPN0002E: Error authenticating client. SPNEGO handshake failed: {0}.
  </MsgText>
  <Explanation>
    A HandshakeFailedException occurred while processing the SPNEGO token received in the HttpServletRequest.
  </Explanation>
  <UserResponse>
    If the problem persists, additional information might be available if you search for the message ID on the following Web sites: WebSphere Application Server Support page: http://www.ibm.com/software/webservers/appserv/was/support/ WebSphere Application Server for z/OS Support page: http://www.ibm.com/software/webservers/appserv/zos_os390/support/ .
  </UserResponse>
</Message>
<Message ID="CWSPN0028W" severity="W" prefix="yes">
  <MsgText pgmKey="security.spnego.no.content.loaded" varFormat="Java">
    security.spnego.no.content.loaded=CWSPN0028W: Unable to load html content from {0}, will use default content. Exception: {1}.
  </MsgText>
  <Explanation>
    This exception is unexpected. The cause is not immediately known.
  </Explanation>
  <UserResponse>
    If the problem persists, additional information might be available if you search for the message ID on the following Web sites: WebSphere Application Server Support page: http://www.ibm.com/software/webservers/appserv/was/support/ WebSphere Application Server for z/OS Support page: http://www.ibm.com/software/webservers/appserv/zos_os390/support/ .
  </UserResponse>
</Message>
<Message ID="CWSPN0018E" severity="E" prefix="yes">
  <MsgText pgmKey="security.spnego.malformed.filter.condition" varFormat="Java">
    security.spnego.malformed.filter.condition=CWSPN0018E: Filter condition is malformed. s1 = {0};  s2 = {1}; s3 = {2}
  </MsgText>
  <Explanation>
    This exception is unexpected. The cause is not immediately known.
  </Explanation>
  <UserResponse>
    If the problem persists, additional information might be available if you search for the message ID on the following Web sites: WebSphere Application Server Support page: http://www.ibm.com/software/webservers/appserv/was/support/ WebSphere Application Server for z/OS Support page: http://www.ibm.com/software/webservers/appserv/zos_os390/support/ .
  </UserResponse>
</Message>
<Message ID="CWSPN0047E" severity="E" prefix="yes">
  <MsgText pgmKey="security.spnego.unknown.host" varFormat="Java">
    security.spnego.unknown.host=CWSPN0047E: Unknown host exception raised for IP address {0}.
  </MsgText>
  <Explanation>
    Could not obtain IP address.
  </Explanation>
  <UserResponse>
    Validate the IP address range specified.
  </UserResponse>
</Message>
<Message ID="CWSPN0036I" severity="I" prefix="yes">
  <MsgText pgmKey="security.spnego.deleteall" varFormat="Java">
    security.spnego.deleteall=CWSPN0036I: All SPNEGO TAI properties have been removed from the security configuration.
  </MsgText>
  <Explanation>
    All SPNEGO TAI properties have been removed from the security configuration.
  </Explanation>
  <UserResponse>
    None, informational only.
  </UserResponse>
</Message>
<Message ID="CWSPN0033I" severity="I" prefix="yes">
  <MsgText pgmKey="security.spnego.addprops" varFormat="Java">
    security.spnego.addprops=CWSPN0033I: SPNEGO TAI property {0} has been added to the security configuration, its value is: {1}.
  </MsgText>
  <Explanation>
    The SPNEGO TAI property added to the security configuration and its value are shown.
  </Explanation>
  <UserResponse>
    None, informational only.
  </UserResponse>
</Message>
<Message ID="CWSPN0003E" severity="E" prefix="yes">
  <MsgText pgmKey="security.spnego.unexpected.exception" varFormat="Java">
    security.spnego.unexpected.exception=CWSPN0003E: An unexpected exception occurred in the SPNEGO Trust Association Interceptor: {0}.
  </MsgText>
  <Explanation>
    The exception occurred while attempting to run the negotiateValidateandEstablishTrust() operation.
  </Explanation>
  <UserResponse>
    If the problem persists, additional information might be available if you search for the message ID on the following Web sites: WebSphere Application Server Support page: http://www.ibm.com/software/webservers/appserv/was/support/ WebSphere Application Server for z/OS Support page: http://www.ibm.com/software/webservers/appserv/zos_os390/support/ .
  </UserResponse>
</Message>
<Message ID="CWSPN0031W" severity="W" prefix="yes">
  <MsgText pgmKey="security.spnego.spnid.notexistent" varFormat="Java">
    security.spnego.spnid.notexistent=CWSPN0031W: spnId {0} is not defined in the SPNEGO TAI configuration.
  </MsgText>
  <Explanation>
    The given spnId value is not defined in the SPNEGO TAI configuration.
  </Explanation>
  <UserResponse>
    Verify the SPNEGO TAI properties and specify a spnId value that exists.
  </UserResponse>
</Message>
<Message ID="CWSPN0011E" severity="E" prefix="yes">
  <MsgText pgmKey="security.spnego.bad.token" varFormat="Java">
    security.spnego.bad.token=CWSPN0011E: A non-valid SPNEGO token has been encountered while authenticating a HttpServletRequest: {0}
  </MsgText>
  <Explanation>
    The SPNEGO token used to authenticate the request is not valid.
  </Explanation>
  <UserResponse>
    If the problem persists, additional information might be available if you search for the message ID on the following Web sites: WebSphere Application Server Support page: http://www.ibm.com/software/webservers/appserv/was/support/ WebSphere Application Server for z/OS Support page: http://www.ibm.com/software/webservers/appserv/zos_os390/support/ .
  </UserResponse>
</Message>
<Message ID="CWSPN0019E" severity="E" prefix="yes">
  <MsgText pgmKey="security.spnego.malformed.filter.operator" varFormat="Java">
    security.spnego.malformed.filter.operator=CWSPN0019E: Filter operator should be one of &apos;&apos;==&apos;&apos;, &apos;&apos;!=&apos;&apos;, &apos;&apos;%=&apos;&apos;, &apos;&apos;&gt;&apos;&apos; or &apos;&apos;&lt;&apos;&apos;. Operator used was {0}.
  </MsgText>
  <Explanation>
    This exception is unexpected. The cause is not immediately known.
  </Explanation>
  <UserResponse>
    If the problem persists, additional information might be available if you search for the message ID on the following Web sites: WebSphere Application Server Support page: http://www.ibm.com/software/webservers/appserv/was/support/ WebSphere Application Server for z/OS Support page: http://www.ibm.com/software/webservers/appserv/zos_os390/support/ .
  </UserResponse>
</Message>
<Message ID="CWSPN0010W" severity="W" prefix="yes">
  <MsgText pgmKey="security.spnego.warn.hostbased" varFormat="Java">
    security.spnego.warn.hostbased=CWSPN0010W: The GSSName principal created (GSSNameType == NT_HOSTBASED_SERVICE) for {0} might cause problems with reverse name lookup.
  </MsgText>
  <Explanation>
    Use of NT_HOSTBASED_SERVICE name type might cause problems with reverse name lookups.
  </Explanation>
  <UserResponse>
    None, informational warning only.
  </UserResponse>
</Message>
<Message ID="CWSPN0020E" severity="E" prefix="yes">
  <MsgText pgmKey="security.spnego.unexpected.condition" varFormat="Java">
    security.spnego.unexpected.condition=CWSPN0020E: Unexpected internal condition: {0}.
  </MsgText>
  <Explanation>
    This exception is unexpected. The cause is not immediately known.
  </Explanation>
  <UserResponse>
    If the problem persists, additional information might be available if you search for the message ID on the following Web sites: WebSphere Application Server Support page: http://www.ibm.com/software/webservers/appserv/was/support/ WebSphere Application Server for z/OS Support page: http://www.ibm.com/software/webservers/appserv/zos_os390/support/ .
  </UserResponse>
</Message>
<Message ID="CWSPN0024E" severity="E" prefix="yes">
  <MsgText pgmKey="security.spnego.reload.failed" varFormat="Java">
    security.spnego.reload.failed=CWSPN0024E: An error occurred during the reloading of the TAI Properties. The previously properties are in effect.
  </MsgText>
  <Explanation>
    This exception is unexpected. The cause is not immediately known.
  </Explanation>
  <UserResponse>
    If the problem persists, additional information might be available if you search for the message ID on the following Web sites: WebSphere Application Server Support page: http://www.ibm.com/software/webservers/appserv/was/support/ WebSphere Application Server for z/OS Support page: http://www.ibm.com/software/webservers/appserv/zos_os390/support/ .
  </UserResponse>
</Message>
<Message ID="CWSPN0021E" severity="E" prefix="yes">
  <MsgText pgmKey="security.spnego.no.delegated.credentials.found" varFormat="Java">
    security.spnego.no.delegated.credentials.found=CWSPN0021E: No delegated credentials were found for user: {0}.
  </MsgText>
  <Explanation>
    This exception is unexpected. The cause is not immediately known.
  </Explanation>
  <UserResponse>
    If the problem persists, additional information might be available if you search for the message ID on the following Web sites: WebSphere Application Server Support page: http://www.ibm.com/software/webservers/appserv/was/support/ WebSphere Application Server for z/OS Support page: http://www.ibm.com/software/webservers/appserv/zos_os390/support/ .
  </UserResponse>
</Message>
<Message ID="CWSPN0027I" severity="I" prefix="yes">
  <MsgText pgmKey="security.spnego.tai.isEnabled" varFormat="Java">
    security.spnego.tai.isEnabled=CWSPN0027I: SPNEGO Trust Association Interceptor is {0}.
  </MsgText>
  <Explanation>
    The initialization state of the SPNEGO Trust Association Interceptor is shown.
  </Explanation>
  <UserResponse>
    None, informational only.
  </UserResponse>
</Message>
<Message ID="CWSPN0038W" severity="W" prefix="yes">
  <MsgText pgmKey="security.spnego.krbconf.fileexists" varFormat="Java">
    security.spnego.krbconf.fileexists=CWSPN0038W: File {0} already exists, it has not been overwritten.
  </MsgText>
  <Explanation>
    The Kerberos configuration file already exists at the given directory location.
  </Explanation>
  <UserResponse>
    Specify a different directory location, delete or rename the existing file.
  </UserResponse>
</Message>
<Message ID="CWSPN0007I" severity="I" prefix="yes">
  <MsgText pgmKey="security.spnego.init.provider" varFormat="Java">
    security.spnego.init.provider=CWSPN0007I: {0} security provider has been added to the configuration.
  </MsgText>
  <Explanation>
    The SPNEGO security provider has been added to the security configuration.
  </Explanation>
  <UserResponse>
    None, informational only.
  </UserResponse>
</Message>
<Message ID="CWSPN9999W" severity="W" prefix="yes">
  <MsgText pgmKey="security.spnego.fix.locale" varFormat="Java">
    security.spnego.fix.locale=CWSPN9999W: (temporary workaround): Current JVM locale changed from {0} to {1}. This is not a permanent change.
  </MsgText>
  <Explanation>
    This exception is unexpected. The cause is not immediately known.
  </Explanation>
  <UserResponse>
    If the problem persists, additional information might be available if you search for the message ID on the following Web sites: WebSphere Application Server Support page: http://www.ibm.com/software/webservers/appserv/was/support/ WebSphere Application Server for z/OS Support page: http://www.ibm.com/software/webservers/appserv/zos_os390/support/ .
  </UserResponse>
</Message>
<Message ID="CWSPN0043E" severity="E" prefix="yes">
  <MsgText pgmKey="security.spnego.reload.initialize.failed" varFormat="Java">
    security.spnego.reload.initialize.failed=CWSPN0043E: An error occurred during the initialization of the reloaded TAI Properties.
  </MsgText>
  <Explanation>
    This exception is unexpected. The cause is not immediately known.
  </Explanation>
  <UserResponse>
    If the problem persists, additional information might be available if you search for the message ID on the following Web sites: WebSphere Application Server Support page: http://www.ibm.com/software/webservers/appserv/was/support/ WebSphere Application Server for z/OS Support page: http://www.ibm.com/software/webservers/appserv/zos_os390/support/ .
  </UserResponse>
</Message>
<Message ID="CWSPN0026I" severity="I" prefix="yes">
  <MsgText pgmKey="security.spnego.reload.not.needed" varFormat="Java">
    security.spnego.reload.not.needed=CWSPN0026I: Reload of the TAI Properties is not needed. The file has not changed since the last reload.
  </MsgText>
  <Explanation>
    This exception is unexpected. The cause is not immediately known.
  </Explanation>
  <UserResponse>
    None, informational only.
  </UserResponse>
</Message>
<Message ID="CWSPN0014E" severity="E" prefix="yes">
  <MsgText pgmKey="security.spnego.kerberos.init.failed" varFormat="Java">
    security.spnego.kerberos.init.failed=CWSPN0014E: An exception occurred during Kerberos initialization. Failure: {0}.
  </MsgText>
  <Explanation>
    This exception is unexpected. The cause is not immediately known.
  </Explanation>
  <UserResponse>
    If the problem persists, additional information might be available if you search for the message ID on the following Web sites: WebSphere Application Server Support page: http://www.ibm.com/software/webservers/appserv/was/support/ WebSphere Application Server for z/OS Support page: http://www.ibm.com/software/webservers/appserv/zos_os390/support/ .
  </UserResponse>
</Message>
<Message ID="CWSPN0032W" severity="W" prefix="yes">
  <MsgText pgmKey="security.spnego.spnid.noprops" varFormat="Java">
    security.spnego.spnid.noprops=CWSPN0032W: Specify the SPNEGO TAI properties to be modified for spnId {0}.&quot;
  </MsgText>
  <Explanation>
    No SPNEGO TAI properties are defined in the security configuration for the given spnId.
  </Explanation>
  <UserResponse>
    Specify each of the SPNEGO TAI properties to be modified. If the selected property is not already defined, it will be defined.
  </UserResponse>
</Message>
<Message ID="CWSPN0046E" severity="E" prefix="yes">
  <MsgText pgmKey="security.spnego.malformed.iprange" varFormat="Java">
    security.spnego.malformed.iprange=CWSPN0046E: Malformed IP range specified. Found {0} rather than a wildcard.
  </MsgText>
  <Explanation>
    Bad IP range specfied.  Must contain only wildcards after the first range.
  </Explanation>
  <UserResponse>
    Ensure everything after the first range specified is a wildcard.
  </UserResponse>
</Message>
<Message ID="CWSPN0023I" severity="I" prefix="yes">
  <MsgText pgmKey="security.spnego.login" varFormat="Java">
    security.spnego.login=CWSPN0023I: User name {0} Token size {1}.
  </MsgText>
  <Explanation>
    This exception is unexpected. The cause is not immediately known.
  </Explanation>
  <UserResponse>
    None, informational only.
  </UserResponse>
</Message>
<Message ID="CWSPN0030W" severity="W" prefix="yes">
  <MsgText pgmKey="security.spnego.spnid.notavailable" varFormat="Java">
    security.spnego.spnid.notavailable=CWSPN0030W: spnId {0} is already defined in the SPNEGO TAI configuration.
  </MsgText>
  <Explanation>
    The given spnId value has already been defined in the SPNEGO TAI configuration.
  </Explanation>
  <UserResponse>
    Verify the SPNEGO TAI properties and specify a value that is not already used; or do not use the spnId option and a value will be automatically selected.
  </UserResponse>
</Message>
<Message ID="CWSPN0005E" severity="E" prefix="yes">
  <MsgText pgmKey="security.spnego.provider.failed" varFormat="Java">
    security.spnego.provider.failed=CWSPN0005E: An unexpected exception occurred when adding the SPNEGO security provider.
  </MsgText>
  <Explanation>
    The shown exception occurred when adding the SPNEGO security provider to security configuration.
  </Explanation>
  <UserResponse>
    If the problem persists, additional information might be available if you search for the message ID on the following Web sites: WebSphere Application Server Support page: http://www.ibm.com/software/webservers/appserv/was/support/ WebSphere Application Server for z/OS Support page: http://www.ibm.com/software/webservers/appserv/zos_os390/support/ .
  </UserResponse>
</Message>
<Message ID="CWSPN0044E" severity="E" prefix="yes">
  <MsgText pgmKey="security.spnego.krbconf.nodefaultrealm" varFormat="Java">
    security.spnego.krbconf.nodefaultrealm=CWSPN0044E: The default_realm in the [libdefaults] section is missing from the Kerberos configuration file (krb5.ini/krb5.conf).
  </MsgText>
  <Explanation>
    The Kerberos configuration file have no default_realm entry in the [libdefaults] section.
  </Explanation>
  <UserResponse>
    In the Kerberos configuration file, specify a default_realm=&lt;Kerberos realm name&gt; in the [libdefaults] section.
  </UserResponse>
</Message>
<Message ID="CWSPN0034I" severity="I" prefix="yes">
  <MsgText pgmKey="security.spnego.modifyprops" varFormat="Java">
    security.spnego.modifyprops=CWSPN0034I: SPNEGO TAI property {0} has been modified in the security configuration, its new value is: {1}, the previous value was: {2}.
  </MsgText>
  <Explanation>
    The SPNEGO TAI property modified in the security configuration and its current and previous values are shown.
  </Explanation>
  <UserResponse>
    None, informational only.
  </UserResponse>
</Message>
<Message ID="CWSPN0004E" severity="E" prefix="yes">
  <MsgText pgmKey="security.spnego.config.error" varFormat="Java">
    security.spnego.config.error=CWSPN0004E: Configuration Error: {0}.  All client access will be denied.
  </MsgText>
  <Explanation>
    The Service Provider Name found in the configuration properties has a null value and is not valid.
  </Explanation>
  <UserResponse>
    Verify and correct the configuration properties.
  </UserResponse>
</Message>
<Message ID="CWSPN0039W" severity="W" prefix="yes">
  <MsgText pgmKey="security.spnego.krbconf.pathinvalid" varFormat="Java">
    security.spnego.krbconf.pathinvalid=CWSPN0039W: Directory {0} does not exist or cannot be written, verify directory exists and is writable.
  </MsgText>
  <Explanation>
    The directory path of the Kerberos configuration file does not exist or cannot be written, verify directory exists and is writable.
  </Explanation>
  <UserResponse>
    Verify that all subdirectories in the specified directory path exist and are writable.
  </UserResponse>
</Message>
<Message ID="CWSPN0042W" severity="W" prefix="yes">
  <MsgText pgmKey="security.spnego.invalid.url" varFormat="Java">
    security.spnego.invalid.url=CWSPN0042W: One of the URLs specified is malformed.
  </MsgText>
  <Explanation>
    A MalformedURLException was encountered parsing one of the specified URLs.
  </Explanation>
  <UserResponse>
    Verify the URL syntax is correct.
  </UserResponse>
</Message>
<Message ID="CWSPN0009E" severity="E" prefix="yes">
  <MsgText pgmKey="security.spnego.init.failed" varFormat="Java">
    security.spnego.init.failed=CWSPN0009E: SPNEGO Trust Association Interceptor configuration is not valid. Failure condition: {0}. If you are not using the SPNEGO TAI, you can ignore this message.
  </MsgText>
  <Explanation>
    The configuration properties used to initialize the interceptor are not valid. The error condition that caused the failure is indicated.
  </Explanation>
  <UserResponse>
    Verify and correct the configuration properties. If you are not using the SPNEGO TAI, you can ignore this message.
  </UserResponse>
</Message>
<Message ID="CWSPN0017E" severity="E" prefix="yes">
  <MsgText pgmKey="security.spnego.allspns.init.failed" varFormat="Java">
    security.spnego.allspns.init.failed=CWSPN0017E: Unable to create GSSCredentials for any of the hosts specified in the configuration properties.
  </MsgText>
  <Explanation>
    This exception is unexpected. The cause is not immediately known.
  </Explanation>
  <UserResponse>
    If the problem persists, additional information might be available if you search for the message ID on the following Web sites: WebSphere Application Server Support page: http://www.ibm.com/software/webservers/appserv/was/support/ WebSphere Application Server for z/OS Support page: http://www.ibm.com/software/webservers/appserv/zos_os390/support/ .
  </UserResponse>
</Message>
<Message ID="CWSPN0016I" severity="I" prefix="yes">
  <MsgText pgmKey="security.spnego.spn.init.success" varFormat="Java">
    security.spnego.spn.init.success=CWSPN0016I: Ready to process host: {0}.
  </MsgText>
  <Explanation>
    This exception is unexpected. The cause is not immediately known.
  </Explanation>
  <UserResponse>
    None, informational only.
  </UserResponse>
</Message>
<Message ID="CWSPN0022E" severity="E" prefix="yes">
  <MsgText pgmKey="security.spnego.no.LtpaToken.found" varFormat="Java">
    security.spnego.no.LtpaToken.found=CWSPN0022E: Expected error. No LTPA Token found for: {0}. Redirection will not be attempted to avoid an infinite redirection loop.
  </MsgText>
  <Explanation>
    This exception is unexpected. The cause is not immediately known.
  </Explanation>
  <UserResponse>
    If the problem persists, additional information might be available if you search for the message ID on the following Web sites: WebSphere Application Server Support page: http://www.ibm.com/software/webservers/appserv/was/support/ WebSphere Application Server for z/OS Support page: http://www.ibm.com/software/webservers/appserv/zos_os390/support/ .
  </UserResponse>
</Message>
<Message ID="CWSPN0006I" severity="I" prefix="yes">
  <MsgText pgmKey="security.spnego.init.ok" varFormat="Java">
    security.spnego.init.ok=CWSPN0006I: SPNEGO Trust Association Interceptor initialization is complete. Configuration follows:
{0}
  </MsgText>
  <Explanation>
    Initialization of the SPNEGO Trust Association Interceptor has completed.
  </Explanation>
  <UserResponse>
    None, informational only.
  </UserResponse>
</Message>
<Message ID="CWSPN0040I" severity="I" prefix="yes">
  <MsgText pgmKey="security.spnego.krbconf.success" varFormat="Java">
    security.spnego.krbconf.success=CWSPN0040I: File {0} has been successfully created.
  </MsgText>
  <Explanation>
    The Kerberos configuration file has been successfully created.
  </Explanation>
  <UserResponse>
    None, informational only.
  </UserResponse>
</Message>
<Message ID="CWSPN0037W" severity="W" prefix="yes">
  <MsgText pgmKey="security.spnego.spnid.negative" varFormat="Java">
    security.spnego.spnid.negative=CWSPN0037W: spnId {0} is not valid, specify a non-negative value.
  </MsgText>
  <Explanation>
    The spnId value must be non-negative.
  </Explanation>
  <UserResponse>
    Specify a non-negative value for the given spnId.
  </UserResponse>
</Message>
<Message ID="CWSPN0001I" severity="I" prefix="yes">
  <MsgText pgmKey="security.spnego.init.start" varFormat="Java">
    security.spnego.init.start=CWSPN0001I: SPNEGO Trust Association Interceptor initialization started.
  </MsgText>
  <Explanation>
    Initialization of the SPNEGO Trust Association Interceptor has started.
  </Explanation>
  <UserResponse>
    None, informational only.
  </UserResponse>
</Message>
<Message ID="CWSPN0045E" severity="E" prefix="yes">
  <MsgText pgmKey="security.spnego.ipstring.convert.error" varFormat="Java">
    security.spnego.ipstring.convert.error=CWSPN0045E: Cannot convert the IP string {0} to an IP address.
  </MsgText>
  <Explanation>
    Conversion error occurred while converting IP string to an IP address
  </Explanation>
  <UserResponse>
    Validate the IP string provided.
  </UserResponse>
</Message>
<Message ID="CWSPN0008I" severity="I" prefix="yes">
  <MsgText pgmKey="security.spnego.remove.provider" varFormat="Java">
    security.spnego.remove.provider=CWSPN0008I: {0} security provider has been removed from the configuration.
  </MsgText>
  <Explanation>
    The SPNEGO security provider has been removed from the security configuration.
  </Explanation>
  <UserResponse>
    None, informational only.
  </UserResponse>
</Message>
<Message ID="CWSPN0025I" severity="I" prefix="yes">
  <MsgText pgmKey="security.spnego.reload.ok" varFormat="Java">
    security.spnego.reload.ok=CWSPN0025I: Reload of the TAI Properties Complete. Active configuration:
{0}
  </MsgText>
  <Explanation>
    This exception is unexpected. The cause is not immediately known.
  </Explanation>
  <UserResponse>
    None, informational only.
  </UserResponse>
</Message>
<Message ID="CWSPN0015E" severity="E" prefix="yes">
  <MsgText pgmKey="security.spnego.spn.init.failed" varFormat="Java">
    security.spnego.spn.init.failed=CWSPN0015E: Unable to create a GSSCredential for: {0}
  </MsgText>
  <Explanation>
    This exception is unexpected. The cause is not immediately known.
  </Explanation>
  <UserResponse>
    If the problem persists, additional information might be available if you search for the message ID on the following Web sites: WebSphere Application Server Support page: http://www.ibm.com/software/webservers/appserv/was/support/ WebSphere Application Server for z/OS Support page: http://www.ibm.com/software/webservers/appserv/zos_os390/support/ .
  </UserResponse>
</Message>
<Message ID="CWSPN0012W" severity="W" prefix="yes">
  <MsgText pgmKey="security.spnego.filter.init.null.string" varFormat="Java">
    security.spnego.filter.init.null.string=CWSPN0012W: A null string is not a valid filtering rule for the SPNEGO Trust Association Interceptor.
  </MsgText>
  <Explanation>
    A null string was used as the argument of the init() operation of the HTTPHeaderFilter.
  </Explanation>
  <UserResponse>
    Correct the filtering rule and restart the application server.
  </UserResponse>
</Message>
<!-- END MESSAGES -->
</TMSSource>
