<?xml version="1.0" encoding="UTF-8"?>
<?xml-stylesheet type="text/css" href="../../resources/stylesheets/wasmsgxml.css"?>
<TMSSource name="TivoliMessages" tmsVersion="1.0" xml:lang="en">
<!-- CMVC MSG File Name = @(#)SIB/ws/code/sib.mediation.session/src/com/ibm/ws/sib/mediation/session/CWSIMMessages.nlsprops, -->
<!-- DO NOT EDIT THIS FILE - This file was generated by the XML/Html & Property emitter -->
<!-- BEGIN MESSAGES -->
<Message ID="CWSIM0010E" severity="E" prefix="yes">
  <MsgText pgmKey="NO_SUCH_DESTINATION_CONFIG_CWSIM0010E" varFormat="Java">
    NO_SUCH_DESTINATION_CONFIG_CWSIM0010E=CWSIM0010E: Mediation {0} attempted to get the destination configuration for destination {1} on bus {2} but it does not exist.
  </MsgText>
  <Explanation>
    The mediation used the SIMediationSession object to get the destination configuration but the destination specified did not exist
  </Explanation>
  <UserResponse>
    Either create the destination the mediation is attempting to query or modify the mediation so that it does not query that destination.
  </UserResponse>
</Message>
<Message ID="CWSIM0002E" severity="E" prefix="yes">
  <MsgText pgmKey="NOT_AUTHORIZED_SEND_CWSIM0002E" varFormat="Java">
    NOT_AUTHORIZED_SEND_CWSIM0002E=CWSIM0002E: User {0} is not authorized to send to destination {1} on bus {2} in mediation {4} at destination {5} on bus {6} running on messaging engine {3}.
  </MsgText>
  <Explanation>
    The mediation used the SIMediationSession object to send a message but the run-as identity for the mediation does not have permission to put messages to the destination at the head of the forward routing path.
  </Explanation>
  <UserResponse>
    Use a different run-as identity for the mediation or give the existing run-as identity permission to access the destination.
  </UserResponse>
</Message>
<Message ID="CWSIM0009E" severity="E" prefix="yes">
  <MsgText pgmKey="INVALID_SIMESSAGE_IMPLEMENTATION_CWSIM0009E" varFormat="Java">
    INVALID_SIMESSAGE_IMPLEMENTATION_CWSIM0009E=CWSIM0009E: The message {0} cannot be sent by mediation {1} on messaging engine {2} on bus {3} as it is not a supported implementation of the SIMessage interface.
  </MsgText>
  <Explanation>
    An unsupported implementation of SIMessage interface was given to the SIMediationSession object.
  </Explanation>
  <UserResponse>
    Create an instance of the SIMessage interface using the APIs supplied.
  </UserResponse>
</Message>
<Message ID="CWSIM0011E" severity="E" prefix="yes">
  <MsgText pgmKey="NO_SUCH_DESTINATION_RECEIVE_CWSIM0011E" varFormat="Java">
    NO_SUCH_DESTINATION_RECEIVE_CWSIM0011E=CWSIM0011E: Mediation {0} attempted to receive a message from destination {1} on bus {2} but it does not exist.
  </MsgText>
  <Explanation>
    The mediation used the SIMediationSession object to receive a message but the destination specified does not exist.
  </Explanation>
  <UserResponse>
    Either create the destination the mediation is attempting to use or modify the mediation so that it does not route messages to that destination.
  </UserResponse>
</Message>
<Message ID="CWSIM0012E" severity="E" prefix="yes">
  <MsgText pgmKey="SIDESTINATION_ADDRESS_FACTORY_ERROR_CWSIM0012E" varFormat="Java">
    SIDESTINATION_ADDRESS_FACTORY_ERROR_CWSIM0012E=CWSIM0012E: An internal error occurred. The SIDestinationAddressFactory could not be obtained. Exception: {0}.
  </MsgText>
  <Explanation>
    This exception is unexpected. The cause is not immediately known.
  </Explanation>
  <UserResponse>
    If the problem persists, additional information might be available if you search for the message ID on the following Web sites: WebSphere Application Server Support page: http://www.ibm.com/software/webservers/appserv/was/support/ WebSphere Application Server for z/OS Support page: http://www.ibm.com/software/webservers/appserv/zos_os390/support/ .
  </UserResponse>
</Message>
<Message ID="CWSIM0003E" severity="E" prefix="yes">
  <MsgText pgmKey="NO_SUCH_DESTINATION_SEND_CWSIM0003E" varFormat="Java">
    NO_SUCH_DESTINATION_SEND_CWSIM0003E=CWSIM0003E: Mediation {0} attempted to send a message to destination {1} on bus {2} but that destination does not exist.
  </MsgText>
  <Explanation>
    The mediation used the SIMediationSession object to send a message but the destination at the head of the forward routing path does not exist.
  </Explanation>
  <UserResponse>
    Create the destination that the mediation is attempting to use, or change the mediation so that it does not route messages to that destination.
  </UserResponse>
</Message>
<Message ID="CWSIM9999E" severity="E" prefix="yes">
  <MsgText pgmKey="TEMPORARY_CWSIM9999" varFormat="Java">
    TEMPORARY_CWSIM9999=CWSIM9999E: {0}
  </MsgText>
  <Explanation>
    If the message does not give sufficient information, see the accompanying error messages for further information.
  </Explanation>
  <UserResponse>
    See the accompanying error messages for further information.
  </UserResponse>
</Message>
<Message ID="CWSIM0004E" severity="E" prefix="yes">
  <MsgText pgmKey="MESSAGE_FORMAT_EXCEPTION_CWSIM0004E" varFormat="Java">
    MESSAGE_FORMAT_EXCEPTION_CWSIM0004E=CWSIM0004E: An internal error occurred. The message {0} received from destination {1} by mediation {2} from messaging engine {3} on bus {4} could not be converted to an SIMessage.
  </MsgText>
  <Explanation>
    This exception is unexpected. The cause is not immediately known.
  </Explanation>
  <UserResponse>
    If the problem persists, additional information might be available if you search for the message ID on the following Web sites: WebSphere Application Server Support page: http://www.ibm.com/software/webservers/appserv/was/support/ WebSphere Application Server for z/OS Support page: http://www.ibm.com/software/webservers/appserv/zos_os390/support/ .
  </UserResponse>
</Message>
<Message ID="CWSIM0015E" severity="E" prefix="yes">
  <MsgText pgmKey="NOT_AUTHORIZED_RECEIVE_CWSIM0015E" varFormat="Java">
    NOT_AUTHORIZED_RECEIVE_CWSIM0015E=CWSIM0015E: User {0} is not authorized to receive from destination {1} on bus {2} in mediation {4} at destination {5} on bus {6} running on messaging engine {3}.
  </MsgText>
  <Explanation>
    The mediation used the SIMediationSession object to receive a message from a destination but the run-as identity for the mediation does not have permission to access the destination.
  </Explanation>
  <UserResponse>
    Modify the mediation so that it uses a different run-as identity, or give the run-as identity permission to access the destination.
  </UserResponse>
</Message>
<Message ID="CWSIM0001E" severity="E" prefix="yes">
  <MsgText pgmKey="UNEXPECTED_EXCEPTION_CWSIM0001E" varFormat="Java">
    UNEXPECTED_EXCEPTION_CWSIM0001E=CWSIM0001E: An unexpected error occurred. Unable to apply mediation {0} on messaging engine {1} for bus {2}. Exception: {3}
  </MsgText>
  <Explanation>
    This exception is unexpected. The cause is not immediately known.
  </Explanation>
  <UserResponse>
    If the problem persists, additional information might be available if you search for the message ID on the following Web sites: WebSphere Application Server Support page: http://www.ibm.com/software/webservers/appserv/was/support/ WebSphere Application Server for z/OS Support page: http://www.ibm.com/software/webservers/appserv/zos_os390/support/ .
  </UserResponse>
</Message>
<Message ID="CWSIM0014E" severity="E" prefix="yes">
  <MsgText pgmKey="NOT_AUTHORIZED_DEFINITION_CWSIM0014E" varFormat="Java">
    NOT_AUTHORIZED_DEFINITION_CWSIM0014E=CWSIM0014E: User {0} is not authorized to access the definition of destination {1} on bus {2} in mediation {4} at destination {5} on bus {6} running on messaging engine {3}.
  </MsgText>
  <Explanation>
    The mediation attempted to use the SIMediationSession object to access the configuration for a bus destination, but the run-as identity for the mediation does not have permission to access the destination.
  </Explanation>
  <UserResponse>
    Modify the mediation so that it uses a different identity, or give the run-as identity permission to access the destination.
  </UserResponse>
</Message>
<Message ID="CWSIM0017E" severity="E" prefix="yes">
  <MsgText pgmKey="MEDIATION_IDENTITY_UNKNOWN_CWSIM0017E" varFormat="Java">
    MEDIATION_IDENTITY_UNKNOWN_CWSIM0017E=CWSIM0017E: An internal error occurred. The mediation {0} at destination {1} on bus {2} running on messaging engine {3} is unable to determine the current run-as identity.
  </MsgText>
  <Explanation>
    This exception is unexpected. The cause is not immediately known.
  </Explanation>
  <UserResponse>
    If the problem persists, additional information might be available if you search for the message ID on the following Web sites: WebSphere Application Server Support page: http://www.ibm.com/software/webservers/appserv/was/support/ WebSphere Application Server for z/OS Support page: http://www.ibm.com/software/webservers/appserv/zos_os390/support/ .
  </UserResponse>
</Message>
<Message ID="CWSIM0013E" severity="E" prefix="yes">
  <MsgText pgmKey="NOT_AUTHORIZED_ACCESS_CWSIM0013E" varFormat="Java">
    NOT_AUTHORIZED_ACCESS_CWSIM0013E=CWSIM0013E: User {0} is not authorized to access the bus {1} in mediation {2} at destination {3} on bus {4} running on messaging engine {5}.
  </MsgText>
  <Explanation>
    The mediation used the SIMediationSession object to access a bus destination but the run-as identity for the mediation does not have permission to access the bus.
  </Explanation>
  <UserResponse>
    Change the run-as identity used by the mediation, or give the existing run-as identity permission to to access the bus.
  </UserResponse>
</Message>
<!-- END MESSAGES -->
</TMSSource>
