<?xml version="1.0" encoding="UTF-8"?>
<?xml-stylesheet type="text/css" href="../../resources/stylesheets/wasmsgxml.css"?>
<TMSSource name="TivoliMessages" tmsVersion="1.0" xml:lang="en">
<!-- CMVC MSG File Name = SERV1/ws/code/websvcs.admin.impl/src/com/ibm/ws/webservices/admin/resources/websvcsAdmin.nlsprops -->
<!-- DO NOT EDIT THIS FILE - This file was generated by the XML/Html & Property emitter -->
<!-- BEGIN MESSAGES -->
<Message ID="CWSAD0058E" severity="E" prefix="yes">
  <MsgText pgmKey="CWSAD0058E" varFormat="Java">
    CWSAD0058E=CWSAD0058E: Cannot find a key within hash table for the update module {0}.
  </MsgText>
  <Explanation>
    The hash table does not contains the EJB JAR information from application installation operation. Error may be caused by using incorrect application or inputs parameters.
  </Explanation>
  <UserResponse>
    Check with the installation inputs or scripts or provide a correct application.
  </UserResponse>
</Message>
<Message ID="CWSAD0022E" severity="E" prefix="yes">
  <MsgText pgmKey="CWSAD0022E" varFormat="Java">
    CWSAD0022E=CWSAD0022E: The logical endpoint name is missing in the parameter.
  </MsgText>
  <Explanation>
    The logical endpoint name is required in the parameter for the specific MBean operation.
  </Explanation>
  <UserResponse>
    Provide the logical endpoint name in the parameter.
  </UserResponse>
</Message>
<Message ID="CWSAD0018E" severity="E" prefix="yes">
  <MsgText pgmKey="CWSAD0018E" varFormat="Java">
    CWSAD0018E=CWSAD0018E: The administrative command cannot find {0} for {1} assets.
  </MsgText>
  <Explanation>
    The specified asset name cannot be found.
  </Explanation>
  <UserResponse>
    Provide the correct asset name.
  </UserResponse>
</Message>
<Message ID="CWSAD0097E" severity="E" prefix="yes">
  <MsgText pgmKey="CWSAD0097E" varFormat="Java">
    CWSAD0097E=CWSAD0097E: URLPrefixMap Validation Error: Problems were encountered while reading the properties for the URL=&quot;{0}&quot; at module =&quot;{1}&quot; 
error encountered=&quot;{2}&quot;
  </MsgText>
  <Explanation>
    Problems were encountered while reading properties within specified URL.
  </Explanation>
  <UserResponse>
    Ensure that properties are specified correctly.
  </UserResponse>
</Message>
<Message ID="CWSAD0061E" severity="E" prefix="yes">
  <MsgText pgmKey="CWSAD0061E" varFormat="Java">
    CWSAD0061E=CWSAD0061E: No target mapping information is found on the deployed module {0}.
  </MsgText>
  <Explanation>
    This could be either an user error or IBM internal error.
  </Explanation>
  <UserResponse>
    Provide the correct module for update or check with the deployment inputs or scripts.
  </UserResponse>
</Message>
<Message ID="CWSAD0057E" severity="E" prefix="yes">
  <MsgText pgmKey="CWSAD0057E" varFormat="Java">
    CWSAD0057E=CWSAD0057E: Ejb jar and its JMS router JAR module are not targeted to the same server. EJB JAR has target of {0} and JMS router JAR module has target of {1}.
  </MsgText>
  <Explanation>
    The destinations of EJB JAR and its JMS router JAR module are not the same.
  </Explanation>
  <UserResponse>
    Check with the installation inputs and scripts or provide a correct application. Sometimes, you may need to provide explicit server information for installation.
  </UserResponse>
</Message>
<Message ID="CWSAD0021E" severity="E" prefix="yes">
  <MsgText pgmKey="CWSAD0021E" varFormat="Java">
    CWSAD0021E=CWSAD0021E: The command parameters contain the following conflicting properties: {0}
  </MsgText>
  <Explanation>
    No more than one asset type is allowed in the query properties.
  </Explanation>
  <UserResponse>
    Provide no more than one asset type.
  </UserResponse>
</Message>
<Message ID="CWSAD0017E" severity="E" prefix="yes">
  <MsgText pgmKey="CWSAD0017E" varFormat="Java">
    CWSAD0017E=CWSAD0017E: The node has not been added because the Feature Pack for Web Services is installed on the deployment manager node and the {0} node is prior to the WebSphere 6.1 level.
  </MsgText>
  <Explanation>
    The Feature Pack for Web Services is installed on the deployment manager node but the managed node is prior to the WebSphere 6.1 level.
  </Explanation>
  <UserResponse>
    Install the same level of the Feature Pack for Web Services on the managed node or upgrade it to the WebSphere 6.1 level before attempting to add the managed node.
  </UserResponse>
</Message>
<Message ID="CWSAD0016W" severity="W" prefix="yes">
  <MsgText pgmKey="CWSAD0016W" varFormat="Java">
    CWSAD0016W=CWSAD0016W: The target module {0} on node {1} cannot be reached because the module and the node require the Feature Pack for Web Services.
  </MsgText>
  <Explanation>
    The module contains JAX-WS Web Services and requires the Feature Pack for Web Services. To map a Web module from an application that requires feature pack functionality even though the Web server does not have feature pack functionality, define the Web server on a node with feature pack augmentation.
  </Explanation>
  <UserResponse>
    Install the Feature Pack for Web Services on the target node.
  </UserResponse>
</Message>
<Message ID="CWSAD0096E" severity="E" prefix="yes">
  <MsgText pgmKey="CWSAD0096E" varFormat="Java">
    CWSAD0096E=CWSAD0096E: URLPrefixMap Validation Errors encountered.  See trace file for additional details.
  </MsgText>
  <Explanation>
    Validation errors were encountered.
  </Explanation>
  <UserResponse>
    Look at trace file for additional details.
  </UserResponse>
</Message>
<Message ID="CWSAD0060E" severity="E" prefix="yes">
  <MsgText pgmKey="CWSAD0060E" varFormat="Java">
    CWSAD0060E=CWSAD0060E: The deployed server target {0} for module {1} is not matching to the update application server target {2} for module {3}.
  </MsgText>
  <Explanation>
    The update module has server target which is different than the server target of deployed module. EJB and its related router modules cannot have different server targets.
  </Explanation>
  <UserResponse>
    Provide the correct module for update, check the deployment inputs or scripts, or make sure EJB and its related router modules have the same server targets.
  </UserResponse>
</Message>
<Message ID="CWSAD0056E" severity="E" prefix="yes">
  <MsgText pgmKey="CWSAD0056E" varFormat="Java">
    CWSAD0056E=CWSAD0056E: Cannot find the target server corresponding to the JMS router JAR module with hash table for key {0}
  </MsgText>
  <Explanation>
    The hash table does not contains the server string for a particular key. Error may be caused by using incorrect inputs parameters of application.
  </Explanation>
  <UserResponse>
    Check with the installation inputs or scripts or provide a correct application. If all correct, contact IBM support.
  </UserResponse>
</Message>
<Message ID="CWSAD0020E" severity="E" prefix="yes">
  <MsgText pgmKey="CWSAD0020E" varFormat="Java">
    CWSAD0020E=CWSAD0020E: The command parameters contain the following not valid property values: {0}
  </MsgText>
  <Explanation>
    The command parameters contain one or multiple not valid property values.
  </Explanation>
  <UserResponse>
    Provide the correct command parameters.
  </UserResponse>
</Message>
<Message ID="CWSAD0095E" severity="E" prefix="yes">
  <MsgText pgmKey="CWSAD0095E" varFormat="Java">
    CWSAD0095E=CWSAD0095E: URLPrefixMap Validation Error: host and port values missing in HTTP URL=&quot;{0}&quot;
  </MsgText>
  <Explanation>
    The HTTP URL fragment provided is missing either the required host or port values.
  </Explanation>
  <UserResponse>
    Add the necessary host and port to the specified URL.
  </UserResponse>
</Message>
<Message ID="CWSAD0055E" severity="E" prefix="yes">
  <MsgText pgmKey="CWSAD0055E" varFormat="Java">
    CWSAD0055E=CWSAD0055E: Ejb jar and its HTTP router WAR module are not targeted to the same server. EJB JAR has the target of {0} and HTTP router WAR module has the target of {1}.
  </MsgText>
  <Explanation>
    The destinations of EJB JAR and its HTTP router WAR module are not the same.
  </Explanation>
  <UserResponse>
    Check with the installation inputs and scripts or provide a correct application. Sometimes, you may need to provide explicit server information for installation.
  </UserResponse>
</Message>
<Message ID="CWSAD0015E" severity="E" prefix="yes">
  <MsgText pgmKey="CWSAD0015E" varFormat="Java">
    CWSAD0015E=CWSAD0015E: The node has not been added because the Feature Pack for Web Services is installed on the {0} node and not on the deployment manager node.
  </MsgText>
  <Explanation>
    The Feature Pack for Web Services is not installed on the deployment manager node but has been installed on the managed node.
  </Explanation>
  <UserResponse>
    Install the same level or a higher version of the Feature Pack for Web Services on the deployment manager node before attempting to add the managed node.
  </UserResponse>
</Message>
<Message ID="CWSAD0094E" severity="E" prefix="yes">
  <MsgText pgmKey="CWSAD0094E" varFormat="Java">
    CWSAD0094E=CWSAD0094E: URLPrefixMap Validation Error: Invalid Protocol(&quot;{0}&quot;), used in an {1} URL=&quot;{2}&quot;, at module=&quot;{3}&quot;. 
Expected Protocols are:&quot;{4}&quot;
  </MsgText>
  <Explanation>
    Invalid protocol found in supplied URL.
  </Explanation>
  <UserResponse>
    Use a valid protocol.
  </UserResponse>
</Message>
<Message ID="CWSAD0054E" severity="E" prefix="yes">
  <MsgText pgmKey="CWSAD0054E" varFormat="Java">
    CWSAD0054E=CWSAD0054E: Cannot find the target server corresponding to the HTTP router WAR module within hash table for key {0}.
  </MsgText>
  <Explanation>
    The hash table does not contains the server string for a particular key. Error may be caused by using incorrect inputs parameters or application.
  </Explanation>
  <UserResponse>
    Check with the installation inputs or scripts or provide a correct application.
  </UserResponse>
</Message>
<Message ID="CWSAD0014E" severity="E" prefix="yes">
  <MsgText pgmKey="CWSAD0014E" varFormat="Java">
    CWSAD0014E=CWSAD0014E: The node has not been added because the version of the Feature Pack for Web Services that is installed on the {0} deployment manager is earlier than the version that is installed on {1} node.
  </MsgText>
  <Explanation>
    The version of the Feature Pack for Web Services that is installed on the deployment manager node must be at the same level or higher than the version that is installed on the node.
  </Explanation>
  <UserResponse>
    Install the same version or a higher version of the Feature Pack for Web Services on the deployment manager node before running the addNode command.
  </UserResponse>
</Message>
<Message ID="CWSAD0049W" severity="W" prefix="yes">
  <MsgText pgmKey="CWSAD0049W" varFormat="Java">
    CWSAD0049W=CWSAD0049W: The binding file of update EJB jar {0} contains JMS router module {1}, but the binding file of deployed EJB jar has no JMS router module.
  </MsgText>
  <Explanation>
    The update EJB jar bindings has an extra HTTP router module than the deployed EJB jar binding.
  </Explanation>
  <UserResponse>
    Provide the correct ejb jar for update or correct the bindings.
  </UserResponse>
</Message>
<Message ID="CWSAD0093E" severity="E" prefix="yes">
  <MsgText pgmKey="CWSAD0093E" varFormat="Java">
    CWSAD0093E=CWSAD0093E: URLPrefixMap Validation Error: Invalid &quot;{0}&quot; URL fragment=&quot;{1}&quot;, at module=&quot;{2}&quot;, {3}
  </MsgText>
  <Explanation>
    A malformed URL was specified.  Error message indicates more details.
  </Explanation>
  <UserResponse>
    See the associated error message for details regarding the errors encountered while parsing the URL fragment.  Correct the URL fragment provided in the properties file.
  </UserResponse>
</Message>
<Message ID="CWSAD0089E" severity="E" prefix="yes">
  <MsgText pgmKey="CWSAD0089E" varFormat="Java">
    CWSAD0089E=CWSAD0089E: URLPrefixMap Validation Error: It is incorrect to use the JMS property name(&quot;{0}&quot;) for a Web Services 
enabled Web module (&quot;{1}&quot;).  The valid URL Prefix Map property name for a Web services enabled Web module is: &quot;{2}&quot;
  </MsgText>
  <Explanation>
    In a Web services enabled Web module, you can only use http as a property name for the URL Prefix Map.
  </Explanation>
  <UserResponse>
    Use appropriate http property name for a Web services enabled Web module.
  </UserResponse>
</Message>
<Message ID="CWSAD0053E" severity="E" prefix="yes">
  <MsgText pgmKey="CWSAD0053E" varFormat="Java">
    CWSAD0053E=CWSAD0053E: The unique key for router {0} cannot be found from key set of hash table.
  </MsgText>
  <Explanation>
    The hash table does not contains the router module information. Error may be caused by using incorrect application or inputs parameters.
  </Explanation>
  <UserResponse>
    Check with the installation inputs or scripts or provide a correct application.
  </UserResponse>
</Message>
<Message ID="CWSAD0013E" severity="E" prefix="yes">
  <MsgText pgmKey="CWSAD0013E" varFormat="Java">
    CWSAD0013E=CWSAD0013E: The specified {0} file name cannot be found.
  </MsgText>
  <Explanation>
    The specified file name cannot be located in the configuration repository.
  </Explanation>
  <UserResponse>
    Provide the correct file name that can be found in the repository.
  </UserResponse>
</Message>
<Message ID="CWSAD0009E" severity="E" prefix="yes">
  <MsgText pgmKey="CWSAD0009E" varFormat="Java">
    CWSAD0009E=CWSAD0009E: There is no Web service in the {0} services index file.
  </MsgText>
  <Explanation>
    The services index file has no entry for a Web service. The file might not be usable.
  </Explanation>
  <UserResponse>
    If the file was manually modified, uninstall and reinstall the service. If this was an internal error, check the servicesIndex.xml and follow the usual steps of debugging errors with the product.
  </UserResponse>
</Message>
<Message ID="CWSAD0092E" severity="E" prefix="yes">
  <MsgText pgmKey="CWSAD0092E" varFormat="Java">
    CWSAD0092E=CWSAD0092E: URLPrefixMap Validation Error: Unrecognized property name &quot;{0}&quot;, at module=&quot;{1}&quot;.  
The valid URL Prefix Map property names for a Web services enabled Enterprise JavaBeans (EJB) module are:  &quot;{2}&quot;, &quot;{3}&quot; and &quot;{4}&quot;
  </MsgText>
  <Explanation>
    In a Web services enabled EJB module, you can only use the following property names: http, jms, and ejb.
  </Explanation>
  <UserResponse>
    Use appropriate property names for a Web services enabled EJB module.
  </UserResponse>
</Message>
<Message ID="CWSAD0088E" severity="E" prefix="yes">
  <MsgText pgmKey="CWSAD0088E" varFormat="Java">
    CWSAD0088E=CWSAD0088E: The input parameter {0} contains malformed sub-string {1}. It should be in the format of name=value.
  </MsgText>
  <Explanation>
    A sub-string in the input parameter is not in the format of name=value.
  </Explanation>
  <UserResponse>
    Provide the input parameter in the format of name value pairs such as name1=value1,name2=value2.
  </UserResponse>
</Message>
<Message ID="CWSAD0052E" severity="E" prefix="yes">
  <MsgText pgmKey="CWSAD0052E" varFormat="Java">
    CWSAD0052E=CWSAD0052E: Cannot find the server string corresponding to the EJB JAR within hash table for key {0}.
  </MsgText>
  <Explanation>
    The hash table does not contains the server string for a particular key. Error may be caused by using incorrect application or inputs parameters.
  </Explanation>
  <UserResponse>
    Check with the installation inputs or scripts or provide a correct application.
  </UserResponse>
</Message>
<Message ID="CWSAD0048E" severity="E" prefix="yes">
  <MsgText pgmKey="CWSAD0048E" varFormat="Java">
    CWSAD0048E=CWSAD0048E: The binding file of update EJB jar {0} has a different JMS router module name {1} than the deployed JMS router module name {2}.
  </MsgText>
  <Explanation>
    The binding has a new JMS router module name than the one on deployed binding.
  </Explanation>
  <UserResponse>
    Provide the correct ejb jar for update or correct the bindings.
  </UserResponse>
</Message>
<Message ID="CWSAD0012E" severity="E" prefix="yes">
  <MsgText pgmKey="CWSAD0012E" varFormat="Java">
    CWSAD0012E=CWSAD0012E: The {0} file name that is provided cannot be used.
  </MsgText>
  <Explanation>
    The file name must not contain slashes, directory or path name.
  </Explanation>
  <UserResponse>
    Provide the correct file name without the slashes, directory or path name.
  </UserResponse>
</Message>
<Message ID="CWSAD0008E" severity="E" prefix="yes">
  <MsgText pgmKey="CWSAD0008E" varFormat="Java">
    CWSAD0008E=CWSAD0008E: The administrative command found multiple services index files for {0} service and {1} module.
  </MsgText>
  <Explanation>
    Multiple services index files were found when only one service index file is expected.
  </Explanation>
  <UserResponse>
    This is an internal error, no user action is required.
  </UserResponse>
</Message>
<Message ID="CWSAD0047W" severity="W" prefix="yes">
  <MsgText pgmKey="CWSAD0047W" varFormat="Java">
    CWSAD0047W=CWSAD0047W: No matched JMS router module is found within the update EJB jar {0} binding file.
  </MsgText>
  <Explanation>
    No JMS router module is found within update EJB jar binding while there is a JMS router module defined in deployed EJB binding.
  </Explanation>
  <UserResponse>
    Provide the correct EJB jar for update or correct the bindings.
  </UserResponse>
</Message>
<Message ID="CWSAD0091E" severity="E" prefix="yes">
  <MsgText pgmKey="CWSAD0091E" varFormat="Java">
    CWSAD0091E=CWSAD0091E: URLPrefixMap Validation Error: Unrecognized property name &quot;{0}&quot;, at module=&quot;{1}&quot;.  
The valid URL Prefix Map property name for a Web services enabled Web module is:  &quot;{2}&quot;
  </MsgText>
  <Explanation>
    In a Web services enabled Web module, you can only use http as a property name for the URL Prefix Map.
  </Explanation>
  <UserResponse>
    Use appropriate http property name for a Web services enabled Web module.
  </UserResponse>
</Message>
<Message ID="CWSAD0087E" severity="E" prefix="yes">
  <MsgText pgmKey="CWSAD0087E" varFormat="Java">
    CWSAD0087E=CWSAD0087E: The MBean operation {0} is not supported for the service {1}.
  </MsgText>
  <Explanation>
    This service does not support the operational control at the service or endpoint level. Therefore, the MBean operation is not supported.
  </Explanation>
  <UserResponse>
    Do not invoke the MBean operation for the specified service.
  </UserResponse>
</Message>
<Message ID="CWSAD0051E" severity="E" prefix="yes">
  <MsgText pgmKey="CWSAD0051E" varFormat="Java">
    CWSAD0051E=CWSAD0051E: Cannot find a key within hash table for EJB JAR {0}.
  </MsgText>
  <Explanation>
    The hash table does not contains the EJB JAR information from application installation operation. Error may be caused by using incorrect application or inputs parameters.
  </Explanation>
  <UserResponse>
    Check with the installation inputs or scripts or provide a correct application.
  </UserResponse>
</Message>
<Message ID="CWSAD0011E" severity="E" prefix="yes">
  <MsgText pgmKey="CWSAD0011E" varFormat="Java">
    CWSAD0011E=CWSAD0011E: There is no operation for the {0} logical endpoint.
  </MsgText>
  <Explanation>
    The services index file has no operation for the endpoint. The file might not be usable.
  </Explanation>
  <UserResponse>
    If the file was manually modified, uninstall and reinstall the service. If this was an internal error, check the servicesIndex.xml and follow the usual steps of debugging errors with the product.
  </UserResponse>
</Message>
<Message ID="CWSAD0050W" severity="W" prefix="yes">
  <MsgText pgmKey="CWSAD0050W" varFormat="Java">
    CWSAD0050W=CWSAD0050W: No binding information is found within the update EJB jar {0}.
  </MsgText>
  <Explanation>
    The binding file is missing from the update EJB jar.
  </Explanation>
  <UserResponse>
    Provide the correct ejb jar for update or correct the bindings.
  </UserResponse>
</Message>
<Message ID="CWSAD0046W" severity="W" prefix="yes">
  <MsgText pgmKey="CWSAD0046W" varFormat="Java">
    CWSAD0046W=CWSAD0046W: The binding file of update EJB jar {0} contains HTTP router module {1}, but the binding file of deployed EJB jar has no HTTP router module.
  </MsgText>
  <Explanation>
    The update EJB jar bindings has an extra HTTP router module than the deployed EJB binding.
  </Explanation>
  <UserResponse>
    Provide the correct ejb jar for update or correc the bindings.
  </UserResponse>
</Message>
<Message ID="CWSAD0090E" severity="E" prefix="yes">
  <MsgText pgmKey="CWSAD0090E" varFormat="Java">
    CWSAD0090E=CWSAD0090E: URLPrefixMap Validation Error: It is incorrect to use the Enterprise JavaBean (EJB) property name(&quot;{0}&quot;) 
for a Web Services enabled web module (&quot;{1}&quot;).  The valid URL Prefix Map property name for a Web services enabled Web module is:  &quot;{2}&quot;
  </MsgText>
  <Explanation>
    In a Web services enabled Web module, you can only use http as a property name for the URL Prefix Map.
  </Explanation>
  <UserResponse>
    Use appropriate http property name for a Web services enabled Web module.
  </UserResponse>
</Message>
<Message ID="CWSAD0086E" severity="E" prefix="yes">
  <MsgText pgmKey="CWSAD0086E" varFormat="Java">
    CWSAD0086E=CWSAD0086E: Cannot stop the service listener for service {0}. You must stop the containing asset instead.
  </MsgText>
  <Explanation>
    This service does not support the operational control at the service or endpoint level.
  </Explanation>
  <UserResponse>
    Stop the asset that contains the service.
  </UserResponse>
</Message>
<Message ID="CWSAD0010E" severity="E" prefix="yes">
  <MsgText pgmKey="CWSAD0010E" varFormat="Java">
    CWSAD0010E=CWSAD0010E: There is no logical endpoint in {0} service.
  </MsgText>
  <Explanation>
    The services index file has no entry for a logical endpoint. The file might not be usable.
  </Explanation>
  <UserResponse>
    If the file was manually modified, uninstall and reinstall the service. If this was an internal error, check the servicesIndex.xml and follow the usual steps of debugging errors with the product.
  </UserResponse>
</Message>
<Message ID="CWSAD0006E" severity="E" prefix="yes">
  <MsgText pgmKey="CWSAD0006E" varFormat="Java">
    CWSAD0006E=CWSAD0006E: The administrative command cannot find {0} logical endpoint.
  </MsgText>
  <Explanation>
    The specified logical endpoint cannot be found in the serivce.
  </Explanation>
  <UserResponse>
    Provide a logical endpoint name.
  </UserResponse>
</Message>
<Message ID="CWSAD0085E" severity="E" prefix="yes">
  <MsgText pgmKey="CWSAD0085E" varFormat="Java">
    CWSAD0085E=CWSAD0085E: Cannot start the service listener for service {0}. You must start the containing asset instead.
  </MsgText>
  <Explanation>
    This service does not support the operational control at the service or endpoint level.
  </Explanation>
  <UserResponse>
    Start the asset that contains the service.
  </UserResponse>
</Message>
<Message ID="CWSAD0045E" severity="E" prefix="yes">
  <MsgText pgmKey="CWSAD0045E" varFormat="Java">
    CWSAD0045E=CWSAD0045E: The binding file of update EJB jar {0} has a different HTTP router module name {1} than the deployed HTTP router module name {2}.
  </MsgText>
  <Explanation>
    The binding has a new HTTP router module name than the one on deployed binding.
  </Explanation>
  <UserResponse>
    Provide the correct ejb jar for update or correct the bindings.
  </UserResponse>
</Message>
<Message ID="CWSAD0005E" severity="E" prefix="yes">
  <MsgText pgmKey="CWSAD0005E" varFormat="Java">
    CWSAD0005E=CWSAD0005E: The administrative command cannot find {0} Web service.
  </MsgText>
  <Explanation>
    The Web services cannot be found in the module.
  </Explanation>
  <UserResponse>
    Ensure that the module has a Web service and that the service name is correct.
  </UserResponse>
</Message>
<Message ID="CWSAD0044W" severity="W" prefix="yes">
  <MsgText pgmKey="CWSAD0044W" varFormat="Java">
    CWSAD0044W=CWSAD0044W: No matched HTTP router module {0} is found within the update EJB jar {0} binding file.
  </MsgText>
  <Explanation>
    No HTTP router module is found within the update EJB jar binding while there is a HTTP router module defined in deployed EJB binding.
  </Explanation>
  <UserResponse>
    Provide the correct EJB jar for update or correct the bindings.
  </UserResponse>
</Message>
<Message ID="CWSAD0108W" severity="W" prefix="yes">
  <MsgText pgmKey="CWSAD0108W" varFormat="Java">
    CWSAD0108W=CWSAD0108W: Unable to deploy the {0} application on the {1} node because it contains an attachment to a policy set that requires version {2} or later of WebSphere Application Server to be installed on the node.
  </MsgText>
  <Explanation>
    The application contains an attachment to a policy set with a policy type that requires the specified minimum version of the application server. The node currently has an earlier version of this product installed.
  </Explanation>
  <UserResponse>
    Target the application to a node that is at the specified minimum version of the application server, or install the specified minimum version of the application server on the target node.
  </UserResponse>
</Message>
<Message ID="CWSAD0084E" severity="E" prefix="yes">
  <MsgText pgmKey="CWSAD0084E" varFormat="Java">
    CWSAD0084E=CWSAD0084E: The asset is not installed on the target {0}.
  </MsgText>
  <Explanation>
    The asset is not installed on the specified server target or cluster target.
  </Explanation>
  <UserResponse>
    Provide the correct server target or cluster target.
  </UserResponse>
</Message>
<Message ID="CWSAD0004E" severity="E" prefix="yes">
  <MsgText pgmKey="CWSAD0004E" varFormat="Java">
    CWSAD0004E=CWSAD0004E: The administrative command cannot find {0} module.
  </MsgText>
  <Explanation>
    The module cannot be found in the service package.
  </Explanation>
  <UserResponse>
    Provide the correct module name for the service package.
  </UserResponse>
</Message>
<Message ID="CWSAD0079W" severity="W" prefix="yes">
  <MsgText pgmKey="CWSAD0079W" varFormat="Java">
    CWSAD0079W=CWSAD0079W: Unable to deploy the application {0} on the node {1} because the node version defined in the binding definition file for the application specific binding is later than the version of the target node.
  </MsgText>
  <Explanation>
    The application specific binding, which is defined in the specified application, requires WebSphere Application Server Version 7.0 or later.
  </Explanation>
  <UserResponse>
    Target the application to a node that is at WebSphere Application Server Version 7.0 or later.
  </UserResponse>
</Message>
<Message ID="CWSAD0043W" severity="W" prefix="yes">
  <MsgText pgmKey="CWSAD0043W" varFormat="Java">
    CWSAD0043W=CWSAD0043W: The number of router modules is not consistance. The binding file of update EJB jar {0} has defined {1} router modules while the binding file of deployed EJB jar {0} has defined {2} router modules.
  </MsgText>
  <Explanation>
    The number of router modules defined for the update EJB jar are not as same as the number found on the deployed EJB jar.
  </Explanation>
  <UserResponse>
    Provide the correct EJB jar for update or correct the binding file.
  </UserResponse>
</Message>
<Message ID="CWSAD0107W" severity="W" prefix="yes">
  <MsgText pgmKey="CWSAD0107W" varFormat="Java">
    CWSAD0107W=CWSAD0107W: Unable to deploy the {0} application on the {1} node because it contains configuration for WS-Policy that requires version {2} or later of WebSphere Application Server to be installed on the node.
  </MsgText>
  <Explanation>
    The application contains configuration files that define how WS-Policy is configured. The application requires the specified minimum version of the application server. The node currently has an earlier version of this product installed.
  </Explanation>
  <UserResponse>
    Target the application to a node that is at the specified minimum version of the application server, or install the specified minimum version of the application server on the target node.
  </UserResponse>
</Message>
<Message ID="CWSAD0039W" severity="W" prefix="yes">
  <MsgText pgmKey="CWSAD0039W" varFormat="Java">
    CWSAD0039W=CWSAD0039W: The extended status report data from a downstream server {0} is not of expected type. The expected type is EndpointStatusReportExtendedData, but the actual type is {1}.
  </MsgText>
  <Explanation>
    The extended status report data fro ma downstream server should be of EndpointStatusReportExtendedData type.
  </Explanation>
  <UserResponse>
    This is an internal error.
  </UserResponse>
</Message>
<Message ID="CWSAD0083E" severity="E" prefix="yes">
  <MsgText pgmKey="CWSAD0083E" varFormat="Java">
    CWSAD0083E=CWSAD0083E: Found {0} extension for the {1} extension point due to a missing or incorrect input parameter.
  </MsgText>
  <Explanation>
    The input parameter may contain wrong or missing package name, so zero or multiple ServiceIndexManager extensions are found matching the input parameter.
  </Explanation>
  <UserResponse>
    Specify the correct asset package names for the input parameter.
  </UserResponse>
</Message>
<Message ID="CWSAD0003E" severity="E" prefix="yes">
  <MsgText pgmKey="CWSAD0003E" varFormat="Java">
    CWSAD0003E=CWSAD0003E: The administrative command cannot find {0} application.
  </MsgText>
  <Explanation>
    The application name cannot be found.
  </Explanation>
  <UserResponse>
    Provide the correct application name.
  </UserResponse>
</Message>
<Message ID="CWSAD0106W" severity="W" prefix="yes">
  <MsgText pgmKey="CWSAD0106W" varFormat="Java">
    CWSAD0106W=CWSAD0106W: Unable to deploy the {0} application on the {1} node because it contains service reference attachments or attachments that are specified in a name-value pair format. The application requires version {2} or later of WebSphere Application Server to be installed on the node.
  </MsgText>
  <Explanation>
    The application contains service reference attachments or attachments that are specified in a name-value pair format. The application requires the specified minimum version of the application server. The node currently has an earlier version of this product installed.
  </Explanation>
  <UserResponse>
    Target the application to a node that is at the specified minimum version of the application server, or install the specified minimum version of the application server on the target node.
  </UserResponse>
</Message>
<Message ID="CWSAD0078E" severity="E" prefix="yes">
  <MsgText pgmKey="CWSAD0078E" varFormat="Java">
    CWSAD0078E=CWSAD0078E: Access denied for resource {0}, {1} authority required.
  </MsgText>
  <Explanation>
    The current user role does not have access to the resource.
  </Explanation>
  <UserResponse>
    Retry the command with a higher level user.
  </UserResponse>
</Message>
<Message ID="CWSAD0042E" severity="E" prefix="yes">
  <MsgText pgmKey="CWSAD0042E" varFormat="Java">
    CWSAD0042E=CWSAD0042E: An error occurred creating the configuration documents in the repository.
  </MsgText>
  <Explanation>
    An unexpected error occurred when saving the configuration documents of the application to the WebSphere repository during application installation.  This message is preceded by a more detailed message regarding the failure.
  </Explanation>
  <UserResponse>
    Refer to the previous messages in the log file for a failure description. If no messages are displayed, see the problem determination information on the Application Server Support Web page: http://www.ibm.com/software/webservers/appserv/was/support/.
  </UserResponse>
</Message>
<Message ID="CWSAD0038E" severity="E" prefix="yes">
  <MsgText pgmKey="CWSAD0038E" varFormat="Java">
    CWSAD0038E=CWSAD0038E: Module {0} cannot not be found.
  </MsgText>
  <Explanation>
    The module cannot be found in the service package.
  </Explanation>
  <UserResponse>
    Provide the correct module name for the service package.
  </UserResponse>
</Message>
<Message ID="CWSAD0002E" severity="E" prefix="yes">
  <MsgText pgmKey="CWSAD0002E" varFormat="Java">
    CWSAD0002E=CWSAD0002E: The ServiceIndexWriter class created an IOException when it writes to the {0} file.
  </MsgText>
  <Explanation>
    An IOException is created when ServiceIndexWriter class writes to the file.
  </Explanation>
  <UserResponse>
    Ensure that the hard disk is not full and you have the writable permission.
  </UserResponse>
</Message>
<Message ID="CWSAD0105W" severity="W" prefix="yes">
  <MsgText pgmKey="CWSAD0105W" varFormat="Java">
    CWSAD0105W=CWSAD0105W: The {0} target module cannot be installed on the {1} node because the module requires version {2} or later of WebSphere Application Server to be installed on the node.
  </MsgText>
  <Explanation>
    The module contains JAX-WS web services and requires the specified minimum version of the application server. The node currently has an earlier version of this product installed.
  </Explanation>
  <UserResponse>
    Install the specified minimum version of the application server on the target node.
  </UserResponse>
</Message>
<Message ID="CWSAD0081E" severity="E" prefix="yes">
  <MsgText pgmKey="CWSAD0081E" varFormat="Java">
    CWSAD0081E=CWSAD0081E: Cannot stop the service listener on server {0} because the containing asset is in status {1} which is not valid to perform the operation.
  </MsgText>
  <Explanation>
    The operation requires the asset in the started status and cannot be performed if the asset is in other status such as unknown, unavailable, partial start, or partial stopped.
  </Explanation>
  <UserResponse>
    Start the containing asset in order to perform the operation.
  </UserResponse>
</Message>
<Message ID="CWSAD0077E" severity="E" prefix="yes">
  <MsgText pgmKey="CWSAD0077E" varFormat="Java">
    CWSAD0077E=CWSAD0077E: The value of serverStringOfDeployedRouterMoudule is null.
  </MsgText>
  <Explanation>
    Cannot obtain server target from deployed router module.
  </Explanation>
  <UserResponse>
    Contact IBM technical support.
  </UserResponse>
</Message>
<Message ID="CWSAD0041E" severity="E" prefix="yes">
  <MsgText pgmKey="CWSAD0041E" varFormat="Java">
    CWSAD0041E=CWSAD0041E: An error occurred configuring {0} in the Application Server repository: {1}
  </MsgText>
  <Explanation>
    Prior messages detail the cause of this failure.  Typically, the error conditions include wrong server and node names that are specified as module targets during installation.
  </Explanation>
  <UserResponse>
    Read the error messages and rectify the problem.
  </UserResponse>
</Message>
<Message ID="CWSAD0037E" severity="E" prefix="yes">
  <MsgText pgmKey="CWSAD0037E" varFormat="Java">
    CWSAD0037E=CWSAD0037E: Cannot invoke MBean operation {0} because the application is either not installed on a 7.0 server or not started.
  </MsgText>
  <Explanation>
    The specified MBean operation requires the application is running on a 7.0 server.
  </Explanation>
  <UserResponse>
    Make sure the application is installed on a 7.0 server and is started before invoking the operation.
  </UserResponse>
</Message>
<Message ID="CWSAD0001E" severity="E" prefix="yes">
  <MsgText pgmKey="CWSAD0001E" varFormat="Java">
    CWSAD0001E=CWSAD0001E: The ServiceIndexReader class created an IOException or a SAXException error when it read the {0} file.
  </MsgText>
  <Explanation>
    An IOException or SAXException error is created when the file is read.
  </Explanation>
  <UserResponse>
    Ensure that the file exists and that it is usable.
  </UserResponse>
</Message>
<Message ID="CWSAD0080E" severity="E" prefix="yes">
  <MsgText pgmKey="CWSAD0080E" varFormat="Java">
    CWSAD0080E=CWSAD0080E: Cannot start the service listener on server {0} because the containing asset is in status {1} which is not valid to perform the operation.
  </MsgText>
  <Explanation>
    The operation requires the asset in the started status and cannot be performed if the asset is in other status such as unknown, unavailable, partial start, or partial stopped.
  </Explanation>
  <UserResponse>
    Start the containing asset in order to perform the operation.
  </UserResponse>
</Message>
<Message ID="CWSAD0040I" severity="I" prefix="yes">
  <MsgText pgmKey="CWSAD0040I" varFormat="Java">
    CWSAD0040I=CWSAD0040I: The application {0} is configured in the Application Server repository.
  </MsgText>
  <Explanation>
    This informational message indicates the program status.
  </Explanation>
  <UserResponse>
    No user action is required.
  </UserResponse>
</Message>
<Message ID="CWSAD0076E" severity="E" prefix="yes">
  <MsgText pgmKey="CWSAD0076E" varFormat="Java">
    CWSAD0076E=CWSAD0076E: The value of serverStringOfUpdatedEJBModule is null.
  </MsgText>
  <Explanation>
    No target is found for updated module.
  </Explanation>
  <UserResponse>
    Contact IBM technical support.
  </UserResponse>
</Message>
<Message ID="CWSAD0104E" severity="E" prefix="yes">
  <MsgText pgmKey="CWSAD0104E" varFormat="Java">
    CWSAD0104E=CWSAD0104E: URLPrefixMap Validation Error: Multiple URL prefix map sections found for module=&quot;{0}&quot; 
Remove any duplicate URL prefix map entries.
  </MsgText>
  <Explanation>
    Multiple URL prefix map sections for the same module were found in the properties file.  You must not configure multiple URL prefix map sections that specify the same module name.  Configuring multiple URL prefix map sections that specify the same module creates ambiguity regarding which updates are requested.
  </Explanation>
  <UserResponse>
    Remove duplicate entries to avoid unintended updates to the master configuration.
  </UserResponse>
</Message>
<Message ID="CWSAD0036E" severity="E" prefix="yes">
  <MsgText pgmKey="CWSAD0036E" varFormat="Java">
    CWSAD0036E=CWSAD0036E: The application is not installed on the target {0}.
  </MsgText>
  <Explanation>
    The application is not installed on the specified server target or cluster target.
  </Explanation>
  <UserResponse>
    Provide the correct node name and server name for the target.
  </UserResponse>
</Message>
<Message ID="CWSAD0075E" severity="E" prefix="yes">
  <MsgText pgmKey="CWSAD0075E" varFormat="Java">
    CWSAD0075E=CWSAD0075E: The value of RepositoryContext is null.
  </MsgText>
  <Explanation>
    Cannot obtain RepositoryContext.
  </Explanation>
  <UserResponse>
    Contact IBM technical support.
  </UserResponse>
</Message>
<Message ID="CWSAD0103I" severity="I" prefix="yes">
  <MsgText pgmKey="CWSAD0103I" varFormat="Java">
    CWSAD0103I=CWSAD0103I: URLPrefixMap Section: module={0}
  </MsgText>
  <Explanation>
    Comments in a properties file indicating what module this section corresponds to.
  </Explanation>
  <UserResponse>
    This is just an informational comment.  No action is required.
  </UserResponse>
</Message>
<Message ID="CWSAD0035E" severity="E" prefix="yes">
  <MsgText pgmKey="CWSAD0035E" varFormat="Java">
    CWSAD0035E=CWSAD0035E: The server or cluster name is missing in the target parameter.
  </MsgText>
  <Explanation>
    Either server or cluster name is required in the target parameter.
  </Explanation>
  <UserResponse>
    Provide the server name or the cluster name in the target parameter.
  </UserResponse>
</Message>
<Message ID="CWSAD0074E" severity="E" prefix="yes">
  <MsgText pgmKey="CWSAD0074E" varFormat="Java">
    CWSAD0074E=CWSAD0074E: No information of map modules to servers is found.
  </MsgText>
  <Explanation>
    This could be either an user error or IBM internal error.
  </Explanation>
  <UserResponse>
    Provide value to map modules to server property for the file or partial application update.
  </UserResponse>
</Message>
<Message ID="CWSAD0102E" severity="E" prefix="yes">
  <MsgText pgmKey="CWSAD0102E" varFormat="Java">
    CWSAD0102E=CWSAD0102E: URLPrefixMap Validation Error: The property that is being requested for deletion in module=&quot;{0}&quot; 
key=&quot;{1}&quot; and value=&quot;{2}&quot; 
does not exist in current URL Prefix Map. 
Current stored URL Prefix Map values are: &quot;{3}&quot;
  </MsgText>
  <Explanation>
    The property that is requested for deletion does not exist in the current URL Prefix Map.
  </Explanation>
  <UserResponse>
    Verify that the property key and value specified matches the current stored values.
  </UserResponse>
</Message>
<Message ID="CWSAD0034E" severity="E" prefix="yes">
  <MsgText pgmKey="CWSAD0034E" varFormat="Java">
    CWSAD0034E=CWSAD0034E: The node name is missing in the target parameter.
  </MsgText>
  <Explanation>
    Node name is required in the target parameter.
  </Explanation>
  <UserResponse>
    Provide the node name in the target parameter.
  </UserResponse>
</Message>
<Message ID="CWSAD0073E" severity="E" prefix="yes">
  <MsgText pgmKey="CWSAD0073E" varFormat="Java">
    CWSAD0073E=CWSAD0073E: No target mapping information is found on the deployed file or partial application {0}.
  </MsgText>
  <Explanation>
    This could be either an user error or IBM internal error.
  </Explanation>
  <UserResponse>
    Provide the correct file or partial application for update or check with the deployment inputs or scripts.
  </UserResponse>
</Message>
<Message ID="CWSAD0101E" severity="E" prefix="yes">
  <MsgText pgmKey="CWSAD0101E" varFormat="Java">
    CWSAD0101E=CWSAD0101E: URLPrefixMap Validation Error: The specified module=&quot;{0}&quot; was not found.  
Ensure correct module name has been specified. Expecting a Web services enabled web(.war) or ejb(.jar) module name.
  </MsgText>
  <Explanation>
    The properties file did not contain a valid module name.
  </Explanation>
  <UserResponse>
    Add correct module name to the properties file.
  </UserResponse>
</Message>
<Message ID="CWSAD0069E" severity="E" prefix="yes">
  <MsgText pgmKey="CWSAD0069E" varFormat="Java">
    CWSAD0069E=CWSAD0069E: Failed to invoke the EndpointManager MBean operation {0} on server {1} due to exception {2}.
  </MsgText>
  <Explanation>
    There is an exception when invoking the EndpointManager MBean operation on a server.
  </Explanation>
  <UserResponse>
    Check the JMX connection to the server is working. If working, this is an internal error. If not working, fix the JMX connection problem.
  </UserResponse>
</Message>
<Message ID="CWSAD0033E" severity="E" prefix="yes">
  <MsgText pgmKey="CWSAD0033E" varFormat="Java">
    CWSAD0033E=CWSAD0033E: Cannot start the service listener on server {0} because the server is not started.
  </MsgText>
  <Explanation>
    Cannot start the service listener if the server is not started.
  </Explanation>
  <UserResponse>
    Start the server that is the target for the service.
  </UserResponse>
</Message>
<Message ID="CWSAD0029E" severity="E" prefix="yes">
  <MsgText pgmKey="CWSAD0029E" varFormat="Java">
    CWSAD0029E=CWSAD0029E: Cannot start the service listener on server {0} because it is a pre-7.0 server. You must start the containing asset instead.
  </MsgText>
  <Explanation>
    Cannot start the service listener on a pre-7.0 server.
  </Explanation>
  <UserResponse>
    Start the asset that contains the service.
  </UserResponse>
</Message>
<Message ID="CWSAD0072E" severity="E" prefix="yes">
  <MsgText pgmKey="CWSAD0072E" varFormat="Java">
    CWSAD0072E=CWSAD0072E: The deployed server target {0} for module {1} is not matching to the update server target {2} for module {3} on partial or single file update.
  </MsgText>
  <Explanation>
    The module with partial or single file update has server target different than the server target of deployed module. EJB and its relted router modules cannot have different server targets.
  </Explanation>
  <UserResponse>
    Provide the correct module for update, check the deployment inputs or scripts, or make sure EJB and its related router modules have the same server targets.
  </UserResponse>
</Message>
<Message ID="CWSAD0100E" severity="E" prefix="yes">
  <MsgText pgmKey="CWSAD0100E" varFormat="Java">
    CWSAD0100E=CWSAD0100E: URLPrefixMap Validation Error: Unable to construct a query from URL fragment: &quot;{0}&quot; at module: &quot;{1}&quot; 
Either no properties were specified, or the &apos;&apos;?&apos;&apos; delimiter is missing from the URL fragment.
  </MsgText>
  <Explanation>
    Either no properties were specified, or a delimiter is missing from the URL.
  </Explanation>
  <UserResponse>
    Add necessary properties or proper delimiter (?) to indicate where to read properties from.
  </UserResponse>
</Message>
<Message ID="CWSAD0068E" severity="E" prefix="yes">
  <MsgText pgmKey="CWSAD0068E" varFormat="Java">
    CWSAD0068E=CWSAD0068E: Logical endpoint {0} cannot be found in service {1}.
  </MsgText>
  <Explanation>
    The specified logical endpoint cannot be found in the serivce.
  </Explanation>
  <UserResponse>
    Ensure that the logical endpoint name is correct.
  </UserResponse>
</Message>
<Message ID="CWSAD0032E" severity="E" prefix="yes">
  <MsgText pgmKey="CWSAD0032E" varFormat="Java">
    CWSAD0032E=CWSAD0032E: The specified application module does not contain any web service.
  </MsgText>
  <Explanation>
    The specified application module does not contain any web service.
  </Explanation>
  <UserResponse>
    Provide the correct application, module, and service name.
  </UserResponse>
</Message>
<Message ID="CWSAD0071W" severity="W" prefix="yes">
  <MsgText pgmKey="CWSAD0071W" varFormat="Java">
    CWSAD0071W=CWSAD0071W: EJB {0} implemented as JAX-WS Web services bean is not an EJB 3.0.
  </MsgText>
  <Explanation>
    Web service enabled EJB module should be greater than or equal to EJB 3.0.
  </Explanation>
  <UserResponse>
    Change or update the EJB to a 3.0-style EJB.
  </UserResponse>
</Message>
<Message ID="CWSAD0028E" severity="E" prefix="yes">
  <MsgText pgmKey="CWSAD0028E" varFormat="Java">
    CWSAD0028E=CWSAD0028E: The service or endpoint listener is already stopped on server {0}.
  </MsgText>
  <Explanation>
    The service or endpoint listener is already stopped on the specific server.
  </Explanation>
  <UserResponse>
    No action is needed since the endpoint listener is already stopped on the specific server.
  </UserResponse>
</Message>
<Message ID="CWSAD0067E" severity="E" prefix="yes">
  <MsgText pgmKey="CWSAD0067E" varFormat="Java">
    CWSAD0067E=CWSAD0067E: Service {0} cannot be found.
  </MsgText>
  <Explanation>
    The specified service cannot be found in the module.
  </Explanation>
  <UserResponse>
    Ensure that the module has a service and that the service name is correct.
  </UserResponse>
</Message>
<Message ID="CWSAD0031E" severity="E" prefix="yes">
  <MsgText pgmKey="CWSAD0031E" varFormat="Java">
    CWSAD0031E=CWSAD0031E: Cannot start the service listener on server {0} because the containing asset is not started.
  </MsgText>
  <Explanation>
    Cannot start the service listener if the containing asset is not started.
  </Explanation>
  <UserResponse>
    Start the asset that contains the service.
  </UserResponse>
</Message>
<Message ID="CWSAD0027E" severity="E" prefix="yes">
  <MsgText pgmKey="CWSAD0027E" varFormat="Java">
    CWSAD0027E=CWSAD0027E: The service or endpoint listener is already started on server {0}.
  </MsgText>
  <Explanation>
    The service or endpoint listener is already started on the specific server.
  </Explanation>
  <UserResponse>
    No action is needed since the service listener is already started on the specific server.
  </UserResponse>
</Message>
<Message ID="CWSAD0070E" severity="E" prefix="yes">
  <MsgText pgmKey="CWSAD0070E" varFormat="Java">
    CWSAD0070E=CWSAD0070E: The target parameter should not contain both server name and cluster name.
  </MsgText>
  <Explanation>
    The target parameter can contain either server name or cluster name but not both.
  </Explanation>
  <UserResponse>
    Pass either server name or cluster name. You can invoke the operation twice, one for the server and one for the cluster.
  </UserResponse>
</Message>
<Message ID="CWSAD0066E" severity="E" prefix="yes">
  <MsgText pgmKey="CWSAD0066E" varFormat="Java">
    CWSAD0066E=CWSAD0066E: The router module {0} cannot be located on the deployment target of {1}.
  </MsgText>
  <Explanation>
    The router modules found within the update EJB binding do not exist or cannot be found on the deployment target.
  </Explanation>
  <UserResponse>
    Include a router module within the application and redo the deployment.
  </UserResponse>
</Message>
<Message ID="CWSAD0030E" severity="E" prefix="yes">
  <MsgText pgmKey="CWSAD0030E" varFormat="Java">
    CWSAD0030E=CWSAD0030E: Cannot stop the service listener on server {0} because it is a pre-7.0 server. You must stop the containing asset instead.
  </MsgText>
  <Explanation>
    Cannot stop the service listener on a pre-7.0 server.
  </Explanation>
  <UserResponse>
    Stop the asset that contains the service.
  </UserResponse>
</Message>
<Message ID="CWSAD0026E" severity="E" prefix="yes">
  <MsgText pgmKey="CWSAD0026E" varFormat="Java">
    CWSAD0026E=CWSAD0026E: The service name is missing in the parameter.
  </MsgText>
  <Explanation>
    Service name is required in the parameter.
  </Explanation>
  <UserResponse>
    Provide the service name in the parameter.
  </UserResponse>
</Message>
<Message ID="CWSAD0025E" severity="E" prefix="yes">
  <MsgText pgmKey="CWSAD0025E" varFormat="Java">
    CWSAD0025E=CWSAD0025E: The module name is missing in the parameter
  </MsgText>
  <Explanation>
    Module name is required in the parameter.
  </Explanation>
  <UserResponse>
    Provide the module name in the parameter.
  </UserResponse>
</Message>
<Message ID="CWSAD0064W" severity="W" prefix="yes">
  <MsgText pgmKey="CWSAD0064W" varFormat="Java">
    CWSAD0064W=CWSAD0064W: The target module {0} on node {1} cannot be reached because the module requires a different node version.
  </MsgText>
  <Explanation>
    The module contains JAXWS Web Services that is required for the WebSphere 7.0 and later.
  </Explanation>
  <UserResponse>
    Install or upgrade the target node to WebSphere 7.0 and later.
  </UserResponse>
</Message>
<Message ID="CWSAD0024E" severity="E" prefix="yes">
  <MsgText pgmKey="CWSAD0024E" varFormat="Java">
    CWSAD0024E=CWSAD0024E: The application name is missing in the parameter
  </MsgText>
  <Explanation>
    Application name is required in the parameter.
  </Explanation>
  <UserResponse>
    Provide the application name in the parameter.
  </UserResponse>
</Message>
<Message ID="CWSAD0099E" severity="E" prefix="yes">
  <MsgText pgmKey="CWSAD0099E" varFormat="Java">
    CWSAD0099E=CWSAD0099E: URLPrefixMap Validation Error: The JMS endpoint URL fragment: &quot;{0}&quot; at module: &quot;{1}&quot; 
is missing the following required property: &quot;{2}&quot;
  </MsgText>
  <Explanation>
    The required URL properties are missing in the specified JMS URL fragment.
  </Explanation>
  <UserResponse>
    Specify all required and missing properties in the specified URL.
  </UserResponse>
</Message>
<Message ID="CWSAD0063E" severity="E" prefix="yes">
  <MsgText pgmKey="CWSAD0063E" varFormat="Java">
    CWSAD0063E=CWSAD0063E: Update module {0} does not match to any of the router modules on the deployed application.
  </MsgText>
  <Explanation>
    This could be an user error or IBM WebSphere internal error.
  </Explanation>
  <UserResponse>
    Provide the correct module for update or chekc with the deployment inputs or scripts.
  </UserResponse>
</Message>
<Message ID="CWSAD0059E" severity="E" prefix="yes">
  <MsgText pgmKey="CWSAD0059E" varFormat="Java">
    CWSAD0059E=CWSAD0059E: Update module {0} is not found on the deployed application.
  </MsgText>
  <Explanation>
    There is not matched name application or module deployed on the server.
  </Explanation>
  <UserResponse>
    Provide the correct module for update or check with the deployment inputs or scripts.
  </UserResponse>
</Message>
<Message ID="CWSAD0023E" severity="E" prefix="yes">
  <MsgText pgmKey="CWSAD0023E" varFormat="Java">
    CWSAD0023E=CWSAD0023E: The queryProps parameter is null.
  </MsgText>
  <Explanation>
    The query parameter should not be null.
  </Explanation>
  <UserResponse>
    Provide queryProps parameter.
  </UserResponse>
</Message>
<Message ID="CWSAD0019E" severity="E" prefix="yes">
  <MsgText pgmKey="CWSAD0019E" varFormat="Java">
    CWSAD0019E=CWSAD0019E: The parameters contain the following not valid property names: {0}.
  </MsgText>
  <Explanation>
    The parameters for the administrative command or MBean operation contain one or more not valid property names.
  </Explanation>
  <UserResponse>
    Provide the correct parameters.
  </UserResponse>
</Message>
<Message ID="CWSAD0098E" severity="E" prefix="yes">
  <MsgText pgmKey="CWSAD0098E" varFormat="Java">
    CWSAD0098E=CWSAD0098E: URLPrefixMap Validation Error: Invalid destination type: &quot;{0}&quot; specified within a JMS endpoint URL fragment, at module=&quot;{1}&quot;
  </MsgText>
  <Explanation>
    A proper destination type is missing in the supplied JMS endpoint URL.
  </Explanation>
  <UserResponse>
    Specify proper destination and destination type.
  </UserResponse>
</Message>
<Message ID="CWSAD0062E" severity="E" prefix="yes">
  <MsgText pgmKey="CWSAD0062E" varFormat="Java">
    CWSAD0062E=CWSAD0062E: Map modules to servers information is needed for partial or single file updated.
  </MsgText>
  <Explanation>
    Cannot find map modules to servers information from user inputs.
  </Explanation>
  <UserResponse>
    Add map modules to servers option with the deployment inputs or scripts.
  </UserResponse>
</Message>
<!-- END MESSAGES -->
</TMSSource>
