<?xml version="1.0" encoding="UTF-8"?>
<?xml-stylesheet type="text/css" href="../../resources/stylesheets/wasmsgxml.css"?>
<TMSSource name="TivoliMessages" tmsVersion="1.0" xml:lang="en">
<!-- CMVC MSG File Name = SERV1/ws/code/webservices/src/com/ibm/ws/webservices/resources/webservicesMessages.nlsprops -->
<!-- DO NOT EDIT THIS FILE - This file was generated by the XML/Html & Property emitter -->
<!-- BEGIN MESSAGES -->
<Message ID="WSWS1020E" severity="E" prefix="yes">
  <MsgText pgmKey="warning.parse.file.failure" varFormat="Java">
    warning.parse.file.failure=WSWS1020E: Unable to parse file {0}
  </MsgText>
  <Explanation>
    An error occurred in the configuration.
  </Explanation>
  <UserResponse>
    If the problem persists, additional information might be available if you search for the message ID on the following Web sites: WebSphere Application Server Support page: http://www.ibm.com/software/webservers/appserv/was/support/ WebSphere Application Server for z/OS Support page: http://www.ibm.com/software/webservers/appserv/zos_os390/support/ .
  </UserResponse>
</Message>
<Message ID="WSWS1008W" severity="W" prefix="yes">
  <MsgText pgmKey="dumpService.failed" varFormat="Java">
    dumpService.failed=WSWS1008W: Unable to dump the configuration as part of debug: {0}
  </MsgText>
  <Explanation>
    This exception is unexpected. The cause is not immediately known.
  </Explanation>
  <UserResponse>
    If the problem persists, additional information might be available if you search for the message ID on the following Web sites: WebSphere Application Server Support page: http://www.ibm.com/software/webservers/appserv/was/support/ WebSphere Application Server for z/OS Support page: http://www.ibm.com/software/webservers/appserv/zos_os390/support/ .
  </UserResponse>
</Message>
<Message ID="WSWS1058E" severity="E" prefix="yes">
  <MsgText pgmKey="unknown.ejb-link" varFormat="Java">
    unknown.ejb-link=WSWS1058E: Application {0}, module {1}, file {2}, port-component-name {3}: service-impl-bean ejb-link {4} does not correspond to any enterprise bean name in the ejb-jar.xml file.
  </MsgText>
  <Explanation>
    The &lt;ejb-link&gt; value must match an existing &lt;ejb-name&gt; value.
  </Explanation>
  <UserResponse>
    Change the &lt;ejb-link&gt; value to match the &lt;ejb-name&gt; value of the proper enterprise bean.
  </UserResponse>
</Message>
<Message ID="WSWS1007E" severity="E" prefix="yes">
  <MsgText pgmKey="client.invalid.wsdlservice.specification.noqname" varFormat="Java">
    client.invalid.wsdlservice.specification.noqname=WSWS1007E: More than one service is in the WSDL file, but service reference {0} in the client deployment descriptor does not specify which service QName to use.
  </MsgText>
  <Explanation>
    If there is more than one service in the WSDL file, the client deployment descriptor must specify a QName of the service to use.
  </Explanation>
  <UserResponse>
    Modify the client deployment descriptor to add a &lt;service-qname&gt; element or modify the WSDL file to contain only one service.
  </UserResponse>
</Message>
<Message ID="WSWS1001E" severity="E" prefix="yes">
  <MsgText pgmKey="clientProcessService.notAvailableError" varFormat="Java">
    clientProcessService.notAvailableError=WSWS1001E: The client process service cannot be accessed.
  </MsgText>
  <Explanation>
    This exception is unexpected. The cause is not immediately known.
  </Explanation>
  <UserResponse>
    If the problem persists, additional information might be available if you search for the message ID on the following Web sites: WebSphere Application Server Support page: http://www.ibm.com/software/webservers/appserv/was/support/ WebSphere Application Server for z/OS Support page: http://www.ibm.com/software/webservers/appserv/zos_os390/support/ .
  </UserResponse>
</Message>
<Message ID="WSWS1062I" severity="I" prefix="yes">
  <MsgText pgmKey="soapcontainer.service" varFormat="Java">
    soapcontainer.service=WSWS1062I: The SOAP Container service has been initialized.
  </MsgText>
  <Explanation>
    This informational message indicates the program status.
  </Explanation>
  <UserResponse>
    No user action is required.
  </UserResponse>
</Message>
<Message ID="WSWS1038W" severity="W" prefix="yes">
  <MsgText pgmKey="warning.ServiceNameSetter.notfound" varFormat="Java">
    warning.ServiceNameSetter.notfound=WSWS1038W: No setter method on {0} with a method name {1} was found for reference {2}.  The service name cannot be changed to {3}.
  </MsgText>
  <Explanation>
    The service name cannot be changed from the default name that is generated in the service locator because a setter method for the service name cannot be found.
  </Explanation>
  <UserResponse>
    Regenerate the client-side artifacts, including the ServiceLocator class with the WebSphere Application Server emitters.
  </UserResponse>
</Message>
<Message ID="WSWS1068E" severity="E" prefix="yes">
  <MsgText pgmKey="ejbInvokeFail00" varFormat="Java">
    ejbInvokeFail00=WSWS1068E: Internal error. A response from a web service endpoint in an Enterprise Java Beans module could not be processed because an endpoint manager could not be located.
  </MsgText>
  <Explanation>
    An internal system error occurred.
  </Explanation>
  <UserResponse>
    Consult the logs in your &lt;profile_home&gt;/logs directory for more information.
  </UserResponse>
</Message>
<Message ID="WSWS1047W" severity="W" prefix="yes">
  <MsgText pgmKey="invalid.defaultport.information" varFormat="Java">
    invalid.defaultport.information=WSWS1047W: The ibm-webservicesclient-bnd.xmi defaultMappings information for serviceRefLink {0} does not correspond to the information in the WSDL file.  One or more of the following values are incorrectly specified in the ibm-webservicesclient-bnd.xmi file: portTypeLocalName {1}, portTypeNamespace {2}, portLocalName {3}, or portNamespace {4}.
  </MsgText>
  <Explanation>
    One or more of the values for the defaultMappings information in the client bindings file cannot be found in the WSDL file.
  </Explanation>
  <UserResponse>
    Verify and correct the defaultMappings information in the client bindings file.
  </UserResponse>
</Message>
<Message ID="WSWS1032E" severity="E" prefix="yes">
  <MsgText pgmKey="error.binding.service.ref.named" varFormat="Java">
    error.binding.service.ref.named=WSWS1032E: {0}: An error occurred while binding service reference {1} in the java:{2} namespace.
  </MsgText>
  <Explanation>
    The service reference cannot be bound into the namespace.
  </Explanation>
  <UserResponse>
    If the problem persists, additional information might be available if you search for the message ID on the following Web sites: WebSphere Application Server Support page: http://www.ibm.com/software/webservers/appserv/was/support/ WebSphere Application Server for z/OS Support page: http://www.ibm.com/software/webservers/appserv/zos_os390/support/ .
  </UserResponse>
</Message>
<Message ID="WSWS1026E" severity="E" prefix="yes">
  <MsgText pgmKey="cannot.load.resource" varFormat="Java">
    cannot.load.resource=WSWS1026E: Error: Resource {0} was not loaded: {1}
  </MsgText>
  <Explanation>
    The resource cannot be loaded by the class or system class loaders.
  </Explanation>
  <UserResponse>
    If the problem persists, additional information might be available if you search for the message ID on the following Web sites: WebSphere Application Server Support page: http://www.ibm.com/software/webservers/appserv/was/support/ WebSphere Application Server for z/OS Support page: http://www.ibm.com/software/webservers/appserv/zos_os390/support/ .
  </UserResponse>
</Message>
<Message ID="WSWS1049E" severity="E" prefix="yes">
  <MsgText pgmKey="j2ee13.webservicesclient.missing.component.scoped.ref" varFormat="Java">
    j2ee13.webservicesclient.missing.component.scoped.ref=WSWS1049E: J2EE 1.3 {0} is missing component-scoped service references.
  </MsgText>
  <Explanation>
    The Java Platform, Enterprise Edition 1.3 Web services client deployment descriptor file, webservicesclient.xml, must contain component-scoped service referencess for a Java EE enterprise bean component.
  </Explanation>
  <UserResponse>
    Add component-scoped service references to the webservicesclient.xml file for enterprise bean components.
  </UserResponse>
</Message>
<Message ID="WSWS1063E" severity="E" prefix="yes">
  <MsgText pgmKey="no.system.service" varFormat="Java">
    no.system.service=WSWS1063E: No Web services system service is available.
  </MsgText>
  <Explanation>
    The configuration for the Web services system service is not available.
  </Explanation>
  <UserResponse>
    Verify that the Web services system service configuration files are correct.
  </UserResponse>
</Message>
<Message ID="WSWS1030E" severity="E" prefix="yes">
  <MsgText pgmKey="error.binding.service.refs" varFormat="Java">
    error.binding.service.refs=WSWS1030E: An error occurred while binding service references: {0}
  </MsgText>
  <Explanation>
    The service reference cannot be bound.
  </Explanation>
  <UserResponse>
    If the problem persists, additional information might be available if you search for the message ID on the following Web sites: WebSphere Application Server Support page: http://www.ibm.com/software/webservers/appserv/was/support/ WebSphere Application Server for z/OS Support page: http://www.ibm.com/software/webservers/appserv/zos_os390/support/ .
  </UserResponse>
</Message>
<Message ID="WSWS1061E" severity="E" prefix="yes">
  <MsgText pgmKey="no.system.router" varFormat="Java">
    no.system.router=WSWS1061E: No system endpoint router is defined for request {0}.
  </MsgText>
  <Explanation>
    No router is defined for the incoming request.
  </Explanation>
  <UserResponse>
    Verify that valid system services endpoints exist with valid system endpoint configuration files.
  </UserResponse>
</Message>
<Message ID="WSWS1000E" severity="E" prefix="yes">
  <MsgText pgmKey="internal.error" varFormat="Java">
    internal.error=WSWS1000E: Error: {0}
  </MsgText>
  <Explanation>
    This exception is unexpected. The cause is not immediately known.
  </Explanation>
  <UserResponse>
    If the problem persists, additional information might be available if you search for the message ID on the following Web sites: WebSphere Application Server Support page: http://www.ibm.com/software/webservers/appserv/was/support/ WebSphere Application Server for z/OS Support page: http://www.ibm.com/software/webservers/appserv/zos_os390/support/ .
  </UserResponse>
</Message>
<Message ID="WSWS1057E" severity="E" prefix="yes">
  <MsgText pgmKey="webservices.config.not.loaded" varFormat="Java">
    webservices.config.not.loaded=WSWS1057E: Internal Error: The Web services global configuration was not loaded.
  </MsgText>
  <Explanation>
    This exception is unexpected. The cause is not immediately known.
  </Explanation>
  <UserResponse>
    If the problem persists, additional information might be available if you search for the message ID on the following Web sites: WebSphere Application Server Support page: http://www.ibm.com/software/webservers/appserv/was/support/ WebSphere Application Server for z/OS Support page: http://www.ibm.com/software/webservers/appserv/zos_os390/support/ .
  </UserResponse>
</Message>
<Message ID="WSWS1015W" severity="W" prefix="yes">
  <MsgText pgmKey="warning.servlet.link.not.found" varFormat="Java">
    warning.servlet.link.not.found=WSWS1015W: Servlet for servlet-link {0} not found.  The port-component {1} is skipped.
  </MsgText>
  <Explanation>
    Either a servlet whose name matches the servlet-link is not found for a port component, or the Web application is not a servlet.
  </Explanation>
  <UserResponse>
    Use a valid servlet name in the &apos;servlet-link&apos; field and verify that the Web application is a servlet.
  </UserResponse>
</Message>
<Message ID="WSWS1059E" severity="E" prefix="yes">
  <MsgText pgmKey="no.wsdl.services.for.qname" varFormat="Java">
    no.wsdl.services.for.qname=WSWS1059E: No WSDL services exist with qname {0}.
  </MsgText>
  <Explanation>
    The service qname that is specified in the service reference does not match any services that are specified in the WSDL file.
  </Explanation>
  <UserResponse>
    Review and correct the service reference&apos;s service qname.
  </UserResponse>
</Message>
<Message ID="WSWS1021W" severity="W" prefix="yes">
  <MsgText pgmKey="warning.no.services" varFormat="Java">
    warning.no.services=WSWS1021W: Warning: No services to deploy.
  </MsgText>
  <Explanation>
    No (zero) services found to deploy.
  </Explanation>
  <UserResponse>
    Specify the services to deploy.
  </UserResponse>
</Message>
<Message ID="WSWS1048E" severity="E" prefix="yes">
  <MsgText pgmKey="j2ee13.webservicesclient.unexpected.component.scoped.ref" varFormat="Java">
    j2ee13.webservicesclient.unexpected.component.scoped.ref=WSWS1048E: J2EE 1.3 {0} contains unexpected component-scoped service references with no component specified.
  </MsgText>
  <Explanation>
    The Java Platform, Enterprise Edition 1.3 Web services client deployment descriptor file, webservicesclient.xml, contains unexpected component-scoped service references for a Java EE Web application or application client module.
  </Explanation>
  <UserResponse>
    Remove the component-scoped service references from the webservicesclient.xml file.
  </UserResponse>
</Message>
<Message ID="WSWS1039E" severity="E" prefix="yes">
  <MsgText pgmKey="no.ejb.ibmbnd.file" varFormat="Java">
    no.ejb.ibmbnd.file=WSWS1039E: The Web services binding file {0} was not found in module {1} in application {2}.  This file is required for this type of module.
  </MsgText>
  <Explanation>
    The noted file is required to make this type of module available as a Web service.
  </Explanation>
  <UserResponse>
    Make sure that the module in the application contains the required binding file.
  </UserResponse>
</Message>
<Message ID="WSWS1031E" severity="E" prefix="yes">
  <MsgText pgmKey="error.binding.service.refs.in.ns" varFormat="Java">
    error.binding.service.refs.in.ns=WSWS1031E: {0}: An error occurred while binding service references in the java:{1} namespace.
  </MsgText>
  <Explanation>
    The service reference cannot be bound into the namespace.
  </Explanation>
  <UserResponse>
    If the problem persists, additional information might be available if you search for the message ID on the following Web sites: WebSphere Application Server Support page: http://www.ibm.com/software/webservers/appserv/was/support/ WebSphere Application Server for z/OS Support page: http://www.ibm.com/software/webservers/appserv/zos_os390/support/ .
  </UserResponse>
</Message>
<Message ID="WSWS1066W" severity="W" prefix="yes">
  <MsgText pgmKey="notContain.componentScopedRefs" varFormat="Java">
    notContain.componentScopedRefs=WSWS1066W: {0} in {1} does not contain a componentScopedRefs element, which is required for configuring security.
  </MsgText>
  <Explanation>
    A componentScopedRefs element is missing from one of the .xmi files.  A componentScopedRefs element is not required unless you are configuring security.
  </Explanation>
  <UserResponse>
    If configuring security, add a componentScopedRefs element to the specified xmi file.  Otherwise, no user action is required.
  </UserResponse>
</Message>
<Message ID="WSWS1005E" severity="E" prefix="yes">
  <MsgText pgmKey="bad.dtd.in.webservices.dd" varFormat="Java">
    bad.dtd.in.webservices.dd=WSWS1005E: The DTD reference in the Web services deployment descriptor is not valid: {0}
  </MsgText>
  <Explanation>
    The Web services deployment descriptor contained a DTD reference that was not valid.
  </Explanation>
  <UserResponse>
    If the problem persists, additional information might be available if you search for the message ID on the following Web sites: WebSphere Application Server Support page: http://www.ibm.com/software/webservers/appserv/was/support/ WebSphere Application Server for z/OS Support page: http://www.ibm.com/software/webservers/appserv/zos_os390/support/ .
  </UserResponse>
</Message>
<Message ID="WSWS1051W" severity="W" prefix="yes">
  <MsgText pgmKey="webservice.ejb.missing.router.module" varFormat="Java">
    webservice.ejb.missing.router.module=WSWS1051W: The Web service-enabled enterprise bean does not have any defined Web service router modules.
  </MsgText>
  <Explanation>
    The Web service-enabled enterprise bean is missing the protocol specification (HTTP, JMS, and so on).
  </Explanation>
  <UserResponse>
    Redeploy the Web service-enabled enterprise bean with a valid protocol.
  </UserResponse>
</Message>
<Message ID="WSWS1018W" severity="W" prefix="yes">
  <MsgText pgmKey="warning.handler.invalid.role" varFormat="Java">
    warning.handler.invalid.role=WSWS1018W: For handlers {0} the handler {1} was not added due to a role statement {2} that is not valid.
  </MsgText>
  <Explanation>
    An error occurred in the handler configuration.  The ignored handler might cause unexpected results.
  </Explanation>
  <UserResponse>
    If the problem persists, additional information might be available if you search for the message ID on the following Web sites: WebSphere Application Server Support page: http://www.ibm.com/software/webservers/appserv/was/support/ WebSphere Application Server for z/OS Support page: http://www.ibm.com/software/webservers/appserv/zos_os390/support/ .
  </UserResponse>
</Message>
<Message ID="WSWS1056E" severity="E" prefix="yes">
  <MsgText pgmKey="wsejbwrapper.expected.method" varFormat="Java">
    wsejbwrapper.expected.method=WSWS1056E: Internal Error: The method &apos;&apos;{0}&apos;&apos; on class &apos;&apos;{1}&apos;&apos;was not found.
  </MsgText>
  <Explanation>
    This exception is unexpected. The cause is not immediately known.
  </Explanation>
  <UserResponse>
    If the problem persists, additional information might be available if you search for the message ID on the following Web sites: WebSphere Application Server Support page: http://www.ibm.com/software/webservers/appserv/was/support/ WebSphere Application Server for z/OS Support page: http://www.ibm.com/software/webservers/appserv/zos_os390/support/ .
  </UserResponse>
</Message>
<Message ID="WSWS1040W" severity="W" prefix="yes">
  <MsgText pgmKey="no.war.ibmbnd.file" varFormat="Java">
    no.war.ibmbnd.file=WSWS1040W: The Web services binding file {0} was not found in module {1} in application {2}.  Certain functionality, such as Web services security is not available.
  </MsgText>
  <Explanation>
    The file is not required, but certain functionality is not available without it.
  </Explanation>
  <UserResponse>
    No user action is required.
  </UserResponse>
</Message>
<Message ID="WSWS1034W" severity="W" prefix="yes">
  <MsgText pgmKey="no.matching.portcompbinding" varFormat="Java">
    no.matching.portcompbinding=WSWS1034W: No port component binding with the name {0} was found in bindings file {1}.
  </MsgText>
  <Explanation>
    The port component binding is not required, but certain functionality is not available without it.
  </Explanation>
  <UserResponse>
    No user action is required.
  </UserResponse>
</Message>
<Message ID="WSWS1065E" severity="E" prefix="yes">
  <MsgText pgmKey="invalid.transportheader.value" varFormat="Java">
    invalid.transportheader.value=WSWS1065E: A transport header value of null or length of zero is specified for header key {0}.  This header key is not valid and will be ignored.
  </MsgText>
  <Explanation>
    This exception is unexpected. The cause is not immediately known.
  </Explanation>
  <UserResponse>
    If the problem persists, additional information might be available if you search for the message ID on the following Web sites: WebSphere Application Server Support page: http://www.ibm.com/software/webservers/appserv/was/support/ WebSphere Application Server for z/OS Support page: http://www.ibm.com/software/webservers/appserv/zos_os390/support/ .
  </UserResponse>
</Message>
<Message ID="WSWS1027W" severity="W" prefix="yes">
  <MsgText pgmKey="register.mbean.failed" varFormat="Java">
    register.mbean.failed=WSWS1027W: Warning: Web services MBean could not be registered: {0}
  </MsgText>
  <Explanation>
    The MBean could not be registered.
  </Explanation>
  <UserResponse>
    If the problem persists, additional information might be available if you search for the message ID on the following Web sites: WebSphere Application Server Support page: http://www.ibm.com/software/webservers/appserv/was/support/ WebSphere Application Server for z/OS Support page: http://www.ibm.com/software/webservers/appserv/zos_os390/support/ .
  </UserResponse>
</Message>
<Message ID="WSWS1044E" severity="E" prefix="yes">
  <MsgText pgmKey="wssec.config.dd.error" varFormat="Java">
    wssec.config.dd.error=WSWS1044E: An error occurred in the configuration. More than one security deployment descriptor is defined, but the program cannot determine which one to use without the WSDL service port.
  </MsgText>
  <Explanation>
    This exception is unexpected. The cause is not immediately known.
  </Explanation>
  <UserResponse>
    If the problem persists, additional information might be available if you search for the message ID on the following Web sites: WebSphere Application Server Support page: http://www.ibm.com/software/webservers/appserv/was/support/ WebSphere Application Server for z/OS Support page: http://www.ibm.com/software/webservers/appserv/zos_os390/support/ .
  </UserResponse>
</Message>
<Message ID="WSWS1022W" severity="W" prefix="yes">
  <MsgText pgmKey="warning.client.reference.wrong.type" varFormat="Java">
    warning.client.reference.wrong.type=WSWS1022W: Client reference {0} not of expected type {1} in java:comp namespace.
  </MsgText>
  <Explanation>
    An unexpected type of client reference was found in the namespace.
  </Explanation>
  <UserResponse>
    If the problem persists, additional information might be available if you search for the message ID on the following Web sites: WebSphere Application Server Support page: http://www.ibm.com/software/webservers/appserv/was/support/ WebSphere Application Server for z/OS Support page: http://www.ibm.com/software/webservers/appserv/zos_os390/support/ .
  </UserResponse>
</Message>
<Message ID="WSWS1016E" severity="E" prefix="yes">
  <MsgText pgmKey="not.unique.pcn" varFormat="Java">
    not.unique.pcn=WSWS1016E: Multiple &apos;&apos;port-component-name&apos;&apos; elements with the value {0} were found.
  </MsgText>
  <Explanation>
    The port-component-name values must be unique.
  </Explanation>
  <UserResponse>
    Use unique port-component-names.
  </UserResponse>
</Message>
<Message ID="WSWS1035E" severity="E" prefix="yes">
  <MsgText pgmKey="exception.context" varFormat="Java">
    exception.context=WSWS1035E: An error occurred in {0}: context information: {1}
  </MsgText>
  <Explanation>
    An exception was generated and the context information is being created.
  </Explanation>
  <UserResponse>
    If the problem persists, additional information might be available if you search for the message ID on the following Web sites: WebSphere Application Server Support page: http://www.ibm.com/software/webservers/appserv/was/support/ WebSphere Application Server for z/OS Support page: http://www.ibm.com/software/webservers/appserv/zos_os390/support/ .
  </UserResponse>
</Message>
<Message ID="WSWS1010E" severity="E" prefix="yes">
  <MsgText pgmKey="error.sax.handler" varFormat="Java">
    error.sax.handler=WSWS1010E: Error: [{0}:{1}:{2}] {3}
  </MsgText>
  <Explanation>
    An error was issued with the deployment descriptor that is listed.
  </Explanation>
  <UserResponse>
    Correct the error with the deployment descriptor.
  </UserResponse>
</Message>
<Message ID="WSWS1060E" severity="E" prefix="yes">
  <MsgText pgmKey="no.system.application" varFormat="Java">
    no.system.application=WSWS1060E: Received request {0} for unregistered system service endpoint {1}.
  </MsgText>
  <Explanation>
    A request has been received for a system application that is not installed and deployed.
  </Explanation>
  <UserResponse>
    Verify the system endpoint name and check for errors during server startup.
  </UserResponse>
</Message>
<Message ID="WSWS1067E" severity="E" prefix="yes">
  <MsgText pgmKey="jaxrpc.load.metadata.fail" varFormat="Java">
    jaxrpc.load.metadata.fail=WSWS1067E: The loading of the metadata for JAX-RPC module {0} has failed.  The exception is: {1}
  </MsgText>
  <Explanation>
    This exception is unexpected. The cause is not immediately known.
  </Explanation>
  <UserResponse>
    If the problem persists, additional information might be available if you search for the message ID on the following Web sites: WebSphere Application Server Support page: http://www.ibm.com/software/webservers/appserv/was/support/ WebSphere Application Server for z/OS Support page: http://www.ibm.com/software/webservers/appserv/zos_os390/support/ .
  </UserResponse>
</Message>
<Message ID="WSWS1046E" severity="E" prefix="yes">
  <MsgText pgmKey="missing.router.module" varFormat="Java">
    missing.router.module=WSWS1046E: The ibm-webservices-bnd.xmi file for enterprise bean module {0} says that the associated router module is {1}.  However, that router module does not exist in the application.
  </MsgText>
  <Explanation>
    The router module is missing from the application.
  </Explanation>
  <UserResponse>
    Fix the application by running the endptEnabler tool.
  </UserResponse>
</Message>
<Message ID="WSWS1055E" severity="E" prefix="yes">
  <MsgText pgmKey="ejbdispatcher.expected.ejs" varFormat="Java">
    ejbdispatcher.expected.ejs=WSWS1055E: Internal Error: An EJB object is expected at dispatcher cleanup.
  </MsgText>
  <Explanation>
    This exception is unexpected. The cause is not immediately known.
  </Explanation>
  <UserResponse>
    If the problem persists, additional information might be available if you search for the message ID on the following Web sites: WebSphere Application Server Support page: http://www.ibm.com/software/webservers/appserv/was/support/ WebSphere Application Server for z/OS Support page: http://www.ibm.com/software/webservers/appserv/zos_os390/support/ .
  </UserResponse>
</Message>
<Message ID="WSWS1013E" severity="E" prefix="yes">
  <MsgText pgmKey="illegal.scope" varFormat="Java">
    illegal.scope=WSWS1013E: Error: Found illegal scope: binding file={0}, portComponentName={1}, scope={2}.
  </MsgText>
  <Explanation>
    The value for the scope is not valid.
  </Explanation>
  <UserResponse>
    Correct the scope in the binding file to one of &apos;Request&apos;, &apos;Application&apos;, or &apos;Session&apos;.
  </UserResponse>
</Message>
<Message ID="WSWS1011E" severity="E" prefix="yes">
  <MsgText pgmKey="fatalerror.sax.handler" varFormat="Java">
    fatalerror.sax.handler=WSWS1011E: Error: [{0}:{1}:{2}] {3}
  </MsgText>
  <Explanation>
    An error was issued with the deployment descriptor that is listed.
  </Explanation>
  <UserResponse>
    Correct the error with the deployment descriptor.
  </UserResponse>
</Message>
<Message ID="WSWS1012E" severity="E" prefix="yes">
  <MsgText pgmKey="missing.web.container" varFormat="Java">
    missing.web.container=WSWS1012E: Error: Web services is missing the Web container.
  </MsgText>
  <Explanation>
    WebSphere Application Server was unable to locate the Web container during Web services startup.
  </Explanation>
  <UserResponse>
    Correct the problems with WebSphere Application Server startup.
  </UserResponse>
</Message>
<Message ID="WSWS1003E" severity="E" prefix="yes">
  <MsgText pgmKey="client.invalid.wsdlservice.specification.noservices" varFormat="Java">
    client.invalid.wsdlservice.specification.noservices=WSWS1003E: The WSDL file that is referenced by the client deployment descriptor service reference {0} contains no services.
  </MsgText>
  <Explanation>
    There are no services defined in the WSDL file.
  </Explanation>
  <UserResponse>
    Modify the WSDL file to include at least one service definition.
  </UserResponse>
</Message>
<Message ID="WSWS1054E" severity="E" prefix="yes">
  <MsgText pgmKey="ejbdispatcher.expected.ejb" varFormat="Java">
    ejbdispatcher.expected.ejb=WSWS1054E: Internal Error: An EJB object is expected at dispatcher invoke.
  </MsgText>
  <Explanation>
    This exception is unexpected. The cause is not immediately known.
  </Explanation>
  <UserResponse>
    If the problem persists, additional information might be available if you search for the message ID on the following Web sites: WebSphere Application Server Support page: http://www.ibm.com/software/webservers/appserv/was/support/ WebSphere Application Server for z/OS Support page: http://www.ibm.com/software/webservers/appserv/zos_os390/support/ .
  </UserResponse>
</Message>
<Message ID="WSWS1037E" severity="E" prefix="yes">
  <MsgText pgmKey="mappingFile.not.found" varFormat="Java">
    mappingFile.not.found=WSWS1037E: The JSR 109 JAX-RPC mapping file {0}, as specified in &lt;webservice-description&gt; {1} in deployment descriptor {2} for module {3} was not found in application {4}.  This Web service description is ignored.
  </MsgText>
  <Explanation>
    The required JAX-RPC mapping file that is named in the Web services deployment descriptor cannot be found in this module.
  </Explanation>
  <UserResponse>
    Make sure that the file name that is specified in the Web service deployment descriptor refers to an existing file in the module.
  </UserResponse>
</Message>
<Message ID="WSWS1042E" severity="E" prefix="yes">
  <MsgText pgmKey="wssec.loadconfig.failed" varFormat="Java">
    wssec.loadconfig.failed=WSWS1042E: An error occurred in loading the configuration for {0}. The exception is {1}.
  </MsgText>
  <Explanation>
    This exception is unexpected. The cause is not immediately known.
  </Explanation>
  <UserResponse>
    If the problem persists, additional information might be available if you search for the message ID on the following Web sites: WebSphere Application Server Support page: http://www.ibm.com/software/webservers/appserv/was/support/ WebSphere Application Server for z/OS Support page: http://www.ibm.com/software/webservers/appserv/zos_os390/support/ .
  </UserResponse>
</Message>
<Message ID="WSWS1041W" severity="W" prefix="yes">
  <MsgText pgmKey="no.matching.wsdescbinding" varFormat="Java">
    no.matching.wsdescbinding=WSWS1041W: No Web service description binding is found in the Web services binding file {0} with the name {1}.
  </MsgText>
  <Explanation>
    The Web service description binding is not required, but certain functionality is not available without it.
  </Explanation>
  <UserResponse>
    No user action is required.
  </UserResponse>
</Message>
<Message ID="WSWS1033W" severity="W" prefix="yes">
  <MsgText pgmKey="warning.handler.not.verified" varFormat="Java">
    warning.handler.not.verified=WSWS1033W: Java class {0} that is specified for handler {1} cannot be loaded.  The handler is skipped. The exception is {2}.
  </MsgText>
  <Explanation>
    The global configuration file (was-webservices.xml) defines a handler that specifies a Java class that cannot be loaded.
  </Explanation>
  <UserResponse>
    Determine and fix the cause of the failure to load the specified Java class.
  </UserResponse>
</Message>
<Message ID="WSWS1045E" severity="E" prefix="yes">
  <MsgText pgmKey="wssec.configuration.error" varFormat="Java">
    wssec.configuration.error=WSWS1045E: An error occurred in loading {0} configuration for {1}. The service cannot be started.
  </MsgText>
  <Explanation>
    This exception is unexpected. The cause is not immediately known.
  </Explanation>
  <UserResponse>
    If the problem persists, additional information might be available if you search for the message ID on the following Web sites: WebSphere Application Server Support page: http://www.ibm.com/software/webservers/appserv/was/support/ WebSphere Application Server for z/OS Support page: http://www.ibm.com/software/webservers/appserv/zos_os390/support/ .
  </UserResponse>
</Message>
<Message ID="WSWS1023W" severity="W" prefix="yes">
  <MsgText pgmKey="warning.client.reference.not.found" varFormat="Java">
    warning.client.reference.not.found=WSWS1023W: The client reference was not found in java:comp namespace.
  </MsgText>
  <Explanation>
    The reference was not found in the namespace.
  </Explanation>
  <UserResponse>
    If the problem persists, additional information might be available if you search for the message ID on the following Web sites: WebSphere Application Server Support page: http://www.ibm.com/software/webservers/appserv/was/support/ WebSphere Application Server for z/OS Support page: http://www.ibm.com/software/webservers/appserv/zos_os390/support/ .
  </UserResponse>
</Message>
<Message ID="WSWS1017E" severity="E" prefix="yes">
  <MsgText pgmKey="client.mappingFile.not.found" varFormat="Java">
    client.mappingFile.not.found=WSWS1017E: The JSR 109 JAX-RPC mapping file {0}, as specified in the client deployment descriptor for service reference {1} cannot be read.
  </MsgText>
  <Explanation>
    The JAX-RPC mapping file that is specified in the Web services client deployment descriptor cannot be read.
  </Explanation>
  <UserResponse>
    Make sure that the file name that is specified in the Web service client deployment descriptor references a valid JAX-RPC mapping file in the module.
  </UserResponse>
</Message>
<Message ID="WSWS1014W" severity="W" prefix="yes">
  <MsgText pgmKey="warning.provider.not.verified" varFormat="Java">
    warning.provider.not.verified=WSWS1014W: Java class {0} that is specified in provider {1} cannot be loaded.  The provider is skipped. The exception is {2}.
  </MsgText>
  <Explanation>
    The global configuration file (was-webservices.xml) defines a provider, which specifies a Java class that cannot be loaded.
  </Explanation>
  <UserResponse>
    Determine and correct the cause of the failure.
  </UserResponse>
</Message>
<Message ID="WSWS1050W" severity="W" prefix="yes">
  <MsgText pgmKey="j2ee13.webservicesclient.nomatching.component.scoped.ref" varFormat="Java">
    j2ee13.webservicesclient.nomatching.component.scoped.ref=WSWS1050W: J2EE 1.3 {0} component-scoped service references do not match the enterprise beans.
  </MsgText>
  <Explanation>
    The deployment descriptor has component-scoped references, but their component names do not match any enterprise bean names in the module.
  </Explanation>
  <UserResponse>
    Remove the webservicesclient.xml file, or correct the component names.
  </UserResponse>
</Message>
<Message ID="WSWS1028E" severity="E" prefix="yes">
  <MsgText pgmKey="init.ejbcollaborator.failed" varFormat="Java">
    init.ejbcollaborator.failed=WSWS1028E: Error: Unable to initialize EJBCollaborator: {0}
  </MsgText>
  <Explanation>
    The Web services enterprise bean collaborator cannot be initialized.
  </Explanation>
  <UserResponse>
    If the problem persists, additional information might be available if you search for the message ID on the following Web sites: WebSphere Application Server Support page: http://www.ibm.com/software/webservers/appserv/was/support/ WebSphere Application Server for z/OS Support page: http://www.ibm.com/software/webservers/appserv/zos_os390/support/ .
  </UserResponse>
</Message>
<Message ID="WSWS1053E" severity="E" prefix="yes">
  <MsgText pgmKey="ejb.service.endpoint.mismatch" varFormat="Java">
    ejb.service.endpoint.mismatch=WSWS1053E: The service endpoint of the ejb-jar.xml ({0}) and webservices.xml ({1}) files do not match.  Application &apos;&apos;{2}&apos;&apos;, Module &apos;&apos;{3}&apos;&apos;, enterprise bean &apos;&apos;{4}&apos;&apos;.
  </MsgText>
  <Explanation>
    The service endpoint in the ejb-jar.xml and webservices.xml files must match.
  </Explanation>
  <UserResponse>
    Correct the service endpoint for the ejb-jar.xml and webservices.xml files.
  </UserResponse>
</Message>
<Message ID="WSWS1009W" severity="W" prefix="yes">
  <MsgText pgmKey="warning.sax.handler" varFormat="Java">
    warning.sax.handler=WSWS1009W: Warning: [{0}:{1}:{2}] {3}
  </MsgText>
  <Explanation>
    A warning was issued with the deployment descriptor that is listed.
  </Explanation>
  <UserResponse>
    Correct the problem with the deployment descriptor.
  </UserResponse>
</Message>
<Message ID="WSWS1064E" severity="E" prefix="yes">
  <MsgText pgmKey="invalid.transportheader.key" varFormat="Java">
    invalid.transportheader.key=WSWS1064E: A transport header key of null or length of zero is specified.  This header key is not valid and will be ignored.
  </MsgText>
  <Explanation>
    This exception is unexpected. The cause is not immediately known.
  </Explanation>
  <UserResponse>
    If the problem persists, additional information might be available if you search for the message ID on the following Web sites: WebSphere Application Server Support page: http://www.ibm.com/software/webservers/appserv/was/support/ WebSphere Application Server for z/OS Support page: http://www.ibm.com/software/webservers/appserv/zos_os390/support/ .
  </UserResponse>
</Message>
<Message ID="WSWS1002E" severity="E" prefix="yes">
  <MsgText pgmKey="error.in.ws.dd.processing" varFormat="Java">
    error.in.ws.dd.processing=WSWS1002E: An error occurred while processing the Web services deployment descriptor for module: {0} with error: {1}
  </MsgText>
  <Explanation>
    Unable to construct a Web services deployment descriptor.
  </Explanation>
  <UserResponse>
    Review the error or the exception stack trace to determine the cause.
  </UserResponse>
</Message>
<Message ID="WSWS1052E" severity="E" prefix="yes">
  <MsgText pgmKey="ejbjar.service.endpoint.not.defined" varFormat="Java">
    ejbjar.service.endpoint.not.defined=WSWS1052E: The service endpoint is not defined.  Application &apos;&apos;{0}&apos;&apos;, Module &apos;&apos;{1}&apos;&apos;, enterprise bean &apos;&apos;{2}&apos;&apos;.
  </MsgText>
  <Explanation>
    The service endpoint is required for a web service-enabled enterprise bean.  The service endpoint is not defined in the ejb-jar.xml file for the specified enterprise bean.
  </Explanation>
  <UserResponse>
    Define a service-endpoint for the enterprise bean in the ejb-jar.xml file.
  </UserResponse>
</Message>
<Message ID="WSWS1043E" severity="E" prefix="yes">
  <MsgText pgmKey="wssec.config.binding.error" varFormat="Java">
    wssec.config.binding.error=WSWS1043E: An error occurred in the configuration. More than one security binding is defined, but the program cannot determine which one to use without the WSDL service port.
  </MsgText>
  <Explanation>
    This exception is unexpected. The cause is not immediately known.
  </Explanation>
  <UserResponse>
    If the problem persists, additional information might be available if you search for the message ID on the following Web sites: WebSphere Application Server Support page: http://www.ibm.com/software/webservers/appserv/was/support/ WebSphere Application Server for z/OS Support page: http://www.ibm.com/software/webservers/appserv/zos_os390/support/ .
  </UserResponse>
</Message>
<Message ID="WSWS1004E" severity="E" prefix="yes">
  <MsgText pgmKey="error.binding.client.refs" varFormat="Java">
    error.binding.client.refs=WSWS1004E: An error occurred while binding client references in java:{0} namespace: {1}
  </MsgText>
  <Explanation>
    Unable to bind client references into the JNDI namespace.
  </Explanation>
  <UserResponse>
    This exception is unexpected. The cause is not immediately known.
  </UserResponse>
</Message>
<Message ID="WSWS1029E" severity="E" prefix="yes">
  <MsgText pgmKey="mds.lookup.failed" varFormat="Java">
    mds.lookup.failed=WSWS1029E: Error: {0}: Metadata service lookup failed: {1}
  </MsgText>
  <Explanation>
    The Metadata service cannot be found.
  </Explanation>
  <UserResponse>
    If the problem persists, additional information might be available if you search for the message ID on the following Web sites: WebSphere Application Server Support page: http://www.ibm.com/software/webservers/appserv/was/support/ WebSphere Application Server for z/OS Support page: http://www.ibm.com/software/webservers/appserv/zos_os390/support/ .
  </UserResponse>
</Message>
<Message ID="WSWS1019W" severity="W" prefix="yes">
  <MsgText pgmKey="warning.handler.invalid.flow" varFormat="Java">
    warning.handler.invalid.flow=WSWS1019W: For handlers {0} the handler {1} is not added because of a flow statement {2} that is not valid.
  </MsgText>
  <Explanation>
    An error occurred in the handler configuration.  The ignored handler might cause unexpected results.
  </Explanation>
  <UserResponse>
    If the problem persists, additional information might be available if you search for the message ID on the following Web sites: WebSphere Application Server Support page: http://www.ibm.com/software/webservers/appserv/was/support/ WebSphere Application Server for z/OS Support page: http://www.ibm.com/software/webservers/appserv/zos_os390/support/ .
  </UserResponse>
</Message>
<Message ID="WSWS1025E" severity="E" prefix="yes">
  <MsgText pgmKey="cannot.find.resource" varFormat="Java">
    cannot.find.resource=WSWS1025E: Error: Resource {0} was not found.
  </MsgText>
  <Explanation>
    The resource cannot be loaded by the class or system class loaders.
  </Explanation>
  <UserResponse>
    If the problem persists, additional information might be available if you search for the message ID on the following Web sites: WebSphere Application Server Support page: http://www.ibm.com/software/webservers/appserv/was/support/ WebSphere Application Server for z/OS Support page: http://www.ibm.com/software/webservers/appserv/zos_os390/support/ .
  </UserResponse>
</Message>
<!-- END MESSAGES -->
</TMSSource>
