<?xml version="1.0" encoding="UTF-8"?>
<?xml-stylesheet type="text/css" href="../../resources/stylesheets/wasmsgxml.css"?>
<TMSSource name="TivoliMessages" tmsVersion="1.0" xml:lang="en">
<!-- CMVC MSG File Name = ws/code/acwa/src/com/ibm/ws/workarea/resources/acwa.nlsprops -->
<!-- DO NOT EDIT THIS FILE - This file was generated by the XML/Html & Property emitter -->
<!-- BEGIN MESSAGES -->
<Message ID="ACWA0022I" severity="I" prefix="yes">
  <MsgText pgmKey="ERR_ILLEGAL_ACCESS2" varFormat="Java">
    ERR_ILLEGAL_ACCESS2=ACWA0022I: In this particular case, a request was made to use the WorkArea service outside the lifecycle of a valid container (e.g. EJB/Web) which is not allowed by the WorkArea service.
  </MsgText>
  <Explanation>
    A work area can only be accessed within the life cycle of a valid container.  Examples of, but not limited to, a valid container are: 1) EJB, 2) Web
  </Explanation>
  <UserResponse>
    Verify that a request to the work area service is only made in the life cycle of a valid container.
  </UserResponse>
</Message>
<Message ID="ACWA0007E" severity="E" prefix="yes">
  <MsgText pgmKey="ERR_WA_BLOCKED" varFormat="Java">
    ERR_WA_BLOCKED=ACWA0007E: Because of a previous error on {0}, the WorkArea on WorkArea Partition: {1}, cannot be accessed.
  </MsgText>
  <Explanation>
    The work area service experienced a significant error during runtime resulting in the possible corruption of user data; the service is blocked until the correct state can be restored (when the thread can be cleaned). For example, when the client process terminates, when the servlet process terminates or when the EJB method call is returned.
  </Explanation>
  <UserResponse>
    Verify that the work area programming model is carefully followed.
  </UserResponse>
</Message>
<Message ID="ACWA0016I" severity="I" prefix="yes">
  <MsgText pgmKey="INF_WAP_NOT_ENABLED" varFormat="Java">
    INF_WAP_NOT_ENABLED=ACWA0016I: WorkArea Partition: {0}, is not enabled on {1}.
  </MsgText>
  <Explanation>
    The given work area partition was not enabled. The given partition will be inaccessible on the given client or server.
  </Explanation>
  <UserResponse>
    Enable the given work area partition if the partition is needed.
  </UserResponse>
</Message>
<Message ID="ACWA0019I" severity="I" prefix="yes">
  <MsgText pgmKey="INF_PARTITION_DOESNT_EXISTS" varFormat="Java">
    INF_PARTITION_DOESNT_EXISTS=ACWA0019I: The WorkArea Partition with name: {0}, was not found.  Verify that a Partition with the given name was successfully created.
  </MsgText>
  <Explanation>
    The requested work area partition could not be found.  The name was incorrectly specified or the partition was either not created or was not created successfully.
  </Explanation>
  <UserResponse>
    Verify that a work area partition with the given name was successfully created.  If it does not exist, create one if needed.
  </UserResponse>
</Message>
<Message ID="ACWA0017I" severity="I" prefix="yes">
  <MsgText pgmKey="INF_WAP_READY" varFormat="Java">
    INF_WAP_READY=ACWA0017I: WorkArea Partition: {0}, is ready on {1}
  </MsgText>
  <Explanation>
    The given work area partition is ready for business.
  </Explanation>
  <UserResponse>
    No user action required.
  </UserResponse>
</Message>
<Message ID="ACWA0015I" severity="I" prefix="yes">
  <MsgText pgmKey="INF_INITIALIZATION_COMPLETE" varFormat="Java">
    INF_INITIALIZATION_COMPLETE=ACWA0015I: Server {0} has already been started and therefore the request to create partition {1} has been denied.  A WorkArea Partition can only be created during server start up.  Once a server is started requests for new WorkArea partitions will be denied.
  </MsgText>
  <Explanation>
    A service can create a work area partition during server start.  However, once the server is started, if a service attempts to create a partition, an exception will be created.
  </Explanation>
  <UserResponse>
    Create the work area partition before the server is started.
  </UserResponse>
</Message>
<Message ID="ACWA0004E" severity="E" prefix="yes">
  <MsgText pgmKey="ERR_NO_AG" varFormat="Java">
    ERR_NO_AG=ACWA0004E: Work area Partition: {0}, could not resolve the ActivityService on {1}.
  </MsgText>
  <Explanation>
    The work area service could not resolve the ActivityService from the client/server&apos;s orb.  Verify that the activity.jar and activityImpl.jar files are available in the process.
  </Explanation>
  <UserResponse>
    If the problem persists, additional information might be available if you search for the message ID on the following Web sites: WebSphere Application Server Support page: http://www.ibm.com/software/webservers/appserv/was/support/ WebSphere Application Server for z/OS Support page: http://www.ibm.com/software/webservers/appserv/zos_os390/support/ .
  </UserResponse>
</Message>
<Message ID="ACWA0012I" severity="I" prefix="yes">
  <MsgText pgmKey="INF_FUTURE_ACTIVITYSERVICE_FORMAT" varFormat="Java">
    INF_FUTURE_ACTIVITYSERVICE_FORMAT=ACWA0012I: The ActivityService on {0} in WorkArea Partition: {1}, could not import context from a forward-level client.
  </MsgText>
  <Explanation>
    The Application Server was invoked by a later version client. The format of the context between these releases has changed. The imported context may have been work area context or may have been some other context. To support interoperation between the Application Server version 4.0 servers and future Application Server clients, you must apply the appropriate service pack. Note that if the client request did contain work area properties, those properties were not imported into the server process.
  </Explanation>
  <UserResponse>
    If the problem persists, additional information might be available if you search for the message ID on the following Web sites: WebSphere Application Server Support page: http://www.ibm.com/software/webservers/appserv/was/support/ WebSphere Application Server for z/OS Support page: http://www.ibm.com/software/webservers/appserv/zos_os390/support/ .
  </UserResponse>
</Message>
<Message ID="ACWA0001E" severity="E" prefix="yes">
  <MsgText pgmKey="ERR_MISSING_KEY" varFormat="Java">
    ERR_MISSING_KEY=ACWA0001E: Message key {0} was not found in any searched catalog.
  </MsgText>
  <Explanation>
    A key was passed into the WorkAreaMessages class to resolve to a string, but a properties file for the locale could not be found and the appropriate message could not be retrieved.
  </Explanation>
  <UserResponse>
    If the problem persists, additional information might be available if you search for the message ID on the following Web sites: WebSphere Application Server Support page: http://www.ibm.com/software/webservers/appserv/was/support/ WebSphere Application Server for z/OS Support page: http://www.ibm.com/software/webservers/appserv/zos_os390/support/ .
  </UserResponse>
</Message>
<Message ID="ACWA0020I" severity="I" prefix="yes">
  <MsgText pgmKey="ERR_INVALID_PARTITION_NAME" varFormat="Java">
    ERR_INVALID_PARTITION_NAME=ACWA0020I: The WorkArea Partition name: {0}, is invalid.  Please use an appropriate name.
  </MsgText>
  <Explanation>
    The partion name field cannot be empty.
  </Explanation>
  <UserResponse>
    Enter an appropriate, non-null name for a partition.
  </UserResponse>
</Message>
<Message ID="ACWA0018E" severity="E" prefix="yes">
  <MsgText pgmKey="ERR_PARTITION_ALREADY_EXISTS" varFormat="Java">
    ERR_PARTITION_ALREADY_EXISTS=ACWA0018E: The WorkArea Partition with name: {0}, has already been created.  Partition names must be unique.
  </MsgText>
  <Explanation>
    A work area partition name must be unique.  If an attempt is made to create a partition with a name that already exists, an exception is created.
  </Explanation>
  <UserResponse>
    Create the work area partition with a unique name.
  </UserResponse>
</Message>
<Message ID="ACWA0003I" severity="I" prefix="yes">
  <MsgText pgmKey="INF_WA_DISABLED" varFormat="Java">
    INF_WA_DISABLED=ACWA0003I: WorkArea service disabled on {0} because of previous errors.
  </MsgText>
  <Explanation>
    The work area service experienced an error during initialization. The service will be inaccessible on the given client or server. The causing error should already have been logged. This message will be displayed when a user attempts to look up the WorkArea service.
  </Explanation>
  <UserResponse>
    If the problem persists, additional information might be available if you search for the message ID on the following Web sites: WebSphere Application Server Support page: http://www.ibm.com/software/webservers/appserv/was/support/ WebSphere Application Server for z/OS Support page: http://www.ibm.com/software/webservers/appserv/zos_os390/support/ .
  </UserResponse>
</Message>
<Message ID="ACWA0002I" severity="I" prefix="yes">
  <MsgText pgmKey="INF_WA_NOT_ENABLED" varFormat="Java">
    INF_WA_NOT_ENABLED=ACWA0002I: WorkArea service not enabled on {0}.
  </MsgText>
  <Explanation>
    The work area service was not enabled. The work area service will be inaccessible on the given client or server.
  </Explanation>
  <UserResponse>
    No user action required.
  </UserResponse>
</Message>
<Message ID="ACWA0008I" severity="I" prefix="yes">
  <MsgText pgmKey="INF_WA_NOT_COMPLETED" varFormat="Java">
    INF_WA_NOT_COMPLETED=ACWA0008I: WorkArea left uncompleted on {0} in WorkArea Partition: {1}.
  </MsgText>
  <Explanation>
    User code began but did not property complete a work area in the servlet or bean of the server process. The work area service will try to complete abandoned work areas in this situation, but users are ultimately responsible for following the work area programming model.
  </Explanation>
  <UserResponse>
    Verify that the work area programming model is carefully followed.
  </UserResponse>
</Message>
<Message ID="ACWA0009I" severity="I" prefix="yes">
  <MsgText pgmKey="INF_WA_NOT_RESUMED" varFormat="Java">
    INF_WA_NOT_RESUMED=ACWA0009I: WorkArea left unresumed on {0}
  </MsgText>
  <Explanation>
    The user code was suspended but did not properly resume a work area in the servlet or bean of the server process. The work area service will try to resume abandoned work areas in this situation, but users are ultimately responsible for following the work area programming model.
  </Explanation>
  <UserResponse>
    Verify that the work area programming model is carefully followed.
  </UserResponse>
</Message>
<Message ID="ACWA0010I" severity="I" prefix="yes">
  <MsgText pgmKey="INF_WA_READY" varFormat="Java">
    INF_WA_READY=ACWA0010I: WorkArea service ready on {0}
  </MsgText>
  <Explanation>
    The work area service is ready for business.
  </Explanation>
  <UserResponse>
    No user action is required.
  </UserResponse>
</Message>
<Message ID="ACWA0006E" severity="E" prefix="yes">
  <MsgText pgmKey="ERR_INTRNL_EXC" varFormat="Java">
    ERR_INTRNL_EXC=ACWA0006E: Unexpected exception in the WorkArea Partition: {0}, on {1} resulting in termination of service.
  </MsgText>
  <Explanation>
    The given work area partition experienced an error during runtime. Depending upon the severity of the error, the service may be blocked until the server method call returns or the client process terminates.
  </Explanation>
  <UserResponse>
    Verify that the work area programming model is carefully followed.
  </UserResponse>
</Message>
<Message ID="ACWA0021I" severity="I" prefix="yes">
  <MsgText pgmKey="ERR_ILLEGAL_ACCESS" varFormat="Java">
    ERR_ILLEGAL_ACCESS=ACWA0021I: The WorkArea Partition with name: {0}, is being illegally accessed outside the normal operational boundaries of the WorkArea service on {1}.
  </MsgText>
  <Explanation>
    A work area can only be accessed within a controlled boundary or in a controlled manner.  Examples of, but not limited to, an illegal access are: 1) Attempting to complete a work area begun by another process.  2) Attempting to remove context set by another process.  3) Attempting to set context into a work area partition before beginning a work area.
  </Explanation>
  <UserResponse>
    Verify that the work area programming model is carefully followed, see the work area documentation.
  </UserResponse>
</Message>
<Message ID="ACWA0011I" severity="I" prefix="yes">
  <MsgText pgmKey="INF_UNRECOGNIZED_FORMAT" varFormat="Java">
    INF_UNRECOGNIZED_FORMAT=ACWA0011I: WorkArea Partition: {0}, on {1} could not import data which was in an unfamiliar format.
  </MsgText>
  <Explanation>
    Context flowed into the work area partition that could not be demarshalled because the context was in an unfamiliar format. The unfamiliar format may reflect a version incompatibility.
  </Explanation>
  <UserResponse>
    If the problem persists, additional information might be available if you search for the message ID on the following Web sites: WebSphere Application Server Support page: http://www.ibm.com/software/webservers/appserv/was/support/ WebSphere Application Server for z/OS Support page: http://www.ibm.com/software/webservers/appserv/zos_os390/support/ .
  </UserResponse>
</Message>
<Message ID="ACWA0014I" severity="I" prefix="yes">
  <MsgText pgmKey="INF_INVALID_MAXRECEIVESIZE_FORMAT" varFormat="Java">
    INF_INVALID_MAXRECEIVESIZE_FORMAT=ACWA0014I: The value passed in for maxReceiveSize is not valid on WorkArea Partition: {0}.  The property passed in was {1}.  The default value of {2} will be used instead.
  </MsgText>
  <Explanation>
    You can set the size of a work area that can be received.  You can do this by setting a maxReceiveSize in the administrative console on the server, or on the client by setting the following system property: com.ibm.ws.workarea.maxReceiveSize=67891, for example.  This warning message is displayed if the system property values are set to an incorrect value, like &quot;abc&quot; for example.
  </Explanation>
  <UserResponse>
    Set a valid number for the maxReceiveSize, see the work area documentation for valid values.
  </UserResponse>
</Message>
<Message ID="ACWA0013I" severity="I" prefix="yes">
  <MsgText pgmKey="INF_INVALID_MAXSENDSIZE_FORMAT" varFormat="Java">
    INF_INVALID_MAXSENDSIZE_FORMAT=ACWA0013I: The value passed in for maxSendSize is not valid on WorkArea Partition: {0}.  The property passed in was {1}.  The default value of {2} will be used instead.
  </MsgText>
  <Explanation>
    You can set the size of a work area that can be sent.  You can do this by setting a maxSendSize in the administrative console on the server, or on the client by setting the following system property: com.ibm.ws.workarea.maxSendSize=67891, for example.  This warning message is displayed if the system property values are set to an incorrect value, like &quot;abc&quot; for example.
  </Explanation>
  <UserResponse>
    Set a valid number for the maxSendSize, see the WorkArea documentation for valid values.
  </UserResponse>
</Message>
<Message ID="ACWA0005E" severity="E" prefix="yes">
  <MsgText pgmKey="ERR_NO_ORB" varFormat="Java">
    ERR_NO_ORB=ACWA0005E: The orb has not been initialized on {0}.
  </MsgText>
  <Explanation>
    A user has attempted to access the work area service before the orb is initialized.
  </Explanation>
  <UserResponse>
    If the problem persists, additional information might be available if you search for the message ID on the following Web sites: WebSphere Application Server Support page: http://www.ibm.com/software/webservers/appserv/was/support/ WebSphere Application Server for z/OS Support page: http://www.ibm.com/software/webservers/appserv/zos_os390/support/ .
  </UserResponse>
</Message>
<!-- END MESSAGES -->
</TMSSource>
