<?xml version="1.0" encoding="UTF-8"?>
<?xml-stylesheet type="text/css" href="../../resources/stylesheets/wasmsgxml.css"?>
<TMSSource name="TivoliMessages" tmsVersion="1.0" xml:lang="en">
<!-- CMVC MSG File Name = ws/code/xd.hmm/src/com/ibm/ws/xd/hmm/nls/Messages.nlsprops -->
<!-- DO NOT EDIT THIS FILE - This file was generated by the XML/Html & Property emitter -->
<!-- BEGIN MESSAGES -->
<Message ID="WXDH6012E" severity="E" prefix="yes">
  <MsgText pgmKey="HMM_UNSUPPORTED_PMI_MODULE_NON_WAS" varFormat="Java">
    HMM_UNSUPPORTED_PMI_MODULE_NON_WAS=WXDH6012E: PMI module {0} is not currently supported for other middleware servers.
  </MsgText>
  <Explanation>
    Specified PMI module is not supported for other middleware servers.
  </Explanation>
  <UserResponse>
    Specify supported PMI modules for middleware servers.
  </UserResponse>
</Message>
<Message ID="WXDH1019E" severity="E" prefix="yes">
  <MsgText pgmKey="HMA_APCDisabled" varFormat="Java">
    HMA_APCDisabled=WXDH1019E: Server {0} cannot be restarted, the application placement controller is disabled, and the minimum number of instances cannot be maintained.
  </MsgText>
  <Explanation>
    The placement controller is disabled and the minimum number of instances cannot be guaranteed.
  </Explanation>
  <UserResponse>
    Start the application placement controller or additional instances.
  </UserResponse>
</Message>
<Message ID="WXDH0043I" severity="I" prefix="yes">
  <MsgText pgmKey="HMC_RemoveReaction" varFormat="Java">
    HMC_RemoveReaction=WXDH0043I: The {0} reaction has been removed from health policy {1}.
  </MsgText>
  <Explanation>
    This message is for informational purposes only.
  </Explanation>
  <UserResponse>
    No action is required.
  </UserResponse>
</Message>
<Message ID="WXDH0050W" severity="W" prefix="yes">
  <MsgText pgmKey="HMC_BGUnsupportedPolicy" varFormat="Java">
    HMC_BGUnsupportedPolicy=WXDH0050W: The health condition of policy {0} does not apply to servers performing long-running work.
  </MsgText>
  <Explanation>
    A policy for transactional work is being applied to a server that is allocated for long-running work.
  </Explanation>
  <UserResponse>
    Check the policy definitions, and ensure that transactional and long-running applications are not deployed to the same targets.
  </UserResponse>
</Message>
<Message ID="WXDH6007E" severity="E" prefix="yes">
  <MsgText pgmKey="HMM_INVALID_ODR_CELL_METRIC" varFormat="Java">
    HMM_INVALID_ODR_CELL_METRIC=WXDH6007E: The ODR cell metric {0} is not valid.
  </MsgText>
  <Explanation>
    Invalid ODR cell metric detected.
  </Explanation>
  <UserResponse>
    Specify valid ODR cell metric.
  </UserResponse>
</Message>
<Message ID="WXDH0030W" severity="W" prefix="yes">
  <MsgText pgmKey="HMC_RestartsDisabled" varFormat="Java">
    HMC_RestartsDisabled=WXDH0030W: Server {0} cannot be restarted.
  </MsgText>
  <Explanation>
    The server has been restarted the maximum number of times consecutively, and a health condition continues to be violated.
  </Explanation>
  <UserResponse>
    Update the maximum number of times to restart the server, and restart the server.
  </UserResponse>
</Message>
<Message ID="WXDH1024E" severity="E" prefix="yes">
  <MsgText pgmKey="HMA_CustomFailed" varFormat="Java">
    HMA_CustomFailed=WXDH1024E: The attempt to start and complete custom task {0} failed.
  </MsgText>
  <Explanation>
    The custom task failed to complete successfully.
  </Explanation>
  <UserResponse>
    No action is required.
  </UserResponse>
</Message>
<Message ID="WXDH0040E" severity="E" prefix="yes">
  <MsgText pgmKey="HMC_AddMemberError" varFormat="Java">
    HMC_AddMemberError=WXDH0040E: Member {0} could not be added to health policy {1}.
  </MsgText>
  <Explanation>
    A member was added to the health policy, but a problem occurred while processing the addition.
  </Explanation>
  <UserResponse>
    Synchronize the configuration repository with all of the nodes. Disable and re-enable the health controller.
  </UserResponse>
</Message>
<Message ID="WXDH9999E" severity="E" prefix="yes">
  <MsgText pgmKey="HMM_GENLERR" varFormat="Java">
    HMM_GENLERR=WXDH9999E: Health controller internal error: data is {0}, and the exception is {1}.
  </MsgText>
  <Explanation>
    An unexpected error occured.
  </Explanation>
  <UserResponse>
    Review the log files where the health controller is running.
  </UserResponse>
</Message>
<Message ID="WXDH0019E" severity="E" prefix="yes">
  <MsgText pgmKey="HMC_NoSrvListen" varFormat="Java">
    HMC_NoSrvListen=WXDH0019E: The server configuration listener could not be started.
  </MsgText>
  <Explanation>
    The health controller could not enable listening for server configuration changes in {0}.
  </Explanation>
  <UserResponse>
    Contact IBM Support.
  </UserResponse>
</Message>
<Message ID="WXDH6009E" severity="E" prefix="yes">
  <MsgText pgmKey="HMM_MISSING_MODULE_METRIC_NAME" varFormat="Java">
    HMM_MISSING_MODULE_METRIC_NAME=WXDH6009E: The module and metric name for {0} operand must be specified
  </MsgText>
  <Explanation>
    The module and metric name for operand is not specified.
  </Explanation>
  <UserResponse>
    Specify module and metric name for operand.
  </UserResponse>
</Message>
<Message ID="WXDH3007W" severity="W" prefix="yes">
  <MsgText pgmKey="HMS_Timeout" varFormat="Java">
    HMS_Timeout=WXDH3007W: The request timeout limit specified by policy {0} was exceeded by server {1} on node {2}. The limit is {3} % and the current timeout fraction is {4} %.
  </MsgText>
  <Explanation>
    The server is experiencing a large number of request timeouts.
  </Explanation>
  <UserResponse>
    If the policy is supervised, check the runtime tasks to approve the configured response.
  </UserResponse>
</Message>
<Message ID="WXDH1023I" severity="I" prefix="yes">
  <MsgText pgmKey="HMA_CustomSuccess" varFormat="Java">
    HMA_CustomSuccess=WXDH1023I: Custom task {0} successfully started and completed.
  </MsgText>
  <Explanation>
    The custom task completed successfully.
  </Explanation>
  <UserResponse>
    No action is required.
  </UserResponse>
</Message>
<Message ID="WXDH0015E" severity="E" prefix="yes">
  <MsgText pgmKey="HMC_TgtNotFound" varFormat="Java">
    HMC_TgtNotFound=WXDH0015E: Cannot find target member {0} for health policy {1}.
  </MsgText>
  <Explanation>
    The target was not added to the health policy, because it could not be found.
  </Explanation>
  <UserResponse>
    Verify that the cell is fully sychronized and the target member exists in the administrative console.
  </UserResponse>
</Message>
<Message ID="WXDH1014I" severity="I" prefix="yes">
  <MsgText pgmKey="HMA_HeapDump" varFormat="Java">
    HMA_HeapDump=WXDH1014I: Heap dumps for server {0} are being issued automatically.
  </MsgText>
  <Explanation>
    This message is for informational purposes only.
  </Explanation>
  <UserResponse>
    No action is required.
  </UserResponse>
</Message>
<Message ID="WXDH6016E" severity="E" prefix="yes">
  <MsgText pgmKey="HMM_INVALID_MBEAN_ONAME" varFormat="Java">
    HMM_INVALID_MBEAN_ONAME=WXDH6016E: The object name query string is not valid. The string should contain both the process and node name or nothing.
  </MsgText>
  <Explanation>
    Incorrect object name query string for MBean detected.
  </Explanation>
  <UserResponse>
    Ensure that string contains both the process and node name or nothing.
  </UserResponse>
</Message>
<Message ID="WXDH1121I" severity="I" prefix="yes">
  <MsgText pgmKey="HMA_RecomendationExpire" varFormat="Java">
    HMA_RecomendationExpire=WXDH1121I: The Health Controller has submitted a task to the Task Management subsystem that will expire at {0}.  The operating mode is {1}.  The task ID is {2}.
  </MsgText>
  <Explanation>
    Health Controller has submitted a task to the Task Management subsystem. See message WXDH1120I for additional information.
  </Explanation>
  <UserResponse>
    If the reaction mode mode is supervised, use the Admin Console Task Management panel to accept the recommendation prior to the expiration time. If the reaction mode is automatic, no user action is required.
  </UserResponse>
</Message>
<Message ID="WXDH1003E" severity="E" prefix="yes">
  <MsgText pgmKey="HMA_NoStart" varFormat="Java">
    HMA_NoStart=WXDH1003E: The following error occurred when trying to start server {0}.
  </MsgText>
  <Explanation>
    The specified server could not be started.
  </Explanation>
  <UserResponse>
    Investigate the cause of the failure in the server log files.
  </UserResponse>
</Message>
<Message ID="WXDH1029I" severity="I" prefix="yes">
  <MsgText pgmKey="HMA_SnmpTrap" varFormat="Java">
    HMA_SnmpTrap=WXDH1029I: A SNMP trap has been issued for server {0}.
  </MsgText>
  <Explanation>
    The health controller requested that a SNMP trap be sent.
  </Explanation>
  <UserResponse>
    No action is required.
  </UserResponse>
</Message>
<Message ID="WXDH0016W" severity="W" prefix="yes">
  <MsgText pgmKey="HMC_ConfigErr" varFormat="Java">
    HMC_ConfigErr=WXDH0016W: An error occurred while reading the configuration repository {0}.
  </MsgText>
  <Explanation>
    The health controller could not read the configuration repository.
  </Explanation>
  <UserResponse>
    Verify that no cell-wide errors reading the configuration repository exist. Otherwise, contact IBM Support.
  </UserResponse>
</Message>
<Message ID="WXDH0011W" severity="W" prefix="yes">
  <MsgText pgmKey="HMC_MaxVFail" varFormat="Java">
    HMC_MaxVFail=WXDH0011W: Server {0} exceeded the maximum amount of verification failures: Disabling restarts.
  </MsgText>
  <Explanation>
    The server failed to restart too many times.
  </Explanation>
  <UserResponse>
    See the log files for possible reasons why the server could not be restarted.
  </UserResponse>
</Message>
<Message ID="WXDH3011W" severity="W" prefix="yes">
  <MsgText pgmKey="HMS_EJB_Response" varFormat="Java">
    HMS_EJB_Response=WXDH3011W: A response time change point has been detected by health policy {0} for server {1} on node {2} for the average EJB method response time: Suspected EJBs are: {3}.
  </MsgText>
  <Explanation>
    A significant change in the average EJB method response time has been observed for one or more EJBs.
  </Explanation>
  <UserResponse>
    Investigate the ODR log files and the log files for the specified server for the cause of the symptoms.
  </UserResponse>
</Message>
<Message ID="WXDH5000I" severity="I" prefix="yes">
  <MsgText pgmKey="HMM_UP" varFormat="Java">
    HMM_UP=WXDH5000I: The health management controller is running and operational.
  </MsgText>
  <Explanation>
    This message is for informational purposes only.
  </Explanation>
  <UserResponse>
    No action is required.
  </UserResponse>
</Message>
<Message ID="WXDH6021E" severity="E" prefix="yes">
  <MsgText pgmKey="HMM_PMI_METRIC_NOT_FOUND" varFormat="Java">
    HMM_PMI_METRIC_NOT_FOUND=WXDH6021E: Metric {0} does not exist in PMI module {1}.
  </MsgText>
  <Explanation>
    Specified metric does not exist in the PMI module.
  </Explanation>
  <UserResponse>
    Specify a valid PMI metric for the given module.
  </UserResponse>
</Message>
<Message ID="WXDH0031I" severity="I" prefix="yes">
  <MsgText pgmKey="HMC_MaintenanceMode" varFormat="Java">
    HMC_MaintenanceMode=WXDH0031I: Server {0} cannot be restarted when the node is in maintenance mode.
  </MsgText>
  <Explanation>
    The health controller will not restart servers on nodes that are in maintenance mode.
  </Explanation>
  <UserResponse>
    No action is required.
  </UserResponse>
</Message>
<Message ID="WXDH0006E" severity="E" prefix="yes">
  <MsgText pgmKey="HMC_ClassNotFound" varFormat="Java">
    HMC_ClassNotFound=WXDH0006E: Health policy not found: {0}
  </MsgText>
  <Explanation>
    The specified health policy was not found.
  </Explanation>
  <UserResponse>
    Verify that the cell is fully synchronized and is displayed on the Health Policies panel. In the administrative console, select Operational policies &gt; Health Policies.
  </UserResponse>
</Message>
<Message ID="WXDH0045E" severity="E" prefix="yes">
  <MsgText pgmKey="HMC_BBError" varFormat="Java">
    HMC_BBError=WXDH0045E: The following error occurred locating the {0} bulletin board: {1}
  </MsgText>
  <Explanation>
    The health controller could not locate the specified bulletin board.
  </Explanation>
  <UserResponse>
    Contact IBM Support.
  </UserResponse>
</Message>
<Message ID="WXDH1018E" severity="E" prefix="yes">
  <MsgText pgmKey="HMA_APCNotFnd" varFormat="Java">
    HMA_APCNotFnd=WXDH1018E: Could not contact the application placement controller: {0}
  </MsgText>
  <Explanation>
    Because the application placement controller cannot be contacted, the dynamic cluster member cannot be restarted.
  </Explanation>
  <UserResponse>
    Ensure that the application placement controller is enabled.
  </UserResponse>
</Message>
<Message ID="WXDH1129I" severity="I" prefix="yes">
  <MsgText pgmKey="HMA_FindBestVacancy" varFormat="Java">
    HMA_FindBestVacancy=WXDH1129I: The Health Controller has asked to find an alternate location to run server {0} and the available replacement location is {1}.
  </MsgText>
  <Explanation>
    This is usually caused by a user or system component requesting the shutdown or setting of maintenance mode for a server or node.
  </Explanation>
  <UserResponse>
    No user action is required at this time.
  </UserResponse>
</Message>
<Message ID="WXDH1015E" severity="E" prefix="yes">
  <MsgText pgmKey="HMA_HeapDumpFailed" varFormat="Java">
    HMA_HeapDumpFailed=WXDH1015E: The heap dump failed for server {0}.
  </MsgText>
  <Explanation>
    Either the server could not be contacted, the JVM does not support the heap dump command, or the maximum number of heap dumps already exists.
  </Explanation>
  <UserResponse>
    Check the log files for additional information.
  </UserResponse>
</Message>
<Message ID="WXDH1027E" severity="E" prefix="yes">
  <MsgText pgmKey="HMA_MaintModeFailure" varFormat="Java">
    HMA_MaintModeFailure=WXDH1027E: An error occurred while attempting to place server {0} into maintenance mode.
  </MsgText>
  <Explanation>
    The health controller was unable to place the server into maintenance mode.
  </Explanation>
  <UserResponse>
    Check the log files for additional information.
  </UserResponse>
</Message>
<Message ID="WXDH6015E" severity="E" prefix="yes">
  <MsgText pgmKey="HMM_INVALID_PORT_HOST" varFormat="Java">
    HMM_INVALID_PORT_HOST=WXDH6015E: The port number or target host is not valid.
  </MsgText>
  <Explanation>
    Incorrect port number or host detected.
  </Explanation>
  <UserResponse>
    Specify a valid host and port number in the 0 to 65535 range.
  </UserResponse>
</Message>
<Message ID="WXDH1123I" severity="I" prefix="yes">
  <MsgText pgmKey="HMA_TaskApproved" varFormat="Java">
    HMA_TaskApproved=WXDH1123I: The Health Controller has received approval for task ID {0}.
  </MsgText>
  <Explanation>
    Health Controller has received user approval for previously submitted task.  The task will be executed.
  </Explanation>
  <UserResponse>
    No user action is required at this time.
  </UserResponse>
</Message>
<Message ID="WXDH1011I" severity="I" prefix="yes">
  <MsgText pgmKey="HMA_ThreadDumped" varFormat="Java">
    HMA_ThreadDumped=WXDH1011I: The health controller issued a thread dump for server {0}.
  </MsgText>
  <Explanation>
    This message is for informational purposes only.
  </Explanation>
  <UserResponse>
    No action is required.
  </UserResponse>
</Message>
<Message ID="WXDH1120I" severity="I" prefix="yes">
  <MsgText pgmKey="HMA_ServerRecomendation" varFormat="Java">
    HMA_ServerRecomendation=WXDH1120I: The Health Controller recommends server {0} be changed to state {1} on node {2}.  Policy {3} reaction mode is {4}.
  </MsgText>
  <Explanation>
    Health Controller has determined a server instance needs to be stopped or started.  See message WXDH1121I for additional information.
  </Explanation>
  <UserResponse>
    If the reaction mode is supervised, use the Admin Console Task Management panel to accept or deny the recommendation. If the reaction mode is automatic, no user action is required.
  </UserResponse>
</Message>
<Message ID="WXDH1028W" severity="W" prefix="yes">
  <MsgText pgmKey="HMA_RestartForceTerminate" varFormat="Java">
    HMA_RestartForceTerminate=WXDH1028W: The server {0} failed to stop.  A force terminate command has been issued.
  </MsgText>
  <Explanation>
    The health controller was unable stop an instance in a normal manner.
  </Explanation>
  <UserResponse>
    Check the log files for additional information.
  </UserResponse>
</Message>
<Message ID="WXDH0008E" severity="E" prefix="yes">
  <MsgText pgmKey="HMC_LoopErr" varFormat="Java">
    HMC_LoopErr=WXDH0008E: An error occurred during the initialization of the health controller: {0}
  </MsgText>
  <Explanation>
    An error occurred during the initialization of the health controller.
  </Explanation>
  <UserResponse>
    Contact IBM Support.
  </UserResponse>
</Message>
<Message ID="WXDH3003W" severity="W" prefix="yes">
  <MsgText pgmKey="HMS_Work" varFormat="Java">
    HMS_Work=WXDH3003W: The maximum number of requests specified by policy {0} was reached by server {1} on node {2}. The limit is {3} requests and the current work is {4} requests.
  </MsgText>
  <Explanation>
    The server has reached the maximum number of permitted requests.
  </Explanation>
  <UserResponse>
    If the policy is supervised, check the runtime tasks to approve the configured response.
  </UserResponse>
</Message>
<Message ID="WXDH0029I" severity="I" prefix="yes">
  <MsgText pgmKey="HMC_RestartsProhibited" varFormat="Java">
    HMC_RestartsProhibited=WXDH0029I: Server {0} cannot be restarted, because the restart process is prohibited at this time.
  </MsgText>
  <Explanation>
    This message is for informational purposes only.
  </Explanation>
  <UserResponse>
    No action is required.
  </UserResponse>
</Message>
<Message ID="WXDH1007I" severity="I" prefix="yes">
  <MsgText pgmKey="HMA_Restart" varFormat="Java">
    HMA_Restart=WXDH1007I: Server {0} is being restarted automatically.
  </MsgText>
  <Explanation>
    This message is for informational purposes only.
  </Explanation>
  <UserResponse>
    No action is required.
  </UserResponse>
</Message>
<Message ID="WXDH6010E" severity="E" prefix="yes">
  <MsgText pgmKey="HMM_UNSUPPORTED_PMI_MODULE" varFormat="Java">
    HMM_UNSUPPORTED_PMI_MODULE=WXDH6010E: PMI module {0} is not currently supported.
  </MsgText>
  <Explanation>
    Specified PMI module is not supported.
  </Explanation>
  <UserResponse>
    Specify supported PMI modules.
  </UserResponse>
</Message>
<Message ID="WXDH1122I" severity="I" prefix="yes">
  <MsgText pgmKey="HMA_TaskDenied" varFormat="Java">
    HMA_TaskDenied=WXDH1122I: The Health Controller has submitted a task that was denied.  The task ID is {0}.
  </MsgText>
  <Explanation>
    Health Controller has submitted a task to the Task Management subsystem and the task was denied.  If there is a reoccurrence of the conditions that originally caused the task to be generated, a new task will be generated.
  </Explanation>
  <UserResponse>
    No user action is required at this time.
  </UserResponse>
</Message>
<Message ID="WXDH1012E" severity="E" prefix="yes">
  <MsgText pgmKey="HMA_ThreadDumpFailed" varFormat="Java">
    HMA_ThreadDumpFailed=WXDH1012E: The thread dump operation failed for server {0}.
  </MsgText>
  <Explanation>
    An error occured attempting to complete a thread dump from the server.
  </Explanation>
  <UserResponse>
    Check the log files for additional information.
  </UserResponse>
</Message>
<Message ID="WXDH1124I" severity="I" prefix="yes">
  <MsgText pgmKey="HMA_TaskExpired" varFormat="Java">
    HMA_TaskExpired=WXDH1124I: The Health Controller has submitted a task that has expired.  The task ID is {0}.
  </MsgText>
  <Explanation>
    Health Controller has submitted a task to the Task Management subsystem and the task has expired.  If there is a reoccurrence of the conditions that originally caused the task to be generated, a new task will be generated.
  </Explanation>
  <UserResponse>
    No user action is required at this time.
  </UserResponse>
</Message>
<Message ID="WXDH6004E" severity="E" prefix="yes">
  <MsgText pgmKey="HMM_MBEAN_NON_WAS" varFormat="Java">
    HMM_MBEAN_NON_WAS=WXDH6004E: MBean operation and attribute invocation are currently not supported for other middleware servers.
  </MsgText>
  <Explanation>
    MBean operation and attribute invocation are currently not supported for other middleware servers.
  </Explanation>
  <UserResponse>
    Operation not supported.
  </UserResponse>
</Message>
<Message ID="WXDH6014E" severity="E" prefix="yes">
  <MsgText pgmKey="HMM_INVALID_HOST" varFormat="Java">
    HMM_INVALID_HOST=WXDH6014E: The target host is not valid.
  </MsgText>
  <Explanation>
    No host or incorrect host detected.
  </Explanation>
  <UserResponse>
    Specify a valid host.
  </UserResponse>
</Message>
<Message ID="WXDH0003I" severity="I" prefix="yes">
  <MsgText pgmKey="HMC_Stopping" varFormat="Java">
    HMC_Stopping=WXDH0003I: Stopping the health controller for {0}.
  </MsgText>
  <Explanation>
    This message is for informational purposes only.
  </Explanation>
  <UserResponse>
    No action is required.
  </UserResponse>
</Message>
<Message ID="WXDH0022E" severity="E" prefix="yes">
  <MsgText pgmKey="HMC_CNError" varFormat="Java">
    HMC_CNError=WXDH0022E: The following error occurred while handling configuration notification: {0}
  </MsgText>
  <Explanation>
    An error occurred as the configuration change was processing.
  </Explanation>
  <UserResponse>
    Review the error for possible resolutions.
  </UserResponse>
</Message>
<Message ID="WXDH0032I" severity="I" prefix="yes">
  <MsgText pgmKey="HMC_RestartInterval" varFormat="Java">
    HMC_RestartInterval=WXDH0032I: Server {0} cannot be restarted, because the last attempt to restart the server occurred too recently.
  </MsgText>
  <Explanation>
    The health controller is configured to maintain a minimum restart interval.
  </Explanation>
  <UserResponse>
    No action is required.
  </UserResponse>
</Message>
<Message ID="WXDH0007W" severity="W" prefix="yes">
  <MsgText pgmKey="HMC_RmWarn" varFormat="Java">
    HMC_RmWarn=WXDH0007W: Member {0} is not found for health policy {1}.
  </MsgText>
  <Explanation>
    The health policy member could not be found or removed.
  </Explanation>
  <UserResponse>
    Verify that the cell is fully synchronized and is displayed in the health policy. In the administrative console, select Operational policies &gt; Health Policies &gt; health_policy_name &gt; Memberships.
  </UserResponse>
</Message>
<Message ID="WXDH1005E" severity="E" prefix="yes">
  <MsgText pgmKey="HMA_NoHeapDumps" varFormat="Java">
    HMA_NoHeapDumps=WXDH1005E: Heap dumps are not supported on server {0}.
  </MsgText>
  <Explanation>
    The server does not support automated heap dumps.
  </Explanation>
  <UserResponse>
    The server must run an IBM JDK on WebSphere Application Server Version 6.0.2 or later.
  </UserResponse>
</Message>
<Message ID="WXDH6019E" severity="E" prefix="yes">
  <MsgText pgmKey="HMM_INVALID_URL" varFormat="Java">
    HMM_INVALID_URL=WXDH6019E: {0} is not a valid URL: {1}.
  </MsgText>
  <Explanation>
    Incorrect URL detected.
  </Explanation>
  <UserResponse>
    Specify a valid URL.
  </UserResponse>
</Message>
<Message ID="WXDH0039I" severity="I" prefix="yes">
  <MsgText pgmKey="HMC_AddMember" varFormat="Java">
    HMC_AddMember=WXDH0039I: Member {0} has been added to health policy {1}.
  </MsgText>
  <Explanation>
    This message is for informational purposes only.
  </Explanation>
  <UserResponse>
    No action is required.
  </UserResponse>
</Message>
<Message ID="WXDH1125I" severity="I" prefix="yes">
  <MsgText pgmKey="HMA_TaskSource" varFormat="Java">
    HMA_TaskSource=WXDH1125I: The Health Controller will submit tasks from the active location {0}.
  </MsgText>
  <Explanation>
    Health Controller will submit tasks to the Task Management subsystem from the indicated cell/node/server.
  </Explanation>
  <UserResponse>
    No user action is required at this time.
  </UserResponse>
</Message>
<Message ID="WXDH1008I" severity="I" prefix="yes">
  <MsgText pgmKey="HMA_RestartSuccess" varFormat="Java">
    HMA_RestartSuccess=WXDH1008I: Server {0} was restarted successfully.
  </MsgText>
  <Explanation>
    This message is for informational purposes only.
  </Explanation>
  <UserResponse>
    No action is required.
  </UserResponse>
</Message>
<Message ID="WXDH0051W" severity="W" prefix="yes">
  <MsgText pgmKey="HMC_NonWasUnsupportedPolicy" varFormat="Java">
    HMC_NonWasUnsupportedPolicy=WXDH0051W: Health policy {0} is not supported for the other middleware server {1}.
  </MsgText>
  <Explanation>
    A policy that is supported only for WebSphere servers is being applied to an other middleware server.
  </Explanation>
  <UserResponse>
    Check the policy definitions, and ensure that unsupported health policies are not created for other middleware servers.
  </UserResponse>
</Message>
<Message ID="WXDH6022I" severity="I" prefix="yes">
  <MsgText pgmKey="HMM_GARBAGE_COLLECTION_HP_VIOLATION" varFormat="Java">
    HMM_GARBAGE_COLLECTION_HP_VIOLATION=WXDH6022I: The current garbage collection percentage of {0} exceeds the threshold of {1}.
  </MsgText>
  <Explanation>
    This message is for informational purposes only.
  </Explanation>
  <UserResponse>
    No action is required.
  </UserResponse>
</Message>
<Message ID="WXDH0034I" severity="I" prefix="yes">
  <MsgText pgmKey="HMC_AddPolicy" varFormat="Java">
    HMC_AddPolicy=WXDH0034I: Health policy {0} has been added.
  </MsgText>
  <Explanation>
    A health policy has been added to the configuration repository and read by the health controller.
  </Explanation>
  <UserResponse>
    No action is required.
  </UserResponse>
</Message>
<Message ID="WXDH0049I" severity="I" prefix="yes">
  <MsgText pgmKey="HMC_NodeInTransition" varFormat="Java">
    HMC_NodeInTransition=WXDH0049I: Server {0} cannot be restarted when the node switches between long-running and transactional work.
  </MsgText>
  <Explanation>
    The node on which the server is running is being reallocated for another type of work. The servers will be stopped.
  </Explanation>
  <UserResponse>
    No action is required.
  </UserResponse>
</Message>
<Message ID="WXDH0033W" severity="W" prefix="yes">
  <MsgText pgmKey="HMC_ClusterMin" varFormat="Java">
    HMC_ClusterMin=WXDH0033W: Server {0} cannot be restarted, because it is the only running member of a cluster.
  </MsgText>
  <Explanation>
    The health controller will not restart the only running member of a cluster.
  </Explanation>
  <UserResponse>
    Start another server in the cluster.
  </UserResponse>
</Message>
<Message ID="WXDH6005E" severity="E" prefix="yes">
  <MsgText pgmKey="HMM_CUSTOM_HEALTH_EVALUATE" varFormat="Java">
    HMM_CUSTOM_HEALTH_EVALUATE=WXDH6005E: The custom health policy evaluation failed.
  </MsgText>
  <Explanation>
    A problem was detected during custom health policy evaluation.
  </Explanation>
  <UserResponse>
    Review the log files where the health controller is running.
  </UserResponse>
</Message>
<Message ID="WXDH0017E" severity="E" prefix="yes">
  <MsgText pgmKey="HMC_NoCfgUpd" varFormat="Java">
    HMC_NoCfgUpd=WXDH0017E: The HealthConfigMonitor could not be located on the deployment manager.
  </MsgText>
  <Explanation>
    The health controller cannot receive health policy updates.
  </Explanation>
  <UserResponse>
    Verify that the deployment manager is running.
  </UserResponse>
</Message>
<Message ID="WXDH0005E" severity="E" prefix="yes">
  <MsgText pgmKey="HMC_EnableError" varFormat="Java">
    HMC_EnableError=WXDH0005E: An exception occurred while enabling the health controller: {0}
  </MsgText>
  <Explanation>
    An exception occurred as the health controller was being enabled.
  </Explanation>
  <UserResponse>
    Contact IBM Support.
  </UserResponse>
</Message>
<Message ID="WXDH1025I" severity="I" prefix="yes">
  <MsgText pgmKey="HMA_MaintMode" varFormat="Java">
    HMA_MaintMode=WXDH1025I: Maintenance mode is being set for server {0}.
  </MsgText>
  <Explanation>
    The health controller is automatically placing the specified server into maintenance mode.
  </Explanation>
  <UserResponse>
    No action is required.
  </UserResponse>
</Message>
<Message ID="WXDH3004W" severity="W" prefix="yes">
  <MsgText pgmKey="HMS_Memory" varFormat="Java">
    HMS_Memory=WXDH3004W: The memory consumption limit specified by policy {0} was exceeded by server {1} on node {2}. The limit is {3} % and the current heap size is {4} % of the maximum of {5} KB.
  </MsgText>
  <Explanation>
    The server is approaching its maximum memory limit.
  </Explanation>
  <UserResponse>
    If the policy is supervised, check the runtime tasks to approve the configured response.
  </UserResponse>
</Message>
<Message ID="WXDH1141W" severity="W" prefix="yes">
  <MsgText pgmKey="HMA_FindBestNoneFound" varFormat="Java">
    HMA_FindBestNoneFound=WXDH1141W: The Health Controller can not locate an alternate location to run server {0}.  Reason Code {1}.
  </MsgText>
  <Explanation>
    This is usually caused by a user or system component requesting the shutdown or setting of maintenance mode for a server or node.
  </Explanation>
  <UserResponse>
    Use the Admin Console to modify the placement of dynamic cluster instances to maintain desired service level performance.
  </UserResponse>
</Message>
<Message ID="WXDH0042I" severity="I" prefix="yes">
  <MsgText pgmKey="HMC_AddReaction" varFormat="Java">
    HMC_AddReaction=WXDH0042I: The {0} reaction has been added to health policy {1}.
  </MsgText>
  <Explanation>
    This message is for informational purposes only.
  </Explanation>
  <UserResponse>
    No action is required.
  </UserResponse>
</Message>
<Message ID="WXDH1002E" severity="E" prefix="yes">
  <MsgText pgmKey="HMA_NADown" varFormat="Java">
    HMA_NADown=WXDH1002E: The following error occurred when trying to communicate with the node agent on {0}.
  </MsgText>
  <Explanation>
    A node agent cannot be contacted when it is not running.
  </Explanation>
  <UserResponse>
    Verify that the node agent is running. Restart the node agent if necessary.
  </UserResponse>
</Message>
<Message ID="WXDH1140I" severity="I" prefix="yes">
  <MsgText pgmKey="HMA_FindBestFinalAnswer" varFormat="Java">
    HMA_FindBestFinalAnswer=WXDH1140I: The Health Controller has selected an alternate location to run server {0}.  The replacement location is {1}.
  </MsgText>
  <Explanation>
    This is usually caused by a user or system component requesting the shutdown or setting of maintenance mode for a server or node.
  </Explanation>
  <UserResponse>
    No user action is required at this time.
  </UserResponse>
</Message>
<Message ID="WXDH0012W" severity="W" prefix="yes">
  <MsgText pgmKey="HMC_ServerDFail" varFormat="Java">
    HMC_ServerDFail=WXDH0012W: Server {0} with restarts disabled failed the health check.
  </MsgText>
  <Explanation>
    The server failed a health check, but restarts are disabled.
  </Explanation>
  <UserResponse>
    See the log files for possible reasons why the server failed the health check.
  </UserResponse>
</Message>
<Message ID="WXDH6008E" severity="E" prefix="yes">
  <MsgText pgmKey="HMM_INVALID_ODR_SERVER_METRIC" varFormat="Java">
    HMM_INVALID_ODR_SERVER_METRIC=WXDH6008E: The ODR server metric {0} is not valid.
  </MsgText>
  <Explanation>
    Invalid ODR server metric detected.
  </Explanation>
  <UserResponse>
    Specify valid ODR server metric.
  </UserResponse>
</Message>
<Message ID="WXDH0004I" severity="I" prefix="yes">
  <MsgText pgmKey="HMC_AlreadyStarted" varFormat="Java">
    HMC_AlreadyStarted=WXDH0004I: The health controller is already started.
  </MsgText>
  <Explanation>
    This message is for informational purposes only.
  </Explanation>
  <UserResponse>
    No action is required.
  </UserResponse>
</Message>
<Message ID="WXDH1142W" severity="W" prefix="yes">
  <MsgText pgmKey="HMA_CluserModeChange" varFormat="Java">
    HMA_CluserModeChange=WXDH1142W: The Health Controller is placing dynamic cluster {0} into {1} operating mode.
  </MsgText>
  <Explanation>
    This is usually caused by a user or system component requesting the shutdown or setting of maintenance mode for a server or node.
  </Explanation>
  <UserResponse>
    No user action is required at this time.
  </UserResponse>
</Message>
<Message ID="WXDH0046E" severity="E" prefix="yes">
  <MsgText pgmKey="HMC_StartError" varFormat="Java">
    HMC_StartError=WXDH0046E: The following error occurred starting the health controller: {0}
  </MsgText>
  <Explanation>
    The health controller could not be started.
  </Explanation>
  <UserResponse>
    Contact IBM Support.
  </UserResponse>
</Message>
<Message ID="WXDH1006I" severity="I" prefix="yes">
  <MsgText pgmKey="HMA_HeapDumpGenerated" varFormat="Java">
    HMA_HeapDumpGenerated=WXDH1006I: A heap dump was automatically generated on server {0} in file {1}.
  </MsgText>
  <Explanation>
    A heap dump can be found at the specified location.
  </Explanation>
  <UserResponse>
    Retain this file for off-line analysis and problem determination.
  </UserResponse>
</Message>
<Message ID="WXDH5001I" severity="I" prefix="yes">
  <MsgText pgmKey="HMM_CoreDump" varFormat="Java">
    HMM_CoreDump=WXDH5001I: The complete set of states for a healthy health management controller is: {0}
  </MsgText>
  <Explanation>
    This message is for informational purposes only.
  </Explanation>
  <UserResponse>
    No action is required.
  </UserResponse>
</Message>
<Message ID="WXDH3002W" severity="W" prefix="yes">
  <MsgText pgmKey="HMS_Age" varFormat="Java">
    HMS_Age=WXDH3002W: The maximum server age specified by policy {0} was reached by server {1} on node {2}. The limit is {3} hours and the current age is {4} hours.
  </MsgText>
  <Explanation>
    The permitted maximum server age has been reached.
  </Explanation>
  <UserResponse>
    If the policy is supervised, check the runtime tasks to approve the configured response.
  </UserResponse>
</Message>
<Message ID="WXDH1026I" severity="I" prefix="yes">
  <MsgText pgmKey="HMA_MaintModeSuccess" varFormat="Java">
    HMA_MaintModeSuccess=WXDH1026I: Server {0} was successfully placed into maintenance mode.
  </MsgText>
  <Explanation>
    The health controller placed the server into maintenance mode successfully.
  </Explanation>
  <UserResponse>
    No action is required.
  </UserResponse>
</Message>
<Message ID="WXDH0014E" severity="E" prefix="yes">
  <MsgText pgmKey="HMC_NGNotFnd" varFormat="Java">
    HMC_NGNotFnd=WXDH0014E: Cannot find the node group for node {0}, {1}.
  </MsgText>
  <Explanation>
    The response time cannot be monitored.
  </Explanation>
  <UserResponse>
    Verify that the cell is fully sychronized and the node group exists. In the administrative console, select System administration &gt; Node groups.
  </UserResponse>
</Message>
<Message ID="WXDH0028E" severity="E" prefix="yes">
  <MsgText pgmKey="HMC_DisableError" varFormat="Java">
    HMC_DisableError=WXDH0028E: The following exception occurred while disabling the controller: {0}
  </MsgText>
  <Explanation>
    An error occurred when the health controller was disabled.
  </Explanation>
  <UserResponse>
    Review the error for possible resolutions.
  </UserResponse>
</Message>
<Message ID="WXDH3012W" severity="W" prefix="yes">
  <MsgText pgmKey="HMS_Timeout_Hang" varFormat="Java">
    HMS_Timeout_Hang=WXDH3012W: The request timeout limit specified by policy {0} was exceeded by server {1} on node {2}. The limit is {3} % and the current timeout fraction is {4} %.  A total of {5} threads may be hung.
  </MsgText>
  <Explanation>
    The server is experiencing a large number of request timeouts, and threads might be hung.
  </Explanation>
  <UserResponse>
    If the policy is supervised, check the runtime tasks to approve the configured response.
  </UserResponse>
</Message>
<Message ID="WXDH3001E" severity="E" prefix="yes">
  <MsgText pgmKey="HMS_NoData" varFormat="Java">
    HMS_NoData=WXDH3001E: No sensor data was received during the control cycle from server {0} for health policy {1}.
  </MsgText>
  <Explanation>
    No sensor data was received from the server.
  </Explanation>
  <UserResponse>
    Ensure that PMI is enabled on the server.
  </UserResponse>
</Message>
<Message ID="WXDH3013W" severity="W" prefix="yes">
  <MsgText pgmKey="HMS_Custom" varFormat="Java">
    HMS_Custom=WXDH3013W: A custom health condition violation is suspected by health policy {0} for server {1} on node {2}.
  </MsgText>
  <Explanation>
    A custom health condition violation has been detected.
  </Explanation>
  <UserResponse>
    Restart the server or specify a custom action.
  </UserResponse>
</Message>
<Message ID="WXDH0009E" severity="E" prefix="yes">
  <MsgText pgmKey="HMC_StopErr" varFormat="Java">
    HMC_StopErr=WXDH0009E: An error occurred while stopping the health controller: {0}
  </MsgText>
  <Explanation>
    An error occurred while stopping the health controller.
  </Explanation>
  <UserResponse>
    Contact IBM Support.
  </UserResponse>
</Message>
<Message ID="WXDH1021W" severity="W" prefix="yes">
  <MsgText pgmKey="HMA_PlanInvalid" varFormat="Java">
    HMA_PlanInvalid=WXDH1021W: The plan generated for server {0} and condition {1} is no longer valid.
  </MsgText>
  <Explanation>
    Conditions have changed since the plan was generated for the server and the condition.
  </Explanation>
  <UserResponse>
    A new plan will be submitted to the task management system for approval.
  </UserResponse>
</Message>
<Message ID="WXDH0021E" severity="E" prefix="yes">
  <MsgText pgmKey="HMC_CLError" varFormat="Java">
    HMC_CLError=WXDH0021E: The following error occurred during the start of the configuration listener: {0}
  </MsgText>
  <Explanation>
    An error occurred starting the health configuration listener.
  </Explanation>
  <UserResponse>
    Review the error for possible resolutions.
  </UserResponse>
</Message>
<Message ID="WXDH0048I" severity="I" prefix="yes">
  <MsgText pgmKey="HMC_BGNoRestart" varFormat="Java">
    HMC_BGNoRestart=WXDH0048I: Server {0} cannot be restarted when performing long-running work.
  </MsgText>
  <Explanation>
    The server is running long-running work, and the scheduler for this work does not permit the server restart.
  </Explanation>
  <UserResponse>
    No action is required.
  </UserResponse>
</Message>
<Message ID="WXDH6013E" severity="E" prefix="yes">
  <MsgText pgmKey="HMM_INVALID_PORT" varFormat="Java">
    HMM_INVALID_PORT=WXDH6013E: The port number is not valid.
  </MsgText>
  <Explanation>
    Incorrect port number detected.
  </Explanation>
  <UserResponse>
    Specify a valid port number in the 0 to 65535 range.
  </UserResponse>
</Message>
<Message ID="WXDH6001E" severity="E" prefix="yes">
  <MsgText pgmKey="HMM_INVALID_OPERAND" varFormat="Java">
    HMM_INVALID_OPERAND=WXDH6001E: An operand that is not valid is specified for {0} operator: Operands must be one of {1}, {2} or {3}.
  </MsgText>
  <Explanation>
    Invalid operand.
  </Explanation>
  <UserResponse>
    Specify a valid operand.
  </UserResponse>
</Message>
<Message ID="WXDH3009W" severity="W" prefix="yes">
  <MsgText pgmKey="HMS_Servlet_Response" varFormat="Java">
    HMS_Servlet_Response=WXDH3009W: A servlet response time change point has been detected by health policy {0} for server {1} on node {2}: Suspected servlets are: {3}.
  </MsgText>
  <Explanation>
    A significant change in response time has been observed for one or more servlets.
  </Explanation>
  <UserResponse>
    Investigate the ODR log files and the log files for the specified server for the cause of the symptoms.
  </UserResponse>
</Message>
<Message ID="WXDH1133I" severity="I" prefix="yes">
  <MsgText pgmKey="HMA_DCChangeCommanReturn" varFormat="Java">
    HMA_DCChangeCommanReturn=WXDH1133I: The Health Controller has received status for command {0} for task ID {1} on server {2}. success={3}
  </MsgText>
  <Explanation>
    Health Controller is attempting to start or stop a server instance.
  </Explanation>
  <UserResponse>
    No user action is required at this time.
  </UserResponse>
</Message>
<Message ID="WXDH1132I" severity="I" prefix="yes">
  <MsgText pgmKey="HMA_DCChangeCommanCall" varFormat="Java">
    HMA_DCChangeCommanCall=WXDH1132I: The Health Controller has issued command {0} for task ID {1} on server {2} that will expire at {3}.
  </MsgText>
  <Explanation>
    Health Controller is attempting to start or stop a server instance.
  </Explanation>
  <UserResponse>
    No user action is required at this time.
  </UserResponse>
</Message>
<Message ID="WXDH1128W" severity="W" prefix="yes">
  <MsgText pgmKey="HMA_FindBestNoVacancy" varFormat="Java">
    HMA_FindBestNoVacancy=WXDH1128W: The Health Controller has asked to find an alternate location to run server {0} and a replacement location is not available.
  </MsgText>
  <Explanation>
    This is usually caused by a user or system component requesting the shutdown or setting of maintenance mode for a server or node.
  </Explanation>
  <UserResponse>
    Use the Admin Console to modify the placement of dynamic cluster instances to maintain desired service level performance.
  </UserResponse>
</Message>
<Message ID="WXDH3008W" severity="W" prefix="yes">
  <MsgText pgmKey="HMS_Leak" varFormat="Java">
    HMS_Leak=WXDH3008W: A memory leak is suspected by policy {0} for server {1} on node {2}.
  </MsgText>
  <Explanation>
    Based on memory usage trends, a memory leak is suspected.
  </Explanation>
  <UserResponse>
    If the policy is supervised, check the runtime tasks to approve the configured response.
  </UserResponse>
</Message>
<Message ID="WXDH1009E" severity="E" prefix="yes">
  <MsgText pgmKey="HMA_RestartFailure" varFormat="Java">
    HMA_RestartFailure=WXDH1009E: The restart operation for server {0} failed.
  </MsgText>
  <Explanation>
    The health controller was unable to restart the server.
  </Explanation>
  <UserResponse>
    Check the log files for additional information.
  </UserResponse>
</Message>
<Message ID="WXDH1001E" severity="E" prefix="yes">
  <MsgText pgmKey="HMA_NoStop" varFormat="Java">
    HMA_NoStop=WXDH1001E: The following error occurred when trying to stop server {0}: {1}
  </MsgText>
  <Explanation>
    The specified server could not be stopped.
  </Explanation>
  <UserResponse>
    Investigate the cause of the failure in the server log files.
  </UserResponse>
</Message>
<Message ID="WXDH5002E" severity="E" prefix="yes">
  <MsgText pgmKey="HMM_CoreDumpErr" varFormat="Java">
    HMM_CoreDumpErr=WXDH5002E: The complete set of states for an unhealthy health management controller is: {0}
  </MsgText>
  <Explanation>
    A detailed list of all health management controller states.
  </Explanation>
  <UserResponse>
    First review task management for potential remedies, otherwise contact IBM support.
  </UserResponse>
</Message>
<Message ID="WXDH2001W" severity="W" prefix="yes">
  <MsgText pgmKey="HMS_NoHangDetect" varFormat="Java">
    HMS_NoHangDetect=WXDH2001W: Thread hang detection is disabled or its status cannot be obtained for server {0}.
  </MsgText>
  <Explanation>
    Thread hang detection must be enabled to provide advisory information on request timeout policies.
  </Explanation>
  <UserResponse>
    If advisory information regarding thread status is desired, enable hang detection for the server, remove it from the request timeout policy, and add it again.
  </UserResponse>
</Message>
<Message ID="WXDH0035E" severity="E" prefix="yes">
  <MsgText pgmKey="HMC_AddPolicyError" varFormat="Java">
    HMC_AddPolicyError=WXDH0035E: Health policy {0} could not be added.
  </MsgText>
  <Explanation>
    A health policy has been added to the configuration repository, but the health controller could not read it.
  </Explanation>
  <UserResponse>
    Synchronize the configuration repository with all of the nodes. Disable and re-enable the health controller.
  </UserResponse>
</Message>
<Message ID="WXDH0038E" severity="E" prefix="yes">
  <MsgText pgmKey="HMC_ModifyPolicyError" varFormat="Java">
    HMC_ModifyPolicyError=WXDH0038E: The {0} of health policy {1} could not be changed.
  </MsgText>
  <Explanation>
    The attribute of the health policy was modified, but a problem occurred processing the new value.
  </Explanation>
  <UserResponse>
    Synchronize the configuration repository with all of the nodes. Disable and re-enable the health controller.
  </UserResponse>
</Message>
<Message ID="WXDH1030E" severity="E" prefix="yes">
  <MsgText pgmKey="HMA_SnmpTrapFailed" varFormat="Java">
    HMA_SnmpTrapFailed=WXDH1030E: The attempt to issue a SNMP trap for server {0} failed.
  </MsgText>
  <Explanation>
    An error occured while attempting to send a SNMP trap.
  </Explanation>
  <UserResponse>
    Check the log files for additional information.
  </UserResponse>
</Message>
<Message ID="WXDH3014W" severity="W" prefix="yes">
  <MsgText pgmKey="HMS_Response_Odrlib" varFormat="Java">
    HMS_Response_Odrlib=WXDH3014W: The average response time limit specified by policy {0} was exceeded by server {1} on node {2}.  The problem was detected by the following Intelligent Management routers: {3}
  </MsgText>
  <Explanation>
    The server is responding too slowly to incoming requests.
  </Explanation>
  <UserResponse>
    If the policy is supervised, check the runtime tasks to approve the configured response.
  </UserResponse>
</Message>
<Message ID="WXDH6020E" severity="E" prefix="yes">
  <MsgText pgmKey="HMM_URL_ERROR" varFormat="Java">
    HMM_URL_ERROR=WXDH6020E: An error occurred when attempting to invoke URL {0}: {1}.
  </MsgText>
  <Explanation>
    URL invocation was not successful.
  </Explanation>
  <UserResponse>
    See the log files for possible reasons of URL invocation errors.
  </UserResponse>
</Message>
<Message ID="WXDH3005W" severity="W" prefix="yes">
  <MsgText pgmKey="HMS_Response" varFormat="Java">
    HMS_Response=WXDH3005W: The average response time limit specified by policy {0} was exceeded by server {1} on node {2}.  The limit is {3} ms and the current value is {4} ms.
  </MsgText>
  <Explanation>
    The server is responding too slowly to incoming requests.
  </Explanation>
  <UserResponse>
    If the policy is supervised, check the runtime tasks to approve the configured response.
  </UserResponse>
</Message>
<Message ID="WXDH0002I" severity="I" prefix="yes">
  <MsgText pgmKey="HMC_Starting" varFormat="Java">
    HMC_Starting=WXDH0002I: Starting the health controller for {0}.
  </MsgText>
  <Explanation>
    This message is for informational purposes only.
  </Explanation>
  <UserResponse>
    No action is required.
  </UserResponse>
</Message>
<Message ID="WXDH3006W" severity="W" prefix="yes">
  <MsgText pgmKey="HMS_Storm_Drain" varFormat="Java">
    HMS_Storm_Drain=WXDH3006W: A storm drain condition is suspected by policy {0} for server {1} on node {2}. The average response time has dropped to {3} milliseconds.
  </MsgText>
  <Explanation>
    A significant decrease in response time and increase in routing weight has been observed on the server.
  </Explanation>
  <UserResponse>
    Investigate the ODR log files and the log files for the specified server for the cause of the symptoms.
  </UserResponse>
</Message>
<Message ID="WXDH0041I" severity="I" prefix="yes">
  <MsgText pgmKey="HMC_RemoveMember" varFormat="Java">
    HMC_RemoveMember=WXDH0041I: Member {0} has been removed from health policy {1}.
  </MsgText>
  <Explanation>
    This message is for informational purposes only.
  </Explanation>
  <UserResponse>
    No action is required.
  </UserResponse>
</Message>
<Message ID="WXDH1004E" severity="E" prefix="yes">
  <MsgText pgmKey="HMA_SrvNotFnd" varFormat="Java">
    HMA_SrvNotFnd=WXDH1004E: The following error occurred when trying to locate server {0}.
  </MsgText>
  <Explanation>
    The server instance could not be found.
  </Explanation>
  <UserResponse>
    Verify that the server still exists.
  </UserResponse>
</Message>
<Message ID="WXDH1130I" severity="I" prefix="yes">
  <MsgText pgmKey="HMA_FindBestNotNeeded" varFormat="Java">
    HMA_FindBestNotNeeded=WXDH1130I: The Health Controller has asked to find an alternate location to run server {0} and a replacement location is not needed.  The server can be stopped or placed into maintenance mode.
  </MsgText>
  <Explanation>
    This is usually caused by a user or system component requesting the shutdown or setting of maintenance mode for a server or node.
  </Explanation>
  <UserResponse>
    No user action is required at this time.
  </UserResponse>
</Message>
<Message ID="WXDH0044W" severity="W" prefix="yes">
  <MsgText pgmKey="HMC_RequiresODRData" varFormat="Java">
    HMC_RequiresODRData=WXDH0044W: Member {0} of health policy {1} is not adjacent to the on demand router.
  </MsgText>
  <Explanation>
    The health policy requires data generated by the on demand router.  Only servers in an adjacent tier to the on demand router will be represented in its data.
  </Explanation>
  <UserResponse>
    Do not use health policies based on on demand router data for this member.
  </UserResponse>
</Message>
<Message ID="WXDH3015W" severity="W" prefix="yes">
  <MsgText pgmKey="HMS_Timeout_Odrlib" varFormat="Java">
    HMS_Timeout_Odrlib=WXDH3015W: The request timeout limit specified by policy {0} was exceeded by server {1} on node {2}.  The problem was detected by the following Intelligent Management routers: {3}
  </MsgText>
  <Explanation>
    The server is experiencing a large number of request timeouts.
  </Explanation>
  <UserResponse>
    If the policy is supervised, check the runtime tasks to approve the configured response.
  </UserResponse>
</Message>
<Message ID="WXDH0036I" severity="I" prefix="yes">
  <MsgText pgmKey="HMC_RemovePolicy" varFormat="Java">
    HMC_RemovePolicy=WXDH0036I: Health policy {0} has been removed.
  </MsgText>
  <Explanation>
    A health policy has been removed from the configuration repository and the health controller.
  </Explanation>
  <UserResponse>
    No action is required.
  </UserResponse>
</Message>
<Message ID="WXDH6006E" severity="E" prefix="yes">
  <MsgText pgmKey="HMM_MISSING_METRIC_NAME" varFormat="Java">
    HMM_MISSING_METRIC_NAME=WXDH6006E: The metric name for {0} operand must be specified.
  </MsgText>
  <Explanation>
    The metric name for operand is not specified.
  </Explanation>
  <UserResponse>
    Specify metric name for operand.
  </UserResponse>
</Message>
<Message ID="WXDH0010W" severity="W" prefix="yes">
  <MsgText pgmKey="HMC_SuspectRS" varFormat="Java">
    HMC_SuspectRS=WXDH0010W: Unexpected restart state {0} for server {1}.
  </MsgText>
  <Explanation>
    The health controller encountered an unexpected state.
  </Explanation>
  <UserResponse>
    Wait until the Restart timeout value is exceeded. Otherwise, contact IBM Support.
  </UserResponse>
</Message>
<Message ID="WXDH1017I" severity="I" prefix="yes">
  <MsgText pgmKey="HMA_HeapDumpSuccess" varFormat="Java">
    HMA_HeapDumpSuccess=WXDH1017I: The following heap dumps were generated for server {0}: {1}
  </MsgText>
  <Explanation>
    The heap dumps were successfully generated for the specified server.
  </Explanation>
  <UserResponse>
    Retain the heap dump files for off-line analysis and problem determination.
  </UserResponse>
</Message>
<Message ID="WXDH1020E" severity="E" prefix="yes">
  <MsgText pgmKey="HMA_APCNoRestart" varFormat="Java">
    HMA_APCNoRestart=WXDH1020E: Server {0} cannot be restarted, and the minimum number of cluster instances cannot be maintained.
  </MsgText>
  <Explanation>
    The application placement controller recommendation would leave too few running server instances.
  </Explanation>
  <UserResponse>
    Start another instance in the dynamic cluster.
  </UserResponse>
</Message>
<Message ID="WXDH1013E" severity="E" prefix="yes">
  <MsgText pgmKey="HMA_ThreadDumpFailedNoServer" varFormat="Java">
    HMA_ThreadDumpFailedNoServer=WXDH1013E: The thread dump failed for server {0}.
  </MsgText>
  <Explanation>
    The server could not be contacted.
  </Explanation>
  <UserResponse>
    Check the log files for additional information.
  </UserResponse>
</Message>
<Message ID="WXDH1016E" severity="E" prefix="yes">
  <MsgText pgmKey="HMA_HeapDumpFailedNoServer" varFormat="Java">
    HMA_HeapDumpFailedNoServer=WXDH1016E: The heap dump failed for server {0}.
  </MsgText>
  <Explanation>
    The server could not be contacted.
  </Explanation>
  <UserResponse>
    Check the log files for additional information.
  </UserResponse>
</Message>
<Message ID="WXDH1010I" severity="I" prefix="yes">
  <MsgText pgmKey="HMA_ThreadDump" varFormat="Java">
    HMA_ThreadDump=WXDH1010I: A thread dump for server {0} is being issued.
  </MsgText>
  <Explanation>
    This message is for informational purposes only.
  </Explanation>
  <UserResponse>
    No action is required.
  </UserResponse>
</Message>
<Message ID="WXDH3010W" severity="W" prefix="yes">
  <MsgText pgmKey="HMS_Response_Warning" varFormat="Java">
    HMS_Response_Warning=WXDH3010W: A server response time change point has been detected for server {0} on node {1}. The average response time has changed from {2} ms to {3} ms.
  </MsgText>
  <Explanation>
    A significant increase in response time has been observed for the server.
  </Explanation>
  <UserResponse>
    Investigate the cause of the increase.
  </UserResponse>
</Message>
<Message ID="WXDH0037I" severity="I" prefix="yes">
  <MsgText pgmKey="HMC_ModifyPolicy" varFormat="Java">
    HMC_ModifyPolicy=WXDH0037I: The {0} for health policy {1} has changed to {2}.
  </MsgText>
  <Explanation>
    This message is for informational purposes only.
  </Explanation>
  <UserResponse>
    No action is required.
  </UserResponse>
</Message>
<Message ID="WXDH6003E" severity="E" prefix="yes">
  <MsgText pgmKey="HMM_MISSING_MBEAN_ATTR_OPR_NAME" varFormat="Java">
    HMM_MISSING_MBEAN_ATTR_OPR_NAME=WXDH6003E: Specify the attribute name or method name for MBean operands.
  </MsgText>
  <Explanation>
    Attribute name or method name for MBean operands is not specified.
  </Explanation>
  <UserResponse>
    Specify attribute name or method name for MBean operands.
  </UserResponse>
</Message>
<Message ID="WXDH6018E" severity="E" prefix="yes">
  <MsgText pgmKey="HMM_ERROR_STAT_RETR" varFormat="Java">
    HMM_ERROR_STAT_RETR=WXDH6018E: An error occurred while obtaining statistics {0} for module {1} on server {2}.
  </MsgText>
  <Explanation>
    Unable to obtain statistics for given module.
  </Explanation>
  <UserResponse>
    See the log files for possible reasons why the statistics were not obtained.
  </UserResponse>
</Message>
<Message ID="WXDH6017E" severity="E" prefix="yes">
  <MsgText pgmKey="HMM_INVALID_METRIC_PATH" varFormat="Java">
    HMM_INVALID_METRIC_PATH=WXDH6017E: The metric path {0} on server {1} is not valid. The missing path element is {2}.
  </MsgText>
  <Explanation>
    Incorrect metric path for server detected.
  </Explanation>
  <UserResponse>
    Specify correct metric path for server and include any missing elements.
  </UserResponse>
</Message>
<Message ID="WXDH6011E" severity="E" prefix="yes">
  <MsgText pgmKey="HMM_UNKNOWN_PMI_MODULE" varFormat="Java">
    HMM_UNKNOWN_PMI_MODULE=WXDH6011E: Unknown PMI module: {0}.
  </MsgText>
  <Explanation>
    Specified PMI module is not supported.
  </Explanation>
  <UserResponse>
    Specify supported PMI modules.
  </UserResponse>
</Message>
<Message ID="WXDH6002E" severity="E" prefix="yes">
  <MsgText pgmKey="HMM_MISSING_MBEAN_ONAME" varFormat="Java">
    HMM_MISSING_MBEAN_ONAME=WXDH6002E: The object name query string for MBean operands must be specified.
  </MsgText>
  <Explanation>
    Object name query string for MBean operands is not specified.
  </Explanation>
  <UserResponse>
    Specify object name query string for MBean operands.
  </UserResponse>
</Message>
<Message ID="WXDH1022I" severity="I" prefix="yes">
  <MsgText pgmKey="HMA_Custom" varFormat="Java">
    HMA_Custom=WXDH1022I: Starting the custom task {0} on target {1}.
  </MsgText>
  <Explanation>
    The health controller is starting a custom task.
  </Explanation>
  <UserResponse>
    No action is required.
  </UserResponse>
</Message>
<!-- END MESSAGES -->
</TMSSource>
