<?xml version="1.0" encoding="UTF-8"?>
<?xml-stylesheet type="text/css" href="../../resources/stylesheets/wasmsgxml.css"?>
<TMSSource name="TivoliMessages" tmsVersion="1.0" xml:lang="en">
<!-- CMVC MSG File Name = ws/code/wsmm.ctlr/src/com/ibm/wsmm/grm/startup/nls/Messages.nlsprops -->
<!-- DO NOT EDIT THIS FILE - This file was generated by the XML/Html & Property emitter -->
<!-- BEGIN MESSAGES -->
<Message ID="ARFM8024I" severity="I" prefix="yes">
  <MsgText pgmKey="HAC_HamStopping" varFormat="Java">
    HAC_HamStopping=ARFM8024I: Stopping ARFM controller for cell {0}, due to de-activation by HA-Manager.
  </MsgText>
  <Explanation>
    The controller that does Autonomic Request Flow Management is being stopped.
  </Explanation>
  <UserResponse>
    Informational message only, no action required.
  </UserResponse>
</Message>
<Message ID="ARFM8032I" severity="I" prefix="yes">
  <MsgText pgmKey="HAC_ResetStopping" varFormat="Java">
    HAC_ResetStopping=ARFM8032I: Stopping ARFM controller for cell {0}, to implement a reset.
  </MsgText>
  <Explanation>
    The controller that does Autonomic Request Flow Management is being stopped.
  </Explanation>
  <UserResponse>
    Informational message only, no action required.
  </UserResponse>
</Message>
<Message ID="ARFM8021E" severity="E" prefix="yes">
  <MsgText pgmKey="HAC_FindTreeFailed" varFormat="Java">
    HAC_FindTreeFailed=ARFM8021E: Failed to get ODC Tree: {0}
  </MsgText>
  <Explanation>
    Something went wrong when the ARFM Controller tried to gain access to the ODC Tree.
  </Explanation>
  <UserResponse>
    Check the propagation mechanism, make sure target.xml exists.
  </UserResponse>
</Message>
<Message ID="ARFM8501E" severity="E" prefix="yes">
  <MsgText pgmKey="TT1_err" varFormat="Java">
    TT1_err=ARFM8501E: Error with one parm, {0}
  </MsgText>
  <Explanation>
    exp
  </Explanation>
  <UserResponse>
    ua
  </UserResponse>
</Message>
<Message ID="ARFM8999E" severity="E" prefix="yes">
  <MsgText pgmKey="WCTL_GENLERR" varFormat="Java">
    WCTL_GENLERR=ARFM8999E: Something unexpected happened in ARFM; data is {0}, and the exception (if any) is {1}.
  </MsgText>
  <Explanation>
    Something unexpected happened.
  </Explanation>
  <UserResponse>
    Debug it if you can, using the information provided, or contact IBM support.
  </UserResponse>
</Message>
<Message ID="ARFM8022E" severity="E" prefix="yes">
  <MsgText pgmKey="HAC_ReadTreeFailed" varFormat="Java">
    HAC_ReadTreeFailed=ARFM8022E: Failed to read ODC Tree: {0}
  </MsgText>
  <Explanation>
    Something went wrong when the ARFM Controller tried to read the ODC Tree.
  </Explanation>
  <UserResponse>
    Check the propagation mechanism.
  </UserResponse>
</Message>
<Message ID="ARFM8003W" severity="W" prefix="yes">
  <MsgText pgmKey="GRM_GetFmsFailed" varFormat="Java">
    GRM_GetFmsFailed=ARFM8003W: Unexpected exception arose when looking up the FilterManagerService: {0}
  </MsgText>
  <Explanation>
    Internal error.
  </Explanation>
  <UserResponse>
    Report to IBM.
  </UserResponse>
</Message>
<Message ID="ARFM8028I" severity="I" prefix="yes">
  <MsgText pgmKey="HAC_OdcStarting" varFormat="Java">
    HAC_OdcStarting=ARFM8028I: Starting ARFM controller for cell {0}, due to On-Demand Configuration (ODC) change.
  </MsgText>
  <Explanation>
    The controller that does Autonomic Request Flow Management is being started.
  </Explanation>
  <UserResponse>
    Informational message only, no action required.
  </UserResponse>
</Message>
<Message ID="ARFM8001E" severity="E" prefix="yes">
  <MsgText pgmKey="GRM_NoConfigFile" varFormat="Java">
    GRM_NoConfigFile=ARFM8001E: ARFM Controller configuration file {0} cannot be read.
  </MsgText>
  <Explanation>
    Internal configuration error: the ARFM Controller cannot start because the configuration file cannot be read.
  </Explanation>
  <UserResponse>
    Have IBM Services correct the error.
  </UserResponse>
</Message>
<Message ID="ARFM8101E" severity="E" prefix="yes">
  <MsgText pgmKey="WCSP_LocErr" varFormat="Java">
    WCSP_LocErr=ARFM8101E: The ARFM for cell {0} suffered an unexpected exception/error when trying to find the location of the MBean holding its controllers; the exception/error is {1}.
  </MsgText>
  <Explanation>
    Internal failure.
  </Explanation>
  <UserResponse>
    Report to IBM.
  </UserResponse>
</Message>
<Message ID="ARFM8025W" severity="W" prefix="yes">
  <MsgText pgmKey="HAC_UnknownEdge" varFormat="Java">
    HAC_UnknownEdge=ARFM8025W: Unknown edge change event {0}.
  </MsgText>
  <Explanation>
    The controller received an unknown edge change event.
  </Explanation>
  <UserResponse>
    Report to IBM.
  </UserResponse>
</Message>
<Message ID="ARFM8002E" severity="E" prefix="yes">
  <MsgText pgmKey="GRM_Read0" varFormat="Java">
    GRM_Read0=ARFM8002E: Cannot happen.
  </MsgText>
  <Explanation>
    Internal error.
  </Explanation>
  <UserResponse>
    Report program defect to IBM.
  </UserResponse>
</Message>
<Message ID="ARFM8030E" severity="E" prefix="yes">
  <MsgText pgmKey="HAC_GrpAbleFail" varFormat="Java">
    HAC_GrpAbleFail=ARFM8030E: Unexpected exception arose while enabling or disabling ARFM controllers in the {0} cell (note: the central cell is {1} and the other connected cells are {2}): {3}.
  </MsgText>
  <Explanation>
    Internal failure.
  </Explanation>
  <UserResponse>
    Report to IBM.
  </UserResponse>
</Message>
<Message ID="ARFM8023I" severity="I" prefix="yes">
  <MsgText pgmKey="HAC_HamStarting" varFormat="Java">
    HAC_HamStarting=ARFM8023I: Starting ARFM controller for cell {0}, due to activation by HA-Manager.
  </MsgText>
  <Explanation>
    The controller that does Autonomic Request Flow Management is being started.
  </Explanation>
  <UserResponse>
    Informational message only, no action required.
  </UserResponse>
</Message>
<Message ID="ARFM8005I" severity="I" prefix="yes">
  <MsgText pgmKey="GRM_NotStandAlone" varFormat="Java">
    GRM_NotStandAlone=ARFM8005I: ARFM Controller disabled because it is configured to run in the HTTP Proxy Filter.
  </MsgText>
  <Explanation>
    ARFM Controllers may run in either the HTTP Proxy Filter or stand alone, the configuration is not stand alone.
  </Explanation>
  <UserResponse>
    None. Informational entry.
  </UserResponse>
</Message>
<Message ID="ARFM8029I" severity="I" prefix="yes">
  <MsgText pgmKey="HAC_OdcStopping" varFormat="Java">
    HAC_OdcStopping=ARFM8029I: Stopping ARFM controller for cell {0}, due to On-Demand Configuration (ODC) change.
  </MsgText>
  <Explanation>
    The controller that does Autonomic Request Flow Management is being stopped.
  </Explanation>
  <UserResponse>
    Informational message only, no action required.
  </UserResponse>
</Message>
<Message ID="ARFM8998W" severity="W" prefix="yes">
  <MsgText pgmKey="WCTL_GENLWRN" varFormat="Java">
    WCTL_GENLWRN=ARFM8998W: Something suspicious happened in ARFM; data is {0}, and the exception (if any) is {1}.
  </MsgText>
  <Explanation>
    Something suspicious happened; this may or may not indicate an error.
  </Explanation>
  <UserResponse>
    Debug it if you can, using the information provided, or contact IBM support.
  </UserResponse>
</Message>
<Message ID="ARFM8031I" severity="I" prefix="yes">
  <MsgText pgmKey="HAC_ResetStarting" varFormat="Java">
    HAC_ResetStarting=ARFM8031I: Starting ARFM controller for cell {0}, to implement a reset.
  </MsgText>
  <Explanation>
    The controller that does Autonomic Request Flow Management is being started.
  </Explanation>
  <UserResponse>
    Informational message only, no action required.
  </UserResponse>
</Message>
<Message ID="ARFM8027E" severity="E" prefix="yes">
  <MsgText pgmKey="HAC_ControllerFailed" varFormat="Java">
    HAC_ControllerFailed=ARFM8027E: Attempt to instantiate ARFM Controller for node group {0} in cell {1} suffered unexpected failure: {2}.
  </MsgText>
  <Explanation>
    Internal failure.
  </Explanation>
  <UserResponse>
    Debug or report to IBM.
  </UserResponse>
</Message>
<Message ID="ARFM8004I" severity="I" prefix="yes">
  <MsgText pgmKey="GRM_NoFMS" varFormat="Java">
    GRM_NoFMS=ARFM8004I: ARFM Controller disabled because this is not an ODR process.
  </MsgText>
  <Explanation>
    ARFM Controllers run only in On-Demand Router processes.
  </Explanation>
  <UserResponse>
    None. Informational entry.
  </UserResponse>
</Message>
<Message ID="ARFM8102E" severity="E" prefix="yes">
  <MsgText pgmKey="WCSP_MBCallFail" varFormat="Java">
    WCSP_MBCallFail=ARFM8102E: The component status provider for ARFM suffered an unexpected exception when trying to query the ARFM controllers MBean: {0}.
  </MsgText>
  <Explanation>
    Internal failure.
  </Explanation>
  <UserResponse>
    Report to IBM.
  </UserResponse>
</Message>
<Message ID="ARFM8026W" severity="W" prefix="yes">
  <MsgText pgmKey="HAC_UnknownChange" varFormat="Java">
    HAC_UnknownChange=ARFM8026W: Unknown topology change event {0}.
  </MsgText>
  <Explanation>
    The controller received an unknown topology change event.
  </Explanation>
  <UserResponse>
    Report to IBM.
  </UserResponse>
</Message>
<!-- END MESSAGES -->
</TMSSource>
