Classic Shell

Classic Shell 網站 Classic Shell

4.3.1 版 – 通用版本

什麼是 Classic Shell?

Classic Shell™ 是增強 Windows 可用性的工具集。 它有可自訂化的 [開始] 功能表和 [開始] 按鈕，加入 Windows 檔案總管的工具列和支援各種較小的功能。

系統需求

Classic Shell 能在 Windows 7, Windows 8, Windows 8.1, Windows Server 2008 R2, Windows Server 2012 和 Windows Server 2012 R2 動作。 同時支援 32 和 64 位元 (以相同安裝程式)。 某些 [開始] 功能表的面板需要 啟用 Aero 佈景主題。 其它至少需要 Basic 佈景主題。

元件

Classic Shell 有 3 個主要元件:
  • Classic Start Menu
  • Classic Explorer
  • Classic IE

解除安裝

您可以從 控制台 -> 程式和功能 解除安裝 Classic Shell。 另一種方式是 再次執行安裝程式並選擇 [移除]。
可能需要登出以完成程序。


Classic Start Menu

Classic Shell 網站 Classic Start Menu

Classic Start Menu 是靈活的 [開始] 功能表，能模仿 Windows 2000, XP 和 Windows 7 的功能表行為。 有許多進階功能:
  • 選擇「典型」或「Windows 7」樣式
  • 以拖放組織管理應用程式
  • 選項顯示「我的最愛」、展開「控制台」等
  • 顯示最近使用的文件。 可自訂顯示的文件數量
  • 翻譯成 35 種語言，包含正體中文以及由右至左的Arabic 和 Hebrew
  • 不停用 Windows 的原始 [開始] 功能表。 您可以在 [開始] 按鈕 [Shift + 按一下] 來存取
  • 在功能表的項目按一下右鍵以刪除、重新命名、排序或執行其它工作
  • 搜尋框協助您尋找程式與檔案而不需以鍵盤快速鍵方式取得
  • 支援跳躍清單提供輕鬆存取最近的文件和一般工作
  • 支援 32 和 64 位元作業系統
  • 支援面板，包含額外第 3 方面板。 能自行製作!
  • 外觀和功能可完全自訂化
  • 支援 Microsoft 的 Active Accessibility
  • 轉換 Windows 功能表的 [所有程式] 按鈕為階層式功能表
  • 實現可自訂 [開始] 功能表
  • 能顯示、搜尋及啟動 Windows 市集應用程式 (Windows 8)
  • 最重要的是 – 完全免費!

樣式

[開始] 功能表提供 3 種樣式的選擇。

2) 單欄典型樣式

此樣式類似 Windows 2000 的功能表。 有 1 欄 [開始] 功能表和垂直文字在側邊。 您可以自訂項目、圖示和文字的順序。
程式、跳躍清單和搜尋結果以層級子功能表顯示。

2) 兩欄典型樣式

此樣式類似 Windows XP 功能表。 能安排功能表項目 2 個欄位。 自訂順序、圖示和文字。
程式、跳躍清單和搜尋結果以層級子功能表顯示。

3) Windows 7 樣式

此樣式類似 Windows Vista 和 Windows 7 功能表。 首欄中項目是預先定義來釘選和最近使用的程式、所有程式清單和搜尋方塊。 次欄中項目能完全自訂。
跳躍清單和搜尋結果在主功能表內顯示。 程式能在主功能表內或以層級子功能表開啟。
此樣式提供比典型樣式較少的自訂選項，但對使用 Windows 7 的人有較熟悉的外觀。

操作

如果您有在 Windows 的舊版本使用 [開始] 功能表，會覺得非常熟悉:

按下 Win 鍵或按一下螢幕角落的 [視窗] 標誌以開啟 [開始] 功能表。

按一下 [視窗] 標誌時按住 Shift 鍵以存取作業系統自己的 [開始] 功能表。

按一下項目執行。

拖曳程式以變更程式在功能表中的順序，或移動到另一個資料夾。

在項目按一下右鍵以重新命名、刪除、檔案總管開啟、排序功能表或執行其它工作。

在 [視窗] 標誌按一下右鍵以編輯 [開始] 功能表的設定、檢視此說明檔案或停止[開始] 功能表。

設定

在 [開始] 按鈕按一下右鍵以存取設定:

您可以選擇只查看基本設定，或所有可用的設定。 暫留在每個設定的上方以查看其作用的簡述。 在搜尋方塊輸入依名稱尋找設定。
每個設定有預設值。 預設值可以是常數，或根據目前系統設定而定。 編輯設定後會成為「已修改」且以粗體顯示。 若要返回預設值，在設定按一下右鍵。

您可以儲存設定為 XML 檔案，並稍後載入回來。 按下 [備份] 按鈕以存取這些功能。 從那也可以重設所有的設定為其預設值。

大部分設定會在編輯後立即變更。 例如可以編輯 [開始] 功能表，接著在「設定」對話方塊開啟時，存取 [開始] 功能表以查看變更。 少數設定在看到變更前將需要結束[開始] 功能表。

備註: 所有的設定視窗可調整大小。 調整大小並隨心所欲的放置。 它們將會記住新的位置。

按一下 「自訂 [開始] 功能表」索引標籤以自訂功能表項目。 根據樣式，您將看到不同的 UI。

針對 典型 樣式，您可以自訂 [開始] 功能表的欄和建立子功能表。 左欄顯示目前功能表中項目，及右欄顯示可用功能表項目。 從右拖曳到左以加入項目到功能表。

針對 Windows 7 樣式，您只能編輯次欄和沒有子功能表的項目。

按兩下圖示編輯項目內容:

在此能選取項目的命令、其文字和圖示。 按下 [還原預設值] 按鈕以取得選擇命令的預設文字和圖示。

命令可以:
  • 預先定義的命令之一 - 從下拉式功能表
  • 自訂可執行字串 - 這可以是程式名稱和其引數，或甚至 URL (比如 http://www.google.com)。 支援環境變數，如 %SystemRoot%
  • 保留空白 - 此時如果使用連結屬性，將以命令動作
連結可以是檔案或資料夾的路徑。 若是檔案，將執行該檔案。 若是資料夾，將以子功能表開啟該資料夾。 某些功能表項目 (比如 [程式] 和 [我的最愛]) 有隱含屬性，因此其「連結」方塊將停用。

圖示可以是:
  • 保留空白 - 此時如果使用連結屬性指向檔案或資料夾，將使用該檔案或資料夾的圖示
  • 資源檔案,圖示 ID - 例如 %windir%\notepad.exe,2。 檔案和逗號之間不能有空格。 確認使用圖示的資源 ID，而非圖示的索引。 為了達到最佳效果，使用圖示方塊旁的 [...] 按鈕
  • ,圖示 ID - 與上方一樣，但資源檔案為 ClassicStartMenuDLL.dll 本身。 當參照到開始功能表的自己圖示時是有用的
  • 圖示檔案 - 例如 C:\Program Files\Mozilla Thunderbird\Email.ico
  • none - 這將使用空白圖示
如果標籤或提示屬性以 $ (錢字符號) 開頭，則系統將視其為 StartMenuL10N.ini 檔案中字串的名稱。 實際文字將根據目前語言設定而定。 這在建立多語言所使用的功能表時是有用的。

如果選取「插入子功能表為按鈕」，而不是顯示功能表項目本身，[開始] 功能表將顯示子項目為按鈕的列。 預設是建立按鈕。 您可以加入分隔符號為最後項目將按鈕靠左對齊，或加入分隔符號為第一個項目將按鈕靠右對齊。 一種可能的使用是以「關機、重新啟動、登出」等個別按鈕取代關機功能表。

系統管理設定

設定是每個使用者且存放在登錄檔。 預設每個使用者能編輯其所有的設定。 系統管理員能鎖定指定設定，因此沒有使用者能編輯:

在此範例，設定「啟用右鍵功能表」鎖定為始終不選取且使用者無法變更。 這是透過加入設定到 HKEY_LOCAL_MACHINE\SOFTWARE\IvoSoft\ClassicStartMenu 登錄檔機碼來達成。 建立名稱為「EnableContextMenu」的 DWORD 值並設成 0。

某些情形下您可能不要針對所有使用者鎖定數值，而只是簡單的修改設定的初始值。 在此情形則在數值的名稱加入「_Default」。 例如，如果您要預設停用內容功能表但仍允許使用者視需要啟用，建立名稱為「EnableContextMenu_Default」的 DWORD 值並設成 0。

了解設定的登錄檔名稱與其數值之輕鬆方式，是修改它接著在以下機碼中尋找: HKEY_CURRENT_USER\Software\IvoSoft\ClassicStartMenu\Settings。
有時您可能要鎖定設定為預設值，但不知預設值為何。 則建立 DWORD 數值並設定成 0xDEFA。

這也是全域設定「EnableSettings」。 在登錄檔設定為 0 以防止使用者開啟 [設定] 對話方塊:

[開始] 功能表也檢查系統管理員所設定的大多數群組原則。 執行 gpedit.msc 並移至 使用者設定 -> 系統管理範本 -> [開始] 功能表和工作列。 從此處可以停用執行、關機、說明和其它功能。 (在 Windows 家用版不可使用)。

也支援透過群組原則編輯設定。 擷取在安裝資料夾中找到的檔案 PolicyDefinitions.zip 並閱讀文件 PolicyDefinitions.rtf 取得更多詳細資料。

更多相關面板

您可以從許多預先安裝的面板挑選:

Classic Start Menu 的面板

或者可以下載並安裝額外第 3 方面板 (從主網站或其它地方)。 下載新面板後，必須複製 .skin 檔案到 Skins 目錄 – 通常是 C:\Program Files\Classic Shell\Skins。 之後將在設定中可以使用。

請注意: 某些外觀可能會針對 Classic, Basic, 或 Aero 模式專門設計。 例如 Aero 面板需要 Glass 支援，如果選取 Classic 或 Basic 佈景主題將看起來怪異。 某些 Aero 面板也需要選取特定 Glass 色。

您可以建立自己的面板。 您將需要支援 alpha 色板的圖像編輯器 (例如 Gimp 或 Photoshop) 和編輯資源檔案的工具 (比如 Resource Hacker 或 Visual Studio)。 當然還有一些圖形設計的人才 :)。 開始前請閱讀 Skinning Tutorial。

搜尋

搜尋框讓您搜尋 [開始] 功能表、PATH 環境變數中程式及索引檔案的內容。 您可以在搜尋框顯示標準功能表項目，接著使用上/下方向鍵找到。 或可以選擇開啟 [開始] 功能表時預設只選取搜尋框。 或可以選擇使用 Tab 鍵時只啟動搜尋框，因此按下 Tab 鍵後可以使用鍵盤進行導覽，有如搜尋框是不存在。

如果是使用 Windows 7 樣式搜尋結果顯示在主功能表，如果是典型樣式則顯示在子功能表。
按一下每個類別以展開及查看更多結果。 按一下結尾的圖示以在檔案總管檢視所有結果。

典型樣式允許您註冊額外「搜尋提供者」，其可以在搜尋框用來搜尋文字。 從功能表選取或按下 Alt + 按鍵 執行搜尋程式。 在此範例，使用 Alt + A 鍵使用 Agent Ransack。

這是在 自訂 [開始] 功能表 索引標籤加入 SearchBoxItem 的子項目來完成:

開啟每個子項目並輸入命令以啟動搜尋程式。 如果您在命令使用 %1，將以搜尋框內容取代，如果使用 %2，將以 URL 樣式編碼的搜尋框取代。 數入標籤、提示和圖示以完成您的功能表項目。 在標籤文字可以使用 & 來標記快速鍵字元 (例如 &Agent Ransack)。

這是可能的一些命令:
以 Agent Ransack 搜尋: "C:\Program Files\Agent Ransack\AgentRansack.exe" -r -f "%1"
以 Everything 搜尋: "C:\Program Files\Everything\Everything.exe" -search "%1"
以 Google 搜尋: http://www.google.com/#q=%2
以 Bing 搜尋: http://www.bing.com/search?q=%2

自訂 [開始] 按鈕

Classic Shell 能加入自己的 [開始] 按鈕到工作列。 甚至能取代 Windows 7 的預設 [開始] 按鈕。 能選擇 Aero 樣式的 [視窗] 標誌、矩形典型按鈕或自行製作。 您需要包含 3 種按鈕狀態的圖像來自訂 [開始] 按鈕 - 標準、焦點和已按下:
[開始] 按鈕圖片
圖片必須是 32 位元 PNG 或 BMP。 預設圖片的寬度決定按鈕的大小，可以輸入自訂寬度覆寫。
您可以線上尋找許多自訂 [開始] 按鈕圖片。 這裡是一些範例:
http://www.classicshell.net/forum/viewforum.php?f=18
http://www.sevenforums.com/themes-styles/34951-custom-start-menu-button-collection.html
 http://www.sevenforums.com/customization/78291-big-group-custom-start-orbs.html
http://tutoriales13.deviantart.com/art/Orbs-153450418

本地化

使用者介面 (除了「設定」對話方塊) 翻譯成 35 種語言。
少數語言翻譯包含「設定」對話方塊。 預設安裝只包含英文。 更多語言可以從 translations 頁面 下載。 請確認下載 Classic Shell 確切版本的翻譯包。

命令列

ClassicStartMenu.exe 支援 5 個命令列參數: -open, -toggle, -togglenew, -exit 和 -settings。

前兩個名稱的建議。 一個開啟典型 [開始] 功能表，另一個切換。 可以使用參數在 [快速啟動列] 建立開啟 [開始] 功能表的捷徑。 或在程式設定熱鍵，比如 WinKey 鍵。

第 3 個「-togglenew」切換預設 Windows [開始] 功能表 (或 [開始] 畫面)。 如果您要建立開啟預設功能表的捷徑或熱鍵是有用的，並使用 Win 鍵為典型功能表。

使用「-exit」結束 [開始] 功能表。 此命令只有在 [開始] 功能表目前未忙碌時才能動作。

使用「-settings」開啟 [開始] 功能表。 這在建立「編輯設定」捷徑時有用。

協助工具

[開始] 功能表支援螢幕讀取工具，比如 JAWS 或 Microsoft 的 Narrator。 如果協助工具支援造成問題，可以從設定的 一般行為 索引標籤停用。


Classic Explorer

Classic Shell 網站 Classic Explorer

Classic Explorer 是 Windows檔案總管的外掛程式:
  • 在檔案總管加入某些一般操作的工具列 (移至上層資料夾、剪下、複製、貼上、刪除、內容、Email)。 工具列可完全自訂
  • 使用更友善的「典型」版本取代 Windows 7 的複製 UI，類似 Windows XP
  • 處理 Windows 檔案總管的資料夾面板中 Alt+Enter 鍵並顯示選取資料夾的內容
  • 提供自訂資料夾面板的選項，使看起來更像 Windows XP 版，或不淡入淡出展開按鈕
  • 能在狀態列顯示可用磁碟空間和合計檔案大小
  • 能在網址列停用軌跡瀏覽
  • 修復在 Windows 7 中斷的長清單功能 – 缺少共用資料夾的重疊圖示、在導覽窗格的跳躍資料夾、在清單檢視中缺少排序標頭和更多

新的複製 UI (僅限 Windows 7)

在 Vista 複製檔案且有衝突時，會以此呈現:

之前

何錯之有?

首先只有您必須讀取完整文字的一半畫面。 此外目前尚不清楚能點選哪些部份。 您必須四處移動滑鼠來探索 UI，有如在 Lucas Arts 探險遊戲。 最後是糟糕的鍵盤可用性。 告訴它 「是，我知道我正在做什麼，我要覆寫所有檔案」 您必須按下 Alt+D，上、上、上、空格! 這比執行 Street Fighter 3 中的 Akuma Kara Demon 移動 還困難。 這東西只有時間和空間，但不是複製檔案。

Classic Explorer 外掛從 Windows XP 取回較簡單的對話方塊:

立即了解能點選的項目 (線索 – 在底端的按鈕)，有簡單鍵盤導覽 (按下 Y 鍵為「是」，A 鍵為複製所有檔案) 且仍然可以看到哪個檔案較新和哪個較大。 當然，就如同 Windows XP，在按一下 [否] 按鈕時按住 Shift 鍵代表「全部皆否」 (或只要按下 Shift+N 鍵)。

如果按一下 [更多…] 將取得 Windows 的原始對話方塊。 從那裡將看到所有的詳細資料並取得「複製，但保留兩者檔案」的額外選項。

重要提示: 只取代 UI。 進行實際複製的底層系統不受影響。

Alt+Enter 鍵在資料夾面板

Alt+Enter 鍵是 Windows 的萬用快速鍵，以帶出選取的內容。 但較新的 Windows 版本，在顯示資料夾的左面板無法動作。 在右側的檔案區則動作正常。 與 Windows XP 的 Alt+Enter 鍵在兩邊皆能正常動作相比，這是不良現象。

若要解決問題， Classic Explorer 外掛程式會偵測您按下 Alt+Enter 鍵並顯示目前選取資料夾的內容。

Windows 檔案總管的工具列

在 Vista 的 Windows 檔案總管沒有如同 Windows XP 中的工具列。 如果要移至上層資料夾，必須使用軌跡瀏覽列。 如果要以滑鼠複製或刪除檔案，必須按一下右鍵尋找 [刪除] 命令。 右鍵功能表會隨著安裝更多殼層擴充功能而變得越來越大，因而需要一些時間尋找右鍵命令。

若要解決問題， Classic Explorer 外掛程式加入新的工具列:

檔案總管工具列

能啟用的按鈕: 移至上層、剪下、複製、貼上、刪除、內容、電子郵件、設定。 可以從 [設定] 對話方塊加入更多按鈕。

提示:
- 按一下 [上移] 按鈕時按住 Ctrl 鍵 以在新的檔案總管視窗開啟上層資料夾。
- 按一下 [刪除] 按鈕時按住 Shift 鍵 以永久刪除檔案

新的工具列在安裝後不會自動顯示於檔案總管。 使用前必須進行一些動作:
  1. 開啟新的 Windows 檔案總管視窗 (Win + E 鍵)
  2. 在檔案總管開啟功能表 – 移至 工具 (Alt + T 鍵)→資料夾選項→檢視 索引標籤，並確認有勾選「一律顯示功能表」。
  3. 在功能表列按右鍵並選取「Classic Explorer 列」以顯示工具列。
  4. 如果選項不可使用 (只看到「鎖定工具列」)，您可能必須從 Internet Explorer 啟用外掛程式。 執行 Internet Explorer，在工具列按一下右鍵，並選取「Classic Explorer Bar」。 它將詢問您是否要啟用此附加元件，選取「啟用」，接著再次重複步驟 1 至 3。
  5. 即使如此仍看不到工具列，有可能 Internet Explorer 擴充功能已在系統停用。 這通常是伺服器的預設值。 開啟「網際網路選項」，移至「進階」索引標籤，並檢查設定「啟用協力廠商瀏覽器延伸」。

狀態列

Classic Explorer 還原原始檔案總管狀態列，顯示可用磁碟空間和選取檔案的大小:

狀態列中檔案大小

不像內建狀態列，即使選取超過 100 個檔案，會顯示選取的大小。 未選取檔案時。會顯示資料夾中所有檔案的合計大小。

Windows 7 提示: Classic Explorer 增強預設狀態列而不是取代。 若要檢視，必須先從 [檢視] 功能表開啟。 狀態列與檔案總管下方看到的藍色 [詳細資料窗格] 不同。 您可以從 [組織管理] 功能表關閉 [詳細資料窗格] 以節省空間。 這也是 Windows 7 檔案總管中 Bug，有時在狀態列未顯示任何文字。 按下 F5 以重新整理檢視並取得狀態列文字。

Windows 8 提示: Classic Explorer 加入自己的狀態列。 您應該隱藏預設的狀態列以節省空間。 在功能區選取 [檢視] 索引標籤，接著按一下 [選項]。 在選項中選取 [檢視] 索引標籤，找到「顯示狀態列」 核取方塊，並取消選取。

設定

您可以從工具列或從 [開始] 功能表存取 Classic Explorer 的設定:

您可以選擇只查看基本設定，或所有可用的設定。 暫留在每個設定的上方以查看其作用的簡述。 在搜尋方塊輸入依名稱尋找設定。
每個設定有預設值。 預設值可以是常數，或根據目前系統設定而定。 編輯設定後會成為「已修改」且以粗體顯示。 若要返回預設值，在設定按一下右鍵。

您可以儲存設定為 XML 檔案，並稍後載入回來。 按下 [備份] 按鈕以存取這些功能。 從那也可以重設所有的設定為其預設值。

按下 [確定] 存放設定。 大部分設定將在下次開啟新的檔案總管視窗時套用。 少數設定在看到變更前將需要登出。

備註: 所有的設定視窗可調整大小。 調整大小並隨心所欲的放置。 它們將會記住新的位置。

這是能自訂的一個範例:
標題列調整

按一下 [工具列按鈕] 索引標籤以自訂工具列:

左欄顯示目前工具列中按鈕，及右欄列出可加入到工具列的按鈕。 您可以從右欄拖曳按鈕到左側，上下拖曳安排按鈕。 如果拖曳一個按鈕在另一個內將建立子功能表。
暫留在每個按鈕上方以查看其作用的簡述。 在每個按鈕按一下右鍵以存取更多功能 (比如刪除、重新命名等)。 從右鍵功能表也可以重設工具列為原始狀態。
在左欄的每個項目必須有唯一名稱。 這是項目的識別字元且只能包含英文字母、數字和底線。 某些項目 (比如 SEPARATOR) 不能重新命名。

重要提示: 並非所有可用的命令有預設圖示或文字。 因為 Windows 沒有該命令的圖示，如 復原、全選等。 如果您要在工具列使用這些按鈕，將必須提供自己的圖示。 參閱以下如何進行。

在工具列放置按鈕後，可以編輯其屬性。 按兩下按鈕編輯:
編輯工具列按鈕
在此能選取按鈕的命令、其文字和圖示。 按下 [還原預設值] 按鈕以取得選擇命令的預設文字和圖示。
命令可以是:
  • 保留空白 - 此時如果使用連結屬性，將以命令動作
  • 預先定義的命令之一 - 從下拉式功能表
  • open <某些資料夾> - 這將在目前瀏覽器開啟資料夾
  • sortby <property> - 這將依給予的內容排序 - name, type, size 或 date。 在內容前使用「-」以遞減順序排序: "sortby -name"。 您可以使用其它內容，如果知道其代碼。 例如 "sortby {B725F130-47EF-101A-A5F1-02608C9EEBAC}, 10" 與 "sortby name" 相同。 更多內容代碼，請參考 Windows SDK 中檔案 propkey.h (也能在此找到 - 下捲到 "Full property table")。 並非所有內容代碼有效或支援 (例如 album year 內容 {56A3372E-CE9C-11D2-9F0E-006097C686F6}, 5 只有在顯示音樂專輯時動作)
  • groupby <property> - 類似 sortby，但依給予的內容分組檔案。 使用命令 groupby 不含內容來停用分組
  • 自訂執行字串 - 這可以是程式名稱和其引數，或甚至 URL (比如 http://www.google.com)。 可以使用環境變數，如 %SystemRoot%。 也可以使用預留位置 %1, %2, %3, %4 和 %5:
    • %1 是目前資料夾的路徑。 請記住，如果目前資料夾是磁碟機的根目錄，將使用反斜線結束 (如 C:\)
    • %2 是選取檔案的路徑。 (只選取單一檔案時)
    • %3 是暫存文字檔案的名稱，包含所有選取的檔案。 文字檔案中每行包含一個檔案與其完整路徑
    • %4 與 %3 相同，但檔案是 Unicode (UTF16) 格式。 檔案包含無 byte 順序標記。 相同命令不能同時使用 %3 和 %4
    • 開發者提示: 使用 %3 或 %4 時，完成後刪除臨時檔案是此命令的責任。 否則將遺留臨時檔案並浪費磁碟空間。 此外，如果命令是主控台應用程式或批次檔案，將以無訊息模式啟動不含主控台視窗
    • %5 是暫存文字檔案的名稱，能用來將命令返回 Classic Explorer。 如果檔案的開始 2 bytes 為 255 和 254，則檔案視為 Unicode。 一次只能使用一個命令。 命令能為:
      • open <資料夾名稱> - 使檔案總管導覽到給予的資料夾
      • select <檔案名稱清單> - 選取給予檔案，剩餘的不選。 檔案名稱必須以 tab 或換行字元分隔。 檔案不能包含路徑。 如果有，將忽略路徑
      • refresh - 重新整理檔案總管
    • 開發者提示: 使用 %5 命令將以無訊息模式執行 (如同使用 %3 或 %4 命令)，但檔案總管也將等待處理程序完成。 處理程序必須儘快完成，因為檔案總管在命令執行期間將停止回應
    • 一些範例請查看下一節，如何使用這些參數
連結可以是檔案或資料夾的路徑。 若是檔案，將執行該檔案。 若是資料夾，將以子功能表開啟該資料夾 (只針對最上層按鈕)。

圖示可以是:
  • 保留空白 - 此時如果使用連結屬性指向檔案或資料夾，將使用該檔案或資料夾的圖示
  • 資源檔案,圖示 ID - 例如 %windir%\notepad.exe,2。 檔案和逗號之間不能有空格。 確認使用圖示的資源 ID，而非圖示的索引。 為了達到最佳效果，使用圖示方塊旁的 [...] 按鈕
  • ,圖示 ID - 與上方一樣，但資源檔案為 ClassicExplorer.dll 本身。 當參照到 Classic Explorer 的自己圖示時是有用的
  • 圖示檔案 - 例如 C:\Program Files\Mozilla Thunderbird\Email.ico
  • none - 這將使用空白圖示
如果標籤或提示屬性以 $ (錢字符號) 開頭，則系統將視其為 ExplorerL10N.ini 檔案中字串的名稱。 實際文字將根據目前語言設定而定。 這在建立多語言所使用的工具列時是有用的。

開發者提示: 自訂命令的按鈕能已勾選或已停用。 工具列檢查登錄檔機碼 HKCU\Software\IvoSoft\ClassicExplorer 對於含按鈕名稱的 DWORD 數值 (名稱用於左欄)。 0 表示正常，1 為已停用，2 為已勾選。 工具列在啟動時讀取登錄檔機碼。 若要強制按鈕更新其狀態在需要尋找所有的檔案總管視窗後，找到類別 ClassicShell.CBandWindow 的子視窗，並貼上訊息 WM_CLEAR。 如果您正在開發工作列所使用的自訂 exe 時是有用的。

自訂命令範例

0) 需要時使用引號

為了支援包含空格的路徑，您可以在路徑參數前後使用引號。 引號非始終需要，比如在以下範例 1 和 2。 請確實測試包含空格路徑的命令以避免意外。

1) 列印目前資料夾

使用此命令: cmd.exe /k echo %1。 目前資料夾的路徑將取代 %1。

2) 在記事本開啟選取的檔案

使用此命令: %SystemRoot%\notepad.exe %2。 選取檔案的完整名稱將取代 %2。 不需要引號，因為 Notepad 使用整個命令列為檔案名稱。

3) 複製選取的檔案到上層資料夾

建立批次檔案名稱為C:\CopyParent.bat:
set list=%1
set list=%list:"=%
for /F "delims=" %%i in (%list%) do copy /Y "%%i" ..
del %1
使用此命令: C:\CopyParent.bat "%3"。 包含所有選取檔案的完整名稱的文字檔案將取代 %3。 批次檔案將讀取該文字檔案的每一行，並複製每個選取檔案到上層資料夾。 在批次檔案結尾，刪除初始暫存檔案。 前兩個 set 命令從 %1 參數移除引號。

4) 選取所有文字檔案

建立批次檔案名稱為 C:\SelectText.bat:
echo select > %1
dir *.txt /b >> %1

使用此命令: C:\SelectText.bat "%5"。 %5 將以空白文字檔取代，其中命令必須輸出單字 "select" 和要選取的檔案清單。「dir *.txt /b」命令提供該清單。

系統管理設定

設定是每個使用者且存放在登錄檔。 預設每個使用者能編輯其所有的設定。 系統管理員能鎖定指定設定，因此沒有使用者能編輯:

在此範例，設定「顯示上移按鈕」鎖定為始終「在上一頁/下一頁之前」且使用者無法變更。 這是透過加入設定到 HKEY_LOCAL_MACHINE\SOFTWARE\IvoSoft\ClassicExplorer 登錄檔機碼來達成。 建立名稱為「ShowUpButton」的字串值並設成「BeforeBack」。

某些情形下您可能不要針對所有使用者鎖定數值，而只是簡單的修改設定的初始值。 在此情形則在數值的名稱加入「_Default」。 例如，如果您要預設 [上移] 按鈕在 [上一頁] 之前但仍允許使用者視需要變更，建立名稱為「ShowUpButton_Default」的字串值並設成「BeforeBack」。

了解設定的登錄檔名稱與其數值之輕鬆方式，是修改它接著在以下機碼中尋找: HKEY_CURRENT_USER\Software\IvoSoft\ClassicExplorer\Settings。
有時您可能要鎖定設定為預設值，但不知預設值為何。 則建立 DWORD 數值並設定成 0xDEFA。

這也是全域設定 EnableSettings。 在登錄檔設定為 0 以防止使用者開啟 [設定] 對話方塊:
停用所有設定

您可以使用 2 個登錄檔設定「ProcessWhiteList」和「"ProcessBlackList」，為個別處理程序啟用或停用 Classic Explorer。 ProcessWhiteList 是將載入 Classic Explorer 的處理程序清單。 只使用處理程序的名稱 (比如「notepad.exe」)，以 , 或 ; 分隔多個名稱。 ProcessBlackList 是不載入 Classic Explorer 的處理程序清單。 您只能使用其中一種清單，如果指定兩種清單，將忽略黑名單。 清單只在啟用檔案總管以外處理程序支援的功能時使用。 此時這些功能是: 共用重疊圖示和取代複製對話方塊。

也支援透過群組原則編輯設定。 擷取在安裝資料夾中找到的檔案 PolicyDefinitions.zip 並閱讀文件 PolicyDefinitions.rtf 取得更多詳細資料。

Windows 設定的相依性

某些 Classic Explorer 設定需要啟用特定 Windows 設定:
  • Windows Vista 導覽窗格樣式 - 使用 Windows 使用 Aero 或 Basic 佈景主題
  • 自動導覽到選取的資料夾 - 當檔案總管設定成「自動展開到目前資料夾」時，此設定才能設為「永遠」。 在 工具 -> 資料夾選項 的 一般 索引標籤查看
  • 在標題列顯示標題 - 標題將顯示完整路徑名稱或只有目前資料夾的名稱。 若要查看完整路徑，需要在 工具 -> 資料夾選項 的 檢視 索引標籤中啟用「在標題列顯示完整路徑 (僅限 Classic 主題)」
  • 所有狀態列設定 - 需要顯示狀態列 (不要與詳細資料窗格混淆)。 檢查 檢視 -> 狀態列

本地化

使用者介面 (除了「設定」對話方塊) 翻譯成 35 種語言。
少數語言翻譯包含「設定」對話方塊。 預設安裝只包含英文。 更多語言可以從 translations 頁面 下載。 請確認下載 Classic Shell 確切版本的翻譯包。


Classic IE

Classic Shell 網站 Classic IE

Classic IE 是 Internet Explorer 的小外掛程式:
  • 在標題列加入標題，以便能看到頁面的完整標題
  • 在狀態列顯示安全性區域
  • 在狀態列顯示載入進度

檢視完整頁面標題，即使不適合索引標籤:

查看進度和安全性區域:

安裝

當您安裝 Classic IE 後首次執行 Internet Explorer ，可能提示有安裝新的附加元件稱為 ClassicIEBHO 和是否要啟用。 按一下 [啟用] 按鈕。 如果未得到提示，移至 工具 -> 管理附加元件 並確認 ClassicIEBHO 已啟用。 啟用附加元件後必須重新啟動 Internet Explorer 以啟動外掛程式。

設定

您可以從 工具 -> Classic IE 設定 或從 [開始] 功能表存取設定。 設定控制標題的色彩和字型，以及在狀態列顯示什麼資訊。

您可以選擇只查看基本設定，或所有可用的設定。 暫留在每個設定的上方以查看其作用的簡述。 在搜尋方塊輸入依名稱尋找設定。
每個設定有預設值。 預設值可以是常數，或根據目前系統設定而定。 編輯設定後會成為「已修改」且以粗體顯示。 若要返回預設值，在設定按一下右鍵。

您可以儲存設定為 XML 檔案，並稍後載入回來。 按下 [備份] 按鈕以存取這些功能。 從那也可以重設所有的設定為其預設值。

按下 [確定] 還原設定。 您需要重新啟動 Internet Explorer 以套用新的設定。

系統管理設定

設定是每個使用者且存放在登錄檔。 預設每個使用者能編輯其所有的設定。 系統管理員能鎖定指定設定，因此沒有使用者能編輯。 這是透過加入設定到 HKEY_LOCAL_MACHINE\SOFTWARE\IvoSoft\ClassicIE 登錄檔機碼來達成。

您可能也希望不鎖定設定但只覆寫其初始值。 則在登錄檔數值的名稱加入「_Default」"。

了解設定的登錄檔名稱與其數值之輕鬆方式，是修改它接著在以下機碼中尋找: HKEY_CURRENT_USER\Software\IvoSoft\ClassicIE\Settings。
有時您可能要鎖定設定為預設值，但不知預設值為何。 則建立 DWORD 數值並設定成 0xDEFA。

這也是全域設定 EnableSettings。 在登錄檔設定為 0 以防止使用者開啟 [設定] 對話方塊:

也支援透過群組原則編輯設定。 擷取在安裝資料夾中找到的檔案 PolicyDefinitions.zip 並閱讀文件 PolicyDefinitions.rtf 取得更多詳細資料。


授權協議

Classic Shell 網站 授權協議

Classic Shell c 2009-2016, Ivo Beltchev
http://www.classicshell.net/

使用此軟體亦即您接受這些條款，如果不接受，請不要使用軟體。

如果您遵守這些授權條款，您有以下權利。

  1. 授權範圍。 此條款只給予一些使用軟體的權利。 作者擁有所有其他權利。

  2. 安裝和使用權利。 這個軟體免費供個人和商業使用。 您可以安裝和使用在您的電腦完全免費。

  3. 再發行權利。 您可以重新發行軟體，只要是免費和不扭曲原始軟體。

  4. 商標。 ClassicShell 名稱和 logo 是作者的商標。 使用它們來識別其他產品或服務是不允許的。

  5. 擔保免責聲明。 軟體是根據「現狀」提供，沒有任何形式的擔保，明示或暗示，包含但不限於適銷性的擔保，適用於特定用途和不侵犯。 在任何事件，作者或版權持有人承擔任何索賠、損害或其他責任，無論是在合同，侵權法的一個動作或否則，引起的，連結軟體或使用或其他交易軟體。

  6. 換句話說: 基本上您可以自由的使用這個軟體為任何目的; 但不要感到驚訝，如果它不能正常工作於您所期待。 您不能讓作者承擔任何損害。 您不能銷售這個軟體來獲利。 畢竟您是免費使用的。


Classic Shell

Classic Shell 網站 連結

在 Classic Shell 網站能找到最新版本:
http://www.classicshell.net/

在此檢視專案歷程記錄:
歷程記錄: http://www.classicshell.net/history/

取得協助

常見問題集的回答請查看此:
FAQ: http://www.classicshell.net/faq/

如果在 FAQ 中找不到您需要的答案，請嘗試討論區:
討論區: http://www.classicshell.net/forum/viewforum.php?f=6

回報問題

在開發討論區回報問題和功能需求:
開發討論區: http://www.classicshell.net/forum/viewforum.php?f=11