ASP.NET 的 MMC 嵌入式管理單元

ASP.NET
ASP.NET 的 MMC 嵌入式管理單元
DropDown image

本章節中的主題會描述如何使用 Microsoft Management Console (MMC) 嵌入式管理單元，來設定 ASP.NET 和 ASP.NET 應用程式。

MMC 會裝載可讓您用來管理電腦、服務、其他系統元件和網路的管理工具。您可以將一或多個稱為嵌入式管理單元的管理工具，加入至管理 Web 應用程式的主控台。Microsoft Management Console (MMC) 的 ASP.NET 嵌入式管理單元工具會提供一站式 (One-Stop) 使用者介面 (UI)，以設定 Web 伺服器及其所裝載的應用程式。它包含了幾個對話方塊，可讓您用來管理特定的功能，例如，自訂錯誤處理或使用者驗證 (Authentication)。

在本節中

ASP.NET 組態設定對話方塊、一般索引標籤
ASP.NET 組態設定對話方塊、自訂錯誤索引標籤
ASP.NET 組態設定對話方塊、授權索引標籤
ASP.NET 組態設定對話方塊、驗證索引標籤
ASP.NET 組態設定對話方塊、應用程式索引標籤
ASP.NET 組態設定對話方塊、狀態管理索引標籤
ASP.NET 組態設定對話方塊、位置索引標籤
編輯/加入連接字串對話方塊
編輯/加入應用程式設定對話方塊
編輯/加入自訂錯誤處理常式對話方塊
編輯規則對話方塊
加入位置對話方塊

相關章節

設定 ASP.NET 應用程式

提供 ASP.NET 組態模型的相關資訊，包括 XML 檔和組態程式設計 API 的用法。
若要對本產品的相關功能或是說明文件的內容提供您寶貴的建議或是指正其中的錯誤，請前往客戶意見網站。


ASP.NET 組態設定對話方塊、一般索引標籤

ASP.NET 組態設定對話方塊、一般索引標籤
請參閱
DropDown image

[ASP.NET 組態設定] 對話方塊的 [一般] 索引標籤，可讓您管理下列兩種類型的組態設定：

  • 連接字串 (Connection String)，定義的資訊是用來建立與資料存放區 (例如資料庫) 的連接。

  • 應用程式設定，是簡易的名稱/值組，可讓您在中心位置建立整個應用程式適用的值。然後，您可以從 Web 應用程式內的任何位置存取應用程式值。保留應用程式設定做為組態的一部分，即可輕鬆變更這些設定。應用程式設定總是被視為字串來儲存。

在 [一般] 索引標籤上進行的設定，會套用至開啟 [屬性] 對話方塊之前所選取的 Web 應用程式。

Note 注意事項

可以繼承組態設定。設定可以定義在 Machine.config 檔中，這個檔案會做為伺服器上所有網站和應用程式的基底組態。在 Web 應用程式層級上進行組態設定，即可建立新設定，或覆寫繼承的設定。

若要開啟一般對話方塊

  1. 在 Microsoft Windows 中，開啟 [系統管理工具]，再按一下 [網際網路資訊服務 (IIS) 管理員]。

    [IIS 管理員] 隨即出現。

  2. 在 [網際網路資訊服務] 下，展開 [Servername (本機電腦)]，然後展開 [網站]，並以滑鼠右鍵按一下 [Websitename] 或 [預設網站]，再按 [屬性]。

    [網站內容] 對話方塊隨即出現。

  3. 按一下 [ASP.NET] 索引標籤，再按 [編輯組態]。

    [ASP.NET 組態設定] 對話方塊隨即出現。

  4. 按一下 [一般] 索引標籤。

工作

使用 [一般] 索引標籤，可以：

  • 定義 Web 應用程式的資料庫連接字串。

  • 建立字串值，以儲存經常使用的資訊。然後，可從應用程式內的任何位置中存取資訊，且該資訊十分容易就可變更。

UI 項目

連接字串管理員

列出針對所選取 Web 應用程式定義的連接字串。繼承的設定會以斜體表示，而已覆寫之繼承的設定會以粗體表示。

加入

按一下以顯示 [編輯/加入連接字串] 對話方塊，您可以在其中建立新的連接字串。

編輯

按一下以顯示 [編輯/加入連接字串] 對話方塊，您可以在其中編輯現有的連接字串。

您可以覆寫繼承的設定，在這種情況下，覆寫的設定只會套用至所選取的 Web 應用程式。您無法編輯繼承的設定，以在較高的組態階層架構中變更其值。

移除

按一下以移除或停用連接字串。

您可以永久地移除為這個 Web 應用程式所定義的新設定。如果移除繼承的設定，則原始設定在階層中的位置保留不變，且 [IIS 管理員] 會為該設定建立 <remove> 項目，這會停用該設定。

重設

按一下以將覆寫或移除的設定還原為其原始值。

[IIS 管理員] 會移除本機覆寫值或刪除 <remove> 項目，以優先使用繼承的設定。

應用程式設定

列出應用程式設定索引鍵/值組。

加入

按一下以顯示 [編輯/加入應用程式設定] 對話方塊，可在其中建立新的索引鍵/值組。

編輯

按一下以顯示 [編輯/加入應用程式設定] 對話方塊，可在其中建立新的索引鍵/值組。

您可以覆寫繼承的設定，在這種情況下，覆寫的設定只會套用至所選取的 Web 應用程式。您無法編輯繼承的設定，以在較高的組態階層架構中變更其值。

移除

按一下以移除或停用索引鍵/值組。

您可以永久地移除為這個 Web 應用程式所定義的新應用程式設定。如果移除繼承的設定，則原始設定在階層中的位置保留不變，且 [IIS 管理員] 會為該設定建立 <remove> 項目，這會停用該設定。

重設

按一下以將覆寫或移除的索引鍵/值組還原為其原始值。

[IIS 管理員] 會移除本機覆寫值或刪除 <remove> 項目，以優先使用繼承的設定。

請參閱

工作

HOW TO：以程式設計方式存取 ASP.NET 組態設定

參考

ASP.NET 組態設定對話方塊、驗證索引標籤
ASP.NET 組態設定對話方塊、授權索引標籤
ASP.NET 組態設定對話方塊、自訂錯誤索引標籤
ASP.NET 組態設定對話方塊、位置索引標籤
connectionStrings 項目 (ASP.NET 設定結構描述)
appSettings 項目 (一般設定結構描述)

概念

ASP.NET 組態概觀


ASP.NET 組態設定對話方塊、自訂錯誤索引標籤

ASP.NET 組態設定對話方塊、自訂錯誤索引標籤
DropDown image

在 ASP.NET Web 網頁或元件中發生錯誤時，ASP.NET 會引發錯誤碼。錯誤可包含下列類型：

  • 編譯時期。

  • 剖析器 (Parser) (錯誤的 ASP.NET 項目)。

  • 組態。

  • 執行階段。

根據預設，ASP.NET 會動態產生錯誤網頁，其中包含錯誤說明、發生錯誤的網頁名稱，以及堆疊追蹤 如果已啟用偵錯模式，則動態產生的網頁還會包含發生錯誤之原始程式碼的摘錄。定義自訂錯誤，即可指定 Web 應用程式在發生錯誤時的回應方式。

Note 注意事項

如需偵錯模式的詳細資訊，請參閱 ASP.NET 組態設定對話方塊、應用程式索引標籤。

若要顯示 ASP.NET 組態設定對話方塊的自訂錯誤索引標籤

  1. 在 Microsoft Windows 中，開啟 [系統管理工具]，再按一下 [網際網路資訊服務 (IIS) 管理員]。

    [IIS 管理員] 隨即出現。

  2. 在 [網際網路資訊服務] 下，展開 [Servername (本機電腦)]，然後展開 [網站]，並以滑鼠右鍵按一下 [Websitename] 或 [預設網站]，再按 [屬性]。

    [網站內容] 對話方塊隨即出現。

  3. 按一下 [ASP.NET] 索引標籤，再按 [編輯組態]。

    [ASP.NET 組態設定] 對話方塊隨即出現。

  4. 按一下 [自訂錯誤] 索引標籤。

工作

使用 [自訂錯誤] 索引標籤，您可以：

  • 指定預設的錯誤網頁，在 Web 應用程式的任何位置發生 ASP.NET 錯誤時都會顯示該網頁。

  • 將特定 HTTP 錯誤碼對應至相應的錯誤網頁。

    Note 注意事項

    只有告知 ASP.NET 的錯誤才可使用對應。例如，預設不會將 HTTP 404 錯誤 (找不到網頁) 告知 ASP.NET。如果要讓 ASP.NET 接收這些錯誤，則可設定網站屬性，將 HTTP 錯誤對應至 .aspx 網頁。

  • 指定自訂錯誤網頁是對所有使用者顯示、不對任何使用者顯示，還是對遠端 (非管理) 使用者顯示。

UI 項目

自訂錯誤模式

按一下模式以指定自訂錯誤的顯示方式，如下所示：

  • 開啟

    一律會顯示自訂錯誤網頁。使用這個設定，可檢視開發 Web 應用程式時的錯誤。

  • 關閉

    不會顯示自訂錯誤網頁。相反，錯誤會動態產生 ASP.NET 錯誤網頁。

  • 僅限遠端

    只會針對不是在 Web 伺服器上本機產生的要求，重新導向錯誤。使用這個模式，可在使用伺服器時檢視 ASP.NET 錯誤，但會將自訂錯誤顯示給 Web 應用程式使用者。

預設重新導向 URL

輸入網頁名稱 (.aspx 或 .htm)，回應 Web 應用程式中任何位置的未處理錯誤時都會顯示該網頁。

繼承的自訂錯誤

列出自訂錯誤網頁，這些網頁繼承自階層中較高層的組態檔。若要覆寫繼承的錯誤設定，您可為要覆寫的狀態碼加入本機自訂錯誤。

本機自訂錯誤

特別列出目前網站的錯誤網頁。

加入

按一下以開啟 [編輯/加入自訂錯誤處理常式] 對話方塊，可在其中指定 HTTP 錯誤碼以及 ASP.NET 偵測到錯誤時所顯示的網頁。

Note 注意事項

只有告知 ASP.NET 的錯誤才可使用對應。例如，預設不會將 HTTP 404 錯誤 (找不到網頁) 告知 ASP.NET。如果要讓 ASP.NET 接收這些錯誤，則可設定網站屬性，將 HTTP 錯誤對應至 .aspx 網頁。

您必須提供 HTTP 錯誤碼和其對應至的網頁 URL。參考的網頁不必位在目前的網站中。

Note 注意事項

[IIS 管理員] 不會驗證所輸入的 URL。

編輯

按一下以開啟 [編輯/加入自訂錯誤處理常式] 對話方塊，可在其中變更在 [本機自訂錯誤] 下所選取之網頁的網頁名稱或錯誤碼。

移除

按一下以刪除錯誤網頁對應。

請參閱

工作

HOW TO：以程式設計方式存取 ASP.NET 組態設定

參考

ASP.NET 組態設定對話方塊、驗證索引標籤
ASP.NET 組態設定對話方塊、授權索引標籤
ASP.NET 組態設定對話方塊、位置索引標籤
connectionStrings 項目 (ASP.NET 設定結構描述)
appSettings 項目 (一般設定結構描述)

概念

ASP.NET 組態概觀


ASP.NET 組態設定對話方塊、授權索引標籤

ASP.NET 組態設定對話方塊、授權索引標籤
DropDown image

[ASP.NET 組態設定] 對話方塊的 [授權] 索引標籤，可讓您根據使用者帳戶和角色，管理目前網站目錄的授權規則 (Rule)。使用 Microsoft Windows 驗證 (Authentication) 或 ASP.NET 表單驗證 (ASP.NET 成員資格)，可建立使用者帳戶和角色。您可以加入、編輯或移除目前網站目錄的規則。除非子系子目錄中的組態檔設定覆寫規則，否則會將規則套用至目前的子目錄和目前 URL 的所有子系子目錄。

還會顯示從 Machine.config 組態檔和任何父系的虛擬目錄中所繼承的規則，但卻不能進行編輯。若要變更繼承來之規則的效果，您可以在網站層次建立新的設定。應用程式設定總是被視為字串來儲存。

在 [授權] 索引標籤上進行的設定，會套用至顯示 [屬性] 對話方塊之前所選取的網站。

Note 注意事項

可以繼承組態設定。設定可以在 Machine.config 檔中加以定義，這個檔案會做為伺服器上所有網站的基底組態。如需 ASP.NET 組態檔的詳細資訊，請參閱 ASP.NET 組態檔階層架構和繼承。

若要開啟授權對話方塊

  1. 在 Windows 中，開啟 [系統管理工具]，再按一下 [網際網路資訊服務 (IIS) 管理員]。

    [IIS 管理員] 隨即出現。

  2. 在 [網際網路資訊服務] 下，展開 [Servername (本機電腦)]，然後展開 [網站]，並以滑鼠右鍵按一下 [Websitename] 或 [預設網站]，再按 [屬性]。

    [網站內容] 對話方塊隨即出現。

  3. 按一下 [ASP.NET] 索引標籤，再按 [編輯組態]。

  4. [ASP.NET 組態設定] 對話方塊隨即出現。

  5. 按一下 [授權] 索引標籤。

工作

使用 [授權] 索引標籤，您可以：

  • 檢視所有繼承之組態檔 (包含 Machine.config 檔) 中所定義的授權規則。

  • 加入、編輯和移除目前網站目錄的授權規則。

規則優先順序

授權規則會按由上至下的順序套用。在某些情況下，可能需要為同一資料夾建立多個規則，才能建立正確的使用權限。例如，可能會建立一個拒絕匿名使用者帳戶存取的規則，也建立第二個拒絕 Guest 角色之使用者帳戶存取的規則。這樣，只有已登入 (非匿名) 且在其他群組 (非 Guest) 中的使用者才可以存取該資料夾。

Web.config 設定

透過 [安全性] 索引標籤管理的 Web.config 設定為 <authorization>、<roleManager> 和 <authentication> 區段。

下列 Web.config 檔的摘錄限制對網站子目錄的存取。允許系統管理員和名為 John 的使用者存取受限子目錄，而拒絕匿名使用者存取該子目錄。

CopyCode image 複製程式碼
<?xml version="1.0" encoding="utf-8"?>
<configuration>
    <system.web>
        <authorization>
            <allow roles="administrators" />
            <allow users="John"/>
            <deny users="?" />
        </authorization>
    </system.web>
</configuration>

UI 項目

繼承的授權規則

列出繼承的授權規則，這些授權規則定義於 Machine.config 檔或任何父系虛擬目錄中 (定義於 ASP.NET 組態檔階層架構和繼承中)。繼承的設定會以斜體表示，而已覆寫之繼承的設定會以粗體表示。

本機授權規則

列出已套用至目前網站目錄和其所有子系目錄的授權規則。

加入

按一下以開啟編輯規則對話方塊，建立新的規則。

編輯

按一下以開啟編輯規則對話方塊，編輯選取的規則。

移除

按一下以便從 [本機授權規則] 中刪除選取的資料列。

請參閱

工作

HOW TO：以程式設計方式存取 ASP.NET 組態設定

參考

ASP.NET 組態設定對話方塊、驗證索引標籤
ASP.NET 組態設定對話方塊、位置索引標籤
connectionStrings 項目 (ASP.NET 設定結構描述)
appSettings 項目 (一般設定結構描述)

概念

ASP.NET 組態概觀

其他資源

ASP.NET 的 MMC 嵌入式管理單元


ASP.NET 組態設定對話方塊、驗證索引標籤

ASP.NET 組態設定對話方塊、驗證索引標籤
DropDown image

[ASP.NET 組態設定] 對話方塊的 [驗證] 索引標籤，可讓您管理目前網站的使用者帳戶和角色驗證。ASP.NET 驗證是取得識別認證 (例如使用者帳戶的使用者名稱和密碼) 的處理序，以驗證針對部分授權單位認證的有效性。如需 ASP.NET 如何實作驗證的完整說明，請參閱 ASP.NET 驗證。

[驗證] 索引標籤也支援加入、移除和設定目前 Web 應用程式的成員資格提供者和角色管理。ASP.NET 角色管理可讓您指定應用程式中使用者帳戶可以存取的資源。角色管理可讓您將使用者帳戶指派給角色，以將使用者帳戶群組視為一個單位。如需 ASP.NET 角色管理的詳細資訊，請參閱瞭解角色管理。

可在 Web 應用程式中建立和使用自訂成員資格提供者。如需如何實作自訂成員資格提供者的完整說明，請參閱實作成員資格提供者。

在 [驗證] 索引標籤上進行的設定，會套用至開啟 [屬性] 對話方塊之前所選取的網站。

Note 注意事項

可以繼承組態設定。設定可以在 Machine.config 檔中加以定義，這個檔案會做為伺服器上所有網站的基底組態。如需 ASP.NET 組態檔的詳細資訊，請參閱 ASP.NET 組態檔階層架構和繼承。

若要顯示 ASP.NET 組態設定對話方塊的驗證索引標籤

  1. 在 Microsoft Windows 中，開啟 [系統管理工具]，再按一下 [網際網路資訊服務 (IIS) 管理員]。

    [IIS 管理員] 隨即出現。

  2. 在 [網際網路資訊服務] 下，展開 [Servername (本機電腦)]，然後展開 [網站]，並以滑鼠右鍵按一下 [Websitename] 或 [預設網站]，再按 [屬性]。

    [網站內容] 對話方塊隨即出現。

  3. 按一下 [ASP.NET] 索引標籤，再按 [編輯組態]。

    [ASP.NET 組態設定] 對話方塊隨即出現。

  4. 按一下 [驗證] 索引標籤。

工作

使用 [驗證] 索引標籤，您可以：

  • 設定目前 Web 應用程式的驗證型別。

  • 加入、移除和修改目前 Web 應用程式的成員資格提供者。

  • 加入、移除和修改目前 Web 應用程式的角色成員資格提供者。

UI 項目

驗證模式

按一下以指定目前網站的驗證模式。如需每個驗證模式的完整說明，請參閱 ASP.NET 驗證。

HTTP Cookie 名稱

輸入 HTTP Cookie 的名稱，用於驗證目前的網站。[HTTP Cookie 名稱] 僅適用於設定表單驗證。

登入 URL

輸入找不到有效的驗證 Cookie 時，將要求重新導向以進行登入的 URL。預設為 login.aspx。[登入 URL] 僅適用於設定表單驗證。

Cookie 保護

按一下以指定驗證 Cookie 要使用的加密型別 (如果有的話)。[Cookie 保護] 僅適用於設定表單驗證。

Cookie 逾時

輸入驗證 Cookie 過期的時間長度，以整數的分鐘為單位。預設為 30。[Cookie 逾時] 僅適用於設定表單驗證。

需要 SSL

選取這個核取方塊，指定需要 SSL 連接來傳輸驗證 Cookie。[需要 SSL] 僅適用於設定表單驗證。

啟用滑動期限

選取這個核取方塊，則在發出要求且已耗用一半以上的逾時間隔時，會重設過期時間，以取得有效的驗證 Cookie。[啟用滑動期限] 僅適用於設定表單驗證。

成員資格提供者類別

按一下以指定目前網站之設定的成員資格提供者。

管理提供者

按一下以開啟 [提供者設定] 對話方塊，可在其中加入、移除和設定目前網站的成員資格提供者。

啟用角色管理

選取這個核取方塊，讓角色管理可管理使用者帳戶群組的存取規則。

角色提供者類別

按一下以指定目前網站之設定的角色成員資格提供者。

管理提供者

按一下以開啟 [提供者設定] 對話方塊，可在其中加入、移除和設定目前網站的角色成員資格提供者。

請參閱

概念

實作成員資格提供者
瞭解角色管理
ASP.NET 組態檔階層架構和繼承

其他資源

ASP.NET 驗證
ASP.NET 的 MMC 嵌入式管理單元


ASP.NET 組態設定對話方塊、應用程式索引標籤

ASP.NET 組態設定對話方塊、應用程式索引標籤
DropDown image

[ASP.NET 組態設定] 對話方塊的 [應用程式] 索引標籤，可讓您管理三種類型的組態設定：

  • 通用編譯、頁面及執行階段設定。

  • 全球化設定。

  • 識別設定。

若要從 Microsoft Internet Information Services (IIS) 管理員顯示 ASP.NET 組態設定對話方塊

  1. 開啟此 Web 應用程式的 [屬性] 對話方塊。

  2. 按一下 [ASP.NET]，再按 [編輯組態]，然後再按一下 [應用程式]。

在 [應用程式] 索引標籤中進行的設定，會套用至顯示 [屬性] 對話方塊之前所選取的 Web 應用程式。您在 [應用程式] 索引標籤中所套用的設定，將會出現在 Web 應用程式之 Web.config 檔的 system.web 組態區段中。

Note 注意事項

可以繼承組態設定。設定可在 Machine.config 檔中定義，該檔案是做為伺服器上所有網站和 Web 應用程式的基底組態。若要建立新設定，或覆寫繼承的設定，您可以在 Web 應用程式層級設定組態設定。

如需 [ASP.NET 組態設定] 的詳細資訊，請參閱 ASP.NET 組態概觀。

工作

  • 使用 [應用程式] 索引標籤，可讓您完成下列工作：

  • 設定 Web 應用程式中之 ASP.NET Web 網頁的預設語言。

  • 設定 Web 應用程式的預設主題和主版頁面 (Master Page)。

  • 啟用 Web 應用程式的偵錯。

  • 指定在 ASP.NET 自動關閉要求之前，可以執行要求的最大秒數。

  • 設定要求、回應和文化特性 (Culture) 設定的內容編碼字元集，文化特性設定會決定與文化特性相關之函式的結果，例如，日期、數字和貨幣格式。

  • 設定將被模擬且 ASP.NET Web 網頁會在其下執行的 Windows 識別。

UI 項目

[應用程式] 索引標籤有下列三個分類：

  • 通用編譯、頁面及執行階段設定

  • 全球化設定

  • 識別設定

通用編譯、頁面及執行階段設定

讓您進行 [頁面語言預設值]、[頁面主題預設值]、[主版頁面預設值]、[啟用偵錯] 和 [要求執行逾時 (秒)] 的組態設定。

頁面語言預設值

讓您選取要在動態 (Dynamic) 編譯檔中使用的預設程式語言。可用的語言包括 [VB] (Microsoft Visual Basic 開發系統)、[C#]、[JS] (Microsoft JScript 開發軟體)，以及 [VJ#] (Microsoft Visual J# 開發工具)。

頁面主題預設值

讓您指定要套用至 Web 應用程式中之所有頁面的預設主題。

主版頁面預設值

讓您指定相對於本機組態檔的主版頁面檔案路徑。

啟用偵錯

讓您指定要編譯正式版本的二進位碼檔案或執行二進位碼檔案偵錯。如果核取方塊已清除，則該值為 false。

要求執行逾時 (秒)

讓您指定在 ASP.NET 自動關閉要求之前，允許執行要求的最大秒數。

全球化設定

讓您進行 [要求的編碼方式]、[回應的編碼方式]、[文化特性] 和 [UI 文化特性] 的組態設定。

要求的編碼方式

讓您指定收到的每一項要求的假設編碼方式，包括發佈的資料和查詢字串。預設值為 UTF-8。

回應的編碼方式

讓您指定回應的內容編碼方式。預設值為 UTF-8。

檔案編碼方式

讓您指定 .aspx、.asmx 及 .asax 檔剖析時的預設編碼方式。

文化特性

讓您選取要處理收到的 Web 要求時的預設文化特性。文化特性會決定與文化特性相關之函式的結果，例如，日期、數字和貨幣格式。

UI 文化特性

讓您選取要處理地區設定相關資源搜尋時的預設文化特性。

識別設定

讓您進行 [模擬]、[使用者名稱] 和 [密碼] 的組態設定。

模擬

讓您指定是否在每一項要求上使用用戶端模擬。

使用者名稱

讓您指定如果在每一項要求上使用用戶端模擬時要使用的使用者名稱。

密碼

讓您指定如果在每一項要求上使用用戶端模擬時要使用的密碼。

請參閱

工作

HOW TO：以程式設計方式存取 ASP.NET 組態設定
HOW TO：設定 ASP.NET Web 網頁全球化的文化特性和 UI 文化特性

參考

ASP.NET 組態設定對話方塊、驗證索引標籤
ASP.NET 組態設定對話方塊、授權索引標籤
ASP.NET 組態設定對話方塊、自訂錯誤索引標籤
ASP.NET 組態設定對話方塊、一般索引標籤
ASP.NET 組態設定對話方塊、位置索引標籤

概念

ASP.NET 組態概觀
ASP.NET 佈景主題和面板概觀
ASP.NET 主版頁面概觀


ASP.NET 組態設定對話方塊、狀態管理索引標籤

ASP.NET 組態設定對話方塊、狀態管理索引標籤
DropDown image

[ASP.NET 組態設定] 對話方塊的 [狀態管理] 索引標籤，可讓您透過對目前網站中網頁的多個要求，管理狀態和網頁資訊。使用者巡覽組成 Web 應用程式的不同 ASP.NET Web 網頁時，ASP.NET 工作階段 (Session) 狀態可讓您為使用者帳戶儲存和擷取值。[狀態管理] 索引標籤可讓您設定如何以及在何處儲存這些值。

在 [狀態管理] 索引標籤上進行的設定，會套用至開啟 [屬性] 對話方塊之前所選取的網站。

Note 注意事項

可以繼承組態設定。設定可以在 Machine.config 檔中加以定義，這個檔案會做為伺服器上所有網站的基底組態。如需 ASP.NET 組態檔的詳細資訊，請參閱 ASP.NET 組態檔階層架構和繼承。

若要顯示 ASP.NET 組態設定對話方塊的狀態管理索引標籤

  1. 在 Microsoft Windows 中，按一下 [開始]，指向 [所有程式]，然後指向 [系統管理工具]，再按 [網際網路資訊服務 (IIS) 管理員]。

    [IIS 管理員] 隨即出現。

  2. 在 [網際網路資訊服務] 下，展開 [Servername (本機電腦)]，然後展開 [網站]，並以滑鼠右鍵按一下 [Websitename] 或 [預設網站]，再按 [屬性]。

    [網站內容] 對話方塊隨即出現。

  3. 按一下 [ASP.NET] 索引標籤，再按 [編輯組態]。

    [ASP.NET 組態設定] 對話方塊隨即出現。

  4. 按一下 [狀態管理] 索引標籤。

工作

使用 [狀態管理] 索引標籤，您可以：

  • 選取目前 Web 應用程式的工作階段狀態模式。

  • 設定 [SQLServer] 和 [StateServer] 工作階段狀態模式。

UI 項目

工作階段狀態模式

按一下工作階段狀態模式。預設工作階段狀態是 [InProc] 模式，即存放在 Web 伺服器的記憶體中。如需 ASP.NET 的可用工作階段狀態模式清單，請參閱工作階段狀態模式。

cookieless 模式

按一下 Cookie 模式以定義何時使用 Cookie 來維護使用者的資訊。如需可用 Cookieless 模式的詳細資訊，請參閱 HttpCookieMode。

工作階段逾時

輸入工作階段結束之前，要求之間所允許的時間 (以分鐘為單位)。

連接字串

輸入連接字串，以識別 StateServer 模式之 ASP.NET 狀態服務的伺服器名稱和連接埠。

網路逾時

輸入 [StateServer] 模式之網路工作階段結束之前，要求之間所允許的時間 (以秒為單位)。

連接字串

輸入連接字串，以識別 [SQLServer] 模式的伺服器名稱和連接埠。

請參閱

參考

HttpCookieMode

概念

工作階段狀態模式
ASP.NET 組態檔階層架構和繼承

其他資源

ASP.NET 的 MMC 嵌入式管理單元


ASP.NET 組態設定對話方塊、位置索引標籤

ASP.NET 組態設定對話方塊、位置索引標籤
DropDown image

您可以使用含有適當 path 屬性 (Attribute) 的 location 標記，將組態設定套用至特定的 Web 應用程式或目錄。path 屬性可用來識別唯一組態設定的特定檔案或子目錄。使用 [ASP.NET 組態設定] 對話方塊的 [位置] 索引標籤，可以在組態檔內部內嵌組態設定。

[ASP.NET 組態設定] 對話方塊的 [位置] 索引標籤，可讓您管理下列項目：

  • 位置組態，這是在節點之組態檔中所定義的路徑位置組態。

若要從 Microsoft Internet Information Services (IIS) 管理員顯示 ASP.NET 組態設定對話方塊

  1. 開啟此 Web 應用程式的 [屬性] 對話方塊。

  2. 按一下 [ASP.NET]，再按 [編輯組態]，然後再按一下 [應用程式]。

在 [位置] 索引標籤中進行的設定，會套用至顯示 [屬性] 對話方塊之前所選取的 Web 應用程式。

注意：可以繼承組態設定。設定可在 Machine.config 檔中定義，該檔案是做為伺服器上所有網站和 Web 應用程式的基底組態。若要建立新設定或覆寫繼承的設定，您可以在 Web.config 檔中的 Web 應用程式層級設定組態設定。

如需 [ASP.NET 組態設定] 的詳細資訊，請參閱 ASP.NET 組態概觀。

工作

使用 [位置] 索引標籤，可讓您完成下列工作：

  • 指定在節點之組態檔中所定義的路徑位置組態。

UI 項目

位置組態

加入

讓您顯示可在其中指定索引和位置的 [加入位置] 對話方塊，以將新位置加入至 [ASP.Net 組態設定] 對話方塊中的 [位置組態] 對話方塊。

編輯組態

讓您顯示節點的新 [ASP.NET 組態設定] 索引標籤，該節點是由包含組態檔中的路徑所指定。

移除

讓您從這個節點的組態檔移除位置項目。

請參閱

工作

HOW TO：以程式設計方式存取 ASP.NET 組態設定

參考

ASP.NET 組態設定對話方塊、一般索引標籤
ASP.NET 組態設定對話方塊、驗證索引標籤
ASP.NET 組態設定對話方塊、授權索引標籤
ASP.NET 組態設定對話方塊、自訂錯誤索引標籤
ASP.NET 組態設定對話方塊、應用程式索引標籤

概念

ASP.NET 組態概觀
保護 ASP.NET 組態


編輯/加入連接字串對話方塊

編輯/加入連接字串對話方塊
DropDown image

[編輯/加入連接字串] 對話方塊可讓您建立新的 ConnectionString 屬性，或編輯現有的 ConnectionString 屬性。當您在 [ASP.NET 組態設定] 對話方塊中，按一下 [一般] 索引標籤上的 [加入] 或 [編輯] 時，[編輯/加入連接字串] 對話方塊便會顯示。

若要從 Microsoft Internet Information Services (IIS) 管理員顯示 ASP.NET 組態設定對話方塊

  1. 開啟此 Web 應用程式的 [屬性] 對話方塊。

  2. 按一下 [ASP.NET]，再按 [編輯組態]，然後再按一下 [應用程式]。

您可以在 [ASP.NET 組態設定] 對話方塊的 [一般] 索引標籤中按一下 [加入]，以顯示 [編輯/加入連接字串] 對話方塊。然後，指定 ConnectionString 屬性和 Connection 參數的名稱或索引鍵。

您也可以在 [ASP.NET 組態設定] 對話方塊的 [一般] 索引標籤中按一下 [編輯]，以顯示 [編輯/加入連接字串] 對話方塊，然後您便可以在該方塊中編輯現有的 ConnectionString 屬性。選取的 ConnectionString 屬性會顯示在 [連接參數] 方塊中。

Note 注意事項

您可以覆寫繼承的設定，在這種情況下，覆寫的設定只會套用至所選取的 Web 應用程式。您無法編輯繼承的設定，以在較高的組態階層架構中變更其值。

如需 [ASP.NET 組態設定] 的詳細資訊，請參閱 ASP.NET 組態概觀。

工作

使用 [編輯/加入連接字串] 對話方塊，可讓您完成下列工作：

  • 將新的 ConnectionString 屬性加入至 [一般] 索引標籤中的 [連接字串管理員] 對話方塊。

  • 在 [一般] 索引標籤的 [連接字串管理員] 對話方塊中，編輯現有的 ConnectionString 屬性。

UI 項目

編輯/加入連接字串

名稱

讓您指定 ConnectionString 屬性的名稱。

如果您是藉由按一下 [一般] 索引標籤中的 [編輯]，來叫用 (Invoke) [編輯/加入連接字串] 對話方塊，那麼您無法指定連接字串的名稱。

連接參數

讓您指定 ConnectionString 屬性的值。

如果您是藉由按一下 [一般] 索引標籤中的 [編輯]，來叫用 [編輯/加入連接字串] 對話方塊，則 [連接參數] 方塊會包含現有 ConnectionString 屬性的值。

確定

讓您套用您所建立的新 ConnectionString 屬性，或是套用所做的變更至現有 ConnectionString 屬性。

取消

讓您關閉 [編輯/加入連接字串] 對話方塊。不會將任何變更寫入連接字串管理員。

請參閱

參考

ASP.NET 組態設定對話方塊、一般索引標籤
connectionStrings 項目 (ASP.NET 設定結構描述)

概念

ASP.NET 組態概觀


編輯/加入應用程式設定對話方塊

編輯/加入應用程式設定對話方塊
DropDown image

應用程式設定是簡單的索引鍵/值組，可讓您在中央位置建立全應用程式值，該位置可從 Web 應用程式中的任何地方來存取。保留應用程式設定做為 Web.config 檔中組態的一部分，您就可以輕鬆變更它們。[一般] 索引標籤上的 [應用程式設定 對話方塊，會顯示應用程式設定索引鍵/值組的清單。

[編輯/加入應用程式設定] 對話方塊可讓您建立和編輯 Web 應用程式設定。

您可以在 [ASP.NET 組態設定] 對話方塊中，於 [一般] 索引標籤的 [應用程式設定] 部分按一下 [加入]，以顯示 [編輯/加入應用程式設定] 對話方塊。然後，指定 AppSettings 屬性的索引鍵和值，其會加入至 [應用程式設定] 對話方塊及 Web 應用程式的 Web.config 檔。

同樣地，您也可以在 [應用程式設定] 對話方塊中選取設定，接著按一下 [編輯]。然後，您可以變更選取的 AppSettings 屬性的值。這些變更會加入至 [應用程式設定] 對話方塊及 Web 應用程式的 Web.config 檔。

若要從 Microsoft Internet Information Services (IIS) 管理員顯示 ASP.NET 組態設定對話方塊

  1. 開啟此 Web 應用程式的 [屬性] 對話方塊。

  2. 按一下 [ASP.NET]，再按 [編輯組態]，然後再按一下 [應用程式]。

如需 [ASP.NET 組態設定] 的詳細資訊，請參閱 ASP.NET 組態概觀。

工作

使用 [編輯/加入應用程式設定] 對話方塊，可讓您完成下列工作：

  • 建立新的索引鍵/值組，可讓您在中央位置建立全應用程式值。

  • 編輯目前在 Web 應用程式中的索引鍵/值組。

UI 項目

鍵值

讓您加入索引鍵/值組的新鍵值。如果您按一下 [編輯]，便無法在文字方塊中指定新鍵值。

值

讓您加入索引鍵/值組的新值。如果您按一下 [編輯]，將可以變更選取之索引鍵/組值的值。

確定

讓您套用您所建立的新 AppSettings 屬性，或是將變更套用至現有的應用程式設定。

取消

讓您關閉 [編輯/加入應用程式設定] 對話方塊，而不要對應用程式設定或 Web 應用程式中的 Web.config 檔做任何變更。

請參閱

參考

ASP.NET 組態設定對話方塊、一般索引標籤
appSettings 項目 (一般設定結構描述)

概念

ASP.NET 組態概觀


編輯/加入自訂錯誤處理常式對話方塊

編輯/加入自訂錯誤處理常式對話方塊
DropDown image

[編輯/加入自訂錯誤處理常式] 對話方塊可讓您將錯誤碼對應至特定的錯誤網頁。ASP.NET 產生錯誤碼時，會顯示指定的網頁。

在 [編輯/加入自訂錯誤處理常式] 對話方塊中進行的設定，會套用至開啟 [屬性] 對話方塊之前所選取的 Web 應用程式。

Note 注意事項

可以繼承組態設定。設定可以定義在 Machine.config 檔中，這個檔案會做為伺服器上所有網站和應用程式的基底組態。在 Web 應用程式層級上進行組態設定，即可建立新設定，或覆寫繼承的設定。

注意：ASP.NET 不接收特定錯誤碼 (例如 404)。您只可對應 ASP.NET 中內部產生的錯誤。

若要開啟編輯/加入自訂錯誤處理常式對話方塊

  1. 在 Microsoft Windows 中，開啟 [系統管理工具]，再按一下 [網際網路資訊服務 (IIS) 管理員]。

    [IIS 管理員] 隨即出現。

  2. 在 [網際網路資訊服務] 下，展開 [Servername (本機電腦)]，然後展開 [Websitename] 或 [預設網站]，再按一下 [屬性]。

    [網站內容] 對話方塊隨即出現。

  3. 按一下 [ASP.NET] 索引標籤，再按 [編輯組態]。

    [ASP.NET 組態設定] 對話方塊隨即出現。

  4. 按一下 [自訂錯誤]。

    • 若要加入自訂錯誤處理常式，請按一下 [加入]。

    • 若要編輯自訂錯誤處理常式，請按一下 [編輯]。

    [編輯/加入自訂錯誤處理常式] 對話方塊隨即出現。

UI 項目

狀態碼

輸入 HTTP 錯誤碼，以對應至錯誤網頁。

重新導向 URL

輸入網頁 URL，讓 ASP.NET 在回應錯誤碼時顯示該網頁。參考的網頁不必位在目前的網站中。

Note 注意事項

ASP.NET 不會驗證您所輸入的 URL。

確定

按一下以儲存自訂錯誤處理常式。

取消

按一下以取消變更。

請參閱

參考

ASP.NET 組態設定對話方塊、自訂錯誤索引標籤
ASP.NET 組態設定對話方塊、自訂錯誤索引標籤


編輯規則對話方塊

編輯規則對話方塊
DropDown image

[編輯規則] 對話方塊可讓您建立新的授權規則，或編輯現有的授權規則。使用 Microsoft Windows 驗證 (Authentication) 或 ASP.NET 表單驗證 (ASP.NET 成員資格)，可建立使用者帳戶和角色。

若要開啟編輯規則對話方塊

  1. 在 Windows 中，開啟 [系統管理工具]，再按一下 [網際網路資訊服務 (IIS) 管理員]。

    [IIS 管理員] 隨即出現。

  2. 在 [網際網路資訊服務] 下，展開 [Servername (本機電腦)]，然後展開 [網站]，並以滑鼠右鍵按一下 [Websitename] 或 [預設網站]，再按 [屬性]。

    [網站內容] 對話方塊隨即出現。

  3. 按一下 [ASP.NET] 索引標籤，再按 [編輯組態]。

    [ASP.NET 組態設定] 對話方塊隨即出現。

  4. 按一下 [授權] 索引標籤。

    • 若要加入規則，請按一下 [加入]。

    • 若要編輯規則，請按一下規則，再按 [編輯]。

    [編輯規則] 對話方塊隨即出現。

工作

使用 [編輯規則] 對話方塊，您可以：

  • 建立新的授權規則或編輯現有的授權規則。

UI 項目

規則型別

按一下 [允許] 允許所有使用者存取。

-或-

按一下 [拒絕] 拒絕所有使用者存取。

如需規則的詳細資訊，請參閱 AuthorizationRuleCollection。

動作

按一下 [所有動作]，以指定允許所有 ASP.NET HTTP 傳輸方法進行存取。[所有動作] 為預設值。

按一下 [特定動作]，再輸入授與存取權之 HTTP 傳輸方法的逗號分隔清單。

在 ASP.NET 已註冊的動詞命令為 GET、HEAD、POST 和 DEBUG。

使用者和角色

必要項。

完成下列一或多個要套用規則的動作：

  • 按一下 [所有使用者] 將規則套用至所有使用者。

  • 按一下 [匿名使用者] 只將規則套用至匿名使用者帳戶。

  • 按一下 [使用者]，再輸入使用者帳戶名稱的逗號分隔清單，以便將規則套用至特定一組使用者帳戶。

  • 選取 [角色] 核取方塊，再輸入角色名稱的逗號分隔清單，以便將規則套用至特定一組角色。

如果同時指定 [使用者] 和 [角色]，則規則只適用於所指定之角色中的使用者帳戶。

使用 Windows 驗證或 ASP.NET 表單驗證 (ASP.NET 成員資格)，可定義使用者帳戶和角色。

確定

按一下以套用規則。

取消

按一下以取消變更。

請參閱

工作

HOW TO：實作簡單表格驗證

參考

ASP.NET 組態設定對話方塊、授權索引標籤
ASP.NET 組態設定對話方塊、授權索引標籤

概念

跨應用程式的表單驗證

其他資源

使用 ASP.NET 角色管理授權 (Visual Studio)


加入位置對話方塊

加入位置對話方塊
DropDown image

[加入位置] 對話方塊可讓您將新的位置組態設定加入至網站。您可以使用含有適當 path 屬性 (Attribute) 的 <location> 標記，將組態設定套用至特定的資源。path 屬性可用來識別要套用唯一組態設定的特定檔案或子目錄。

當您在 [ASP.NET 組態設定] 對話方塊中，按一下 [位置] 索引標籤下的 [加入] 按鈕時，[加入位置] 對話方塊便會顯示。

若要從 Microsoft Internet Information Services (IIS) 管理員顯示 ASP.NET 組態設定對話方塊

  1. 開啟此 Web 應用程式的 [屬性] 對話方塊。

  2. 按一下 [ASP.NET]，再按 [編輯組態]，然後再按一下 [應用程式]。

您可以使用 [加入位置] 對話方塊執行下列作業：

  • 指定位置項目的索引 (鍵)。

  • 指定要加入至 [位置] 組態清單之位置的值。

UI 項目

索引

指定位置項目的索引 (鍵)。

位置

指定要加入至清單之項目的值 (例如，特定檔案或目錄的路徑)。

確定

將您所輸入的新位置值，套用至 [ASP.NET 組態設定] 對話方塊的 [位置組態] 方塊中。關閉 [加入位置] 對話方塊。

取消

關閉 [加入位置] 對話方塊。不會將任何變更寫入 [位置組態] 方塊中。

請參閱

參考

ASP.NET 組態設定對話方塊、位置索引標籤
選擇位置/開啟網站對話方塊、本機 IIS 索引標籤

概念

ASP.NET 組態概觀


dv_aspnetmmchxs {2DDA7CF9-E8CF-4df1-98E8-521EDE1C5FC7}

dv_aspnetmmchxs {2DDA7CF9-E8CF-4df1-98E8-521EDE1C5FC7}
DropDown image

dv_aspnetmmchxs {2DDA7CF9-E8CF-4df1-98E8-521EDE1C5FC7}

{2DDA7CF9-E8CF-4df1-98E8-521EDE1C5FC7}

{2DDA7CF9-E8CF-4df1-98E8-521EDE1C5FC7}

若要對本產品的相關功能或是說明文件的內容提供您寶貴的建議或是指正其中的錯誤，請前往客戶意見網站。