資料來源精靈螢幕 1

[image]

SQL Server Native Client 說明
資料來源精靈螢幕 1
傳送回函

指定資料來源的名稱及描述，以及資料來源將連接到的 SQL Server 伺服器的名稱。

選項

名稱

當 ODBC 應用程式要求連接到資料來源時所使用的資料來源名稱。 例如，Personnel。資料來源名稱會顯示於 [ODBC 資料來源系統管理員] 對話方塊中。

說明

(選擇性) 資料來源的描述。 例如，「所有員工的雇用日期、薪資記錄以及目前的複查」。

選取或輸入伺服器名稱

網路上 SQL Server 執行個體的名稱。 您必須在下一個編輯方塊中指定伺服器。

在大多數情況下，SQL Server Native Client ODBC 驅動程式都可以使用預設通訊協定順序及此方塊中提供的伺服器名稱進行連接。 如果您要為伺服器建立別名或設定用戶端網路程式庫，請使用「SQL Server 組態管理員」。

如果您使用的電腦與 SQL Server 的相同，則您可以在伺服器方塊中輸入 "(local)"。 接著，即使執行的是非網路版的 SQL Server，使用者也可連接到 SQL Server 的本機執行個體。 多個 SQL Server 執行個體可以在同一部電腦上執行。 若要指定 SQL Server 的具名執行個體，請將伺服器名稱指定為 ServerName\InstanceName。

如需有關不同網路類型之伺服器名稱的詳細資訊，請參閱《SQL Server 線上叢書》中的 SQL Server 安裝文件集。

完成

如果在此螢幕上指定的資訊即為連接到 SQL Server 所需的全部資訊，即可按一下 [完成]。 在精靈其他螢幕上指定的所有屬性都使用預設值。

將意見反應提供給 Microsoft

© 2012 Microsoft Corporation. 著作權所有，並保留一切權利。


資料來源精靈螢幕 2

[image]

SQL Server Native Client 說明
資料來源精靈螢幕 2
傳送回函

指定驗證的方法，並設定 Microsoft SQL Server 進階用戶端項目，以及在設定資料來源時，SQL Server Native Client ODBC 驅動程式用來連接至 SQL Server 的登入與密碼。

選項

使用網路登入識別碼的整合式 Windows 驗證

指定 SQL Server Native Client ODBC 驅動程式要求使用安全 (或信任) 的連接，以連接到 SQL Server。 選取之後，不論伺服器目前的登入安全性模式為何，SQL Server 都會透過此資料來源，使用整合式登入安全性來建立連接。 所有提供的登入識別碼或密碼都會被忽略。 SQL Server 系統管理員必須已建立 Windows 登入與 SQL Server 登入識別碼之間的關聯 (例如，使用 SQL Server Management Studio)。

(選擇性) 您可以指定伺服器的服務主體名稱 (SPN)。

登入識別碼

如果已選取 [由使用者所輸入的登入識別碼及密碼進行 SQL Server 帳戶驗證]，則指定 SQL Server Native Client ODBC 驅動程式在連接至 SQL Server 時所使用的登入識別碼。 這僅適用於用來決定伺服器預設值的連接，而不適用於建立此連接之後，使用資料來源所建立的後續連接。

密碼

如果已選取 [由使用者所輸入的登入識別碼及密碼進行 SQL Server 帳戶驗證]，則指定 SQL Server Native Client ODBC 驅動程式在連接至 SQL Server 時所使用的密碼。 這僅適用於用來決定伺服器預設值的連接，而不適用於使用新的資料來源建立的後續連接。

如果選取 [使用網路登入識別碼的整合式 Windows 驗證]，或者清除 [連線到 SQL Server 以獲得其他設定選項的預設設定]，則會停用 [登入識別碼] 和 [密碼] 方塊。

將意見反應提供給 Microsoft

© 2012 Microsoft Corporation. 著作權所有，並保留一切權利。


資料來源精靈螢幕 3

[image]

SQL Server Native Client 說明
資料來源精靈螢幕 3
傳送回函

指定預設資料庫、驅動程式所使用的各種 ANSI 選項及鏡像伺服器的名稱。

選項

[變更預設資料庫為] 方塊

指定預設資料庫的名稱，以用於使用此資料來源所建立的任何連接。 清除此方塊時，連接會使用為該伺服器之登入 ID 所定義的預設資料庫。 選取此方塊時，方塊中所命名的資料庫會覆寫為該登入識別碼定義的預設資料庫。 如果 [附加資料庫檔案名稱] 方塊具有主要檔案的名稱，則主要檔案所說明的資料庫會附加為使用 [變更預設資料庫為] 方塊中指定之資料庫名稱的資料庫。

使用登入 ID 的預設資料庫比在 ODBC 資料來源中指定預設資料庫更有效。

[鏡像伺服器] 核取方塊

指定要鏡像之資料庫的容錯移轉夥伴名稱。 如果資料庫名稱未顯示在 [變更預設資料庫為] 方塊中，或顯示的名稱為預設資料庫，則 [鏡像伺服器] 會變成灰色。

(選擇性) 您可以指定鏡像伺服器的伺服器主體名稱 (SPN)。 鏡像伺服器的 SPN 會用於用戶端與伺服器之間的相互驗證。

[附加資料庫檔案名稱] 核取方塊

為可附加的資料庫指定主要檔案的名稱。 此資料庫會附加而做為資料來源的預設資料庫。 指定主要檔案的完整路徑及檔名。 [變更預設資料庫為] 方塊中指定的資料庫名稱會當做附加資料庫的名稱使用。

[使用 ANSI 引號識別項] 核取方塊

指定在 SQL Server Native Client ODBC 驅動程式連接時，啟用 QUOTED_IDENTIFIERS。 選取此核取方塊時，SQL Server 會強制執行有關引號的 ANSI 規則。 雙引號僅可用於識別項，如資料行及資料表名稱。 字元字串必須以單引號括住：

複製影像 複製程式碼
SELECT "LastName"
FROM "Person.Contact"
WHERE "LastName" = 'O''Brien'

如果清除此核取方塊，則當使用引號識別項的應用程式 (如 Microsoft Excel 隨附的 Microsoft Query 公用程式) 利用引號識別項產生 SQL 陳述式時，就會發生錯誤。

[使用 ANSI 空值、留白和警告] 核取方塊

指定在 SQL Server Native Client ODBC 驅動程式連接時，啟用 ANSI_NULLS、ANSI_WARNINGS 及 ANSI_PADDINGS 選項。

當啟用 ANSI_NULLS 時，伺服器會強制執行關於 NULL 資料行比較的 ANSI 規則。 必須針對所有 NULL 比較使用 ANSI 語法 "IS NULL" 或 "IS NOT NULL"。 Transact-SQL 語法 "= NULL" 不受支援。

當啟用 ANSI_WARNINGS 時，SQL Server 會針對違反 ANSI 規則但未違反 Transact-SQL 規則的情況，發出警告訊息。 此類錯誤包括執行 INSERT 或 UPDATE 陳述式時截斷資料，或在執行彙總函式期間產生 NULL 值。

當啟用 ANSI_PADDING 時，就不會自動修剪 varchar 值結尾的空格，以及 varbinary 值結尾的零。

應用程式意圖

當連接到伺服器時，宣告應用程式工作負載類型。 可能的值為 [ReadOnly] 和 [ReadWrite]。

多重子網路容錯移轉

如果您的應用程式要連接到不同子網路上的高可用性災害復原 (AlwaysOn 可用性群組) 可用性群組 (AG)，則啟用 [多重子網路容錯移轉] 會設定 SQL Server Native Client 來提供目前使用中伺服器的更快速偵測與連接。

將意見反應提供給 Microsoft

© 2012 Microsoft Corporation. 著作權所有，並保留一切權利。


資料來源精靈螢幕 4

[image]

SQL Server Native Client 說明
資料來源精靈螢幕 4
傳送回函

指定 SQL Server 訊息所使用的語言、字元集轉譯，以及 SQL Server Native Client ODBC 驅動程式是否應該使用區域設定。 您也可以控制長期執行查詢及驅動程式統計資料設定的記錄。

選項

變更 SQL Server 系統訊息的語言為

SQL Server 的每一個執行個體都可具有多組系統訊息，每一組都可使用不同的語言 (例如，英文、西班牙文、法文等)。 如果資料來源是針對具有多組系統訊息的伺服器而定義，則您可以指定您要用於系統訊息的語言。 在清單中，按一下語言。 如果在 SQL Server 上只安裝了一種語言，則此選項無法使用。

使用高度加密資料

選取時，透過使用此 DSN 建立的連接所傳遞的資料將會加密。 預設會加密登入，即使清除該核取方塊亦然。

為字元資料執行轉譯

選取此核取方塊時，SQL Server Native Client ODBC 驅動程式會使用 Unicode 來轉換在用戶端電腦與 SQL Server 之間傳送的 ANSI 字串。 SQL Server Native Client ODBC 驅動程式有時會在用戶端電腦上的 SQL Server 字碼頁與 Unicode 之間轉換。 若要執行此作業，SQL Server 所使用的字碼頁必須是用戶端電腦上可用的其中一個字碼頁。

若清除此核取方塊，ANSI 字元字串中的延伸字元在用戶端應用程式與伺服器之間傳送時就不會進行任何轉譯。 如果用戶端電腦正在使用與 SQL Server 字碼頁不同的 ANSI 字碼頁 (ACP)，則 ANSI 字元字串中的延伸字元可能會被錯誤解譯。 如果用戶端電腦正在使用的 ACP 字碼頁與 SQL Server 所使用的字碼頁相同，則延伸字元會被正確解譯。

當輸出流通貨幣、數字、日期和時間時，請使用地區設定

指定驅動程式使用用戶端電腦的區域設定，以格式化字元輸出字串中的貨幣、數字、日期及時間。 針對透過資料來源連接之使用者的 Windows 登入帳戶，驅動程式會使用預設區域設定。 請針對僅顯示資料的應用程式 (而非處理資料的應用程式) 選取此選項。

將長時間執行的查詢儲存到記錄檔

指定驅動程式記錄查詢時間長於 [長查詢時間] 值的任何查詢。 長期執行查詢會記錄在指定的檔案中。 若要指定記錄檔，請在方塊中輸入完整路徑及檔名，或按一下 [瀏覽]，透過瀏覽現有檔案目錄來選取記錄檔。

長時間查詢的時間 (毫秒)

指定長期執行查詢記錄的臨界值 (以毫秒為單位)。 執行時間長於此毫秒數的任何查詢都會被記錄。

記錄 ODBC 驅動程式統計資料至記錄檔

指定要記錄統計資料。 將統計資料記錄至指定檔案。 若要指定記錄檔，請在方塊中輸入完整路徑及檔名，或按一下 [瀏覽]，透過瀏覽現有檔案目錄來選取記錄檔。

統計資料記錄是以 Tab 分隔的檔案，可以在 Microsoft Excel 或其他任何支援以 Tab 分隔檔案的應用程式中進行分析。

將意見反應提供給 Microsoft

© 2012 Microsoft Corporation. 著作權所有，並保留一切權利。


SQL Server 登入對話方塊 (ODBC)

[image]

SQL Server Native Client 說明
SQL Server 登入對話方塊 (ODBC)
傳送回函

當您呼叫 ODBC 連接，但卻沒有為驅動程式指定足夠的資訊以連接至 SQL Server 時，Microsoft SQL Server Native Client ODBC 驅動程式就會顯示 [SQL Server 登入] 對話方塊。

選項

伺服器

網路上 SQL Server 執行個體的名稱。 從清單中選取伺服器或執行個體名稱，或在 [伺服器] 方塊中輸入伺服器或執行個體名稱。 (選擇性) 您可以在用戶端電腦上使用 [SQL Server 組態管理員] 建立伺服器別名，並在 [伺服器] 方塊中輸入該名稱。

如果您使用的電腦與 SQL Server 的相同，則可輸入 "(local)"。 接著，即使執行的是非網路版的 SQL Server，您也可連接到 SQL Server 的本機執行個體。

如需有關不同網路類型之伺服器名稱的詳細資訊，請參閱《SQL Server 線上叢書》中的 SQL Server 安裝文件集。

使用信任連線

選取此方塊時，則表示 SQL Server Native Client ODBC 驅動程式要求使用安全 (或信任) 的連接，以連接到在 Microsoft Windows 2000、Windows XP 或 Windows 2003 上執行的 SQL Server 執行個體。 不論伺服器目前的登入安全性模式為何，SQL Server 都會透過此資料來源，使用整合式登入安全性來建立連接。 所有提供的登入識別碼或密碼都會被忽略。 SQL Server 系統管理員必須已建立 Windows 網路識別碼與 SQL Server 登入識別碼之間的關聯。

清除此方塊時，SQL Server 會透過此資料來源，使用標準登入安全性來建立連接。 您必須為所有連接要求指定登入識別碼和密碼。

重要事項：使用 Windows 驗證的信任連接會比使用 SQL Server 驗證進行驗證的連接更安全。 請盡可能使用信任連接。

伺服器 SPN

如果您使用了信任連接，就可以指定伺服器的服務主要名稱 (SPN)。

登入識別碼

如果清除了 [使用信任連接]，則指定連接時所使用的 SQL Server 登入識別碼。 如果選取了 [使用信任連接]，則會停用 [登入識別碼] 方塊。

密碼

如果清除了 [使用信任連接]，則指定連接時所使用之 SQL Server 登入識別碼的密碼。 如果選取了 [使用信任連接]，則會停用 [密碼] 方塊。

選項

顯示或隱藏 [選項] 群組。 如果 [伺服器] 具有值，就會啟用 [選項] 按鈕。

變更密碼

選取此方塊時，會顯示 [新密碼] 和 [確認新密碼] 方塊。

新密碼

指定新的密碼。

確認新密碼

再次指定新密碼，以進行確認。

資料庫

指定用於連接的預設資料庫。 此設定會覆寫伺服器上指定用於登入的預設資料庫。 如果未指定任何資料庫，則連接會使用伺服器上指定用於登入的預設資料庫。

鏡像伺服器

指定要鏡像處理之資料庫的容錯移轉夥伴名稱。

鏡像 SPN

(選擇性) 您可以指定鏡像伺服器的 SPN。 鏡像伺服器的 SPN 會用於用戶端與伺服器之間的相互驗證。

語言

指定要用於 SQL Server 系統訊息的國家語言。 執行 SQL Server 的電腦必須安裝此語言。 此設定會覆寫伺服器上指定用於登入的預設語言。 如果未指定任何語言，則連接會使用伺服器上指定用於登入的預設語言。

應用程式名稱

(選擇性) 指定要針對 sys.sysprocesses 中的此連接，儲存在資料列上的 program_name 資料行中的應用程式名稱。

工作站 ID

(選擇性) 指定要針對 sys.sysprocesses 中的此連接，儲存在資料列上的 hostname 資料行中的工作站 ID。

將意見反應提供給 Microsoft

© 2012 Microsoft Corporation. 著作權所有，並保留一切權利。


SQL Server 登入對話方塊 (OLE DB)

[image]

SQL Server Native Client 說明
SQL Server 登入對話方塊 (OLE DB)
傳送回函

當您嘗試建立 OLE DB 連接，但卻沒有為提供者指定足夠的資訊以連接至 SQL Server Database Engine 的執行個體時，SQL Server Native Client OLE DB 提供者就會顯示 [SQL Server 登入] 對話方塊。

選項

伺服器

網路上 SQL Server Database Engine 執行個體的名稱。 從清單中選取伺服器或執行個體名稱，或在 [伺服器] 方塊中輸入伺服器或執行個體名稱。 (選擇性) 您可以在用戶端電腦上使用 [SQL Server 組態管理員] 建立伺服器別名，並在 [伺服器] 方塊中輸入該名稱。

如果您使用的電腦與 SQL Server 的相同，則可輸入 "(local)"。 接著，即使執行的是非網路版的 SQL Server，您也可連接到 SQL Server 的本機執行個體。

如需有關不同網路類型之伺服器名稱的詳細資訊，請參閱《SQL Server 線上叢書》中的 SQL Server 安裝文件集。

使用信任連線

選取此方塊時，則表示 SQL Server Native Client OLE DB 提供者要求使用安全 (或信任) 的連接，以連接到在 Microsoft Windows 上執行的 SQL Server 執行個體。 不論伺服器目前的登入安全性模式為何，SQL Server 都會透過此資料來源，使用整合式登入安全性來建立連接。 所有提供的登入識別碼或密碼都會被忽略。 SQL Server 系統管理員必須已建立 Windows 登入與 SQL Server 登入識別碼之間的關聯。

清除此方塊時，SQL Server 會透過此資料來源，使用標準登入安全性來建立連接。 您必須為所有連接要求指定登入識別碼和密碼。

重要事項 重要事項

使用 Windows 驗證的信任連接會比使用 SQL Server 驗證進行驗證的連接更安全。 請盡可能使用信任連接。

伺服器 SPN

如果您使用了信任連接，就可以指定伺服器的服務主要名稱 (SPN)。

登入識別碼

如果清除了 [使用信任連接]，則指定連接時所使用的 SQL Server 登入識別碼。 如果選取了 [使用信任連接]，則會停用 [登入識別碼] 方塊。

密碼

如果清除了 [使用信任連接]，則指定連接時所使用之 SQL Server 登入識別碼的密碼。 如果選取了 [使用信任連接]，則會停用 [密碼] 方塊。

選項

顯示或隱藏 [選項] 群組。如果 [伺服器] 具有值，就會啟用 [選項] 按鈕。

變更密碼

選取後，會顯示 [新密碼] 和 [確認新密碼] 方塊。

新密碼

指定新的密碼。

確認新密碼

再次指定新密碼，以進行確認。

資料庫

指定用於連接的預設資料庫。 此設定會覆寫伺服器上指定用於登入的預設資料庫。 如果未指定任何資料庫，則連接會使用伺服器上指定用於登入的預設資料庫。

鏡像伺服器

指定要鏡像處理之資料庫的容錯移轉夥伴名稱。

鏡像 SPN

(選擇性) 您可以指定鏡像伺服器的 SPN。 鏡像伺服器的 SPN 會用於用戶端與伺服器之間的相互驗證。

語言

指定要用於 SQL Server 系統訊息的國家語言。 執行 SQL Server 的電腦必須安裝此語言。 此設定會覆寫伺服器上指定用於登入的預設語言。 如果未指定任何語言，則連接會使用伺服器上指定用於登入的預設語言。

應用程式名稱

(選擇性) 指定要針對 sys.sysprocesses 中的此連接，儲存在資料列上的 program_name 資料行中的應用程式名稱。

工作站 ID

(選擇性) 指定針對 sys.sysprocesses 中的此連接，儲存在資料列上的 hostname 資料行中的工作站 ID。

將意見反應提供給 Microsoft

© 2012 Microsoft Corporation. 著作權所有，並保留一切權利。


SQL Server 的連接索引標籤

[image]

SQL Server Native Client 說明
SQL Server 的連接索引標籤
傳送回函

您可以使用 [連接] 索引標籤來指定連接至 Microsoft SQL Server 資料的方式。

這個 [連接] 索引標籤是提供者特有的，而且只會顯示 OLE DB Provider for Microsoft SQL Server 所需的連接屬性。

選項

選取伺服器

從下拉式清單中選取伺服器名稱，或是輸入您要存取之資料庫所在的伺服器位置。 在伺服器上選取資料庫是個別的動作。 您可以按一下 [重新整理]，藉以重新整理此清單。

輸入要登入到伺服器的資訊

指定驗證服務。

[Windows NT 整合式安全性] 會指定 SQL Server 驅動程式要求使用安全 (或信任) 的連接，以連接至在受支援 Microsoft 作業系統上執行的 SQL Server。 選取之後，不論伺服器目前的登入安全性模式為何，SQL Server 都會透過此資料來源，使用整合式登入安全性來建立連接。 所有提供的登入識別碼或密碼都會被忽略。 SQL Server 系統管理員必須已建立 Windows 登入與 SQL Server 登入識別碼之間的關聯。 如果您選取了 Windows NT 整合式安全性，也可以選取要用於用戶端與伺服器之間相互驗證的服務主體名稱 (SPN)。

或者，輸入特定的使用者名稱和密碼，以便向資料來源驗證登入資訊。 SQL Server 驅動程式將不會要求使用安全 (或信任) 的連接，以連接至 SQL Server。 SQL Server 將使用標準登入安全性來建立連接。 您必須為所有的連接要求指定 SQL Server 登入識別碼和密碼。

選取 [允許儲存密碼]，即可允許密碼與連接字串儲存在一起。 密碼是否可包含於連接字串中完全取決於呼叫應用程式的功能。 系統會傳回密碼並以未遮罩與未加密的方式儲存密碼。

核取 [空白密碼]，讓指定的提供者在連接字串中傳回空白的密碼。

選取資料庫

從下拉式清單中選取資料庫，或輸入資料庫名稱。 您可以選擇性地指定鏡像資料庫，而且如果您選取了 Windows NT 整合式安全性，還可以指定鏡像伺服器的 SPN。 鏡像伺服器的 SPN 會用於用戶端與伺服器之間的相互驗證。

選取 [附加資料庫檔案做為資料庫名稱]，即可為可附加的資料庫指定主要檔案的名稱。 此資料庫會附加並且當做資料來源的預設資料庫使用。 指定主要檔案的完整路徑及檔名。 [變更預設資料庫為] 方塊中指定的資料庫名稱會當做附加資料庫的名稱使用。

變更密碼

如果您正在使用 SQL Server 驗證，這個選項可讓您變更 SQL Server 密碼。

測試連接

按一下 [測試連接]，即可嘗試連接至指定的資料來源。 如果連接失敗，請確定設定正確無誤。 例如，拼字錯誤和區分大小寫都可能會導致連接失敗。

將意見反應提供給 Microsoft

© 2012 Microsoft Corporation. 著作權所有，並保留一切權利。


SQL Server 的進階索引標籤

[image]

SQL Server Native Client 說明
SQL Server 的進階索引標籤
傳送回函

指定提供者會等候初始化完成的時間量 (以秒為單位)。

選項

連接逾時

指定提供者會等候初始化完成的時間量 (以秒為單位)。 如果初始化逾時，系統就會傳回錯誤而且不會建立連接。

將意見反應提供給 Microsoft

© 2012 Microsoft Corporation. 著作權所有，並保留一切權利。


文件集的法律注意事項

[image]

文件集的法律注意事項
傳送回函

本文件是以原本的形式提供， 本文件中所表達的資訊和觀點，包括 URL 及其他網際網路網站參考資料，如有變更恕不另行通知。 您應自行承擔使用本文件的風險。

此處描述的部分範例僅供說明使用，純屬虛構， 並無意圖亦不應將其影射為任何實際關聯或連接。

本文件不會為您提供任何 Microsoft 產品的任何智慧財產權的任何法律權限。 您可以在內部為了參考用途來複製及使用本文件。

© 2012 Microsoft. 著作權所有，並保留一切權利.

Microsoft, Active Directory, ActiveX, Bing Maps, Excel, IntelliSense, MSDN, MS-DOS, PivotChart, PivotTable, PowerPoint, SharePoint, SQL Server, Visual Basic, Visual C#, Visual C++, Visual Studio, Windows, Windows NT, Windows Server 及 Windows Vista 是 Microsoft 集團的商標。 SAP NetWeaver 是 SAP AG 在德國和其他一些國家 (地區) 的註冊商標。 其他所有的商標為各擁有人所有之財產。

SQL Server 支援及升級的文件集原則

Microsoft SQL Server 2012 軟體文件集包括《Microsoft Microsoft SQL Server 2012 線上叢書》、安裝文件集、開發人員參考文件集、教學課程、讀我檔案、已知問題文件、範例程式碼、範例資料庫以及 Microsoft 所發行的知識庫文件，這些全都包含有關 SQL Server 特性與功能的內容。 此支援和升級原則適用於 Microsoft SQL Server 2012 文件集，包括 Microsoft SQL Server 2012 版本及 Service Pack 的讀我檔案；讀我檔案可視為《Microsoft SQL Server 2012 線上叢書》的延伸部分。

本文件內所含範例的主要目的在於闡釋某個概念，或說明特定陳述式或子句的合理使用。 多數範例並不包含通常可在完整生產系統中找到的所有程式碼，因為已將某些一般資料驗證及錯誤處理部分移除，以將焦點放在範例中的特定概念或陳述上。 這些範例或其中包含的任何原始程式碼並不包含於技術支援的服務範圍之內。

在某些情況下，Microsoft SQL Server 2012 中的特定功能未經過充分的測試或開發，所以不打算提供給您使用。 這類功能通常會當做預留位置； 因此，軟體中包含的某些功能不會記載於文件集中。 未記載的功能或是有註明僅供 Microsoft 內部使用的功能將不提供給您使用，也不會受到 Microsoft 客戶支援服務的支援。 除非 Microsoft SQL Server 2012 文件集另外註明，否則協力廠商內容 (包括搭配 Microsoft SQL Server 2012 使用這類協力廠商內容所產生的問題) 將不會受到 Microsoft 客戶支援服務的支援，而且也可能造成資料遺失。 Microsoft 客戶支援服務也不支援利用或使用未記載之進入點 (如未記載的 API) 的資料庫或應用程式，其中包括但不限於：預存程序、擴充預存程序、函數、檢視、資料表、資料行、屬性或中繼資料。

升級至 Microsoft SQL Server 2012 未來版本的伺服器或資料庫，對於利用及使用未記載之進入點的應用程式或資料庫可能不適用，而且也不受支援。 當您使用 Microsoft SQL Server 2012 文件集中未記載之 Microsoft SQL Server 包含的 SQL Server 特性與功能時，將不會受到支援，這樣的使用也可能造成資料遺失。

將意見反應提供給 Microsoft

© 2012 Microsoft Corporation. 著作權所有，並保留一切權利。