ThinPrint Output Gateway

Manufacturer (Headquarters):

Cortado AG

Alt-Moabit 91 a/b

10559 Berlin

Germany/Alemania

ThinPrint Website: www.thinprint.com

ThinPrint Community: forum.thinprint.com/cs